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1. Welcome to INDOTWise 4.5 
A Message from CAD Support 

Welcome to DOTWise 4.5, our fifth major release of a MicroStation and InRoads SS4 workspace, and 

our first major rewrite of the ProjectWise and MicroStation chapters since the 2.0 version.  While 

much of what’s in this document hasn’t changed, care has been given to make sure that all 

documentation and imagery is current, offering clearer and more up to date information.  Also, 

moving to SS4 InRoads means that we’re moving forward with OpenRoads technology which lays the 

future groundwork for upcoming Bentley releases and is covered as it pertains to the INDOT Plans 

Production process in the latter chapters of this document. 

In addition to the latest release of the MicroStation and InRoads workspace, we have migrated our 

ProjectWise infrastructure from an on-premise system to a system hosted on the cloud by Bentley 

Systems.  In order to facilitate the migration, we have created a new INDOTWise datasource to 

replace the former DOTWise datasource.  To account for this in this document, we have updated the 

associated documentation and imagery as necessary. 

Now fully vested in the InRoads SS4 environment, and the OpenRoads technology it contains, this 

document is intended to roll up all the enhancements to the CAD Workspace, ProjectWise and 

InRoads suites into a single document.  While this document won’t show every new item, we will hit 

on the major productivity enhancements and procedural changes.  Please keep in mind that this 

document is not a replacement for Fundamentals training on each of these products, and can be 

supplemented with the use of each products online Help file. 

We want to impart to you *why* things are, as much as *how* certain tools work or what buttons to 

click to perform a particular operation.   

The focus of this document is to answer the question, “What has changed in CAD and where can I 

find all the needed information to take advantage of those changes?”  The answer is simple: Right 

here in this document.  Note that the focus is on the how these tools work and a rough guideline on 

how they should look.  As always, Users should consult the current Indiana Design Manual for 

requirements related to the content and presentation of INDOT plans. 

If for any reason you believe that the information provided in this document is not accurate or clearly 

explained, please do not hesitate to let us know.  We will make every effort to make it right. 

Thanks, 

INDOT CAD Support 

2. INDOTWise 4.5 
INDOT has internally standardized on the use ProjectWise for all CAD management and file storage 

needs, and has expanded our system to include a number of other agency disciplines.  This chapter 

will cover how to get access to the system, the folder layout, per project security, and general usage. 
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2.1 Requesting ProjectWise Access via ITAP (INDOT Technical Application 

Pathway) 

Enrolling for ProjectWise requires going through the INDOT Technical Applications Pathway (more 

commonly known as ITAP), which is how it will be referred to throughout the rest of the document.  

The following sections will cover getting into ITAP, enrolling for the INDOT ProjectWise application 

with the appropriate roles, and how to request additional roles at a later time. 

2.1-1 Getting to ITAP 

You can access ITAP via the INDOT Intranet at http://intranet.indot.state.in.us/ or directly at 

http://itap.indot.in.gov/.  Going through the intranet, you can find the link for ITAP under the Popular 

Applications heading shown below.  This is located toward the center of the page. 

 
ITAP Link on the Intranet Homepage 

2.1-2 ITAP Overview: 

• The ITAP Main Page provides a list of a user’s approved applications with application details, 

a link to request access to additional INDOT applications, and a link to request additional 

roles for some applications.  (Click the Help icon at top left of page for additional 

instructions). 

• If you have already used ITAP in the past and enrolled or logged in for access to other 

applications they will show on your main page when you click the ITAP link.  It should look 

very similar to this screen.   

http://intranet.indot.state.in.us/
http://itap.indot.in.gov/
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The ITAP Main Page 

2.1-3 Request a new ProjectWise Account 

Once in ITAP, the following steps can be used to request an account: 

1. A User may request access to a new INDOT application from the ITAP Menu and from the ITAP 

Home Page itself. 

1.1. Option #1 -To request a new application from the ITAP Menu, select Application, and then 

Request New Application. 

 

  

Request New Application 
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1.2. Option #2-To request a new application from the ITAP Home Page, click on the link “Click 

here to request access to new application”. 

 
Request New Application 

2. Selecting Request New Application from the ITAP Menu or the link “Click here to request access 

to new application” from the ITAP Home Page will display the Application Enrollment panel. 

 

  

Application Enrollment 
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3. In the Application Enrollment panel, select the ProjectWise entry, followed by the DOTWise listing 

underneath it from the left side of the panel.  Application Details and Available Roles (if 

applicable) will be displayed on the right side of the Application Enrollment panel. 

 

DOTWise Application Enrollment 

4. Select the applicable roles for your current position. It is possible to have more than one role, but 

in many cases your primary work assignment will cover your ProjectWise needs.  Please also 

keep in mind that when enrolling in the INDOT ProjectWise system, all INDOT users have read 

only access to all other files in the system.  There is no need to request a role for the sole 

purpose of reading the files.  A role should only be selected for a discipline where you will need 

to actively edit documents. 

5. To complete the application enrollment, select the Submit button on the bottom of the right hand 

panel. 
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6. If the submission was successful, the message below displays.  Click on the OK button. 

 

7. If your account already has a pending request for the application, you’ll receive the following 

message. Select OK to continue.  This indicates that a request is currently outstanding and 

awaiting additional input. 

 

  

Successful Request 

Pending Request 
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Once the request has been completed, you will receive an email with a recap of what has been 

requested.  In addition to this information, it will also contain the name of the business administrator 

responsible for approving the next step in the process. 

 

Note: INDOT CAD Support acts on account requests in the order we receive them, normally in 1 

business day.  For internal users, your request will first need to be approved by your immediate 

supervisor.  If you do not receive a timely response to your account request, please contact 

indotcadsupport@indot.in.gov and we can provide the name of the person who received your 

request.  Please keep in mind however, we cannot circumvent the approval process. 

Upon approval of the application enrollment, two emails will be received. First will be an automated 

email from the ITAP system stating that approval has been granted to the application. The second 

email in most cases will be a confirmation from the INDOT CAD Support staff with relevant 

information including information on getting the software installed for the INDOT ProjectWise system. 

  

Request Acknowledgement 

mailto:indotcadsupport@indot.in.gov
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2.1-4 Request Additional Roles 

To request an additional role(s) for one of your approved applications, click on the link, “Click here to 

request additional roles” in the Application Details panel to display the View/Edit Roles panel.  You 

may be changing groups or need access temporarily to work on a project.  This will require the same 

approval process as when initial enrollment occurs.   

 
Requesting Additional Roles 

In the View/Edit Roles panel, to request a Role, click on the Checkbox under Select next to the Role 

name. A checkmark that is grayed out indicates that particular role is already assigned. 

 Click on the Submit button to submit the request or click Cancel to return to the Main Page panel. 

 
Requesting Additional Roles 
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2.2 ProjectWise Folder Structure 

2.2-1 Overview: 

To maintain standardization, avoid duplication, and provide a better workflow, a Location: 

Designation Number (abbreviation Des. No. will be used throughout remainder of document) based 

project structure currently best suits INDOT’s workflow.  As shown in the image below, when the 

Documents is expanded, there will be a listing of all the District locations, as well as other folders 

that will be discussed later. 

 

 

The INDOT ProjectWise Root Folder Structure 
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2.2-2 Project folders 

Expanding any district folder will display a list of any Des. No. that has been requested under that 

location.  The route number and/or description will be displayed in the description field. 

 
District w/Des. No. 

Each group/discipline will have their folder structure directly under the District\Des. No.  These 

structures are created as needed via the DOTWise Project Creator. 

In the following illustration, a Project containing all currently included disciplines is shown.  

Depending on what stage of the project workflow you’re currently in, it’s possible that very few of 

these folders will exist at a given time, and will be added later in the project development process. 

 
Project w/Disciplines 
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2.2-3 Other folders (Non-District Folders): 

Corridor Development – This group’s data is stored in this location prior to being associated to a Des. 

No.  A corridor development folder also exists under a Lead Des. No when the data is associated to a 

project. 

Construction – This location is for the Construction and Construction Management groups to perform 

non des processes. 

Environmental Services – In addition to the Environmental Services group folder under the Location: 

Des. No., there is also this folder which will contain all Non-Des. No. projects that are exclusive to 

Environmental Services. 

INDOT Workspace – Location of the new Managed Workspace files that used to be located on the X: 

drive.  This also includes the location of InRoads resource files such as the XIN, Drafting Notes, and 

cell libraries.  Unless specifically directed, resources from this folder should not be used. 

INDOTWise Temporary Storage – Data in the folder has been imported into ProjectWise, but has not 

yet been moved to the appropriate project location.  This folder is not visible unless your discipline 

has data within it. 

RailRoads – Location of in-process RailRoad files to be shared amongst the group prior to placing in 

the Des No. project related folder. 

Resources – This folder takes the place of the previous Common folder.  All groups will have their 

own folder for documents which pertain to their group’s operation.  The CAD Support group has also 

created a Design Information folder containing informational documents (formerly DSInfo). 

Right of Way Services – This folder contains the Right of Way Excess ROW Sales information. 

Roadway Services/Traffic – This folder contains Roadway Services/Traffic data that does not apply 

to a Des. No. 

Standards – The Standards group folder is directly under the Documents folder due to their differing 

workflow.   

Technical Services – This folder contains Technical Services/Traffic project data. 

Template Documents – Contains INDOT specific document templates and seed files.  These are 

used throughout the document creation process as needed.  Specific procedures for using these 

documents can be found throughout this book. 

Traffic Safety – This group’s data is stored in this location prior to being associated to a Des. No.  A 

Corridor Development folder also exists under a Lead Des. No. when the data is associated to a 

project. 

Utilities – Location of in-process Utility files to be shared amongst the group prior to placing in the 

Des. No. project related folder. 
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2.2-4 ProjectWise Resources\Documentation Folder 

Under the Resources folder covered in the previous section, there is a Documentation folder.  This 

folder is the location of all CAD Support and other user provided documentation for all users to 

access.  The files in this location range from simple, single process technical notes all the way 

through the full DOTWise manual, along with links to other valuable content such as the INDOT Sign 

Catalog.   

In addition to this documentation, new for the CAD Fall 2019 release, the Peer group has requested 

a number of documentation checklists that can be found under the CAD Process Checklists folder.  

These checklists can be used during the design/plans production process as a quick overview of the 

steps, and as a reference back to this document for the specific processes and how to perform 

them. 

2.3 ProjectWise Security Overview 

2.3-1 Overview: 

The INDOT ProjectWise Datasource (INDOTWise) adheres to a strict security model—providing inner 

discipline security, while providing all INDOT users the ability to review other data as necessary.  In 

addition to these security features, there are additional policies that are used administratively in 

order to provide rapid support and file restorations, should the need arise.  These policies are as 

follows: 

1. Projects will be created by the DOTWise Project Creator.  

2. Users will not have folder delete privileges; this will aid in CAD Support’s and IOT’s ability to 

process restores in a timely fashion. 

3. Document delete privileges will be assigned at management discretion. 

4. Users will no longer be able to adjust the security settings of template folders/projects 

created by the DOTWise Project Creator.   

5. District and Central Office now share a common security group.  Data access and rights are 

based on need and positional responsibilities. 

There is no longer a distinction between Central Office and District users.  For example, instead of a 

Central Office Environmental Services group and a separate group in each district, all Environmental 

Services users have the same rights across all locations and projects.  This is to increase 

collaboration between locations with a minimal need for security adjustment. 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/Resources/Documentation/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Resources/Documentation/CAD%20Process%20Checklists/


 

25  

 

2.3-2 Consultant Access 

At this time, DOTWise access has been made available to the INDOT consultant community via ITAP 

(Section 2.1).  Throughout the project lifecycle, it will be quite possible at the root of the Des. No. to 

see folders named after various consultant firms.  A project containing a consultant folder would look 

like the following: 

 
Des. No. with Consultant Folder 

Any instance where a consultant is placing data into our datasource, the following conditions will 

apply: 

1. The folder will be named with the consultants’ name. 

2. The consultant will only be able to see the data placed in their folder or the Shared sub-

folder. 

3. All INDOT Users will be able to see all consultant data. 

4. The shared folder is provided for all INDOT users to place data they need to share back to the 

consultant (copies are recommended).  Only the intended consultant will see this data. 
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2.4 The DOTWise Project Creator 

The DOTWise Project Creator tool allows internal and external users the ability to create ProjectWise 

projects without modifying the underlying security model.  Depending on the roles/groups you have 

requested and granted access to, you will be taken to one of three interfaces. 

The DOTWise Project Creator interface (Choose Project Type) will look as shown below and will only 

show for anyone that is in the Corridor Development or Traffic Safety group.  Any other groups will be 

taken directly to the Des Number Project interface (i.e. Design or Survey).  This allows for you to 

choose to create a Des No. or Non Des project. 

 

1. By selecting the Project Type from the pull down you will be taken to one of the other two 

interfaces (Des Number Project or Non Des Project) 

 

The DOTWise Project Creator interface (Des Number Project) will look as shown in the following 

step and is for all disciplines other than Traffic Safety and Corridor Development (i.e. Design, 

Survey, Geotechnical, Hydraulics).  The interface for a Non Des Project allows for the creation of 

projects that do not have a Des No. in SPMS.  This functionality is currently only enabled for the 

Traffic Safety and Corridor Development groups for folder placement in their respective folder 

locations outside the District/Des. Structure. 
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2. To create a ProjectWise project, enter a Des Number for the project and click the Click here to 

validate the entered Des Number button. 

 

The application will check to see if the Des Number is a valid Des Number or not. If the Des 

Number entered is not a valid Des Number, a message will be displayed stating that the Des 

Number entered is not valid. 

Note: The DOTWise Project Creator is updated with fresh project information nightly.  If your project 

is not showing as valid, it’s advised to wait 24 to 48 hours for the system to update.  If the folders 

are required immediately, please submit a ticket to CAD Support requesting their manual creation. 
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3. Clicking the OK button will allow you to change the Des Number to a valid Des Number.  If a valid 

Des Number is entered, a message will be displayed stating that the Des Number is valid. 

 

4. Click the OK button and you will see that the Project District Location and Project Route Number 

values are displayed on the form. You will also notice that the User Location dropdown list is 

enabled. 
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5. Select a User Location from the User Location dropdown list.  (Be sure to select the location 

where you physically reside and not where the project is being built).  This will ensure the files 

are stored locally to where you are working).  The Project District location is defined by data from 

SPMS.  

 

The User Discipline dropdown list will then become enabled.  

6. Select the User Discipline in which you are working. 
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If Environmental Services is selected, a User Sub Discipline dropdown list will become visible. 

In this case you will need to select a User Sub Discipline. If a User Discipline other than 

Environmental Services is selected, the User Sub Discipline dropdown list will not be visible 

and you are ready to create the project. 

 

7. To create the project, click the Create Project button. 
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A confirmation message will appear showing that the project is in the process of being created. You 

will also see the project information.  There may be a small delay (1-2 minutes) before the project 

shows in ProjectWise. 

 

8. Click the OK button to start a new project from the beginning. 

The DOTWise Project Creator interface (Non Des Project) will look as show below and is for 

anyone that is in the Corridor Development or Traffic Safety group.  This interface allows for the 

creation of projects that do not have a Des No. 
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9. To create a Corridor Development or Traffic Safety ProjectWise project, enter the Project ID in the 

first field and select the User Discipline from the pull down as shown below.   

 

10. Once completed filling in the information, select the Create Project button 

 

11. The Reset button will take you back to the Start and allow you to begin the process all over again. 
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2.5 Auto-Logins for Integrated Applications 

ProjectWise has the ability to have integrated applications such as MicroStation or Microsoft Office 

automatically log in to ProjectWise with your user credentials.  In prior versions, when attempting to 

use one of these applications from the desktop, you would be prompted for your login information 

prior to being able to communicate with ProjectWise.  This new feature removes that step and allows 

you direct access without being prompted. 

2.5-1 Enabling Auto-Login 

To enable this feature:  

1. In ProjectWise Explorer, go to the “Tools > Network Configuration Settings…” option.  This will 

present you with the network settings for your ProjectWise Client. 

 
Network Configuration Settings 
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2. On the displayed panel, we’re concerned with the 4th tab, iDesktop Auto-Login.  This panel 

shows all the integrated applications that ProjectWise has found on your machine. 

 
IDesktop Auto-Login 

3. To enable the automatic login to your Datasource, you will need to adjust the following.  First, 

highlight the application you wish to have auto-login. Then select the Modify button. 

 
Application Auto-Login Settings 
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4. At this time, you will want to adjust your settings as shown.  These settings will cause your 

client to automatically login your application to the DOTWise datasource with your user 

credentials. 

 
Enabling Single Sign On 

5. Finally, select OK and repeat these steps are necessary to configure auto-login for any 

additional applications.  When completed, your dialog will look similar to the following: 

 
Auto-Logins Enabled 

6. When completed, select Save and close any remaining windows for the Network 

Configuration settings. 
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2.6 ProjectWise and Documentation Notes 

The remainder of the ProjectWise Explorer materials in this document assume that the end user has 

taken the ProjectWise Explorer CONNECT Edition Basics-The ProjectWise Explorer Client Bentley 

Learn Course, or has a functional knowledge of the application in previous versions.  As not to 

duplicate documented materials, any specific processes can be reviewed in the listed training 

material or the online application help under the Help > Contents menu item.  Any other items can 

be sent to INDOT CAD Support as a Help Desk Ticket. 

Note: With the rollout of the ProjectWise Explorer CONNECT Edition, Bentley has changed how they 

refer to the ProjectWise Projects.  To maintain consistency, INDOT CAD will adopt the updated 

naming of Work Areas where we previously referred to Projects throughout this document. 

2.7 Productivity Enhancements 

2.7-1 Utilization of the Data Warehouse (Work Area Properties and Environments) 

The Data Warehouse is INDOT’s internal data repository with the vast majority of project-related 

information provided by the many systems within the agency.  Several departments within MIS at 

INDOT (GIS, CAD, and SPMS) have worked as a team to ensure that the information provided within 

the Data Warehouse is correct and updated in a timely manner.  By bringing together all of the data 

that these systems provide, ProjectWise can use this data in a variety of ways in both the CAD 

environment (e.g., populate Title Sheets) and also within ProjectWise interface (e.g., Work Area 

Properties). 

As a major enhancement to the available functionality within the INDOT ProjectWise datasource, 

we’re now providing metadata fields for all major disciplines that are part of the project development 

process.  At this time, all Work Areas will have at least a Des. No. and archival field at the Work Area 

level and the Des. No. field at the document level.  These placeholders have been put in place to 

allow the ability to add metadata to existing documents as the datasource functionality evolves over 

time. 

2.7-2 Features for all Work Areas 

• Separate Environments:  There are now specific Environments for each area of a project.  As 

described below, this allows us to streamline the data available to each work group. 

• Documents Properties to populate sheet models:  One of the major changes in Version 2.0 of 

the INDOTWise workspace was the shift from populating sheet models with project properties 

to using document properties to perform this function.  The major factor in this change is the 

fact that it allows users to utilize searches based on document attributes.  This functionality 

has not changed for this release. 

• Similar Interfaces: Through the use of environments, we were able to minimize the number 

of interfaces available while still providing the customization needed between different work 

groups. 

2.7-3 Workflows and States 

At this time, ProjectWise is currently enabled to send documents to ERMS directly for the Design 

discipline, and archive for all disciplines.  To facilitate this functionality, all disciplines now have 
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workflows and states available which can be used as document flags when specific milestones have 

been met and documents need sent to ERMS. 

As this is an evolving process, most workflows only contain an initial, interim and archival state as 

shown: 

 
Default States for Each Workflow 

The Design Workflow contains far more steps, as will be discussed later in this chapter. 
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2.8 Work Area Properties 

2.8-1 Overview: 

As discussed previously, projects will be created via the DOTWise Project Creator.  After the Work 

Area is created, Work Area properties will be editable by the person(s) responsible for the project.  

There are a few variables that are populated using the data warehouse in the Work Area properties.  

Others will need to be populated by the responsible parties.  

 All items populated using the Data Warehouse are driven by the Designation Number.  If the 

Designation Number changes, all information will change along with it. 

 
INDOT Work Area Properties 

 Contract Number, Survey Book, Project Number and Bridge File information is still populated in 

INDOT border sheets using Project Information.  Please make sure that this information is populated 

in the “Design” Work Area Properties dialog box. 

At the time of the writing of this manual, the functionality to populate some of the above described 

Project Properties does not exist and they will have to be keyed into the Work Area Properties dialog 

box. 

To access the Work Area Properties dialog box, highlight your project by left mouse clicking on your 

project in the datasource tree in ProjectWise Explorer.  Then in the ProjectWise Explorer toolbar, click 
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on Folder > Properties.  Alternatively, it can also be accessed by right clicking on the Work Area in the 

datasource tree and selecting Properties. 

 

 
Accessing Work Area/Folder Properties 

To simply view your current Work Area properties, left click on your project in the datasource tree.  

Your Work Area Properties will be displayed in the Properties window located in the bottom right 

portion of the ProjectWise Explorer. 

 
Work Area Properties Tab 



 

40  

 

For a complete description of the Work Area Properties dialog box, and the various tabs contained 

within, please see the sections titled “Folder Properties” and “Work Area Properties” in your Bentley 

Institute, ProjectWise Explorer CONNECT Edition Basics-The ProjectWise Explorer Client Bentley 

Learn Course or under the Help>Contents menu in ProjectWise. 

2.8-2 Modifying Custom Properties 

You can add or edit the custom Work Area properties at any time via the Properties tab on the Work 

Area Properties dialog box. 

 
Work Area Properties 

Any of the items under this tab (including the Work Area Type) can be edited by either entering text, 

or in certain cases, by using the pre-populated pull down menu. 
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2.9 Creating New Documents 

The creation of new documents is covered in the Bentley Institute Course Guide via BLN, titled 

ProjectWise Explorer CONNECT Edition Basics-The ProjectWise Explorer Client.  The following section 

covers the specifics of creating a document using the INDOT provided seed files.  For other 

document creation processes, please refer to the BLN material for specifics or the ProjectWise 

application help. 

2.9-1 Creating Documents from ProjectWise Seed Files 

When creating a new document within the INDOT Workspace, the user will need to know a few items: 

• The location of the Template Documents for SS2 (Documents\Template Documents\Seed). 

• The location of the Template Documents for SS4 (Documents\Template Documents\SS4 

Seed) 

• The type of document creation wizard (Advanced or No). 

• The location where the file needs to go. 

Note:  These steps apply for any document created from a pre-existing file in the ProjectWise 

datasource, including those for MicroStation, Office or otherwise. 

 
Template Documents 

With the template documents located, we need to start the document creation process.  Within the 

folder you’d like to create the document in, either Rt. Click in the document panel and select New -> 

Document, or access this from the Document window.  If you’ve previously defined a wizard, you may 

be shown a blank document panel; for this example, however, the assumption will be made that no 

default wizard has been set.  Upon starting the New -> Document command, you will be prompted 

with the following dialog: 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/Seed/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/
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Document Creation Wizards 

Select the option for Advanced Wizard as illustrated in the prior screenshot, which will begin the 

Advanced Document Creation Wizard and the accompanying steps.   

Note:  It is highly advised that the user NOT check the “Make this wizard the default” checkbox. 

On the Select a Template dialog box, enable the Use ProjectWise document as a template radio 

button, and then click Select. 

 
Advanced Document Creation 
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Then, in the folder selection area of the following dialog box, navigate to Documents\Template 

Documents\SS4 Seed\MicroStation\ and select one of the available DGN seed files. 

 
Selecting a Template Document 

The following can also be found via the BLN Bentley Institute Course Guide Titled ProjectWise 

Explorer CONNECT Edition Basics-The ProjectWise Explorer Client. 

“A ProjectWise template is the same as a Microsoft template, or a seed file in MicroStation.  It is a 

file that is copied to create a new document.  You can use a document stored in ProjectWise or a 

document that resides outside ProjectWise as a template.” 

With that being said, there have been Template Documents created within ProjectWise for most of 

the integrated applications/programs used at INDOT.  These include Microsoft Office, MicroStation, 

ProjectWise Plot Organizer and the Microsoft Excel spreadsheet tables that are pasted as links into 

MicroStation. 

Note:   Be sure to give the proper file extension for the document you are creating. 

Example File Extensions 

File Type Extensions 

MicroStation .dgn 

InRoads SS4/PowerInRoads .dgn 

ProjectWise InterPlot .ips 

Adobe PDF .pdf 

Microsoft Word .doc or .docx 

Microsoft Excel .xls or .xlsx 

 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/
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2.9-2 File Associations with the SS4 Workspace 

As you may have noticed in the above section, InRoads SS4 and PowerInRoads both use .dgn as 

their file extension.  This is due to how both products now operate and launch.  As such, the file 

extension alone is no longer sufficient to determine what application will load when started.  For this 

we must look at the application association for these files.  The below screen capture was generated 

from the document properties dialog through the Document > Properties menu item or by right 

clicking and selecting properties. 

 

In the previous screen capture, you’ll notice that the Prplan 50.dgn is now associated directly to 

InRoads SS4.  This is very important going forward.  If you wish to access a file with InRoads SS4 or 

PowerInRoads, the application association must be set to the relevant product.  This will affect if 

these applications launch and the workspace information they launch with. 

• PowerInRoads must be associated with the application of the same name. 

• InRoads/OpenRoads SS4 must be associated with the InRoads SS4 application. 

Note:  For the period of time that INDOT is running both SS2 and SS4 products, file associations will 

be very important.  For any file you wish to use with the SS4 workspace, please associate these with 

InRoads SS4; and for those using the SS2 workspace, they should be associated with PowerInRoads 

SS2.  This includes any regular drawings that do not contain civil data.  There is no issue with using 

Power InRoads for drafting processes. 

2.9-3 Importing Documents into ProjectWise 

During the course of a project, it is inevitable that you will acquire documents that are not contained 

within ProjectWise.  Importing a Document into your ProjectWise Project can be accomplished a 

couple of different ways. 

You may receive these documents via email, or CD/DVD, or they may reside on a network server.  
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2.9-3a Drag and Drop 

The simplest method for moving a file or files into ProjectWise is to simply use the Microsoft 

Windows method of dragging the file from its current location and dropping it into the appropriate 

project folder in your ProjectWise Explorer. 

1. Using Windows Explorer, navigate to any document you wish to place into ProjectWise 

2. Select the files as shown in the example. 

 
Selecting Files in Windows Explorer 

3. Using Microsoft Windows methodology, drag the selected files and drop them into the 

appropriate folder of your project. 

 
ProjectWise Project 
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4. Since the documents have already been created, you may select No Wizard in the Select a 

Wizard dialog box.  Click OK. 

 
Document Creation Wizard Selection 

5. After processing, the files should appear in the Documents folder of your Project in 

ProjectWise Explorer.  If they don’t appear during the import process, you may need to 

refresh your view either by using the View > Refresh command, or by using the F5 key on the 

keyboard. 

 
Files Imported into ProjectWise 

Note:  When dragging and dropping files into ProjectWise, you’re only making a copy of these 

documents in the ProjectWise datasource.  If you no longer need the copies you imported, you can 

delete them at this time from the Windows Explorer. 
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2.9-4 Creating Folders and Copying/Moving Documents 

Note: Moving documents in ProjectWise is considered a two part process.  The first is copying the 

document, and the second is the deletion of the original file.  In order to move files within the 

system, you must have the document delete privilege on your account; otherwise, you will only be 

able to move files. 

1. In the datasource tree of ProjectWise Explorer, right click on the Documents folder for your 

project, and select New Folder. 

 

Creating New Folders 
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2. In the Create Folder dialog box, name the folder.  You may leave the Description field blank. 

Once complete, select OK to create the folder and go back to the ProjectWise Explorer or Add 

to create the folder and be presented with the folder properties. 

 
Create Folder Dialog 

3. To the copy/move your documents, select the documents using typical Windows selection 

methods (CTRL key + Click to select multiple individual files, or SHIFT key + Click to select a 

range of files). 

 
Multiple File Selection 
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4. At this time, right click and hold on one of the selected files.  Drag from the Document Panel 

to the folder location in the Folder Tree where you want to move the files. 

 
Right Click and Drag 

5. When hovering over the folder to place the files, release the right mouse button.  You will be 

presented with the below menu: 

 
The Copy/Move Menu 

  



 

50  

 

6. Select the appropriate movement method for your files.  Please keep in mind the note from 

the beginning of this section regarding moving files and the necessity of having the 

Document Delete privilege.  

2.9-5 Save and/or Save As 

Should you create a document such as a Word or Excel document without first creating it in 

ProjectWise, you can use the Save and Save As commands to save that document into ProjectWise. 

1. Start Microsoft Word or Excel from your Start > All Programs menu. 

2. Place some text in the document. 

3. On the product ribbon, click File and select Save As.  You’ll be presented with a series of 

options similar to the following.  Select the ProjectWise entry and the Browse button. 

 

 

Office Application Save As 
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4. You should get the ProjectWise Login dialog box.  If you are connected to the INDOT network 

(via direct network connection in the office, or VPN) the following steps can be used.  In the 

Datasource dropdown, select the INDOTWise entry.  Then select the Use Windows Single 

Sign-On for authentication option. 

 

ProjectWise Log in Via Integrated Application 

If you’re connected externally via laptop without VPN, the following information should be 

used: 

Datasource: INDOTWise (this should be populated in the pull down) 

User Name: dot\your INDOT username 

Password: your INDOT password 

5. In the Select a Wizard dialog box, select No Wizard and click OK. 
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6. In the following Save Document As dialog, click Select and navigate to the folder in your 

project where you want to save the document. 

 
External Application ProjectWise Save As Dialog 

 

Save As Folder Selection 

7. Fill in the remainder of the dialog boxes in the Save Documents As dialog box.  For ease of 

navigation, we suggest that you put the extension on the Document name as well as the File 

Name.  The application window should be automatically populated.  The Department drop 

down is optional. 
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8. Click Save.  When prompted, enter any comments relevant to the placement of your file into 

ProjectWise and select OK to complete the file saving process. 

 
Document Comments 

Attention:  Upon importing a CAD document (DGN, DWG, etc.) with references into ProjectWise 

Explorer you will want to run the Reference Scan on the file(s) that you imported.  Further 

information on the Reference Scan tool can be found in the Help>Contents of ProjectWise. 
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2.10 Interfaces: The Plan Production Environment 

The Environments and Interfaces discussed in the following chapters are intended to be in a 

constant state of improvement.  Therefore, if you require an addition or change at any time, please 

channel those requests through the proper personnel (CAD Peer Group Members) so that we may 

attend to them in a timely manner. 

Helpful Hint: By setting your interface before you create a new document, you can complete that 

interfaces task during the document creation process. 

2.10-1 Document Properties 

As with the Work Area Properties, there is information in the Document Properties that is populated 

utilizing the information contained in the Data Warehouse.  As mentioned earlier, this information is 

driven by the Designation Number that is entered in the Work Area Properties. 

2.10-2 __PROJECT INFORMATION 

Each project within the INDOTWise datasource will contain a non-associated (no extensions, For 

Information Only) document labeled “Project Information.”  This document, along with the __Project 

Information interface, can be used to view information that was retrieved using either the SPMS 

system or by going to the Management Information Portal (MIP). 

 
Design Folders w/Project Information Document 

In the Plan_Production Environment however, the __Project Information interface can and should be 

used for much more than just reporting information that can be accessed in other locations. 

  



 

55  

 

2.10-2a __PROJECT INFORMATION Interface, Attributes Tab (Universal Title Sheet) 

The Universal Title sheet is intended for use with ALL Title sheets.  Please keep in mind that while 

driven from the INDOT Data Warehouse, it is possible and acceptable to have empty fields in your 

properties.  This means that if you do not have information for a certain field in the interface, then it 

is acceptable to leave that field blank.  (Example:  Bridge information on a Roadway project) 

To access the Universal Title sheet, set your Interface to __PROJECT INFORMATION and go to the 

properties of the applicable file.  (Hint:  The shift bar is a shortcut to document properties.) 

 
The _PROJECT INFORMATION Interface. 

 
Opening Document Properties 
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On the Document Properties dialog, select the Attributes tab. 

 
The Universal Title Sheet Interface 

This interface has been created with the intention that it should serve every title sheet in use by 

INDOT Design.  This includes 24” x 36” Roadway and Bridge Title sheets, as well as the 8.5” x 11” 

Title sheets. 

Note: In the title bar of the previous screen capture, notice the [Unsaved default values].  This 

denotes that the document is pulling all its properties directly from the configured system queries.  

At this time, any changes to Work Area properties would be immediately reflected at the document 

level.  Once any value is modified, this notation will be removed and any document updates will have 

to occur manually using the document Update field discussed in the next section. 
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2.10-2b __PROJECT INFORMATION Interface, More Attributes Tab (Project 

Information) 

The More Attributes tab provides some of the information that would otherwise be found in the Data 

Warehouse or SPMS.  This is provided for your convenience.  However, there are a few fields to take 

note of: 

 

More Attributes 

Document File Name:  This is provided as an additional resource for INDOT users to cut and paste 

the document file name into a problem report.  

ERMS Document Type:  This field is used for the ProjectWise to ERMS document upload tool and is 

discussed in section 2.10-6: ERMS Upload. 

Update Project Info:  The More Attributes tab is set up in such a manner that all fields should update 

automatically.  However, there may be a time that the user wishes to make sure he or she has the 

most current information.  In that case, simply select “UPDATE” in the editable field (pull down), then 

select “Save” from the dialog box. 
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2.10-3 __SIGNATURE 

Use of the __SIGNATURE interface is discussed in Chapter 4 of this manual 

2.10-4 REVISIONS 

The REVISIONS interface is tied to the sheet revision blocks, and allows for quick entry into the fields 

provided without having to use MicroStation to modify this information.  It appears as follows: 

 
REVISIONS Interface 

2.10-5 DRAWN/DESIGNED/CHECKED BY 

Due to the ability to create multiple sheets in one .dgn, the Title Block Integration for this interface 

has been removed from the INDOT sheet models.  However, for those that wish to take advantage of 

this functionality, we have provided a methodology for using this interface.  By default, some of the 

InRoads sheets do contain this functionality, so please verify whether or not your file has these fields 

prior to replacing them. 
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2.10-6 ERMS Upload 

This is a new Interface for use with the ProjectWise to ERMS tools discussed in section 2.23.  This is 

an informational interface used to give the user information on who the last user was to send the 

document to ERMS, when it was sent, and what state the document was in when sent. 
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2.11 Title Block Integration 

2.11-1 Overview: 

Due to the move from using Project Information to populate our title blocks to using document 

interfaces, there has been a new task bar developed in MicroStation to allow for use of some of our 

Title Block Integration cells (tag sets). 

The new task bar is titled Title Block Integration and can be found under the INDOT Tools workflow: 

 
Task Navigation – Title Block Integration 
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The Title Block Integration task bar consists of only two tasks: 

 
Title Block Integration Tools 

• Attach Cell Library:  This attaches the “Title Sheet Integration” cell library, which in turn 

contains 5 cells for use with the various interfaces available.  

• Update Title Block: This updates all title block information driven by document interfaces.  

2.11-2 Title Sheet Integration Cell Library 

The Title Sheet Integration Cell Library consists of 5 cells.  The orientation of these cells is set so that 

they are placed in the lower right corner of the large “D” size sheets. 

 
elect_sig_box 

The elect_sig_box cell is intended to be used with electronic signatures.  The process of utilizing 

electronic signatures is discussed in detail in Chapter 4. 

 
Signature Placeholder 
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2.11-2a Drawn By/Designed/Checkedby 

The checkedby cell is intended to be used with the DRAWN/DESIGNED/CHECKEDBY interface and 

the Plan Production environment within ProjectWise. 

 
Drawn By/Checked By Cells 

 
Drawn By/Checked By Interface Selection 

 
Drawn By/Checked By Interface 
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2.11-2b revisions 

The revisions cell is intended to be used with the REVISIONS interface and the Plan Production 

environment within ProjectWise.  

 
Revisions Cell 

 
Revisions Interface Selection 

 
Revisions Interface 
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2.11-2c sht_num 

The sht_num cell is intended to be used with the automatic page numbering feature available 

through ProjectWise InterPlot Organizer. 

2.11-2d signature 

The signature cell is intended to be used with the _SIGNATURE interface and the Plan Production 

environment within ProjectWise.  Further instructions on the use of this feature are in Chapter 4 of 

this manual. 

 
Signature Cell 

 
Signature Interface Selection 

 
Signature Interface 
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WARNING:  With the exception of the sheet_num cell, all of the cells contain tag sets with very 

distinctive names.  Placement of the cells in sheet models that already contain these tags—or 

placing duplicate cells in sheet models—may result in these cells not working.  If you have issues of 

this type, please contact CAD Support via a Help Desk ticket. 
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2.12 ProjectWise Interfaces and Special Character Integration 

With the DOTWise 3.1 (Fall 2012) release of the CAD Workspace, non-True Type fonts are no longer 

available for use in the CAD Environment, with the exception of the SignCAD fonts.  Users will notice 

that all fonts will now appear in the font drop-down list within MicroStation preceded with a TT 

whereas in the past their names may have been preceded by the Bentley B. 

Also with this change, a number of special characters are not directly available for use in certain 

ProjectWise Interfaces, although they may be accessed as Windows special characters.  One 

application in particular is the Universal Title Sheet interface (section 2.9-2a) in ProjectWise as it is 

used to place the project latitude and longitude on an INDOT title sheet. 

In general, in order to place a special character when no Insert Symbol command or shortcut is 

available, users must hold the ALT key and type a series of digits from the number pad (the primary 

keyboard number row will not work in combination with the ALT key).  In the case of placing the 

degree symbol in the latitude and longitude values, the key-in sequence is ALT+0176.  See the table 

at the end of this section for a listing of common windows special characters. 

Example:  For 6 degrees 23 minutes and 23 seconds you would type 6[ALT+0176]23’23” to obtain 

the result shown below. 

 

MicroStation will then process the degree symbol and place it where called by a tag on one of the 

template title sheets, as shown below. 

 

Special Characters 

Symbol Key-In Description 

° ALT 0176 Degrees 

± ALT 0177 Plus or minus 

¼ ALT 0188 Fraction: One Fourth 

½ ALT 0189 Fraction: One Half 

¾ ALT 0190 Fraction: Three Fourths 
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2.13 ProjectWise Views 

ProjectWise views control the display of documents and columns that you see in the ProjectWise 

Documents panel, and can also influence what is displayed in the Preview panel when looking at 

Document Properties.  Views can control the display of a number of different items from various 

document properties such as creation and modification dates, to Environment/Interface specific 

pieces of data such as specific document attributes.   

Views can be accessed by right clicking on the ProjectWise Explorer menu bar and making sure the 

View entry is checked. 

 
Enabling Views 

This will display the View toolbar: 

 
The View Toolbar 

When selected, the View toolbar will show the views that have been created for the datasource, or 

any you may have created.  In most instances the view will be set to INDOT Default which covers the 

display of a number of default columns: 

Document Name Document Updated Time 

File Name Out to 

Document Description Created Time 

File Size Created By 

File Update Time Folder ID 

File Updated By Version 

Folder Storage Storage 

Folder GUID Local File Directory 
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Having these features enabled in the system default view allows for most of the relevant information 

to be displayed about the files, and additional information that’s useful in troubleshooting.  Again, 

this view has been set for the entire datasource unless one is specified for a particular area. 

In addition to the INDOT Default View, there is also an ERMS Upload Document Status for each 

discipline in the system.  This view for instance shows the last user to upload a document to ERMS 

from ProjectWise, the state it was in, and when it was sent. 

End users can also create and modify their own view, which is covered in the next section. 

2.13-1 Custom Views 

In some instances, it may be desired to have a view tailored to a specific set of data or a personal 

view with more information than the INDOT Default covers.  This section will look at how to create 

and use these views. 

When creating/editing custom views, you can go to View -> Manage Views from the ProjectWise 

Explorer menu.  

 
Manage Views 

This will take you to the Manage Views dialog.  In the example below, you can see that a number of 

views have been created under this account for various purposes.   

 
Manage Views 
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A new view can be created by selecting the New button in the upper right corner.  On the Create View 

dialog, you can then begin populating the view with available datasource columns. 

 
Create View 

To create a view, you need to first give it a name in the View name field.  After that, it’s a matter of 

adding the relevant columns to your view.  The initial view creation will give you Name, Description, 

and File Name.  From that point you can then add a number of different columns with information 

from the system.  On the Create View dialog you can add information from four areas: 

• Basic Columns – These are system columns for document information, which includes items 

such as modification and creation dates, version information, and a number of other items. 

• Folder Columns – This can display information about the documents parent folder, including 

any information about its dates, storage area, etc. 

• Environment (Plans_Production in this example) – These are the fields that contain 

document properties specific to the discipline you’re working in.  For example in Design, this 

could include Spec Years, Project Manager, etc.  Anything that is part of the Document 

Attributes or More Attributes will show up under this option. 

• Work Area Properties – This allows for adding any of the properties assigned to the parent 

work area. 

With these, you can tailor a view to the specific columns of information you want displayed while 

working in the system.  Should you need to Modify/Delete the view, you can use the commands back 

on the Manage Views panel. 
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With custom views, you may wish to override the INDOT Default as the default view for the system to 

one of the ones you’ve created.  To do so, go into the View Properties (highlight the view, select 

Modify).  On this panel, you’ll see two tabs.  Select the Set Defaults tab. 

 
View Properties – Set Defaults 

On this panel, you can set the selected view as your default for any folder document view or preview 

pane using the Datasource section.  The same can be done for Search results, or individual folders 

or Environments. 
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2.14 Versioning 

Versioning is not officially supported by INDOT CAD Support but is available for power user use.  For 

more information on versioning and how to use it, please refer to the application help and the 

Working with Versions section. 

To identify documents that have versions, you may see multiple copies of the same file in the same 

folder.  If you have edit access, one of these will show the icon (pencil) denoting it’s an editable 

document, and the rest of the copies will be denoted by the read only document icon (open book).  If 

a user does not have edit access, all copies of the document will be denoted as read only.  The 

copies with the read only icon will be the versions.  Depending on the user, they may or may not use 

a specific versioning scheme. 

 
Document with Versions 

At this point, using the INDOT Default view, if you scroll to the right, you will see a column for version 

which looks like this for the above documents. 

 
Versions naming displayed in the Document Panel 

Again, this is not officially supported functionality, but these methods will allow you to identify 

documents that have versions and if you need clarity from the document provider as to what’s the 

most recent or if they’re asking you to view older versions. 
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2.15 Revised Template Sheet Models 

To reduce duplication and ease navigation, we have split up sheets_eng.dgn into two separate files. 

D size_sheets.dgn:  All 24 x 36 (D size) sheet models now reside in this design file. 

Ltr_sheets.dgn:  All 8.5 x 11 (letter size) sheet models now reside in this design file. 

In addition to separating the large format sheet models from the smaller ones, MicroStation’s ability 

to convert units on the fly has allowed for the metric versions of these sheet models to be removed. 

2.16 Searching  

As with the previous version of ProjectWise, searching plays an important role in interacting with your 

documents on a day to day basis.  Searching via the Search Form or Search Builder has not changed 

significantly in this version.   Supplemental information can be found in the application help file, or 

on the Bentley Learn Network course referred to earlier in this chapter. 

2.16-1 Search Form, Search Builder, and Searching for Document and Work Area Data 

ProjectWise allows for searching on Work Area and Document metadata from the various interfaces 

we’ve discussed thus far.  In order to search for this data, we will need to use the Search Form with 

the appropriate Environment and Interface selected. 

 
Starting an Advanced Search 

• Select your folder via a right-click and navigate to Advanced Search: 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/DGN/D%20size_sheets.dgn
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/DGN/Ltr_sheets.dgn
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• You will then be prompted for the search method you would like to use.  For this example, we 

will be using the Search Form.  You could also select the Search Builder should you prefer to 

perform your search in a different method.  At this time, you may also define one of the 

methods as your default search style.  Should you need to change this setting, you may 

adjust the options under Tools > Wizard Manager and selecting the Search Definition Tab.  

 
Selecting a Search Type with the Search Form 

• Once in the Search Form, you will need to define the Environment you’re searching in.  This is 

done by adjusting the Environment Name area in the Folder portion of the panel.  In the 

following illustration, we are showing a selection being performed on documents in the 

Plan_Production environment.  It is NOT required that you toggle “Find in this Environment 

only” for these searches, however it is recommended.  Should an identically named attribute 

be present in a different environment and have information that is the same as what you’ve 

searched on, it will be returned as a valid result.  

 
Folder and Environment Definition 
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Searching Title Sheet Attributes 

 
Searching More Attributes 
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• Once you’ve selected the environment you’d like to search with, you will then navigate to the 

Attributes or More Attributes tab (This is dependent on the environment your document’s 

use.  Further information is provided in the first section of this document) at the top of the 

Search Form.  On this panel, you will see the attribute layout for the environment.  For this 

example, we’re looking at the INDOT Universal attribute layout for Plan_Production.  

Note:  Unlike the document attribute panel, the Search Form version of this panel has no locked 

fields.  This is to allow you the ability to search on any field available and retrieve documents that 

have the information you need. 

 
Format Criteria for Searches 

At this point, you will then be able to search for documents using any available field on the Attribute 

Panel.  As a reminder, you can use Format Criteria on any field in order to perform more intelligent 

searches.  You can do this by right-clicking any field as shown and selecting Format Criteria. 

As you complete the setup of your search, you may then execute the search, or proceed to save it 

and re-use it as necessary.  The default behavior for saved searches is to associate them with the 

project you’re currently working in.  Should you wish to adjust this, you will need to browse to the 

ROOT level in the location browser.  This will allow you to save your own personal searches that are 

not associated to a specific project. 
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2.16-2 Saved Searches 

Within ProjectWise, pre-configured saved searches are now being provided.  At the district level, 

Saved Searches that relate to each Discipline are provided; such as Survey, Design, etc.  Under each 

Des. No., searches are provided for a variety of document types and time last modification times.  

These are basic searches over the entire project but will allow for a quick access to information 

within. 

 
District Level Saved Searches 
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Note:  When performing saved searches, we recommend you push the output to a new window.  You 

can do this by right clicking on the saved search and selecting Start Saved Search in a New Window 

as shown: 

 
Running a Saved Search to a New Window 

This will provide a secondary window with your search results, allowing for the ability to browse both 

the datasource and your search at the same time. 

  



 

78  

 

2.17 Custom Folders 

With the current folder structure being used in ProjectWise, all users will see the full list of active 

projects across the agency.  In order to ease browsing through this data to get to the project you 

need, Custom Folders have been enabled for your use. 

In your document tree you will see an entry for Custom Folders underneath the Documents folder: 

 
Custom Folders 

The Custom Folders can be thought of as a “Favorites” for ProjectWise.  By using these folders, you 

can virtually bookmark your project in the datasource allowing for fast access without the need to 

drill into the datasource to find it.  When linking to documents or full Work Areas within the 

datasource, all data in that location is virtually linked back to the location of files/Work Area in 

ProjectWise.  As this is a live link to the original data, all rights in regards to folder/document 

creation/deletion apply.   

Note:  Be extremely careful when using the Delete command within Custom Folders.  While behaving 

similar to a web browser’s favorites, any document action you perform in the Custom Folders will 

occur to the document itself, of which deletion is the most destructive.  Do not use Delete to remove 

a file from your Custom Folders as it will completely delete the file should you have permissions.  

Instead, use the Remove from Folder option if applicable. 

The following steps will walk you through the steps of creating a set of Custom Folders and linking to 

your data. 
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2.17-1 Using Custom Folders 

1. In ProjectWise, navigate to the Custom Folders and expand them.  Right click on Personal 

Folders and select create: 

  
Creating a Custom Folder 

2. When prompted, create your personal folders.  Some possible custom folders you may wish 

to have are for active projects, region projects, or for resource documentation. 

 
Creating a Custom Folder 

3. Once you’ve created your folder, it shows up under the Personal Folders in ProjectWise.  This 

folder is one only you can see, so each person will need to setup their Custom Folders 

however benefits them the most. 
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4. At this point, you’re now ready to begin populating your Custom Folder.  You do this by 

dragging and dropping anything you’d like into the Custom Folder of your choosing.  This will 

create a live link to your data. 

 
Dragging a Folder/Document into Custom Folders 

5. Should you wish to remove any link from your custom folder, right click on the project/file 

and select Remove from Folder.  This will remove the link without modifying your data.  Any 

other method of deletion/removal will delete your data depending on your permission levels. 

 
Removing an Item from Custom Folders 



 

81  

 

2.17-2 Agency Global Folders 

With the 2019 Fall release of DOTWise, the INDOT CAD Support group has added an INDOT CAD 

Support entry under Custom Folders\Global Folders\CAD Support.  This folder has been added for 

end users to quickly locate a number of commonly used resources such as Documentation, Plotting 

Files, Template Documents, and WMS Imagery without having to navigate throughout the folder tree 

when trying to reach these resources.   

 
CAD Support Global Folders in ProjectWise Explorer 

 
Global Folders when Browsing in an Integrated Application 
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2.18 Applications Without ProjectWise Integration 

As has been discussed, ProjectWise provides a managed environment for working with your 

documents and data.  It achieves this through a combination of file operations and application 

integration with applications such as MicroStation, ProjectWise InterPlot, and Microsoft Office 

applications.  The user experience with these applications is almost transparent as the direct 

application integration allows the user to open/modify/save files directly to and from the ProjectWise 

datasource. 

What happens with applications that are not integrated, though?  This section will explain the events 

that happen and procedures that will need to be taken to work with a small subset of the 

applications that are used by Production during the Project Lifecycle. 

Currently, there are a few non-Bentley applications that are being used at INDOT that do not have 

native ProjectWise integration (i.e. MathCAD, SignCAD).  If you have questions about a particular 

application you are using and its integration with ProjectWise, contact CAD Support. 

As these programs lack ProjectWise integration, you may have to perform additional steps to retrieve 

your data and then work with it.  In the following sections, we will discuss the options available to 

work with these types of data. 

2.18-1 Working with Non-Integrated Applications 

ProjectWise allows two ways for the end user to work with applications that are not integrated with it.  

The first way is by providing a semi-managed/integrated environment.  In this instance, ProjectWise 

relies on the file extension to guess what application the file should be opened in. 

Warning:  The following procedure only works with single files.  Applications that rely on more than 

one file, or a master file and multiple data files will need to be handled in a different manner that is 

discussed later in this section. 

For example, we’ll examine the behavior of .log files.  Outside of ProjectWise, when a .log file is 

opened, it will automatically start Notepad, as Windows Explorer knows that this is the application 

that should be used.  In the ProjectWise environment, you will see similar behavior.  When a .log file 

is opened from the ProjectWise environment, you will be prompted with the following: 

 
Open Document With Dialog 
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Note: It’s possible that more than one application is eligible to open files of a specific type.  As 

shown in the previous illustration, in addition to NotePad, RM Log File is also an installed application 

that can open this type of file.  If presented, you will need to determine the appropriate application 

to proceed. 

ProjectWise communicates with Windows Explorer to check what application it should open the file 

with.  In the case of .log files, ProjectWise finds that Windows Explorer wants to open the file with 

Notepad, so it makes the same assumption.  This is not static behavior, however.  As shown in the 

previous illustration, ProjectWise first prompts you via the “Open Document With” window.  

Additionally, you are also provided a Browse button; you may manually define the application you 

wish to open the file with.  The applications listed in this option are a list of commonly available 

applications on the computer you’re working at. 

 
Selecting an Application to Open With 

Once satisfied with the application selected to open the file, you may then work with it normally. 

While working in the application, you will notice some differences from working in an integrated 

application.  When you perform save/open operations in a non-integrated application, you will not 

receive the ProjectWise dialog windows, but rather, the standard Windows Explorer ones.  This will 

also be true for any file operation command that would prompt you with similar options such as an 

import/export, an attachment, or a link. 
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Note: When performing non-integrated file operations, these applications will typically display the 

path to the file in your local ProjectWise working directory.  You should not attempt to directly access 

the files at this location, or manually edit or modify them.  It is possible to get your data out of sync 

with the server and to lose data. 

As you complete work with the file, you are then ready to check the document back in.  ProjectWise 

remembers the application that opened the file and maintains knowledge of its status as you’re 

working on them.  When you’ve completed work, you will need to save your file, and then exit the 

application.  As the application closes, ProjectWise will see that work on the file has completed and 

will then prompt you to check the file in. 

 

Document Check In 

It should be noted that this will only happen when the application is closed, as ProjectWise only 

maintains knowledge of the application and not the file operations (Save As, File -> Close, etc.) 

performed within it. 

Note: When working with documents that use a single session for all documents of that specific 

type, it’s possible for ProjectWise to not automatically prompt for file check in when one of the files 

is closed.  The system maintains knowledge of the application in whole, and a single file closure will 

not be enough to trigger the check in.  It will display once the entire application is closed.  

Alternatively, you can use the Local Document Organizer to check those files in. 
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2.18-2 Working with Documents of an Unknown Type or Multiple Files 

As shown in the prior example, ProjectWise is very flexible in maintaining control over applications 

when working with single files.  For applications that rely on multiple files, a master file and 

additional data files, or a single file that does not have an application association, a different 

procedure is required. 

For files that match the preceding criteria, you will need to use the document export tools within 

ProjectWise.  The document export process is a ProjectWise-managed process that places files in a 

location of your choosing, while maintaining knowledge of these files for re-import at a later time.   

For this example, you can use any small group of files.  To start the export process, select the files 

you wish to export and select the Export option by right clicking on the files, or selecting the option 

from the Document menu. 

 

The Document Export Command 

This will start the ProjectWise Document Export Wizard; the first panel is information and may be 

skipped.  On the second panel, you are prompted to select the method with which you’d like to 

retrieve your document.  The two options presented are Export and Send to Folder.  To maintain a 

semi-managed environment, we will be selecting the Export option as it allows ProjectWise to 

maintain knowledge of the exported file and allows for later re-import.  The Send to Folder option 

should only be used when you want to create an unmanaged copy--which causes ProjectWise to only 

make a copy of your file locally with no method of re-import. 

On this panel, you also need to select the folder where you’d like to export the files.  When selecting 

this location, you must make sure that you select a location that is consistent and predictable.  If you 

do not specify locations in this manner, the potential for data loss exists, or the possibility of 

overwriting data.  For the example shown here, the path of C:\Projects\Test has been chosen.  

During production use, this would translate into the Des. No. and route of the project you are 

exporting files from.  This gives you an easily identifiable container to place your files while working 

on them. 
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Once you’re satisfied with the export location and any potential comments you’d like to be recorded 

in the Audit Trail, you may then select the Next button. 

 
Document Export Wizard 

The documents will be exported from ProjectWise and their icons will change to denote that they are 

exported. 

 
Completed Document Export 

You’re now free to work on the files how you normally would outside of ProjectWise.  As the files are 

not being opened within ProjectWise, no automatic prompts for check in will be shown.  Also, in the 

event your files exported are DGNs, it is probable that the appropriate libraries are unavailable. 

Upon completion of working with your files, you will then need to re-import the documents back into 

the datasource.  To perform this step, you may either use the Local Document Organizer, or highlight 

an exported document and select Import from the Document/right-click menu.  To provide the 
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utmost data security, and flexibility in data sharing, it is recommended that you re-import your data 

daily.  In the event of PC hardware problems, this will prevent large amounts of data and work loss, 

along with making the most up-to-date copies of your data available for use by other members of the 

project. 

The single document Import process behaves as though you’re checking in the file that was 

exported.  You will be prompted to add meaningful comments during the check-in process as you are 

with other documents. 

To re-import your data, you will use the Local Document Organizer that is a component of 

ProjectWise Explorer.  This can be found under the Tools -> Local Document Organizer.  You will be 

presented with the following window: 

 
Local Document Organizer 
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This tool defaults to having only Checked Out documents shown.  You will change the filter to the 

Exports (floppy disk) option as shown in the prior image.  To ease the re-import process, it is 

suggested that you sort your exported documents by file name.  This will make sure that all 

documents in that location are together.  To re-import the documents, you then need to select all of 

the files that you’d like to re-import and right-click on them.  Select the import option as shown. 

 
Import Menu Item 

Once you’ve selected the import option, you will be prompted to enter any relevant comments 

pertaining to this operation.  Relevant comments include any operations you may have performed. 

 
Document Check In 
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This will re-import and remove any documents that you initially exported prior to working with your 

data.  Any new files will remain in the designated location on your PC.  To bring these newly created 

documents into ProjectWise, you will need to open the export location on your PC in Windows 

Explorer, and select the remaining files (no subfolders) and drag and drop these files into the 

necessary folder for your project in ProjectWise. 

  
Drag and Drop of New Files 

The Document Export Process: Things to remember! 

• Make sure you export your documents to a consistent and predictable location. 

• Re-import your data daily.  It is your responsibility to maintain your most recent data. 

• Do not move exported files, as ProjectWise only retains information regarding these files 

when they are in their exported locations.  Moving these files presents the potential for data 

loss. 
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2.19 LEAP Bridge Integration with ProjectWise 

Unlike typical Bentley applications, the LEAP Products integrate with ProjectWise in different 

fashions.  This section will cover a very high-level overview of how these products integrate. 

2.19-1 LEAP Bridge Concrete 

The first step in LEAP Bridge Concrete integration is to enable the ProjectWise login.  To do so: 

1. Launch LEAP Bridge Concrete. 

2. In the application, navigate to the Options > Preferences menu. 

 
LEAP Bridge Concrete Preferences 

3. On the Preferences dialog, enable the checkbox for ProjectWise Login on Startup.  Select OK 

when completed. 

 
Enabling ProjectWise Login 
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4. Close and Relaunch LEAP Bridge Concrete.  You will be presented with the ProjectWise login 

dialog.  Select INDOTWise for the Datasource and Use Single Sign On and select Log In.  

Note: With the new INDOTWise datasource, there will NOT be an option for DOTWise as 

shown below—but the process is exactly the same. 

 
LEAP Bridge Concrete Login 

5. Once logged in, the typical LEAP Bridge dialogs will now use ProjectWise file operation 

dialogs such as Save As, and File Browsers.  At this time, you are integrated with ProjectWise 

and can leverage this integration similar to other applications such as MicroStaton. 

2.19-2 LEAP Bridge Steel 

LEAP Bridge Steel uses a different interface methodology for ProjectWise integration.  The 

application integration in this application is configured via its Ribbon interface.  To begin: 

1. Launch LEAP Bridge Steel.  Navigate to the ProjectWise ribbon. 

 
ProjectWise Ribbon 

2. For LEAP Bridge Steel, you may directly interact with the system using the tools presented 

without needing to enable any preference.  From the previous screen capture, there are two 

items of note.  The first is the Data Sources: entry.  For this one, select INDOTWise.  The 

second option is directly above the Data Sources and is a checkbox for Silent Login.  By 

enabling this, your ProjectWise session will immediately login to the system with your 

credentials, bypassing the login dialog. 
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3. Once connected, the Open and Add buttons will activate allowing you to perform your typical 

file operations on LEAP Bridge Steel files, again replacing any file operation commands and 

browsers with their ProjectWise counterparts. 

2.19-3 STAAD Pro 

STAAD Pro does integrate with ProjectWise.  The most important initial note is that a STAAD project 

file should not be directly placed in the datasource.  The following process will cover how to place 

STAAD data into the system properly, and then open it afterward.  These steps assume that you 

already have a STAAD Pro project that you’ll want to place in the system. 

1. Open STAAD Pro, on the home screen, select the Share link. 

 

2. On the Share panel, select ProjectWise, and then navigate to the location of your STAAD files.  

Once you select the .STD file, all associated project files will also be included as shown. 
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3. Once prepared, select the Add button in the lower right of the previous display.  You will be 

prompted with a ProjectWise login.  As we’ve done with previous logins, make sure to select 

the INDOTWise datasource, and enable the Single Sign On check box.  Click on Log In when 

ready. Note: With the new INDOTWise datasource, there will NOT be an option for DOTWise 

as shown below—but the process is exactly the same. 

 

4. At this time, you will be prompted with a Document Creation Wizard choice.  For the purposes 

of this example, we will be using No Wizard. 
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5. On the following panel, select the ProjectWise location you’d like to place the file and then 

select Save. 

 

Note: The highlighted portion of the above screen shot shows the format of the file placed in 

ProjectWise.  STAAD automatically changes and requires that ProjectWise uploaded projects 

be in the .STZ format instead of the .STD format. 

6. You will be prompted to enter any upload comments when you select Save.  Enter any 

necessary.  Upon closing the STAAD software, you will be prompted to check the project file. 

7. To then open a STAAD project, open the application, and select ProjectWise on the Open tab 

that’s initially presented. 

 

Note: The STAAD project file (.STZ) should not be opened directly from ProjectWise.  Please 

open these files through the STAAD application to ensure that all functionality is present. 

8. When presented with the ProjectWise login, your Datasource should be remembered from 

uploading a file.  If not, select DOTWise and enable the Single Sign On checkbox.  Click Log In 
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when ready.  Note: With the new INDOTWise datasource, there will NOT be an option for 

DOTWise as shown below—but the process is exactly the same. 

 

9. Navigate to the appropriate location in ProjectWise and select your .STZ file.  Select Open 

when ready. 

 

Note: You may be prompted to associate to a project.  INDOT is not currently using this 

functionality, so if this prompt occurs, please cancel it. 

10. At this time, you’ll be placed into your STAAD project.  You can modify your data in the typical 

fashion, and then when you close your file, you’ll be prompted to check the project file back 

in. 
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2.19-4 RM Bridge 

RM Bridge does integrate with ProjectWise, however it uses its own version of the ProjectWise tools 

in order to function within that system.  As it uses these non-standard integration methods, it’s highly 

advised that if you’d like to use this functionality, you will need to review the application-provided 

documentation on this tool.  This information can be found under the Help? > Technical Notes > 

Project Wise Access, and will open a .PDF with the relevant information. 

  
RM Bridge ProjectWise Documentation 

2.19-5 LEAP Consys and RAM Elements 

LEAP Consys and RAM Elements do not have any ProjectWise integration.  If you would like to try and 

use these products with ProjectWise, please refer to Section 2.18.  
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2.20 OpenBridge Designer Integration with ProjectWise 

Instead of leaving ProjectWise integration up to each of the individual products, OBD moves the 

integration up to the top level of the OpenBridge Designer.  On the OpenBridge Designer main 

screen, select the ProjectWise icon, and login appropriately.  Be sure to choose INDOTWise as the 

datasource and Bentley IMS for the authentication method.  NOTE: Be sure you are logged into the 

CONNECTION Client first, prior to logging in with this method. 

 

 

 

Logging into ProjectWise within OpenBridge Designer 

When successfully logged in, the status bar in the lower right will show that ProjectWise is Logged In, 

and the icon will be grayed out for the duration of your OBD session. 
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At this point, you can create your file.  Select the New File icon. 

 

If you opt to place your files in ProjectWise, fill out the Save Document As window similar to what’s 

shown below: 
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Please note that you can save the file to your local disk by selecting the Save to disk or Cancel 

buttons.  If you do so, or have not logged into ProjectWise prior to creating the new file, you will be 

presented with the standard Windows Save As window. 

 

Give your file a name and save it to proceed. 



 

100  

 

2.21 The ProjectWise Managed Workspace 

The Managed Workspace is a feature of ProjectWise that allows MicroStation workspace files to be 

managed within the ProjectWise environment.  Benefits of doing this are that all workspace files are 

located and administered in a single location.  This allows for the rapid deployment of updates and 

changes; while allowing flexibility in what and how workspace resources are accessed. 

Like the plotting resources (such as pen tables, design scripts and settings files); the managed 

workspace has taken the place of X:\ drive locations for most CAD resources.   

As this is just a location change for the workspace, end user impact should be minimal; and with few 

exceptions, no changes should be particularly evident. 

2.21-1 Managed Workspace Export 

The managed workspace attaches itself to any document opened by a MicroStation based 

application (MicroStation, Bentley View, Power InRoads, etc.) from within ProjectWise.  In particular, 

you can expect the managed workspace to be active when viewing/editing DGNs, DWGs, DXFs or any 

other file ProjectWise opens with MicroStation. 

When opening CAD files from ProjectWise for the first time, you will see the following. 

 
Managed Workspace Export Dialog 

This is the Managed Workspace Export Progress dialog, and it shows the status of ProjectWise 

placing the workspace in your working folders.  The first time you open a CAD file after the workspace 

has been initialized, this dialog will take a short amount of time to download all the relevant files and 

configure your workstation for the first time. 

Subsequent file opens will reduce the amount of time required for the export to complete—as once 

the files have been downloaded, ProjectWise will only update them if there’s been a change at the 

server.  This ensures that you always have the most up-to-date workspace files available. 
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2.21-2 Working with the Workspace 

Day to day use of the workspace has not changed in a visible manner.  All tool boxes, macros, and 

symbology resources have been updated to automatically be available when you access your files.  

Areas where you may see differences are in the file paths where items such as cells are being 

attached from, or where you’re initially directed to attach other resources. 

Cells in particular are loaded, on-demand resources in the workspace.  They are not copied out the 

first time you run the workspace, but are loaded when you access their icon in the toolbox.  At this 

time, you may see a slight hesitation as ProjectWise is downloading the appropriate file to your PC.  

After this initial install, it will load instantly unless there’s been a change to the file that causes it to 

be re-downloaded. 

2.21-3 INDOT Customized Fonts 

With the release of MicroStation V8i, Bentley no longer provides a method of maintaining and further 

customizing font resource files.  Due to this limitation, INDOT customized fonts have been 

discontinued and we’ve instead moved to using true type fonts only.  The benefits of this method are 

that files will seamlessly translate between CAD packages and this will prevent the various other 

issues such as text rendering improperly or with the wrong character set. 

As such, the Office of Standards and Policy has provided CAD tech notes on how the special 

character cells that have been instituted as their replacement should be used in conjunction with the 

True Type fonts. 

2.21-4 MicroStation and Files with SignCAD Fonts 

With the removal of the legacy INDOT font resource file, the managed workspace is now configured 

to have the SignCAD fonts available on every project as there's no longer a conflict with existing 

resources. 

2.21-5 MicroStation, File -> Open and Workspace Reloads 

When opening files from the File -> Open command in MicroStation, you may be prompted with the 

following dialog: 

 
Managed Workspace Prompt when Switching Files 

This dialog denotes that there’s a difference between the workspace you currently have loaded and 

the workspace options for the file you’re attempting to open (most commonly a file based, reference 

path will change).  In most instances the user can safely select No to proceed to their next file as 

most files now share the same workspace.  One should consider however if they are switching from a 

MicroStation to an InRoads associated file so the appropriate civil resources are loaded. 
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2.22 Local Document Organizer 

As the managed workspace copies files to your local machine, ProjectWise will allow you to manage 

these through the Local Document Organizer.  It’s highly recommended that you not remove the 

workspace documents from your PC unless directed by CAD Support.  ProjectWise will handle the 

updating and export of documents “as needed” behind the scenes to provide a seamless 

experience. 

If you do purge these files, the first time you open a CAD file, ProjectWise will re-download the 

workspace, providing a slight delay similar to the first time it’s used. 

Should CAD Support request you purge your workspace copies, go to the Local Document Organizer 

(Tools -> Local Document Organizer… from the ProjectWise Explorer menu).  On the Local Document 

Organizer toolbar, select the button for Workspace Copies as shown: 

 
Local Document Organizer 

This window functions similarly to the Copies option, in that you can only Purge or Refresh these 

documents.  Check out will be unavailable as these are administered by the CAD Support staff.  

Should they request you purge your workspace copies, select all entries in this window and either 

right-click and select Purge Copy or perform the same option from the Action menu. 
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2.23 Document Archival and Audit Process (PW to UCM) 

2.23-1 Introduction 

With the rollout of DOTWise 3.5, the process of sending documents from ProjectWise to ERMS has 

been put in place and is now available for use.  The following document looks at the requirements 

for setting up Design documents on the ProjectWise side, sending them to ERMS, and then locating 

them once they’ve been uploaded.  Also, this material covers the process of preparing your Work 

Area for archiving for future use. 

Please note that the information in this document only applies to Work Areas created after the 

Spring (March) 2014 release.  Work Areas created prior to this date will not have the appropriate 

metadata frameworks and will not function properly with the processes discussed.  If there are any 

questions, please contact CAD Support via a Helpdesk Ticket with your Des. No. 

2.23-2 Sending Documents to ERMS and Preparing for Archiving and Design Workflow 

2.23-2a Document Naming 

A critical step in the transferring of documents from ProjectWise to ERMS is that they are properly 

named according to the Project File Naming Conventions sheet (link provided in section 3).  In order 

for them to be placed in the proper workflow in ERMS and in order to locate them using search tools 

for later recovery, they must be named using these naming conventions. 

2.23-2b ProjectWise Enhancements Required for ProjectWise to ERMS Transfers 

In the DOTWise 3.4 release, the INDOT ProjectWise structure underwent a major overhaul to enable 

the following functions that are key to the document transfer process: 

• All disciplines have a Project Type 

• All disciplines have a Workflow & State configuration 

• All disciplines have an Environment structure 

• All Work Area Types are keyed to the project Designation Number 

• All Environments have Properties for: 

o Designation Number 

o ERMS/UCM Document Type 

o The last date the document was sent to ERMS/UCM 

o The last state the document was in when sent to ERMS/UCM 

o The last user to send the document to ERMS/UCM 

The next section will discuss how these enhancements are used in conjunction to send a document 

from ProjectWise to ERMS. 
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2.23-2c Transferring Documents from ProjectWise to ERMS 

As part of the DOTWise 3.5 release, all ProjectWise users within INDOT have been provided a new 

extension that appears in the ProjectWise Documents menu and right click context menu. 

 
The Export Documents to ERMS Menu 

This menu item is toward the bottom of the documents menu, and will only appear on documents.  It 

will not function when selecting document sets, folders, or projects. 

The following steps are required when sending a document from ProjectWise to ERMS: 

1. Locate the document to be sent in ProjectWise (under the Des No -> Discipline folder). 

2. Right-click and select Properties command and make sure all applicable Project and 

Environment data is filled out. 

a. The Discipline Work Area folder (ex. Design).  Ensure as much information as possible 

is filled out as permissions allow.  The Des. No. is required (pre-populated by SPMS) 

and the other fields should be filled out accordingly.  Focus on the last 4 fields; these 

properties will help determine where in the ERMS Design workflow the document will 

be placed. 
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Project Property Checks 

 
Required – Designation Number 
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b. Look at the document properties with the _PROJECT INFORMATION interface active.  

(By right-clicking and selecting the properties command from the selected 

document).  Fill out as many document properties as possible on both the Attributes 

and More Attributes panels.  The ERMS Document Type is required and corresponds 

to the available document types when manually uploading a document to ERMS. 

 

The _PROJECT INFORMATION Interface and Document Properties 

 
Attributes, More Attributes and ERMS Document Type 
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3. Next, set the appropriate document state from the Document’s parent folder properties 

Workflow & State tab.  These states also correspond with those required when manually 

uploading files to ERMS.  To change a document state, select it in the Workflow & State tab 

and use the up/down arrows on the upper right to change the state.  This can also be 

accomplished by right clicking on the document in the ProjectWise Explorer and Selecting the 

Change State entry and its sub options Next, Previous, or Change. 

 
Folder Properties 

 
Workflow & State 
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Workflow & State on a Document 

4. With all the appropriate information filled out at the Work Area, Environment and Workflow & 

State levels, it’s now possible to send the document to ERMS.  In the Document window, 

right click on the document(s) that are ready to transfer, and select the Export Documents to 

ERMS option. 

 
Export Documents to ERMS 
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5. Selecting the menu will cause a brief pause to occur where the selected documents are 

queued to be transferred into ERMS.  At the conclusion of this process, the selected 

documents will show that the PWUCM user is the last user listed in the Updated By column.  

This is due to how the process updates the date, user, and state the document was sent. 

 
The Updated By User (Post Queuing) 

6. To inspect the upload information, change the ProjectWise Interface to ERMS Upload, and 

perform a properties on one of the sent documents.  Change the tab to More Attributes.  The 

Last Sent By, On, and State have all now been populated. (Refresh – F5) 

 
The ERMS Upload Interface 

 
The ERMS Upload More Attributes 
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7. At this time, the selected documents have been queued to be sent to ERMS.  As this is a 

scheduled process, the documents may not be immediately available in ERMS, and care 

should be taken when making further modifications.  Due to potential delays in processing, 

documents should not be edited in ProjectWise until they are verified to be in ERMS in the 

correct workflow and with their complete metadata. 

Note: When .DGNs are selected to be moved to ERMS, any associated reference files will also be 

exported and moved to ERMS. 

2.23-3 Other Methods of Preparing and Sending Documents 

In addition to the single file method demonstrated in the previous section, the ProjectWise to ERMS 

tool also accommodates the sending of multiple files at once as long as all the appropriate data is 

applied to the files.  The two methods that will be discussed in this section are the usage of 

Advanced Searches and Document Sets to collect your files. 

2.23-3a Collecting Multiple Documents to send to ERMS/UCM using an Advanced 

Search 

1. Using advanced searches is a good way to locate multiple files to send to ERMS. 

2. Right click on the folder that contains the documents you wish search for. 

3. The Right click menu will appear (select Advanced Search) as shown below: 
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4. The Select Search Definition Dialog box will appear, giving you the option to Search Form or 

Search Builder.  Select the Search Form option as shown below: 

 

5. Once Select, click the OK button to the right 
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6. Once you have clicked the OK button, the Search by Form dialog will appear on the screen. 

Next, select the State Pull down.  In the State Pull down, select the stage of Audit you are 

searching for as shown below:  
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7. Select the OK button of the dialog box.  As mentioned earlier, it might be beneficial to place 

the results in a new window.  The following screen capture shows the results that are 

presented with that option enabled.  Remember this is just one example of a search on 

Stage 1 documents.  Your search can be as advanced as you choose to make it. 

 

8. The results screen will appear with the results of your search. 

 

9. Each of the file’s properties are now available to you, and be sure to fill in all the required 

attributes related to them before exporting to ERMS. 
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10. Select each file and check the More Attributes tab and ensure the ERMS Document Type has 

been selected (as shown below) – can be arrowed through each file. 

 

11. You can then select the files you wish to export to ERMS/UCM. 

 

12. You will right click once you have selected the files and will then scroll down to the bottom of 

the pop-up menu and select Export Documents to ERMS. The screen will flash a brief second 

as the export is being completed. 

Depending on the frequency with which you may need to use these searches, please keep in mind 

that you can save them and use them repeatedly for your project. 
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2.23-3b Collecting Multiple Documents to send to ERMS/UCM using a Document Set 

A document set is a grouping of documents. A document set can either be a flat set, which is just a 

collection of documents that are grouped together but with no physical connection to each other, or 

a logical set, which is any document in ProjectWise that has other documents referenced into it. 

1. To create a Document set in order to send multiple files to ERMS, follow these instructions. 

2. Under the Discipline (i.e. Design, Survey) folder and sub-folder containing the files you wish 

to export, Shift+Click or Ctrl_Click on the files (Be sure to check attributes for these files and 

make sure ERMS Document type have been set for all files) you want in the Document set as 

shown below: 

 

3. A pop-up menu will appear, and you will scroll down and select Set New. 

4. You will then give the Document set and appropriate name. Then click the OK button 
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5. Once selected, a box will pop up with the Document Set files in it as shown below: 

 

6. Once again ensure the correct document type is set in the More Attributes tab for all the files.  

You can then close the dialog box. 

7. With the document set open, select the files you’re prepared to send and right click and 

select the Export Documents to ERMS command.  The screen will flicker as the files are 

being exported. 

 

2.23-4 Archiving Projects from ProjectWise to ERMS/UCM 

As with the Audit and Export to ERMS processes shown in the previous sections, we have created 

tools to allow for the archiving of completed projects from ProjectWise and the transfer of those 

projects/files to ERMS. 

This archiving procedure is a two-step process, and there are two major responsibilities needed for 

the successful archiving of a project: 

1. Each discipline is required to flag their own relevant documents—as they are the subject 

matter experts.  At the conclusion of each discipline’s project responsibilities, the relevant 

parties will need to perform their archival steps. 

2. The Project Manager will be responsible for ensuring that each discipline has flagged the 

appropriate documentation prior to initiating the full project archive process. 
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2.23-4a Per Discipline Setting a project (Ready for Archiving) Workflow and State 

The first portion of the project archiving tools are discussed in this section.  The following are the 

steps that members of each discipline are responsible for during their project development process—

and can be performed at any relevant time during the project process.  Note that these steps do 

share some common features with the other steps in sending documents from ProjectWise to UCM; 

particularly the usage of Workflows and States. 

There are two methods within ProjectWise for setting the State of a file to Ready for Archiving.  We 

want all users to understand that there is no need to archive all files within a project.  We only want 

files that are necessary (i.e. no working or draft copies). 

1. The first method is started by right clicking the folder containing the files within a discipline 

(see image below of MS folder under Design) 
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2. Once the Properties dialog is selected it will appear on the screen and you will select the 

Workflow and State tab 

Note: When .DGNs are selected to be moved to ERMS, any associated reference files will also be 

exported and moved to ERMS. 
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3. By opening the various states, you will be able to see what files are currently in what state.  

You will from this window be able to move a file from its current state to the state of Ready 

for Archiving.  You select the file (it will highlight) and you then select the green arrow to the 

right and click the arrow until the files moves to the next state.  Note that multiple files can 

be selected in this step through the use of Ctrl+Click or Shift+Click selection methods. 
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4. Once the file/files have been transitioned to the Ready for Archiving State, you will select the 

OK button at the bottom of the dialog. 

 

5. The second method is to individually select the files from the folder by right clicking and 

selecting the Change State -> Change command 
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6. This will bring up the Change Workflow State dialog box (it will show the selected file you 

have chosen in its current state).  You can click the green arrow to the right (as many times 

as needed) to move the file to the Ready for Archiving state. 
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7. Once moved to the Ready for Archiving State, select the Close button. 

 

With the appropriate documents in the Ready for Archiving state, this portion of the archival process 

is complete.  The complimentary portion of the process where the PM sends the entire project will be 

completed at the appropriate milestone at which time the data will be sent to ERMS.  Until that time, 

the project data will continue to reside in ProjectWise for all users. 
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2.23-5 PM project management of ProjectWise projects to flag Archive – YES 

Throughout the development of a project, each discipline will complete their steps as shown in the 

previous section.  Once all disciplines have prepared their portions of the project, the Project 

Manager can then flag the full project for archiving.  Please note that considerations should be made 

if the project is undergoing continuing mitigation studies. 

1. As Project Manager of a Des No. project in ProjectWise it is expected that the Final Status for 

moving the project to ERMS/UCM will be determined by you.  It will be your responsibility to 

check SPMS and with the disciplines prior to setting the property Archive to YES.  This is done 

as shown in the following screen shot by going to the properties tab of the Des No. Work 

Area. 

 

When this status is checked, the tool developed to move the files to ERMS will see the property and 

move the files from ProjectWise (they will then disappear from your datasource view).  This process is 

not instantaneous, and the project may continue to be viewable for a day after the archiving has 

been requested.  This is due to the scheduled nature of the process and care should be made to not 

modify documents after the project has been set to Archive: YES. 
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3. MicroStation and V8i Interface 

3.1 What’s New in MicroStation V8i 

MicroStation V8i SS4 has continued with the interface enhancements that have been present since 

the initial release of MicroStation V8i.  Our goal in this chapter is to provide you with a guide to the 

interface and some of the options that you will see. 

3.1-1 Application Window Layout Changes 

The Tasks dialog is the default task navigation interface. This dialog is docked to the left-hand edge 

of the application window. 

The Main task is embedded in the Tasks dialog. 

 
Task Navigation in the INDOT Workspace 
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3.1-2 Tasks dialog 

Used to view the Task List and to select the tasks, workflows, and tools with which you need to work. 

The size of the icons in the Tasks dialog is set in the Preferences dialog. You also can choose to 

show or hide Navigation icons. In the default setup, tools from the Main toolbox have been 

integrated into the Tasks dialog in a Main task. 

 

The Drawing Task 
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You can dock the Tasks dialog to the left or right edge of the application window. By default, the 

Tasks dialog is docked to the left edge of the application window, and the active task is the Drawing 

task. 

You can resize, minimize, dock, undock, open, and close the Tasks dialog. You can also theopen a 

workflow in a separate instance of the Tasks dialog. 

If you have position mapping turned on, the keys are displayed next to the tools in the Tasks dialog. 

When the position mapping keys have focus, they appear on a dark background. When they do not 

have focus, they appear on a light background. 

If you hide tools while viewing tasks in the Tasks toolbox or in views, these tools will be hidden in the 

Tasks dialog. 

3.1-2a Main toolbox 

The Main task is used to select general usage element selection, manipulation, and modification 

tools. 

The Main task, containing tools from the Main toolbox, is open when you start the program for the 

first time. By default, tools from the Main toolbox appear as a Main task in the Tasks dialog, which is 

docked to the left-hand edge of the application window. The Tasks dialog can be undocked or 

docked to the right-hand edge. Right-clicking in the Main task and selecting Open 'Main' as Toolbox 

opens the toolbox as a floating toolbox. 

 

  



 

127  

 

3.1-3 Tasks 

By clicking the drop arrow next to the Tasks heading, all tasks will be displayed in a hierarchical tree. 

Clicking a task in the tree expands the task—making it the root task—and hides the other tasks. 

 
Task Navigation Flyout Menu 

Once a subordinate task has replaced Tasks as the root task, clicking the task's tab displays all tasks 

in a hierarchical tree. Clicking Tasks in the tree resets Tasks as the root task. 

 
Resetting the Tasks Dialog 

3.1-3a Main task tools  

In the default setup, tools from the Main toolbox have been integrated into the Tasks dialog in a 

Main task. You can hide the Main task tools in the Tasks dialog by clearing the Show Main Task 

Tools check box in the Task Navigation category of the Preferences dialog. You also can customize 

the Main task tools.  
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3.1-3b Task Tabs 

Clicking the down arrow on a task's tab expands the task so you can see the tasks and tools in it. 

Clicking the up arrow collapses the task and hides them. 

You can click the icons on a task's tab to view the tools in one of several layout modes: 

• Icon Layout mode 

• List Layout mode 

• Panel Layout mode (the default) 

The icon belonging to the first tool in a task is displayed on the task's tab. You can select a different 

icon for the task in the Customize dialog. 

In the default setup of the INDOT Workspace the following tabs are visible: 

• Civil Workflows (InRoads only) 

• InRoads Commands (InRoads only) 

• Civil Tools (InRoads only) 

• Print Preparation 

• INDOT Tools 

• Subsrface Utilities 

• Drawing 

• Drawing Composition 

• Terrain Model 

• Solids Modeling (3D only) 

• Surface Modeling (3D only) 

• Mesh Modeling (3D only) 

• Feature Modeling (3D only) 

• Visualization (3D only) 

• Animation (3D only) 
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3.1-3c Pop-up menu for the selected task 

Right-clicking a task presents a list of settings for the task.  

 

Task Layout Options 

• Set as Task Root — The selected task becomes the root task, which moves it to the top of the 

Tasks dialog and hides the other tasks. 

• Clear Task Root — Resets the task so that it is no longer the root task. 

• Layout Mode > Icon — Displays the tools as icons only. 

• Layout Mode > List — Displays the tools' icons, position mappings, and names. 

• Layout Mode > Panel — Displays the tools' position mappings and icons. 

• Apply Layout Mode to All — Applies the current task's layout mode to all tasks. 

• Open as Toolbox — Opens the selected task as a toolbox. 

• Open in new Dialog — It must be a workflow and must have child tasks in it in order to open it 

in a separate dialog.  When the Tasks dialog is docked, the new dialog appears on a separate 

tab at the bottom of the Tasks dialog. 

• Display Help — Available only if a help topic is linked to the selected custom tool, task, or 

workflow. Opens the help topic. 

• Show/Hide Tools > (Tools' names) — Allows you to show or hide individual tools. 

• Show/Hide Tools > Show All — Shows all of the tools. 

• Show/Hide Tools > List — Lists the tools in a dialog in which you can choose which to show or 

hide them. 
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3.1-4 Dockable Dialogs 

To gain more screen space, there are many dialogs that you can dock to the edges of the 

MicroStation application window.  

3.1-4a To dock a dockable dialog 

1. Select a dockable dialog's title bar.  Most dialogs in MicroStation are able to be docked, and 

if they are able to, docking indicators similar to the below example will be displayed. 

 
Single Docking Indicator (Left) & Full Docking Indicator (Right) 

2. Drag the dialog over one of the docking indicators that appear in the center of the screen or 

along the edges of the application window. 

 

3. As soon as you begin to drag a dockable dialog, a transparent block representing the dialog 

is attached to your pointer, and moves with the pointer until you release the mouse button. 
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4. Place the pointer over one of the docking indicators.  This highlights the available docking 

region along the corresponding edge of the application window. 

 
Bottom Docking Indicator with Possible Docking Region 

5. Release the mouse button.  The dialog is docked within the selected docking region, and is 

displayed in its entirety. 
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3.1-4b To turn on Auto Hide for a docked dialog 

1. Dock a dockable dialog to an edge of the application window. 

2. Click the Auto Hide (pushpin) icon in the upper-right corner of the docked dialog.  The docked 

dialog disappears from view, and a roll-out tab appears in its place along the same edge of 

the application window. 

 

3.1-4c To turn off Auto Hide for a docked dialog 

1. Place the pointer over a docked dialog's roll-out tab. 

2. While the dialog is displayed, click the Auto Hide icon.  The dialog is re-docked along the 

same edge of the application window.  

 

3.1-4d To undock or float a docked dialog 

Double-click the title bar of a docked dialog. The dialog returns to the position in which it was last 

floating. 
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3.1-4e To re-dock a floating dockable dialog 

Double-click the title bar of a floating dockable dialog which has been docked at least once. The 

dialog returns to the location where it was last docked. 

3.1-4f To close a docked dialog 

If the dialog is docked, simply click the dialog's Cancel icon (next to the Auto Hide icon).  If Auto Hide 

is enabled, first pause the pointer over a docked dialog's roll-out tab, then while the dialog is 

displayed, click the dialog's Cancel icon, or simply enter the key-in that is normally used to close the 

dialog. 

If you close a dialog while it is docked, and later click the icon or enter the key-in that normally opens 

the dialog, the dialog will open again to the position it was last docked. 

If a dialog is docked when MicroStation exits it will be docked in the same position the next time you 

start the product. 

3.1-4g List of dockable dialogs 

The following is the list of dockable dialogs and which edges they can be docked to: 

• Tool Settings window (left or right) 

• Element Information dialog (left or right) 

• Project Explorer dialog (left or right) 

• Link Sets dialog (left or right) 

• Tasks dialog (left or right) 

• Markups dialog (left, right, top, or bottom) 

• Item browser (left or right) 

• Details dialog (left, right, top, or bottom) 

• Feature Manager dialog (left or right) 

• References dialog (top or bottom) 

• Raster Manager dialog (top or bottom) 

• Models dialog (top or bottom) 

• Saved Views dialog (top or bottom) 

• Level Manager dialog (top or bottom) 

• Level Display dialog (left, right, top, or bottom) 

The way in which you dock one of these dialogs is different from the way in which you dock a toolbox. 
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3.1-4h Using Docking Indicators 

As you drag a dockable dialog, docking indicators appear on the screen. These docking indicators 

indicate which edges of the application window the selected dialog can be docked to. In most cases, 

a dockable dialog can only be docked either horizontally or vertically; however some dialogs, like the 

Level Display dialog, can be docked both horizontally and vertically. 

 

If the selected dialog can be docked horizontally, then the docking indicator at the center of the 

screen will have arrows that point toward the top and bottom edges of the application window, and 

matching docking indicators appear along the top and bottom edges. If the selected dialog can be 

docked vertically, then the docking indicator at the center of the screen will have arrows that point 

toward the left and right edges of the application window, and matching docking indicators appear 

along the left and right edges. 

 

You can release the dialog over any of these arrows, and the dialog will be docked to the 

corresponding docking region. While it is mostly a matter of preference whether you use the docking 

indicator at the center of the screen or the ones at the edge of the application window, there is a 

slight difference in the two.  

Using the center docking indicators will position the dialog so that it takes up the remaining free 

space along the length of the selected edge of the application window. For example, if there is 

already a dialog that is docked vertically on the left edge of the application window, then dropping a 

horizontally docking dialog over the center docking indicator, pointing toward the top edge of the 

application window, will dock the dialog so that it fits in the remaining space along the top edge. 

Using the docking indicators at the edges of the application window let you decide where specifically 

along the selected edge you want to dock the dialog. For example, if there is already a dialog docked 

to the left edge, you can use the edge docking indicators to select whether you want to dock the new 

dialog on top of the existing dialog, or to the left or right of it, or above or below it.  
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If you are moving a dockable dialog and there are no dockable dialogs currently docked to the edge 

of the application window that the selected dialog can be docked to, then the center controls will not 

display. 

3.1-4i Other dialogs that can be docked 

The following dialogs are also dockable; however their docking behavior follows the standard docking 

behavior for toolboxes: 

• Key-in window 

• View Groups window 

• AccuDraw window 

• Drawing Scale window 

• Snap Mode button bar 

3.1-4j Dialogs that are docked by default 

When you start MicroStation for the first time and open a file, certain dockable dialogs are already 

docked. This is because the product delivers a docking preference file that defines which dialogs are 

docked by default, and where.  As you make changes to the location of docked dialogs, that 

information is saved in your personal docking preference file, rather than in the delivered default 

docking preference file. 
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3.1-5 Workflows 

A workflow can consist of one or more tasks. In most cases, a workflow consists of a collection of 

tasks organized in the order that you will use them to complete a project or job. Each task contains 

the tools you need to complete the task. The Drawing Composition workflow is delivered with 

MicroStation. 

 

Workflow icon 

 

The Civil Tools Workflow 
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3.1-6 INDOT Dialogs, Tasks and Workflows 

A new .dgnlib will accompany this document that has many new and exciting changes and 

enhancements that leverage the latest version of MicroStation.  We (CAD Support) have taken a few 

steps to organize the task navigation section of the Application Window to make it more user friendly 

and INDOT specific.  Via the managed workspace in ProjectWise, when a .dgn file is opened, the Task 

Navigation will appear as follows: (See INDOT Tools) 

 
Task Navigation with INDOT Tools 
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3.1-6a INDOT Tools Workflow 

This new INDOT Tools workflow has separated the INDOT specific applications, tools, tasks and 

dialogs.  Once activated (by selecting) it will appear as in the following image: 

 
The INDOT Tools Workflow 

1. Right mouse click in the INDOT Tools tab and select Open ‘INDOT Tools’ in a new Dialog and 

you will be provided a separate dialog containing these tools.   

 
Opening INDOT Tools Separately 
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This will allow you to dock it as a separate dialog below the existing Main Tasks dialog. 

 

Docking the INDOT Tools Workflow 
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2. Using the docking indicators, select the bottom arrow to place the new INDOT Tools dialog 

below the other Tasks dialog. 

 

Split Task/Workflow Docking 
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3. Clicking this task displays all tasks in a hierarchical tree. Clicking a task in the tree expands 

the task, making it the root task, and hides the other tasks. 

4. Once a subordinate task has replaced Tasks as the root task, clicking the task's tab displays 

all tasks in a hierarchical tree. Clicking Tasks in the tree resets Tasks as the root task. 

5. It will then appear as shown, giving you access to both dialogs, but keeping them specific 

and separate.   

 
Docked/Combined Workflows 
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The other option is to use The Auto Hide (pushpin – icon) pointing down, hiding each of the task 

dialogs off to the left of the screen. The pushpin will then point left. 

 

Docked 

 

Hidden 

 

Un-Pinned Tasks 
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When you hover over the tools you wish to use/see they will appear as shown in the following 

picture: 

 

Task Flyout 

If you wish to place/dock the tasks dialog back out in the application window again, click on the 

pushpin as it points left and make it point down by selecting it. 

3.1-6b Tools Included in the INDOT Tools Task Navigation 

To ease many steps in the Drafting and Design processes that are discussed in this document, 

numerous tools have been created to the INDOT Tools workflow.  This section will discuss the various 

tools included. 

 
Text Tools 
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The tools contained in this tool box are used to quickly change text case, alignment, and other text 

functionality. 

 

 

Annotation Styles 

These tool task contain a wide variety of annotation text and dimension styles in both Letter and Full 

size formats. 

 
Applications 
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The Applications tool box contains quick links that can be used to quickly start and stop the 

MicroStation plug-in applications that are currently available.  These are AutoDesk Vehicle Tracking 

and Descartes.  InRoads no longer shows as an option as it can only be launched directly and not 

from within MicroStation. 

 
Cell Libraries/Tools 

The Cell Libraries/Tools tool box contains quick links to loading each of the INDOT cell libraries.  It 

also contains cell based tools such as the MDL based cell tools application. 

 
Line Style Scale Tools 

The Line Style Scale tools provide a series of scaling options to override any annotation scale or 

global scale linestyle scaling options.  These should only be used on legacy drawings. 

 
Model Drawing Scale 
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The Model Drawing Scale tool provides quick access to the drawing scale toolbar where working 

units and annotation scale can be adjusted. 

 
Reset Bylevel 

The Reset bylevel tool resets all active element symbologies to their current ByLevel state. 

 
Professional Stamps 

The Professional Stamps tool loads the PE/LS Stamp cell library. 

 
Survey 

The Survey tool box contains quick links to some of the most commonly used survey-related tools 

with their default settings.  It also provides access to the Survey cells via the Cell Selector. 

 
Title Block Integration 
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The Title Block Integration tools provide access to the cell library containing the cells used for 

ProjectWise titleblock integration, along with a tool used to force a synchronization of title block 

attributes from ProjectWise. 

 
Traffic 

The Traffic tool box contains links to all the traffic cell libraries, along with a shortcut to the AutoDesk 

Vehicle Tracking software. 

 

OpenRoads Extensions 

This toolbar contains any OpenRoads Extensions that have been added to the workspace.  Currently 

only the Cross Section Synchronization tool resides in this toolbar.  Note that it will only function in 

InRoads or PowerInRoads. 
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3.1-6c INDOT – INFO 

With the release of the new workspace, the INDOT-INFO tools along with others have been moved 

into a Project Explorer linkset.  To view this information, start the Project Explorer under the 

MicroStation File menu. 

On the Project Explorer you’ll see a Links tab.  Included in this tab are a number of resources both 

from Bentley and INDOT to assist in your usage of the workspace.  With the INDOT option in the 

dropdown selected, you’ll see numerous options. 

 

Various help resources can be found in this command.  For items developed within INDOT or to reach 

the helpdesk select the appropriate option.  Additionally, many other ProjectWise resources have 

been included so they are easily accessible. 
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3.2 User Interface Enhancements 

The addition of drag-and-drop support, the ability to customize right-click menus and the Tasks 

dialog, and three new ways to customize the status bar make the interface easier to use. 

3.2-1 Drag-and-drop support 

As of MicroStation V8i (SELECTSeries 1), additional drag-and-drop functionality has been added. 

Note:  Not all functionality will be available when working within ProjectWise. 

 

MicroStation Native Drag and Drop Operations 

Some of the possible drag and drop operations are: 

• Drag and drop models from the Models dialog to the Project Explorer dialog 

• Drag and drop a saved view from the Saved Views dialog to the Project Explorer dialog 

• Drag and drop files and folders from Windows Explorer to the Project Explorer dialog 

• Drag and drop links from the Project Explorer dialog to a view window 

• Drag and drop links within the Project Explorer dialog 

• Drag and drop saved views from the Saved Views dialog to a view window 
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• Drag and drop models from the Models dialog to a view window 

• Drag and drop DGN, DWG, and DGNLIB files from Windows Explorer to the Saved Views 

dialog 

One common use of the drag and drop feature is between the Models dialog and a view window. 

 

Drag and Drop Functions with Command Modifiers 

3.2-2 Right-click context menus based on named expressions 

When customizing right-click context menus and menu items (Workspace > Customize > Context 

Menus dropdown), you can show or hide and enable or disable them based on tests created in the 

Named Expressions dialog. For example, you can create a right-click menu item that will be visible 

only when you are working on a sheet model by setting the menu item's Show/Hide Test property to 

“IsSheetModel.” Or you can create a right-click menu item that will be visible but enabled only when 

you are working on a sheet model by setting the menu item's Enable/Disable Test property to 

“IsSheetModel.” You can determine where the context menu or context menu item will be placed in 

the right-click menu by setting its Priority field. 
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3.2-3 Show/Hide support in Tasks dialog 

Right-clicking a task in the Tasks dialog opens a menu that allows you to show or hide the following: 

• Show/Hide Tools > (Tools' names) — Allows you to show or hide individual tools. 

• Show/Hide Tools > Show All — Shows all of the tools. 

• Show/Hide Tools > List — Lists the tools in a dialog in which you can choose which to show or 

hide them. 

3.2-4 Show/Hide support in status bar 

Right-clicking in the status bar opens a menu allowing you to show or hide sections of the status bar. 

 

Status Bar Options 

3.2-5 Coordinates display in status bar 

Left-clicking in the Running Coordinates section of the status bar turns on the coordinates display. As 

you move your cursor, the coordinates of your current position display according to the active 

Tentative Point Mode. When you left-click, a menu displays six options. The Delta modes show the X, 

Y, and Z displacement from the last data point. The Distance modes show the distance and direction 

from the last data point. 
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Coordinate Formats 

3.2-6 Locks dialog 

Left-clicking the Locks icon on the status bar and selecting Full on the popup menu opens the Locks 

dialog.  

 
Locks Dialog and Menu 
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3.3 Models Enhancements 

The enhancements to Models include additional viewing capabilities, Project Explorer integration 

with the Models dialog, and sheet name display in the Models dialog. 

Models have additional new features in MicroStation V8i (SS1 and SS2). 

3.3-1 View different models from the same file in each view 

You can view more than one model from the same file in separate views. In the example below, 

notice that the “Multi-models View” view was created and the titles of the two views match two 

separate models in the Models dialog. 

 

Multiple Model Display 

3.3-2 Project Explorer integration in Models dialog 

An icon has been added to the Model Manager dialog. The icon puts the dialog into one of two 

modes: 

Active File Mode:  Shows the current source of the models. If set to Active File, the models are in the 

master file. If set to Link Set, the models are in Project Explorer. 
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Active Files/Link Set Models 

Link Set Mode:  Shows a Project Explorer layout, allowing you to select an active file or folder from 

the active project in Project Explorer. 



 

155  

 

 

Active File Model Options 

3.3-3 Models dialog displays the sheet name 

The Sheet Name column has been added to the Models dialog in support of sheet sequencing. The 

sheet name should match the corresponding sheet link name in Project Explorer. If the two get out of 

sequence (that is, the sheet link name was changed in Project Explorer or in the Model Properties in 

the Model dialog), the new sheet name can either be pushed out from Project Explorer to the model 

or pulled from the model back to Project Explorer so they are synchronized.  

 

Models with Sheet Names 
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3.4 Menu Changes 

The following sections list changes in the menu structure. The Edit, Workspace, Window, and Help 

menus are unchanged. 

3.4-1 File menu changes 

• Selecting Import > CAD Files opens the Import dialog. 

• Selecting Export > SVG opens the Export SVG dialog. 

• As of MicroStation V8i SELECTSeries 1, exporting to Maxwell Scene has been replaced by 

exporting to Luxology. 

• Selecting Export > OBJ opens the OBJ Export Settings dialog. 

• Batch Print is removed and has been replaced by Print Organizer. Selecting Print Organizer 

opens the Print Organizer dialog. 

• Selecting File > Publish i-model opens the Publish i-model dialog. 

• Selecting Export > Luxology opens the Create Luxology File dialog, which is used to export the 

.ixo file. 

• Selecting File > Point Clouds opens the Point Clouds dialog. 

3.4-2 Element menu changes 

• Detailing Symbol Settings is removed. It is replaced by Detailing Symbol Styles, which opens 

the Detailing Symbol Styles dialog. In this dialog you can create and edit detailing symbols. 

• Selecting Element Templates opens the Element Templates dialog, which in the previous 

edition was accessible in the Customize dialog. 

3.4-3 Settings menu changes 

• Selecting Display Styles opens the Display Styles dialog. 

• Locks > Depth Lock is removed. It is no longer used. 

• The Rendering submenus have been reorganized. Selecting Rendering > Settings opens the 

Render Settings dialog. 

• Snaps > Tangent From has been renamed Tangent Point. 

• Snaps > Perpendicular From has been renamed Perp Point. 

• Rendering > Light Setup is removed. The Light Setups and Light Manager dialogs have been 

consolidated into a new Light Manager dialog, which is opened by selecting Rendering > 

Light Manager. 

3.4-4 Tools menu changes  

• The Tools menu has been reorganized. All toolboxes are accessible from the Tools menu. 

Each tool appears in only one toolbox. 

• You can select tools and view controls directly from the Tools menu. 

• For example to select the Scale tool, select Tools > Manipulate > Scale. To open the 

Manipulate toolbox, select Tools > Manipulate > Open as ToolBox. 

• The Main submenu returns to provide more convenient access to child toolboxes of the Main 

toolbox. 

• The Geographic submenu provides access to geographic tools. 

• The Clash Detection menu item provides access to the Clash Detections toolbox. 
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• The Point Clouds menu item provides access to the Point Cloud toolbox. 

3.4-5 Utilities menu changes  

• The Render menu item's submenus have changed. The submenus are Fly Through, Solar 

Study, Animation, and Luxology. 

• Selecting Named Expressions opens the Named Expressions dialog. 

• The Generate Section menu item is removed. 

• The Install Fonts menu item is removed. 

• The Render > View menu item is removed. 

• The DWG > Audit menu item is removed. 

• The DWG > Recover menu item is removed. 

3.4-6 Application menu 

• No significant changes 

• Due to inconsistencies with AutoTrack, SignCAD, and InRoads; multiple Application menus 

may appear. 
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3.5 Text Enhancements 

Text enhancements include the ability to change case by a selection set or fence. The Advanced tab 

allows for comparisons between styles. Word Processor updates include an insert field, subscript 

and superscript icons and right-click operation to change the case. The Edit Text tool retains its text 

settings and the Find/Replace Text tool supports data fields. 

3.5-1 Change case by selection set or fence. 

This tool is used to change the case of a piece of text. Case change options include Upper Case, 

Lower Case, Title Case, and First Capital. This tool also supports text selection via a fence.  This tool 

can be found under the Tools > Text menu, labeled as Change Case.  This tool supersedes the 

previous version included with the TextUtil.ma package. 

 

Change Text Case 

3.5-2 Text Style dialog enhancements  

For information on INDOT Specific fonts, please see Appendix B. 
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3.5-2a Advanced tab allows comparison between styles 

Two new modes (Comparison and Differences) have been added to the Advanced tab of the Text 

Styles dialog. Comparison mode shows a side by side comparison of the properties of two selected 

text styles. Differences mode shows the differences of the properties of two selected text styles. 

 

Text Style Comparison 

 

Text Style Differences 
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3.5-3 Word Processor enhancements 

Three new icons have been added to the Text Editor — Word Processor dialog. 

The Insert Field icon opens the new Field Type Picker dialog, used to select the type of field to be 

created. See Placeholder fields for more information. 

 

Text Functions 

The Superscript icon allows you to create text with superscript by typing in the text, clicking the 

superscript icon, then typing in the number. The Apply Changes to all Text check box must be toggled 

off to place superscript. 

 

Superscript Text 

The Subscript icon allows you to create text with subscript by typing in the text, clicking the subscript 

icon, then typing in the number. The Apply Changes to all Text check box must be toggled off to place 

subscript. 

 

Subscript Text 

3.5-3a Right-click to change case 

The Change Case > Upper Case and Change Case > Lower Case menu items have been added to the 

right-click menu of the Text Editor — Word Processor dialog. 

3.5-4 Using Fonts 

MicroStation supports three types of fonts: True Type, RSC (MicroStation Resource Font) and SHX 

(AutoCAD Fonts). 

3.5-4a True Type Fonts 

Many TrueType fonts are delivered with Windows, and many more are available from various vendors 

for free or for purchase. TrueType is an industry standard format supported by MicroStation. In 

general, this is the recommended font type for use in MicroStation. TrueType fonts also include full 
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Unicode support (note: not all TrueType fonts contain characters for all languages). TrueType fonts 

are always filled, and therefore do not provide good support for “stick” fonts (as opposed to SHX and 

RSC fonts). 

3.5-4b RSC (MicroStation Resource Font) 

This font format is MicroStation-specific, and RSC fonts are stored in MicroStation resource (.rsc) 

files. A single resource file may contain several RSC fonts. RSC fonts have a number and a name, but 

only one font by a given number can be used at a time during a MicroStation session. If multiple RSC 

fonts share the same number, the last one to be loaded is the font assigned to that number in a 

given session. RSC fonts are locale-encoded, but support more than 255 characters (e.g. for some 

Asian languages). The code page of RSC fonts is specified in the font configuration file. If you use 

font characters for symbols, use RSC fonts rather than TrueType fonts.  

Due to various compatibility issues, and lack of customization tools, RSC other than those provided 

with SignCAD are no longer available for use in the INDOT Workspace. 

3.5-4c SHX (AutoCAD Fonts) 

MicroStation supports AutoCAD’s font format (including normal SHX fonts, SHX Unifonts, and SHX 

Bigfonts). You should use SHX fonts only when you must ensure AutoCAD compatibility, and TrueType 

fonts are not a viable option. SHX Unifonts are the current standard, and allow a single font (and font 

file) to contain characters in the entire Unicode range. Older SHX fonts only support up to 255 

characters, and thus require a paired SHX Bigfont to support languages with more than 255 

characters (e.g. Asian languages). In MicroStation, specifying a paired SHX Bigfont is optional, and is 

recommended if you require characters that cannot be provided by the base SHX font.  

If AutoCAD is installed, MicroStation searches for SHX fonts in AutoCAD’s Fonts directory (the “Fonts” 

folder in the installation directory of the most recently used version of AutoCAD). With or without 

AutoCAD, MicroStation searches the directories specified by MS_FONTPATH, as well as the same 

directory as the design file requesting the font.  

DWG Export: AutoCAD natively supports SHX fonts, and no special export is performed. 

3.5-5 Edit Text tool retains text settings 

In the past, the Edit Text tool would change the active settings whenever you edited a piece of text. 

This behavior has been changed so settings revert to the previous settings when the Edit Text tool is 

closed. This change affects the active settings only and not the text styles. 

3.5-6 Find/Replace Text supports data fields 

The Find/Replace Text tool can now find and replace text in enter data fields. 
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3.5-7 Disabling Text Field Backgrounds 

Various text tools may take advantage of MicroStation fields, tying Model or other properties to a 

piece of text.  Depending on the workflow, it may be desirable to disable the background of the text 

field for use in other applications. 

To disable the field background, go to the Workspace -> Preferences menu and navigate to the Text 

option on the left.  Enable the fourth option, Hide Field Background. 

 
Disabling Field Backgrounds 
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3.6 References Enhancements 

A major enhancement to references is the ability to edit a reference from within the active model. 

In addition, the active model's annotation scale applies to annotations in references. 

References have additional new features in MicroStation V8i (SELECTSeries 1). 

3.6-1 Activate reference for in-place editing 

A new capability lets you edit a reference in-place. That is, you can edit a reference from within the 

active model. To do this you first must activate the reference.  

 

Reference Activation 
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When a reference is activated: 

• Only operations on the activated reference are permitted. 

• By default, all elements in references above the activated reference in the file hierarchy, as 

well as the active model, are displayed with an override color. You can control whether or not 

an override color is used, and what the color is. 

• If you activate another reference, the currently activated reference is automatically 

deactivated. 

• The reference is locked so that it cannot be edited in another session. 

• DGN library data, such as levels and level filters, is not available in an activated reference 

file. 

• Activated referenced in InRoads allows for the interaction with underlying civil data such as 

terrains and alignments. 

3.6-2 References support active model annotation scale 

In the past you may have added annotations to design models that are referenced into sheets. You 

also may have added annotations directly on the sheet. If the annotations were too small, you would 

have changed the model's annotation scale, but that would have affected only the annotations 

directly on the sheet. The annotations in the reference were not changed. Therefore, the only way 

you could change the annotations was to exchange into the reference and scale them. 

Now the active model's annotation scale applies to annotations in references, too. If you change the 

scale of the annotations on the sheet, the scale of the annotations in the references changes as 

well. 

To make a reference's annotations use the active model's annotation scale, you must turn on this 

option. In the References dialog there is a new column named Use Active Annotation Scale. If this 

column is not visible, right-click in the column headings and turn it on. To turn on this option for a 

reference, click in this column to make a check mark appear. 

3.6-3 Detail scale 

Detail scale helps you represent the Master:Ref scale in terms of the sheet scale. For example, if 

your sheet scale (annotation scale) is 1/8” = 1´ and you want to place a detail reference of scale 

1/4” = 1´, simply pick the new scale from the Detail Scale combo box. It automatically computes the 

Master:Ref scale as 2:1. 

3.6-4 Synchronize with saved view 

When you attach a saved view, you can specify that the display of the reference should always be 

synchronized with the original saved view. In the Reference Attachment Settings dialog, turn on the 

Synchronize with Saved View check box. 

In order to change the appearance of a reference, you have to modify the saved view that it is 

synchronized with. This is to ensure fidelity of display properties such as view attributes, level masks, 

clip volume, display styles and others. 
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When synchronized, the reference location is also realigned. Specifically, when the reference is 

synchronized with the saved view, the reference center and saved view center remain aligned. You 

can see the effect of this in two ways:  

In an unsynchronized state, the reference is first shifted and then synchronized. 

When synchronized, the saved view center is changed; for example, the saved view is stretched. 

3.6-5 Drawing title 

When attaching a reference on a sheet, you can optionally create a drawing title. A drawing title 

describes a drawing on a sheet. If there are four references on a sheet (top, front, right, and 

isometric), you create four drawing titles to demarcate the four references. It plays a crucial role in 

automatically linking call-outs across sheets. Properties such as Name, Detail Scale, and Identifier 

are displayed in the call-outs in the form of fields. 

3.6-6 Change Attachment Orientation 

In this edition you can change the orientation of the reference attachment by clicking the reference's 

Orientation column in the References dialog.  

3.6-7 Reference Detail Scale 

When attaching a reference (a design or drawing model) into a sheet model, the referenced model's 

annotation scale is applied as the detail scale, and the Reference Scale (Master:Ref Scale) is 

calculated from the referenced model's annotation scale and the active model's annotation scale. 

3.6-8 Working with RDL Files 

With this release of the CAD Workspace, ProjectWise and redlining capabilities are available via a 

web browser at dotwise.indot.in.gov. Please note that this site is not available internally. The .rdl file 

is a redlining file created by using these tools and can be attached as a standard reference in 

MicroStation and used in the same manner. 

4. Plotting 
As of this latest release, CAD Support is advocating the use of the Print Organizer tool in OpenRoads 

Designer and MicroStation to create plots—which will eventually replace ProjectWise InterPlot 

Organizer once the OpenRoads Designer rollout occurs.  As with prior releases of the INDOT 

Workspace, users can continue to use the ProjectWise InterPlot Software to fulfill their plotting needs 

for the foreseeable future; however, it is strongly suggested by CAD Support to transition to using 

Print Organizer to create plots.  This chapter will discuss the processes needed to create and print 

plot sets for each method.  Also, with the update to Adobe Acrobat DC, we will discuss the steps to 

create and implement your digital signature on plan sheets for each method as well. 

All of the enhancements to the plotting environment are a product of countless hours of research 

based on the lessons that CAD Support has learned over previous releases of the workspace and 

best practices in place within INDOT and other agencies.   
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It should also be noted that Print Organizer can facilitate all the same functionality as InterPlot 

Organizer, except that it does require some minor changes to the document signature process—

which will be covered later in this chapter. 

4.1-1 PDF Support Only 

First up, we’d like to provide some notes on how plotting is supported.  Due to the number of 

different plotter and printer configurations currently available across all INDOT locations, CAD 

Support is now using a) preconfigured Print Styles for use with Print Organizer, and b) a single 

driver/multiple plotter setup for exporting files to PDF using InterPlot Organizer.   As PDF is largely 

becoming the standard format for the publishing of documents to ERMS and for transport across the 

agency, CAD support has found that this method will allow better control for the consistency of plots, 

while maintaining the flexibility to send the completed PDF to any preferred hardcopy device 

(printer/plotter).   

The attempted usage of any non-supported Print Style, plot queue, or hard copy device can 

potentially result in application instability, or the failure of the application to generate the 

appropriately formatted end product.  Please ensure that you’re using the appropriate methods 

discussed in the following sections. 

4.2 How to Create a Plot Set with Print Organizer 

This section will cover the necessary steps to create a plot set using the INDOT CAD Workspace and 

the Print Organizer tool in MicroStation.  Then after covering the process, a subsection is provided 

with tips on how to use Print Organizer most effectively and troubleshooting common issues that may 

arise when using the tool. 
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4.2-1 Creating the Plot Set 

1. The Print Organizer tool can be accessed by going to File > Print Organizer… in the 

MicroStation menu bar. 

 

Accessing Print Organizer 

The Print Organizer dialog will then appear as shown: 

 

Print Organizer Dialog 
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2. To add files to the plot set, click on File > Add Files to Set… in the Print Organizer dialog. 

 

Add Files to Set 

3. This will open the Create Print Definitions dialog.  On this dialog, click on the Add button to 

add the necessary files to the plot set. 

 

Add button 
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4. Once the desired files have been added, the fields in the “Print definition creation options” 

section will then become enabled.  To apply a Print Style to the files, click on the magnifying 

glass icon to the right of the “Print style name:” field. 

 

Selecting a Print Style 

Upon clicking on the icon, the user will be presented with a list of preconfigured Print Styles 

to apply. 

 

Preconfigured INDOT Print Styles 
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To provide clarity, here is an explanation of the naming convention for these print styles: 

8.5 x 11 Configured for use with 8.5 x 11 sheets. 

Full Size Configured for use with Full Size sheets. 

Color Configured specifically for use if plotting in color is desired. 

XSec Configured specifically for use with cross section sheets. 

 

5. Select the desired Print Style from the list and click OK to exit the Apply Print Style dialog.  

With the files added and the Print Style applied, proceed to click OK on the Create Print 

Definitions dialog to apply the Print Style to the files—which will then be added to the plot set. 

 

Applying Print Style to the Added Files 

Upon completion of the processing, the Print Style will be applied to the selected files, and 

the resulting plots will be added to the plot set in the Print Organizer dialog.  The example 

shown below results from applying the INDOT Full Size_XSec PDF Print Style to a cross 

section drawing. 

 

Plots Created and Added to Plot Set 
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6. Once all of the desired plots have been created, it is highly recommended to first save the 

plot set for future use.  To accomplish this, click on File > Save As… in the Print Organizer 

dialog, and select the No Wizard option when prompted.  It is suggested to save this under 

the Plot Sets folder for the ProjectWise project being worked from.  Name the plot set as 

desired, and click Save to save the plot set file (.pset) to ProjectWise. 

7. To print the plot set to PDF format, click on File > Print… in the Print Organizer dialog. 

 

File > Print… 

8. On the Print dialog that appears, click on the magnifying glass icon in the Submit section to 

save the resulting PDF file to a desired destination (it is suggested to save this outside of 

ProjectWise). 

 

Selecting Desired Destination of PDF File 
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9. After selecting the destination, click OK to print the plot set to PDF format.  Once completed, 

the PDF file will be created and placed in the desired location. 

4.2-2 Print Organizer Tips and Troubleshooting 

This section will cover some tips and best practices when it comes to using Print Organizer.  

Troubleshooting common issues in Print Organizer will also be covered. 

4.2-2a Creating a Plot Set Using Multiple Print Styles 

It could be a common occurrence to need to use multiple Print Styles to create a plot set.  In a much 

similar fashion to the current process with InterPlot Organizer, if a user needed to create a plot set 

that contained sheets with cross sections AND ALSO contained sheets without cross sections (Plan 

and Profile sheets for example), the process for adding files to the set would need to be run twice: 

once for the cross sections file using a cross section-specific Print Style, and a second time for the 

other sheets that are not cross sections.  To continue from where Section 1.2-3 left off, if it was 

necessary to add other sheets to the plot set, the process would need to be run a second time.  This 

time, the Create Print Definitions dialog would look similar to the following: 

 

Adding Sheets to a Plot Set with a Separate Print Style 

Note that the Print Style chosen is not associated with cross sections.  Separate print styles are 

needed in this scenario, as the sheet border frames are addressed differently between cross section 

sheets and any other sheet—which is how the plot extents are determined.  The resulting plot set 

would now look like the following: 
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Completed Plot Set with a Second Print Style 

When completed, the second set of sheets will be placed into the plot as denoted above. 

4.2-2b Adjusting Raster Options on Plots 

If a plot in the plot set contains raster imagery, the user can adjust the Raster Options on it if 

desired.  To access these settings, right-click on the plot in the plot set and select Properties.  Then 

click on the Advanced tab in the Properties dialog that appears to view the raster settings. 
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Raster Options 

Of particular note is the “Print raster in grayscale” setting, which allows the user to have the raster 

image plotted in grayscale vs. color.  There is also the Raster Quality setting, where a user can set 

the Quality factor as a percentage of the printer resolution (dpi).  The default setting that has been 

configured with the Print Styles is a factor of 50 (percent).  This can be adjusted if desired, but note 

that a higher factor could have a significantly negative effect on the time it takes for Print Organizer 

to process the plot. 

4.2-2c Using an Incorrect Print Style to Add Files to a Plot Set 

If an incorrect Print Style is chosen to add plots to a plot set, undesirable results will occur.  Here is 

an example of what occurs when a non-cross section Print Style is applied to a cross section drawing: 



 

175  

 

 

Applying Non-Cross Section Print Style to a Cross Section Drawing 

What ends up happening is that only one plot gets created—and that one plot contains all of the 

sections.  This is why it’s important to use a cross section specific Print Style when working with 

cross sections—as these Print Styles have been configured to split the cross sections into their 

separate sheets. 

 

Conversely, if a cross section specific Print Style is applied to a drawing that does not contain cross 

sections, no plots will get created in the plot set.  Instead, notifications will appear in the Message 

Center in MicroStation to notify you of the issue: 

 

 

Applying Cross Section Print Style to a Non-Cross Section Drawing 

No plots get created in this scenario because the cross section Print Styles are configured to 

specifically look for cross section border frames to create the separate sheets.  All sheets other than 

cross sections do not have these border frames, so the Print Style is not able to create plots from 

them. 

4.3 How to Create a Plot Set with ProjectWise InterPlot Organizer 

This section will cover these necessary steps to creating a plot set using the INDOT CAD Workspace 

and InterPlot Organizer software.  The following subsections are presented in the order these steps 

should be performed in order to make sure that each step is appropriately covered, and the specifics 

of each feature are discussed. 

4.3-1 Attaching Plot Drivers 

When using ProjectWise InterPlot Organizer, one must first attach an eligible print driver from the 

ProjectWise InterPlot Server.  For the agency, we have provided a PDF plot queue to spool against 

using an HP plotter driver that provides excellent performance to quality in a mixed raster/vector plot 

environment which is typical of the plots generated by design staff.  All files plotted from IPLOT or 

ProjectWise InterPlot Organizer will be plotted using this plot queue.  It can be attached from the 

following server location, and this should be completed prior to creating a plot set: 
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DOTAPPP012VW 

You will need to type the following into the address bar… \\DOTAPPP012VW\ 

At this location, there will be one plot queue for your usage. 

• HPQueue 

 
DOTAPPP012VW HP Queues 

This can be selected by simply double clicking on the queue in your Windows Explorer which will 

connect it to your computer and make it available for use with InterPlot. 

4.3-2 HP Plot Queue Settings 

In order for our sheets to align properly on the page, we have enabled a number of form sizes to best 

accommodate most plotting situations.  As part of these form sizes, we have enabled the full bleed 

form sizes allowing for minimal setup to place our plots with the correct margins when using our 

settings files. 

The most commonly used form sizes on the HP are listed below: 

HP Form Sizes 

Oversize: Arch D 

Oversize: Arch B 

Oversize: ANSI B (Tabloid) 

 

As previously mentioned, Interplot Settings Files (.set) will be provided to quickly apply a common set 

of plotting settings using these and other common form sizes.  Should any manual adjustments to 

plots be needed, a number of different possible settings will need adjusted, which will be discussed 

later in this chapter after we’ve created a plot set and investigated the settings. 



 

177  

 

 

Iplot Properties 

The changes for using the HP forms are as follows: 

1. Make sure you’ve selected the appropriate form size from the chart earlier in this section. 

2. Do NOT check “Use full paper size”.  HP Forms have a built in margin factor that will cause 

the scaling of your prints to be incorrect.  By disabling the full paper size setting, it will 

recognize only the printable area which is consistent with the old OCE forms. 

3. All other settings should remain the same.  There may be specific adjustments that need to 

be made on a per-sheet basis. 

4.3-3 Launching the ProjectWise InterPlot Organizer 

InterPlot Organizer can be launched in a number of ways.  As with most other applications such as 

MicroStation and InRoads, it’s highly advised to launch the software from within ProjectWise so all 

integrated functions are enabled.  To do so: 

1. Locate the Plot Sets folder under your Design project 

 
The Plot Sets Folder 
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2. In the Document pane, right click and select New > Plot Set (if this option is unavailable, 

please submit a ticket to INDOT CAD Support) 

 
Creating a New Plot Set in ProjectWise 

3. A Create Plot Set window will be displayed.  Type in your Plot Set name, followed by the 

appropriate file extension of .ips.  As always, it’s recommended that the Name and 

Description be kept the same. 

 
Creating the .ips File 

4. Upon selecting OK on the previous dialog, your plot set file will be created.  You may then 

double click the file to launch the ProjectWise InterPlot Organizer: 

 
The Created Plot Set 

5. This will launch the application and you can proceed with plot creation. 
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4.3-4 Creating Plots in the ProjectWise Plot Organizer 

With a file to place our plots into, we can begin the process of creating the actual plots themselves.  

This section will cover the initial setup of our plot file, along with creating the plots from pre-defined 

extents, and using a settings file and design script to configure these plots in the appropriate ways 

1. With the plot set open in the InterPlot Organizer, select the File > Print Setup menu item. 

 
Printer Setup 

2. On the presented Printer Setup window, make sure that the Printer Name is set to the 

HPQueue device from DOTAPPP012VW, listed earlier in this section.  Select OK when ready. 

 
Setting the HPQueue 
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3. Next, select either File > Create Plots, or the Create Plots button on the toolbar 

 
Creating Plots 

4. At this time, you’ll be presented with the Create Plots Dialog.  However, prior to proceeding, 

we will be looking at some of the options that will be needed on this panel, specifically how to 

define your plotting extents using InterPlot Search Variables, and the usage of Settings Files 

and their Design Scripts. 

 
The Create Plots Dialog 
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5. On the Create Plots dialog, select the Add button and browse to and select the file you’d like 

to add to your plot set.  For this example, the test data will be using a copy of our template D 

size_sheets.dgn to illustrate advanced functionality. 

 
Adding DGN Files 

6. Before proceeding further, we will be looking at some of the options that are presented on 

this panel; specifically how to define your plotting extents using InterPlot Search Variables, 

and the usage of Settings Files and their Design Scripts. 

4.3-4a Using IPLOT Search Variables 

When initially creating plots, it is possible to used pre-defined model definitions to define individual 

plots.  Times where this could be used are situations where there may be multiple sheet models in a 

single DGN where you want to have each sheet represented included in your plot set without defining 

each and every model.  This can also be extended to basic design models. 

Note: The usage of these variables must be done at the time the plots are created using the Create 

Plots dialog.  If not used at this time, you cannot go back and extract the models from the created 

plot, you must delete the plot entry and re-create it. 

Both of the model extractions are done through the same process, only changing the variable used.  

This section will cover how and when to use these variables.  As we’re using the D size_sheets.dgn in 

this example, we may wish to create a plot for each of the sheet models that are contained in this 

file. 
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1. Select the plot you’ve added in the upper section of the Create Plots dialog.  Under Manually 

specified options, click on MicroStation DGN files and then click Options. 

 
Changing DGN Plot Options 

2. On the Plot Creation Options dialog, click on the Area tab.  Under Plot area, enable Sheet, 

and under Search models, type IP_SHEETDEF_MODELS to create a plot for each sheet 

model.  To create a plot for each design model, use IP_DESIGN_MODELS instead. 

 
Using IP_SHEETDEF_MODELS 
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3. When completed, select OK on the Plot Creation Options dialog, and then again on the 

Create Plots dialog.  The result will look similar to the following: 

 
Plots After Searching for Sheet Models  

At this time, every sheet model and sheet definition now has a configured plot in the Plot Organizer, 

however they don’t have the appropriate form sizes or scaling.  In the next section, we’ll look at the 

settings files and how to apply these to your plots at the time you create them. 

4.3-4b Design Scripts and Settings Files 

In this section, we’ll be covering the usage of Settings Files and their associated Design Scripts.  

When used at the time of plot creation, these tools can do a number of things that can assist in the 

setup of your plots, such as applying form sizes and adjusting scaling.  A full list of the features we’ve 

enabled for the Settings File and Design Scripts can be found below: 

Settings Files Design Scripts 

Applies pre-defined form sizes Defines percentage based screening on color 

Configures appropriate margins for plots Provides global screening based on element 

level 

InRoads Only: Extracts plots based on a 

predefined plot shape (typically for use with 

Cross Sections) 

Enables text replacement for page numbering, 

model name, plot date, plot time, and signature 

date 

Automatically attaches the appropriate Design 

Script 

Creates Digital Signature block for active 

placement in Adobe Acrobat 

 Sets appropriate pen thickness 

Also as a further integration into ProjectWise, all Design Scripts and Plot Settings files have been 

stored in ProjectWise.  This insures that all users have access to the most up to date file(s) at all 

times.  These can be found at: 

pw:\\indot-pw.bentley.com:indot-pw-01\Documents\Resources\Plotting\ 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Resources/Plotting/
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• INDOT HPQueue_AN.set - to be used with Electronic Signatures and Auto Page Numbering 

(for use with the HP Plot Queues for full size sheets). 

• INDOT HPQueue_NN.set - to be used with Electronic Signatures and no Page Numbering (for 

use with HP Plot Queues for full size sheets). 

• INDOT HP_Letter_AN.set - to be used with Electronic Signatures and Auto Page Numbering 

(for use with HP Plot Queues, and letter size sheets). 

• INDOT HP_Letter _NN.set - to be used with Electronic Signatures and no Page Numbering (for 

use with HP Plot Queues, and letter size sheets). 

The Design scripts can be found in the “Design Scripts” folder directly under the Plotting folder.  

These will be automatically attached when one of the previously listed .set files are used. 

In addition to the above .set files, you will also find a comparable version of the .set to be used with 

sheets cut from InRoads (ex. INDOT InRoads_HPQueue_AN.set).  These sheets do not follow the 

standard convention of being cut to true sheet models with paper border, rather they are adjusted 

differently.  To compensate, an exterior boundary set to transparent has been created for these 

borders.  These .set files use this shape as the plotting extents for InRoads sheets.  Other than that 

difference, these .set files should be used and configured in the exact same manner as previously 

shown.  It’s highly recommended that the .set files be attached at the time of plot creation to allow 

all instances of a level name to be found and taken into account.  Not doing this may cause InterPlot 

to find the incorrect instance of a plot shape in a given file and not return the plot expected. 

INDOT Pen Table_BW.tbl is automatically attached by the .set files as well, and controls the color 

table for finished prints.  Please note that all these resources are tailored to use with the DOTWise 

system and are for the creation of PDF output only. 

To attach the .set file at the time of plot creation, the following steps should be used: 

1. With your Input files added to the Create Plots dialog, select the Browse button on the Plot 

creation options > Settings file name: field. 

 
Applying Settings Files 
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2. Navigate to the Documents\Resources\Plotting location in ProjectWise and select the 

appropriate settings for your needs.  In this example, we’ll be using the INDOT 

HPQueue_AN.set. 

 
Selecting Settings Files 

3. Your Create Plots dialog will then look like this prior to creating the plot entries. 

 
Adding Plots with a Settings File 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Resources/Plotting/
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4.3-5 Creating Plots in the ProjectWise Plot Organizer – Continued 

Please note that the number is continued in sequence from section 4.3-4 Creating Plots in the 

ProjectWise Plot Organizer, not the subsections presented within. 

7. At this point, we’ll continue our sample plots.  The sample will be created as discussed in the 

two prior sections where we defined a Sheet Definition to search for, and the application of 

the INDOT HPQueue_AN.set file.  On the Create Plots dialog shown in the previous section, 

hit OK and InterPlot will create a series of plots based on the criteria that’s been defined. 

8. With the plots created, you can now see in the Design Script, Pen Table (for colors), Paper 

Size, Scale, and Plot Size are now pre-set to the appropriate values for a full size D size set of 

plans. 

Fully Setup Plots 

9. At this time, you can now proceed with creating the actual PDF out of the Organizer.  On the 

InterPlot Organizer toolbar, select the PDF button or from the File > Export PDF button. 

 
Export to PDF 
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10. On the Export PDF dialog, set your options as you’d prefer.  The most common method is to 

send all plots to a single PDF file using the settings shown.  You can however adjust the plots 

you want to send by selecting them on the Plot Organizer prior to starting the Export. 

 
Export to PDF Settings 

11. Select Create PDF and then place the file where you’d like.  It’s recommended to send the 

finished PDF to your PC to validate that the content is correct and then drag and drop it into 

ProjectWise when confirmed correct. 

12. InterPlot Organizer will then process your plots and create the PDF file.  When you see the 

below in the status bar, your plot is completed and can be verified prior to uploading to 

ProjectWise or sent wherever else it is needed. 

 
Export to PDF Completed 
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4.3-6 ProjectWise Tips and Troubleshooting 

4.3-6a Additional Notes on Design Scripts and Color Tables 

In most instances, the settings provided by the Design Scripts are suitable for most situations.  In the 

event you need to use other Design Scripts or color tables, the following process should be followed.  

For any plot you need to circumvent the settings on: 

1. Right click on the plot to be modified, and select the Properties setting. 

 
Opening Plot Properties 

2. On the displayed Properties panel, select the General tab. 

 
Properties > General Tab 
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3. On the General tab, the two items that are typically modified would be the Design Script or 

MicroStation pen tablet entries shown below: 

 
Modifying the Design Script/Pen Table 

4. For Design Scripts, at \Documents\Resources\Plotting\Design Scripts\ in ProjectWise you 

can find No Screening options which remove the automatic plot screening in the default 

entries. 

5. For Pen Tables, at \Documents\Resources\Plotting\Pen Tables\ in ProjectWise you can find 

a color pen table in addition to the black and white one. 

6. When completed, select the OK button on the Properties panel.  Note that you can modify 

multiple plots at once by selecting them and then performing the properties changes. 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/Resources/Plotting/Design%20Scripts/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Resources/Plotting/Pen%20Tables/
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4.3-6b InterPlot Troubleshooting and the Rasterized setting 

One of the most common issues with InterPlot are files that appear to cause the plot set to not 

process.  This is most commonly caused by files that have a large raster image pasted within the plot 

extents.  The first step prior to submitting a problem report should be to enable the Rasterized 

setting on the affected sheets within the plot set and then resending the plot.  To locate the 

Rasterized setting, right click on the plot in your set and select Properties.  In the Properties, select 

the General tab and check the box for Rasterized at the bottom of the window. 

 
The Rasterized Setting 

In many instances, this will resolve issues with plots and allow the set to go through properly.  Please 

be advised that this setting should be used judiciously, as it does increase the amount of time that 

individual plots can take to be processed.  
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4.4 Reducing the Size of PDF Files Created from Plot Sets 

After creating a PDF plot set from either Print Organizer or ProjectWise InterPlot Organizer, it is 

recommended that users reduce its file size from within Adobe Acrobat.  The process for this is 

described below: 

1. With the PDF file open in Adobe Acrobat, click on File > Reduce File Size. 

 

File > Reduce File Size from Acrobat Menu 

2. You will then be prompted to select a folder location where your reduced size PDF will be 

saved.  Choose a folder that’s already listed, or you can choose a different folder if 

necessary. 

 

Save As Reduced Size PDF 
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3. As prompted, name the reduced size PDF to be created, and click Save.  Saving it to your 

local computer is shown below. 

 

Naming the Reduced Size PDF 

4. Adobe will then proceed with the file compression process, which can take a few minutes 

depending on the amount data it has to compress.  Once completed, the file will be created 

and placed in the specified location.  In addition, a message will appear to let you know how 

much the original PDF file was compressed. 

 

File Size Reduction Message 

4.5 Preparing an Electronic Signature 

In this section, we will discuss the creation of the Electronic signature and the associated image with 

it. 

4.5-1 Creating a .pdf of your Signature 

Note:  Before starting this process, you will need to determine where your Digital ID should be saved, 

which should be in a secure location that only you have access to.  One suggestion would be in your 

Documents folder or your H:\ drive.  This will ensure that your Digital ID will be available to you as 

long as you are logged into the DOT domain. 

You will need to locate an INDOT photocopier that also scans images for this next exercise.  One that 

also sends the scanned image to you via email would be a best case scenario. 
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1. Navigate within ProjectWise to … \Documents\Resources\Design Information\Electronic 

Signatures\Electronic Signature.pdf. (This folder contains the sheets on 8.5” x 11” paper 

that you use to scan your signature.) 

2. Open (read only) Electronic Signature.pdf (This is an 8.5” x 11” print of the signature area on 

a large format (D+ 24” x 36”) border sheet. 

 

PDF Electronic Signature Template 

Notice the faint yellow line in the signature area.  Your signature must be contained entirely 

within this area.  (Your signature should not cross the line above “DESIGN ENGINEER”. 

o Print the .pdf onto an 8.5” x 11” sheet of paper, and then sign the printed piece of 

paper as you would sign a contract document.  Remembering to keep your signature 

within the now very faint box described in the previous step.  Some additional 

suggestions are: 

• Use a black pen, blue doesn’t always cooperate in gray scale situations and can 

contribute to poor contrast with the finished product. 

• Use a fine point marker or felt tip pen.  Both will give the actual signature some 

weight that will transfer better when inserted/cropped/scaled. 

• Exaggerate the size of your signature.  This will also assist in visibility when it is 

inserted/cropped/scaled. 

3. Locate a printer/copier with scanning and emailing capabilities.  Then scan and email the 

paper with your signature to yourself. 

4. Open the .pdf that you previously scanned/emailed using Adobe Acrobat.  If you do not have 

Adobe Acrobat, you will need to locate a machine with this installed.   Please contact your 

supervisor and security coordinator should you require this software. 

5. You may have to rotate the image so that it is orientated properly.  This can be accomplished 

using the Rotate View tool in Adobe Acrobat. 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Resources/Design%20Information/Electronic%20Signatures/Electronic%20Signature.pdf
pw://indot-pw.bentley.com:indot-pw-01/Documents/Resources/Design%20Information/Electronic%20Signatures/Electronic%20Signature.pdf
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Scanned PDF Signature 
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6. Using the zoom tools, make your signature just large enough that you see it, and a portion of 

the surrounding data.  As shown below. 

 
Scanned PDF Signature 

7. In Adobe Acrobat Reader in the menu bar, go to View > Tools > Edit PDF > Open 

 

Cropping the PDF Signature 

8. This will open the Edit PDF toolbar and pane.  On the toolbar, select the Crop Pages tool. 
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9. Draw a box around your signature by left clicking the mouse button and dragging the mouse.  

Try to get as close to the outline of the previously mentioned “faint yellow line” as shown in 

an earlier step in this exercise. If necessary, drag the corner handles of the cropping 

rectangle until the cropping rectangle is the size you want.  Do not cross any of the elements 

in the border sheet. 

 

Cropping the PDF Signature 

10. Double-click inside the cropping rectangle. 

 

Cropping the PDF Signature 

  



 

197  

 

11. This will open the Crop Pages dialog box.  Make sure that all of your options match those 

illustrated below except the margins which may differ for all users. 

 

Cropping the PDF Signature 

12. Click Ok. 

 

The Finished PDF Signature 
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13. Save the file making sure to place it in a location that meets the criteria listed in the note at 

the beginning of this series of exercises. 

Note:  When using Adobe Acrobat Professional DC, you will need to make sure that the background 

is turned on so that the electronic signature will cover the “this media not considered a certified 

document” text that is in the signature block on the border sheets.  

14. On the Edit PDF toolbar, you may have to select the ellipsis or More menu (depends on if the 

window is maximized), followed by Background > Add. 

 
PDF Signature Background 

15. Then, taking the default settings, click OK on the Add Background dialog box. 

 
Adding a Signature Background 

16. At this time, save your PDF signature image to a location you can locate for the following 

steps. 
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4.5-2 Creating an Electronic Certificate 

Once you have created a .pdf version of your signature, you then need to create a secure certificate 

to use to manage your signature.  Once created, the certificate will be stored by you in a secure 

location and you will be required to send the CAD Support staff a version of your certificate so that 

we may store it in a secure location in ProjectWise, should there be a need to either verify your 

signature or replace a lost (deleted) local copy.  This can be done using either Adobe Acrobat 

Professional or Acrobat Reader. 

1. In the Adobe Acrobat Professional tool bar select Edit > Preferences.  

 

Creating the Electronic Signature 
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2. In the left column of the Preferences dialog box select Signatures and then click More in the 

Identities & Trusted Certificates area of the dialog box. 

 
Adobe Signature Preferences 

3. In the left column of the Digital ID and Trusted Certificates Settings dialog box select Digital 

IDs, and then click Add ID. 

 

Creating the Electronic Signature ID 
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4. In the Add Digital ID dialog box, select A new digital ID I want to create now, and then select 

the Next button. 

 

Adding the Digital ID 

5. Select the New PKCS#12 Digital ID File and then select the Next button. 

 

Adding the Digital ID 
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6. Fill out the dialog with the appropriate information.  The Organization Unit should be your 

District and Division. (i.e.…. CO – Roadway Services, CO – Structural Services, Vincennes 

Design, Seymour Design…).  All other settings may be left with their default values. 

 

Adding the Digital ID 
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7. Now you will need to save the Digital ID.   Make sure to place the file into a location that 

meets the criteria described in the note at the beginning of this series of exercises. 

When saving the PFX file (Digital ID), make sure you use the following file naming convention.  

Date is necessary in the event another Digital ID is created in the future.  The Adobe version 

is important for compatibility reasons. 

 

Userid_YYYYMMDD.pfx  [CADSupport_20180731.pfx] 

 

You will need to create a password that you will use every time you apply your Digital ID.  

Don’t forget your password or you will need to create a new Digital Id.  The password has to 

be a minimum of 6 characters and it is case sensitive. 

 

Adding the Digital ID 

8. Select Finish. 
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9. Now, highlight your name and select the Export option.  The file created in this can be used 

to validate your Digital ID. 

 
Exporting the FDF File 

10. Select the Save the data to a file option and click Next. 

 

Exporting the FDF File 
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11. When saving the exported file, make sure that the path is to the same location as your Digital 

ID.  The Save As type should be set to Acrobat FDF Data Exchange. 

 

Userid_YYYYMMDD_ver.fdf  [CADSupport_20180731_DCprof.fdf] 

 

Exporting the FDF File 

12. Now that you have created a certification file to validate your Digital ID, you will need to email 

that .fdf file to INDOT CAD Support (indotcadsupport@indot.in.gov).  INDOT will then be the 

holder of this file to validate any contract plans that you have signed electronically.  The .fdf 

file will be kept in a secure location within ProjectWise where it cannot be altered in any way.   

 

Exporting the FDF File 

Note:  If you would like for CAD Support to store a copy of the .pdf of your signature, make sure to 

forward a copy of the .pdf at the same time that you send the copy of your .fdf file. 

mailto:indotcadsupport@indot.in.gov
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4.5-3 Creating the Electronic Signature Image 

Now, using either Adobe Acrobat, you’ll need to generate the graphical appearance of your signature.   

For this, we’ll return to the scanned image of the signature you generated earlier in this section. 

1. Click More in the Creation & Appearance area of the Preferences dialog box. 

 

PDF Signature Properties 

2. In the Appearances area of the Creation and Appearances Preferences dialog box, click New. 

 
Combining the PDF & FDF Signatures 
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3. This opens the Configure Signature Appearance dialog box.  Configure this dialog as 

described below. 

 
Combining the PDF & FDF Signatures 

• Title: Use the name that you use in your signature. 

• Configure Graphic:  Select Imported Graphic and select the File button.  Browse to the 

location that you stored the .pdf of your signature. 

• Configure Text:  Disable all!  We will use the functions of IPLOT to fill in the date. 

• Text Properties: Use the default selection. 

4. Now you have created you Electronic Signature Image.  Click the OK button. 

5. Click on the Ok button on the Creation and Appearances Dialog box, this will take you back to 

the Preferences dialog box, Select OK. 
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4.6 Applying Electronic Signatures to Exported PDFs 

4.6-1 Overview: 

As mentioned at the front of this chapter, the use of Electronic Signatures has been approved and is 

in use by INDOT.  Note that the Electronic Signature is not placed on every sheet in the document, 

but is used to electronically sign and seal the entire plan set.  If, after placing the Electronic 

Signature any page within the .pdf plan set is altered in any way, the Electronic Signature will appear 

with a broken indicator. 

4.6-2 “Signing” sheets within the plan set 

Per the approval INDOT has received, it has been determined that a graphic representation of the 

Engineers signature responsible for each sheet within a plan set is acceptable.  Therefore, an 

interface has been provided for the purpose of signing the sheets within a plan set.  This can be 

done either individually or as a group function. 

4.6-2a Placing the Graphic Representation of a Signature on individual Sheets: 

1. In ProjectWise Explorer, Set your interface to _Signature 

2. Modify the Properties of the MicroStation file that you want to place the Graphic 

Representation in. 

 

Setting Document Properties 
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3. Select the Attributes Tab of the Document Properties dialog Box and place the Name of the 

Responsible Engineer and the Date. 

 

__Signature Interface in ProjectWise 

4. The Graphic Representation of the signature will be placed on the sheet model using a script 

type font. 

 

Printed PDF Signature (prior to Signing) 
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4.6-2b Placing the Graphic Representation of a Signature on Multiple Sheets 

1. In ProjectWise Explorer, Set your interface to _PROJECT INFORMATION. 

2. Select the properties of the MicroStation files that you want to place the Graphic 

Representation in and on the Document menu, select Modify. 

  

Modifying Multiple Document Properties 

3. Select the Plan_Production tab on the Modify documents dialog box and scroll down to the 

entries for “SIG_DATE” and “SIGNATURE”.  

 
Modifying Multiple Document Properties 
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4. Place the name of the Responsible Engineer and date, and then select apply. 

5. The Graphic Representation of the signature will be placed on the sheet models using a 

script type font. 

 

Printed PDF Signature (prior to Signing) 

4.6-3 Electronically Signing the Plan Set Created by Print Organizer 

With Print Organizer, the plan set (.pdf) will be signed using the Responsible Engineer’s electronic 

signature after the plot is created.  The process differs slightly from the process that has been used 

in ProjectWise InterPlot Organizer, in that the user has to manually create the digital signature field 

to enter their signature. 

1. Create your plot set (.pset file) using the necessary Print Styles as discussed in section 4.2. 

2. Print the plot set to PDF format and open it using either Adobe Acrobat Professional or Adobe 

Acrobat Reader. 

3. View the Title Sheet and notice the text located in the “CERTIFIED BY:” area, stating that 

“THIS MEDIA SHOULD NOT BE CONSIDERED A CERTIFIED DOCUMENT”.  This is the text block 

that was put in place for ProjectWise InterPlot Organizer.  Due to a known functionality issue 

between Print Organizer and MicroStation SS4 and SS10, this block does not automatically 

get converted to a digital signature field when exported to PDF format.  Instead, the block is 

essentially treated as text. 

 

 

 

Unsigned PDF Document 
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4. To remedy the issue, a digital signature field needs to be created.  This can be accomplished 

by clicking on the Tools tab and then clicking on the Add button under Certificates in the 

Forms & Signatures section.  The button text will then change to “Open”, and then click the 

button again. 

 

Add Digital Signature Field 

5. With the Certificates tool set active, click on Digitally Sign in the toolbar. 

 

 

Digitally Sign 

6. You will then be prompted to click and drag to draw the area of your digital signature field.  

Proceed to draw the area such that it covers up the text that currently exists in the block.  

You may receive a warning about the signature field being “fairly small”.  This can be 

disregarded, so click the Sign button to proceed. 

 

Creating Digital Signature Field 
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7. This will activate the “Sign with a Digital ID” dialog box.  Fill this form out as you see fit.  Then 

after using the password that you chose when you created your Digital ID (4.5-2), select 

Continue on the first panel, and then Sign once you’ve selected the appropriate image. 

 

Applying the Electronic Signature 
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8. After clicking on Sign in Acrobat DC, you will automatically be prompted to save your signed 

file in another location.  Place this file at a location of your choosing and then drag/drop it 

into ProjectWise. 

 

Signature Confirmation 

9. With the signature applied, you can then validate that the file is signed using the steps 

outlined in Section 4.6-5. 

4.6-4 Electronically Signing the Plan Set Created by ProjectWise InterPlot Organizer 

With ProjectWise InterPlot Organizer, the plan set (.pdf) will be signed using the Responsible 

Engineer’s Electronic signature after the plot is created.  This is accomplished by using one of the 

new design scripts provided. 

1. Create your plot set (.ips file) using one of the design scripts discussed in Section 4.3-1 of 

this document. 

2. Export the .pdf file and open using either Adobe Acrobat Professional or Adobe Acrobat 

Reader. 

3. Open the Title Sheet and notice in the “Certified by” area, text stating that “THIS MEDIA 

SHOULD NOT BE CONSIDERED A CERTIFIED DOCUMENT”.   This text is in place to ensure that 

the reviewer knows that the plan set has not yet been signed by the responsible engineer.  

This text is in place on both the letter size and 24” x 36” title sheets. 

 

Unsigned PDF Document 
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4. To electronically sign the plan set, the responsible engineer can simply left mouse click on 

shaded signature box.  To sign the document select “Sign Document”. 

 
PDF Document Signing 

5. This will activate the “Sign with a Digital ID” dialog box.  Fill this form out as you see fit.  Then 

after using the password that you chose when you created your Digital ID (4.5-2), select 

Continue on the first panel, and then Sign once you’ve selected the appropriate image. 

 

Applying the Electronic Signature 
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6. After clicking on Sign in Acrobat DC, you will automatically be prompted to save your signed 

file in another location.  Place this file at a location of your choosing and then drag/drop it 

into ProjectWise. 

 

Signature Confirmation 

7. With the signature applied, you can then validate the signature using the steps in the 

following section. 

4.6-5 Verification of Signatures 

If the need to verify a signature arises, CAD Support will be able to provide the appropriate files for 

verification provided the end user has provided their .fdf file for storage.  Otherwise the signature will 

present that the file is in its original, unaltered state.  To verify signatures in Adobe Acrobat, the 

following process can be done: 

1. After applying the signature to your file, you can then validate that the file is signed by 

clicking on the signature itself.  You will receive a Signature Validation Status dialog similar to 

what is shown below: 

 

Signature Validation Status 
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2. You can also further vet the signature at this point by clicking on the Signature Properties 

button.  Note that you can then see all the signatures applied to a single document. 

 
Signature Properties 

5. InRoads, OpenRoads and ProjectWise 
InRoads and OpenRoads technologies are integrated with both MicroStation and ProjectWise. As 

such, the ProjectWise Managed Workspace delivers InRoads configurations and template files within 

the managed ProjectWise environment.  Throughout this document, specific functionality of InRoads 

with ProjectWise will be called out and expanded on in a workflow specific manner. 

5.1 InRoads and OpenRoads, What’s the Difference? 

Throughout the coming chapters, you’ll see references to InRoads, OpenRoads, native tools and 

OpenRoads technologies.  It’s important to know that in the SS4 version of the software, all of these 

functionalities are available—it’s just a matter of determining which tools belong with each reference.  

We have tried to distinguish which toolsets are being used, but the following listings will shed some 

light on the specifics. 

InRoads and Native Tools – These are the tools and file formats that are recognizable from the SS2 

Version of InRoads.  Native tools would be anything that’s on the InRoads Explorer, so items like 

Annotations, Plan and Profile Generator, and the like.  These references may also include the old file 

formats such as ALGs, DTMs, etc. 

OpenRoads and OpenRoads Technologies – SS4 is the last version of software that will be branded 

as InRoads.  As such, Bentley has started bringing the branding of the next generation product down 

to the current release and are calling these OpenRoads Technologies.  For INDOT purposes, the 

major areas where these will be used are items such as OpenRoads Survey, Terrains, Civil Geometry, 
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Corridor Modeling, and Cross Sections as these all rely on features not found in the old InRoads 

toolset. 
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5.2 InRoads Standards and Seed Files 

This section will discuss the location of INDOT-specific InRoads standards and seed files for use with 

the application.  All InRoads files except DGN seed files will be found under folders within the 

following ProjectWise path: pw:\\indot-pw.bentley.com:indot-pw-01\Documents\INDOT 

Workspace\OpenRoads\Workspace\.  It’s highly advised that users do not interact directly with files 

under this location as InRoads and the underlying OpenRoads technology require that the workspace 

maintains a high degree of integration. 

5.2-1 XIN File 

The INDOT-configured XIN file can be found in the XIN folder and is named INDOT.xin.  This file 

contains many of the INDOT-specific customizations for the look and feel of features such as 

topographical items, alignments, and profiles used by the native InRoads tools.  It also contains 

preferences for a wide variety of functions including stationing, curve sets, and plan and profile 

sheets, along with many other INDOT specific functions.   

New to the SS4 release of the workspace, the agency INDOT.xin is automatically attached upon 

starting InRoads.  This can be overridden to use personal XIN files by using either Project Defaults or 

.RWK project files.  Please see the following warning about performing this operation. 

Warning: Due to the high level of connectivity between the OpenRoads required DGNLibraries and 

the XIN, care should be used when modifying a personal XIN.  Any user wishing to customize the XIN 

must start with a fresh copy of the XIN listed previously as legacy XIN files may produce 

unpredictable results.  Be advised that when contacting INDOT CAD Support, setting the XIN back to 

the agency default will be the first troubleshooting step performed. 

In addition to the warning above, also be warned that if you are using a customized XIN file from 

prior to the December 2020 ProjectWise migration, processes such as plans production and cross 

section creation will not work as expected due to these processes using hard-coded ProjectWise 

paths.  In these cases, please use either the default XIN file or submit a helpdesk ticket for 

assistance. 

5.2-2 INDOT Specific Preferences 

Within the XIN, there are numerous tools that have preferences configured for items and 

functionality specific to INDOT.  When you see the following button when using an InRoads tool, it is 

recommended to check within and see if there’s an INDOT specific setup: 

 

Preferences Button 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/
pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/
pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/xin/
pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/xin/INDOT.xin
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When inspecting the preferences, you may see a wide variety of preferences for differing situations.  

The following illustration shows the preferences defined for the View Contours tools: 

 

View Contours Preferences 

The naming convention for preferences is as follows: 

• Default - A predefined preference.  For many tools, this may be setup to be the same as the 

most commonly used INDOT preference. 

• IN … – An INDOT specific preference. 

• IN PW … - An INDOT specific preference requiring a connection to DOTWISE to use. 

• xBentley Default – The default preference as defined by Bentley.  In most cases this should 

not be used except for troubleshooting. 

5.2-3 ITL File 

With the release of the InRoads/OpenRoads SS4 workspace, a customized agency template library 

has been created and is now available.  It contains a number of default templates configured with 

agency specific feature, component, and point naming.  It also contains the relevant templates used 

by the agency civil cells. 

These templates can be found under the template_library folder, in the INDOT.itl file.  Similar to the 

XIN, this library is automatically attached at startup. 

5.2-4 Civil Cells 

With the migration to InRoads SS4 and OpenRoads technology, the workspace now contains a 

number of Civil Cells.  These can be found under the civil cells folder and are attached automatically 

at startup.  Note that these are DGNLib files, and direct customization will not be available. 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/data/template_library/
pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/data/template_library/INDOT.ITL
pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/civil%20cells/
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5.2-5 Cell Libraries 

All INDOT cells for use with InRoads can be found under the cell folder.  There are currently two cell 

libraries in use under this folder: 

• INDOT Aerial Engineering InRoads Cell Library.cel 

• IN_InRoads.cel 

• IN_MOTCells.cel 

• IN_PE-LS-Stamps.cel 

• IN_Signs_Construction.cel 

• IN_Signs_Guide.cel 

• IN_Signs_Recreational.cel 

• IN_Signs_Regulatory.cel 

• IN_Signs_School-ObjectMarkers.cel 

• IN_Signs_Warning.cel 

The first library is used by the Aerial Survey group for topographical collection.  The second library is 

used for the display of point features in the topographical surface and other items such as cells 

placed for title sheet integration and north arrows. 

5.2-6 Plans Production 

The files located under Plans Production are used in the creation of cross sections and sheets 

created using the Plan and Profile Generator.  Discussion of these files will be expanded with their 

usage in the Plans Production workflow. 

5.2-7 InRoads DGN Seed Files and the Importance of File Associations 

InRoads allows for any DGN or model in a DGN to be a container for InRoads elements at any time.  

As such, the first item required when starting an InRoads project is the appropriate unit DGN seed 

file.  For all new projects that are created after the Fall 2013 release of the Indiana Design Manual 

Part 1 (Ch. 106, Section 26-1.01 memo requiring Geo-Coordinated seed files), you will be provided a 

Survey seed file in the pw:\\indot-pw.bentley.com:indot-pw-01\Documents\District\Des No.\ 

Survey\Project Files folder of your project with the following naming convention: Des #_SRxx Seed 

2D.dgn and Des #_SRxx Seed 3D.dgn.  These seed files are used to set the coordinate system for 

every InRoads based file in your project.  Each will already have the properly selected working units 

for your project.  If you are a consultant working on an INDOT project and do not have access to the 

Survey\Project Files folder, please contact your Surveyor to request the newly required geo-

coordinated seed files. 

Your project might fall outside the requirement window of the new design memo, so you may 

continue to use the previous method of creating your own seed file (or possibly ask the Surveyor if 

they can create one for you).  The files you will need are located with the rest of the INDOT specific 

ProjectWise seed files.  They can be found at pw:\\indot-pw.bentley.com:indot-pw-

01\Documents\Template Documents\SS4 Seed\InRoads\. 

At the root of this location, 2 seed files have been provided, corresponding to the units of 

measurement used in current INDOT projects.  These are: 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT&space;Workspace/OpenRoads/Workspace/cell/
pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/Plans%20Production/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/InRoads/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/InRoads/
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• INDOT_US_SVFT_3Dseed.dgn 

• INDOT_US_SVFT_2Dseed.dgn 

Please note that in both instances 2D and 3D versions of each file have been made available.  

OpenRoads technology allows for the full use of civil data regardless of the availability of the Z axis.  

For instance, when showing 3D OpenRoads elements in a 2D seed file, a 3D model will automatically 

be created as needed.  Throughout the remaining chapters, care should be given to what seed file a 

particular function would best function in.   

These files are configured with Design History disabled to remove compatibility errors caused by the 

rapid display and deletion of elements during the design process. 

Finally, as InRoads is integrated with ProjectWise, these seeds are configured with their application 

association set to InRoads SS4 causing InRoads to launch when the files are checked out and 

opened.  To disable this functionality, perform a Document -> Properties (Space Bar shortcut) on the 

document in ProjectWise.  When presented with the document properties panel, you can then adjust 

the application association as shown: 

 
ProjectWise Application Association 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/InRoads/INDOT_US_SVFT_3Dseed.dgn
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/InRoads/INDOT_US_SVFT_2Dseed.dgn
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5.3 Working with InRoads/OpenRoads 

5.3-1 ProjectWise 

5.3-1a Project Creation 

The first step in working with InRoads and ProjectWise is the creation of your project.  At this time, 

the Design project template has been setup to have distinct InRoads and MS folders to separate 

your data.  As always if your project does not yet have a design folder please create the 

project/folder using the DOTWise Project Creator. 

5.3-1b Survey Provided Files 

When starting an InRoads project, you can expect having access to the following InRoads and 

MicroStation files: 

FOR SS2 VERSION PROJECTS 

1. Des #_SRxx Control Points.fwd – InRoads survey book with control points 

2. Des #_SRxx LCRS Plat.dgn – MicroStation plat DGN 

3. Des #_SRxx Survey Alignment.alg – InRoads Survey Alignments 

4. Des #_SRxx Survey Surface.dtm – InRoads DTM of Survey processed features 

5. Des #_SRxx Survey Surface Boundary.dtm – InRoads DTM of Survey Boundary 

6. Des #_SRxx Survey.xin – InRoads XIN, specific to the processed data 

7. Des #_SRxx Topo.dgn – MicroStation DGN of topographical features 

8. Des #_SRxx Topo.fwd – InRoads FWD containing the processed Survey 

9. Des #_SRxxSeed.dgn – Sets the coordinate system for every InRoads based file in your 

project. 

10. IN_GeoCS.dty - This file contains the customized coordinate system information and should 

not be needed as this is also provided as part of the Seed file. 

FOR SS4 VERSION PROJECTS 

1. Des #_SRxx Seed 2D.dgn – Sets the coordinate system for every InRoads based file in your 

project and contains a Default model in 2D. 

2. Des #_SRxx Seed 3D.dgn – Sets the coordinate system for every InRoads based file in your 

project and contains a Default model in 3D. 

3. IN_GeoCS.dty - This file contains the customized coordinate system information and should 

not be needed as this is also provided as part of the Seed file. 

4. Des #_SRxx Survey Fieldbook.dgn - Contains Fieldbook information for TOPO and Control 

Points in the OpenRoads Format (survey fieldbook) along with the existing terrain model.  

This will be done in a 3D model. 

5. Des #_SRxx Survey Alignment.dgn - Contains Survey alignment(s) in the OpenRoads Format 

(civil data – linear elements).  This will be done in a 2D model. 

6. Des #_SRxx LCRS Plat.dgn  - MicroStation plat DGN 

7. Des #_SRxx Survey Alignment.alg – InRoads Survey Alignments, Legacy format for 

annotation. 

8. Des #_SRxx Existing Terrain.dtm – InRoads DTM of Survey terrain model, with applicable 

triangulation cleanup.  This terrain will only contain the existing triangulated terrain and any 

features that are included in that triangulation.  This can be used with the native InRoads 
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tools for 3D analysis as it will match the OpenRoads existing terrain and is discussed in 

Chapter 6.3-5 

9. Des #_SRxx Annotation Surface.dtm – InRoads DTM of Survey processed features, Legacy 

formant for annotation.  This should not be used for any functions beyond the native 

annotation tools and should be created using the import process described in Chapter 6.3-6. 

 

To begin a project, it’s recommended to copy the Alignment and Terrain DGNs that Survey provides 

into your Design\InRoads folder in ProjectWise.  These are the base files you’ll start your project from 

and should be available in a read-write location as you will be directly interacting with them. 

With these files copied into your project, it’s suggested to rename the DGN containing the survey 

alignment to Des #_SRxx Design Alignment.dgn.  This will alleviate confusion and specifically denote 

that this file is for the proposed alignments while maintaining the collected information from the 

Survey alignment. 

5.3-1c Base Drawing Creation 

To start creating a project, the only item required is a base DGN to start the product with.  Using the 

advanced document creation wizard, you can create your base drawings using the unit appropriate 

seed file as noted in Section 5.2-7.  The INDOT base drawing naming convention will still be used. 

Project information will be organized into several base drawings.  The information is separated based 

on categories of information included.  These base drawings are the locations for all line work.  Most 

base drawings will be created while in InRoads in MicroStation.  By using MicroStation referencing 

tools, a base drawing can be enhanced to view other base drawing information as a backdrop.  

Please refer to Appendix A - Naming Conventions for a summary of base drawings.  Below is a list of 

Standard Base Drawings to be used at INDOT and descriptions of their contents. Other names are 

possible based on project needs. 

Standard Base Drawings (InRoads created) 

Drawing Names / 

Logical Names 

Descriptions / 

Reference Descriptions 

Examples 

Survey Alignment Survey Centerline Des #_SRxx Survey Alignment.dgn   

Survey Section Corner US Government Section Corners Des #_SRxx Survey Section Corner.dgn 

Survey Contours Survey Existing Contours Des #_SRxx Survey Contours.dgn 

Survey Topography Survey Existing Topography Des #_SRxx Survey Terrain.dgn 

Explan scale 

 

Design Existing Topography Explan 20.dgn 

Explan 50.dgn 

Explan 100.dgn 

Prplan scale  Proposed Design Strings Prplan 20.dgn 

Prplan 50.dgn 

Prplan 100.dgn 

RW Existing scale Existing Right of Way RW Existing 20.dgn 

RW Existing 50.dgn 

RW Existing 100.dgn 

Design Alignments Design Alignments Design Alignments.dgn 
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If your project is anticipated to require multiple scales, it is desirable to create multiple base 

drawings at those scales.  Creating the multiple scaled drawings is easily done by creating a new 

plan display titled appropriately for the scale to be created, and then displaying the appropriate 

models at the desired scale.  Some examples of scales and various usages are presented below. 

Using this procedure makes it extremely easy to vary the scale of a sheet by simply picking the base 

drawings that have the desired scaling when referencing into the MicroStation drawings.  From this 

point forward, only a 1” = 50’ scale will be used in this documentation, the scale will vary with 

projects, and other scales can be developed using the same procedures are described. 

US Scales 

Scale Typical Uses 

1” =  20’ Construction details and other detail drawings.  

1” =  30’ Bridge Layouts 

1” =  50’ Most common scale used in plan and profile sheets 

and plan drawings. 

1” = 100’ Pavement marking plans, and other miscellaneous 

sheets. 

 

Note:  OpenRoads technologies make substantive use of the Annotation Scaling tools in 

MicroStation for element and feature display.  When discussing multiple scaled base drawings, it 

may be beneficial to create a single base drawing and then scale the content through using the 

scaling settings available on reference files. 
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5.4 Starting InRoads 

At this point, you should now have your ProjectWise project, and a base sheet created.  If using the 

seed files as defined with InRoads SS4 as the application association, you may Check Out/Open the 

file directly from ProjectWise, which will start both MicroStation and InRoads Suite. 

If you changed the application association for the DGN seed file to MicroStation, you will need to 

Check Out/Open the file—which will only start MicroStation.   

Note with SS4 there is no longer a method to open InRoads from within MicroStation.  Files must be 

associated with InRoads SS4 to open the product. 

5.5 Opening, Closing and Saving InRoads Files from ProjectWise 

With the integration of InRoads and ProjectWise, procedures for opening, closing, and saving files in 

InRoads differs from these functions as shown in training.  As with MicroStation and other integrated 

applications, standard Open and Save dialogs are replaced with ProjectWise integrated dialogs with 

extended functionality.  Please keep in mind that these options will be used when working with the 

legacy file formats of the InRoads software. 

5.5-1 Opening Existing Files 

Opening files from within InRoads uses the standard ProjectWise Open dialog as shown: 

 
InRoads File types in ProjectWise 

To ease finding appropriate file types, the preceding illustration shows the available file types that 

have been defined in the ProjectWise environment.  The following applications correspond to these 

common InRoads files types: 
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• InRoads Drafting Notes - .dft 

• InRoads Drainage - .sdb 

• InRoads Geometry Project - .alg 

• InRoads Preference - .xin 

• InRoads Project - .rwk 

• InRoads Roadway Design - .ird 

• InRoads Survey Data - .fwd 

• InRoads Template Libraries - .itl 

Additionally, you may selectively open files in a read only mode by adding them to the lower portion 

of the open dialog and enabling the check box for open read only: 

 
Adding Files to an Open list/Read Only 

5.5-2 Saving New Files 

When performing a Save for the first time, or a Save As on an existing file, you will be presented with 

an InRoads/ProjectWise specific Save As dialog, as shown below: 

 
InRoads/ProjectWise Save As Dialog 

All ProjectWise Save dialogs require you to define your project folder, document name, file name, 

and description.  It’s still recommended that you maintain the same naming convention—at least for 

the document and file names.  Also, it’s very important to make sure the application is appropriately 

set to the InRoads file type you’re attempting to save, as the dialog does not assume the file type 

you’re saving. 
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5.5-3 Closing Files 

When closing files from within InRoads, the behavior is slightly different from other integrated 

applications.  Due to how ProjectWise functions and InRoads works within MicroStation, there is no 

automatic prompt for check in, or automatic updating to the ProjectWise datasource.  It’s 

recommended that when you’ve saved your files and have closed InRoads, that you use the 

ProjectWise Local Document Organizer to check the remainder of your files in.  You will be prompted 

to check-in your DGN per the standard functionality, but it’s probable that you have any number of 

additional InRoads files open that also need checked in. 

You can do this by opening the Local Document Organizer from ProjectWise: 

 
Local Document Organizer Button 

With the Local Document Organizer open, you can then browse to the checked out option, and then 

select all of the files you need to check in.  Once selected, you can right-click on the highlighted files 

and perform a check in as shown: 

 
Local Document Organizer Mass Check-In 

It’s recommended that each check in be accompanied by good comments to allow quick review of 

anything that may have been done. 
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5.5-4 InRoads/ProjectWise Organizer 

Within the InRoads environment, there is an additional shortcut to the ProjectWise Local Document 

Organizer and it can be found under the InRoads Explorer -> File -> ProjectWise Organizer… menu 

item: 

 
Local Document Organizer Access from InRoads 

This is a self-contained version of the Local Document Organizer and it acquires application focus 

from InRoads/MicroStation, preventing you from working within the application.   

While you’re working on the existing files and making/saving changes, you will want to use this tool 

to update your server copies frequently as not to lose any data. 
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5.6 Setting Up InRoads 

With the switch to OpenRoads, the first two of the following steps are no longer required.  These 

items are automatically attached.  The content of these instructions, however, is still valid and useful 

depending on the situation. 

5.6-1 Attaching the XIN 

With the SS4 release, it’s no longer necessary to attach an XIN.  The default INDOT.xin from the 

workspace will be automatically attached to your project.  Should you need to attach a XIN, select 

File -> Open from the InRoads Explorer.  When presented with the ProjectWise open dialog, browse 

the location of your XIN and select the file.  Once opened, your InRoads Explorer should look similar 

to the following showing the location from the Managed Workspace where the file has been 

downloaded to: 

  

INDOT.XIN Attached 

Note that while the Access Mode above shows Read-Write, changes will only be saved to the copy in 

your working directory and will not be posted back to the server.  The working directory copy will be 

refreshed on subsequent openings of the software and changes will be lost. 

If you attached from a local project copy, the path will reflect the XIN location, and the Access Mode 

will display Read-Write indicating that you can write changes to the XIN file you’ve selected. 
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5.6-2 Attaching the Cell Library 

With the XIN attached, you may need to attach the cell library prior to drawing any features.  If you 

receive the following error when attempting to draw features: 

 
Cell Library Not Attached 

InRoads is indicating that it cannot find the appropriate cells for your features. 

To attach the cell library, use the MicroStation Cell Library tool (MicroStation -> Element -> Cells 

menu option) and browse to Documents\INDOT Workspace\OpenRoads\Workspace\cell\ and select 

IN_InRoads.cel.  At this time, it is recommended that you save the settings for your file prior to 

continuing (MicroStation-> File -> Save Settings). 

Note:  ProjectWise automatically attaches this cell library on startup via the Managed Workspace.  

Instances of this error will only occur if you’re working disconnected from ProjectWise. 

5.6-3 Project Defaults/.RWK Files 

As the InRoads training courses demonstrate, Project Defaults and .RWK files both provide 

substantial benefit when opening, saving and closing your files.  The full functionality of these tools 

has been maintained in InRoads in ProjectWise, however there are some slight differences in what 

dialogs are displayed when working with these.  First, you will examine Project Defaults. 

The Project Defaults (InRoads Explorer -> File -> Project Defaults) can be used to pre-open specific 

InRoads configuration files, while pre-defining paths to save to when creating new surfaces, 

alignments, corridors, etc. 

The top half of the dialog, the Default Preferences section, allows you to pre-open InRoads 

configuration files such as the .XIN preferences, .DFT drafting notes, and various drainage 

configuration files.  The lower half allows you to define project specific paths for InRoads file types, 

so that when performing Opens/Save/Save As functions, your default path will take you directly to 

the folder location specified on your Project Defaults.  Please note that when defining these paths 

that proper operation will require that the desired path be browsed to and not placed with plain text.  

This will ensure that the appropriate folder is actually opened when using the Project Defaults. 

Additionally on this panel, you can define a default preference for all panels that you may interact 

with.  Due to the number of different preferences available in the INDOT.XIN, it’s recommended that 

you leave this setting at Default as shown.  In many cases, the default preference is configured to 

use a commonly scaled INDOT setup. 

pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/
pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_InRoads.cel
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For more flexible Project Defaults, use of the $(_DGNDIR) (exactly as shown with the parentheses) 

variable can be used from the ProjectWise Directory and Project Default Directory.  Use of this 

variable in Project Defaults will have all InRoads dialogs default to the location of the currently open 

DGN for all file operations (Save, Save As, and Open). 

 
InRoads Project Defaults 

For more granular control of the files you open and save, you will want to use the .RWK project files.  

The .RWK will allow you to define specific files that you’d like to open/update with the project file.  

The initial Save dialog is the same as the InRoads with ProjectWise save dialog shown in Section 5.5-

2.  By selecting the Options button in this panel, you will be presented the standard .RWK dialog for 

adding/updating files.  Further discussion of .RWK files can be found in the Bentley InRoads Road 

Fundamentals documentation. 

 
RWK File Saving Options 
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5.6-4 Enabling Application Add-Ins/Variable Manager 

Not all tools within InRoads are immediately available in the base configuration.  There are 

numerous application add-ins that are disabled but are extremely useful for day to day usage.  These 

can be accessed via the InRoads Explorer -> Tools -> Application Add-Ins menu option. 

The following menu is then presented: 

 
InRoads Application Add-ins 

The upper portion of the application add-in dialog presents a list of available application add-ins.  

The lower portion of the dialog shows where the commands for the add-in can be found.  To enable 

an application add-in, select the check box to its left. 

Of the available application add-ins, it will be necessary to enable the following: 

• Global Scale Factors Add-In – Enables the global scale factor tool for resizing of InRoads 

symbols, linestyles and text 

Additional useful add-ins may also be enabled, such as: 

• Active Project Settings Add-In – Used to select active surfaces, alignments, etc. without 

activating them from the InRoads Explorer 

• Copy Preference Add-In – Enables the tools for copying preferences and styles from one XIN 

to another. 

• Horizontal and Vertical Elements Add-In – Alignment creation tools similar to the element 

method alignment tools in MX. 
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5.6-5 Variable Manager 

Variable Manager, enabled through the Application Add-Ins, includes a number of additional 

application customization.  Once enabled, to access Variable Manager, you to go to the InRoads 

Explorer -> Tools -> Variable Manager.  As these are more situation and usage specific tools, it is 

recommended you contact CAD Support before using them. 

5.6-6 MicroStation and InRoads Status Bars 

One convention that requires monitoring while using InRoads is the location of statuses that InRoads 

uses to prompt for input, or provide information.  As it has a high degree of integration with 

MicroStation, InRoads will use both its own status bar and, depending on the active function, may 

also use the MicroStation status bar.  Below is an example of each form of output and the location 

where it can be found. 

  
InRoads Status Bar (Lower left corner of InRoads Explorer) 

 
MicroStation Status Bar (Lower left corner of MicroStation Application) 
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5.7 Global Scale Factors 

Due to differences on how InRoads interacts with linestyle scaling, a mixture of both Drawing Scale 

and directly defined scale factors must be used.  When displaying information using OpenRoads 

technology (survey fieldbooks, terrain models), annotation scale should be used.  All InRoads Native 

Tools (features accessed from the InRoads Explorer) will use an option referred to as Global Scale 

Factors.  As noted in Section 5.6-4, you will need to enable this tool via the Application Add-Ins 

dialog.  When enabled, you will be presented a new menu option under the InRoads Explorer -> Tools 

-> Global Scale Factors: 

 
Global Scale Factors 

The Global Scale Factors tool presents a small dialog box similar to the MicroStation Annotation 

Scale dialog: 

 
Global Scale Factors 

Note the preceding screen capture illustrates the new 1:50 scaling values.  Cells of any scale must 

now have an additional factor of 12 added in to maintain compatibility with both OpenRoads and 

InRoads.  So an example would be for 1:20, cells would be at 240 (20*12); at 1:30, they would use 

360 (30*12). 
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This tool allows for the scaling of many InRoads elements including features, annotation text, and 

cell sizes.  Throughout the Plans Production process, you will want to use these tools to create base 

and text drawings of specific scales. 

Included below are samples of some of the most common standard base drawings: 

 
Explan 50 

 
Prplan 50 
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5.8 OpenRoads Technologies  

5.8-1 Using 2D Seed Files/Models for Design 

In a departure from previous versions and guidance, OpenRoads technologies highly emphasize the 

use of 2D models for the Design process.  Throughout this document, many instances that previously 

referred to the use of a 3D seed file/model configuration have been amended to reflect this change 

in software philosophy.   

As part of using a 2D seed file, the OpenRoads product will automatically create a 3D model on the 

fly.  Bentley advises that when performing operations, all work be done in the 2D model with a view 

of the 3D model open so that modifications can be seen as they occur.  This 3D model will only be 

created once a terrain model has been generated or attached and activated. 

A proposed workflow would be to process all survey in a 3D seed file, and then attach this 3D 

content to a 2D seed file for alignment and design purposes. 

5.8-2 Alignment Naming in OpenRoads 

Within the following chapters, in many cases you’ll see references to how alignments are or should 

be named.  Convention currently is to name these Line”A”, Line “B”, etc.  Please be advised that 

while most functions within OpenRoads can accommodate this naming, some features that use this 

name to preconfigure their output—such as cross sections—may not support the usage of the 

quotation marks in their naming.  Should you run into any issues with a tool that has the alignment 

name in it, the first step should be to eliminate the quotation marks and attempt the tool again. 

5.8-3 OpenRoads and MicroStation Multi-View Configurations 

As discussed in the previous section, OpenRoads will automatically create 3D models when started 

from a 2D seed.  In these instances and others such as profile creation and dynamic cross section 

review, it may be advantageous or required to open multiple views.  The following steps will cover 

how to open additional views, and then if necessary, how to display content from a different model. 

1. When in the product (MicroStation or PowerInRoads), locate the View Groups toolbar.  Normally 

it’s docked at the bottom of the display.  If not displayed, navigate to Tools -> Tool Boxes menu 

item and locate the View Groups entry to enable it.  It can also be enabled with the Ctrl + T 

shortcut key-in. 
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2. By default, most files will open with view 1 active as your active display.  To open an additional 

display, select one of the other views so the button is depressed. 

 

3. At this point, depending on the tool in use or if you’re modifying the display, the steps will branch 

off.  If the tool prompts to select an active display to show content (profile creation, dynamic 

cross sections), place a data point in the display as requested.  If wanting to display content from 

a different model, continue on. 

4. With the view open, select the View Properties button. 

 

5. On the View Attributes, expand the View Setup leaf.  Under the Models dropdown, select the 

appropriate -3D model.  These models will name themselves after the base DGN model that the 

terrain is created in. 

 

6. At this time, two models would be displayed.  View 1 would presumably have the 2D Default 

model displayed, and the Default-3D model will display in View 2. 
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5.8-4 Project Explorer 

In InRoads SS4, the tools that interact with OpenRoads technology no longer use the external file 

formats that you’re accustomed to from SS2.  File types such as DTM, ALG, and FWD are no longer 

required for many of the tools.  Bentley has now made the DGN file the container for much of this 

data.  To access this data, the InRoads Explorer is not used, OpenRoads now uses the MicroStation 

Project Explorer.   

When starting InRoads you may need to enable the Project Explorer.  To do so, go to the MicroStation 

File menu and select the Project Explorer option. 

 
Starting the Project Explorer 

With the Project Explorer open, you should see the following tabs when in InRoads.  Note that these 

are not available when using MicroStation only. 

 
The Project Explorer in InRoads 
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If your Project Explorer doesn’t show the tabs shown above, you may have to enable these.  This 

commonly occurs if multiple sessions of MicroStation and InRoads are accessing the same user 

preferences at the same time.  To enable these, on the MicroStation toolbar go to Settings -> Project 

Explorer. 

 
Project Explorer Settings 

On the Project Explorer Settings, make sure all the Browsers are set to True.  This will enable the Civil 

tabs to the correct state. 

 
Project Explorer Browsers 
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5.8-5 Drawing Scale 

As was briefly discussed earlier in the chapter, OpenRoads tools do not respect the Global Scale 

Factors that InRoads uses.  In lieu of these tools, OpenRoads now leverages the MicroStation 

Drawing Scale Tools.  It’s highly recommended that these tools be loaded and docked for quick 

accessibility at all times.  To enable these tools, go to the MicroStation menu and select Settings  -> 

Drawing Scale.  This will provide a dialog that looks like the following: 

 
The Drawing Scale and Annotation Lock 

As shown, this tool controls the scaling of all Annotation enabled elements including linestyles, text, 

dimensions, and cells.  This tool should be used to control the scaling of any OpenRoads data, but 

will not present proper scaling with all native InRoads tools.  Care should be given to using this in 

addition to other manual scaling factors as the results could be incorrect. 

With the Annotation Lock enabled (the orange highlighted “A” icon), changing the scaling value 

beside it will dynamically rescale all elements by the defined value. 

Note: Initially all items should be drawn up at a Full Scale 1:1 setting.  Drawing items up at higher 

scales may cause them to improperly display in your drawing.  This can be resolved by setting the 

scale back to Full Scale 1:1 and then selecting the desired scale from the listing. 

5.8-6 File Referencing 

As discussed previously, OpenRoads data is now all stored directly in DGN files.  One major 

advantage of this functionality is that standard MicroStation referencing allows for OpenRoads data 

to be visible through the reference documents.  Examples of this functionality will be discussed 

further in the coming chapters, particularly in areas such as the creation of a terrain model from a 

referenced survey field book, and in the modeling of a corridor from referenced terrain and geometry 

files. 

6. Using InRoads for Survey/Routeplat Production 
The following sections discuss the usage of InRoads for Routeplat development.  These procedures 

should be used for the development of survey deliverables as noted in Chapter 106 (formerly 

chapter 26) of the INDOT Design Manual.  Additionally, they cover the new OpenRoads processes 

used out of the SS2 Workspace.  More in-depth discussion of these procedures can be found in the 

https://www.in.gov/indot/design_manual/
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2016 INDOT InRoads for Survey Using OpenRoads learning path published on the Bentley Learning 

Network. 

In addition to the InRoads specific tools noted throughout this section, also keep in mind the Survey 

tools provided on the INDOT Tools task navigation pane in MicroStation.  Details on these items can 

be found in section 3.1-6b: Tools Included in the INDOT Tools Task Navigation. 

6.1 What’s Changed with Survey in OpenRoads 

With the release of OpenRoads Survey, the following coding changes have been necessitated: 

New Control Codes have been incorporated to replace the +O, +D, +H InRoads offset note 

commands.  Note that the (-) indicates which direction would be a negative value: 

• AD* is for vertical offsets, Up/Down(-)   

o Example: AD*-2 UE02 B would result in UE02 2 feet below the observation at the 

start of the string. 

• NF* is for distance offset, Front(-)/Back   

o Example: NF*4.5 PTCS would result in PTCS 4.5 feet back from the observation. 

• LR* are for left/right offsets, Up/Down(-)   

o Example: LR*-7 TB04 would result in TB04 7 feet to the left of the observation. 

The EXTARC code can no longer be used to create a closed 3 point circle.  Advisement from Bentley 

is that circles should have 4 shots, with the fourth shot being near the first shot so only a small linear 

element closes out the circle. 

Planimetric graphics no longer function on native InRoads Surveys (.FWD files), as Bentley has 

changed the graphical functions to accommodate OpenRoads.  OpenRoads will automatically draw 

up and place text consistent with the old planimetric graphics.  However, these do not dynamically 

scale and now rely on MicroStation Drawing Scale tools. 

  

https://learn.bentley.com/app/Public/ViewLearningPathDetails?lpId=110270&callFrom=home
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6.2 InRoads Survey Options 

When working with the InRoads Survey tools, knowledge of the InRoads Survey Options (Tools -> 

Survey Options) is beneficial.  This section will touch on some of the more important options that you 

may have to interact with. 

 
General 

On the General tab, the three scaling options for cell, text and line may need adjusted depending on 

the desired scale of your graphics.  Additionally, there are the options for Automatic Refresh which 

will affect when InRoads will update the planimetric graphics while working on the fieldbook.  

Depending on the type and volume of changes, disabling this setting may be advantageous, as the 

interactive graphics refresh can cause system slowdowns depending on the size of your survey. 
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Units 

On the Units tab, you have the option of changing the unit format, angular format and precision. 

 
Symbology 

The items on the Symbology tab can be used to override the default symbology of graphics created 

from planimetrics. 
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Corrections and Observation Standard Deviations 

These tabs control how InRoads interprets input from data collector files. 

 
The Preferences Button 

On all tabs of the Survey Options dialog, there is a Preferences button.  This button allows you to load 

pre-defined settings for the Survey options.  Currently there are pre-defined options for both 10 and 

50 scale setups.  More information on preferences can be found in section 5.2-2 INDOT Specific 

Preferences. 

With the switch to OpenRoads, these functions will not be used as much as previously.  All settings 

have been moved to the relevant dgnlib files that are automatically attached.  There are still some 

options that these settings influence, largely on the text display side of the equation. 
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6.3 Creating InRoads Survey Deliverable Files 

With the move to OpenRoads technology for Survey, there are some slight changes to the 

deliverables for an InRoads SS4 project.  The following workflow will step through the process of 

creating each file for a survey project. 

As the intent is that every project should now be geocoordinated, the first document in the workflow 

will be the geocoordinated seed files.  These will allow for all project files to be created and based off 

the same coordinate system, allowing the file content to be shown spatially without the need to 

configure each individual file. 

6.3-1 Creating the Geocoordinated Seed Files (2D and 3D) 

The following procedure steps through the process for creating the Geocoordinated Seed file for use 

through the project lifecycle.  The creation of these files allow for any CAD files based on the created 

seed file to be instantly consumed by the ESRI ArcGIS Products and made available for a variety of 

other uses.  With OpenRoads changes to document handling and civil information, these steps 

should be performed for both a 2D and 3D file (shown).   

1. After creating your Survey Work Area in your DES No. specific project via the DOTWise Project 

Creator, navigate to the Project Files folder: 

 

2. With the Project Files folder selected and its contents displayed in the Document pane, right 

click in the document pane and select New -> Document. 

 
Starting the New Document Wizard 
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3. You’ll then be presented with a series of options; we’ll use the Advanced Wizard option. 

 
Using InRoads for Design/Plans Production 

4. This will start the Advanced Documentation Creation Wizard.  The first panel is informational 

and can be bypassed.  The second panel confirms your location.  If for some reason you 

didn’t have the correct folder active in your document panel, you can select it now or confirm 

the path shown. 

5. The next panel allows us to select our template document we’d like to use.  On the first line 

“Use a ProjectWise document as a template” option and then press the select button. 

 
Select a Template dialog 
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6. In the “Select Template Document” panel, navigate to the InRoads Seed files in the 

ProjectWise System and select the appropriate unit files for your project and that the file you 

select is the 3D version: 

 

pw:\\indot-pw.bentley.com:indot-pw-01\Documents\Template Documents\SS4 

Seed\InRoads\ 

 
Selecting a US Survey Foot InRoads Seed File 

7. With your file selected, you can then proceed to the next screen.  If you are prompted for 

Document Attributes, you may proceed beyond this screen as well. 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/InRoads/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/InRoads/
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8. The final step in creating the document is to provide a name.  Seed drawings should be titled 

with the following format: Des #_SRxx Seed 3D.dgn.  To ease document searches and for 

consistency purposes, all three names should be the same as shown.  Also worth noting is 

the Application dropdown, as it illustrates the InRoads SS4 association as shown in the 

screen capture. 

  
Document Properties and Naming 

9. Select Next to complete the document naming process.  The final two pages of the wizard 

confirm the document properties and create the document.  Proceed through these and then 

continue on in the same Project Files folder. 

10. From your Project Files folder, right-click and Check Out your IN_GeoCS.dty file locally. 
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11. Navigate to your newly created seed file in the Survey\Project Files folder & double click on 

the file to open it in InRoads. (Allow for Managed Workspace to download).   

   

12. Once InRoads has started, start Bentley Map software by selecting Applications->Activate-

>Activate Map from the Applications pull-down beneath the InRoads Group. 

 

13. Open the Geographic tool in MicroStation by selecting Tools->Geographic->Open as Toolbox. 

 

14. Click on the Select Geographic Coordinate System tab within the Geographic toolbox. 
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15. In the Geographic Coordinate System (GCS) toolbox select the From Library tab.  

 

The Library tab contains folders with all the available coordinate systems.  The Favorites, 

ProjectGCS, AgencyGCS, and Library are the folders you will see.  In the ProjectGCS as well as the 

AgencyGCS folders, there will be a list of coordinate Systems for Indiana State Plane East and West 

and the Local Ground Coordinate System (LGCS) templates.  New in the SS4 release are the newly 

adopted county coordinate systems used statewide. 

16. At this point in the process, you may have data that can use one of the newly adopted county 

coordinate systems.  If your data conforms to this configuration, please select and apply the 

correct coordinate system at this time and proceed to the next section on creating the world 

file.  If you have legacy data that is using a false northing and easting, continue on with the 

remaining steps in this section to complete customizing and applying your LGCS. 
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17. If you have a legacy project where geocoordination information must be entered manually, 

you will need to select and modify the Local Ground Coordinate System definition titled 

“Copy-LGCS Template – LGCS” by right clicking on it in the ProjectGCS list and choosing Edit 

Coordinate System Properties. 

   

18. You will need to modify the Name, Description, Origin of Latitude, Origin of Longitude, 

Azimuth, Scale Reduction, False Easting and False Northing to the appropriate values from 

metadata for the User Defined Local/Ground Coordinate System of the project. 

These values can be obtained from the Local Ground Coordinate System (LGCS) metadata you 

created for the survey.  The name and description should be related to the INDOT project, DES 

number and road designation (ex. Des #_SRxx).  The Azimuth is the Convergence Angle at the origin 

point for the Local Ground Coordinate System.  The convergence angle can be obtained by using 

Corpscon (U.S. Army Corps of Engineers) or from Trimble Business Center (TBC).  If the convergence 

angle is a negative value it will need to be input in decimal degree format.   An example of the 

Corpscon output with the convergence angle is below.  Depending on the units of the survey you 

may need to change from US Survey Feet to International Feet of Meters. The scale reduction is the 

combined scale factor (CSF) from the TBC for the LGCS you created for the Survey.  
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Here is an example of the Coordinate System definition once the Parameters have all been input. 

  

19. Once you have updated the necessary information, select OK and the new coordinate system 

will be stored.  It will now be listed along with the originals as shown.  (It will retain this 

information in the IN_GeoCS.dty file). 
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20. Now that the new Coordinate System has been created, you can select it and assign it to the 

drawing by double left clicking on it in the list.  

 

21. A pop-up dialog may appear asking you to choose:  Be sure to select the option to keep the 

storage units as they are (shall not be changed) as shown below. 
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22. The newly selected Coordinate System will now appear in the Geographic Coordinate System 

dialog window as shown: 

 

23. Upon completion of these steps you will need to exit MicroStation and Check-in your CAD file.    

This will only check in the active .dgn file and not the .dty file.  Please add comments upon 

check-in. 
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24. Go to the active Project Files folder in the appropriate project location in ProjectWise and 

check-in the IN_GeoCS.dty file. 

   

25. Right click on the file in the list and select Check-In. 

These steps should be repeated to create a 2D version of the seed file.  In all steps where 3D is 

specified, replace the 3D with the appropriate 2D equivalent or naming.  

This will place the checked out copy back into your Project Survey location with the updated 

information and the time file was last updated.  (Be sure to add comments as to what changes you 

made to this file).  Any time you wish to edit the data in the IN_GeoCS.dty file related to the active 

project, it must be checked out first and then checked back in to ensure it remains current to that 

project. 

 

With the LGCS defined within the dgn file the survey can be processed through InRoads in the typical 

manner.  The only difference is that MicroStation knows the parameters to convert data in any other 

standard coordinate system to the LGCS.  This means that ortho-imagery, GIS files, etc. can be 
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referenced to the dgn file and MicroStation will re-project them to the LGCS on-the-fly so that the 

data is all spatially referenced.  

6.3-2 Creating a World File 

In the same ProjectWise folder as the MicroStation dgn and IN_GeoCS.dty files for your survey are 

stored you will need to create a .wld file.  The .wld file contains the necessary parameters to 

transform the dgn files to the State Plane Coordinate system.  This allows the data in the files to be 

re-projected on-the-fly to its appropriate location on the ground in the real world.  

The .wld file is ASCII format and can be created in Notepad or any other editor.  The name of the file 

needs to be esri_cad.wld.  By using this naming convention only one .wld file is necessary and the 

ESRIGIS Products will automatically associate the esri_cad.wld file to all the dgn files in that directory 

folder. 

The data in the .wld file will consist of the Local Ground Coordinate System for two well established 

control points and the corresponding State Plane Coordinates for the same two points. 

The format of the coordinates in the esri_cad.wld will be the following: 

Line 1: [LGCS Easting (CP 1)] [LGCS Northing (CP 1)] [SPCS Easting (CP 1)] [SPCS Northing (CP 1)]   

Line 2: [LGCS Easting (CP 2)] [LGCS Northing (CP 2)] [SPCS Easting (CP 2)] [SPCS Northing (CP 2)]   

 

Note:  LGCS = Local Ground Coordinate System 

 SPCS = State Plane Coordinate System 

 CP = Control Point 

 
Here is an example esri_cad.wld file: 

6.3-3 Creating the Survey Fieldbook DGN file 

Creating the fieldbook DGN file is the first instance where we find the need to choose a particular 

seed file.  In this instance, you’ll need to start with the 3D geocoordinated seed file you created 

earlier.   

1. Using the Des #_SRxx Seed 3D.dgn you created earlier in this chapter, create a new 

document under your Survey\Project Files folder.  Use the Advanced Document Wizard and 

instead of pointing to a pre-existing seed file, point back to the Des #_SRxx Seed 3D.dgn.  

Name this file Des #_SRxx Survey Fieldbook.dgn. 
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Note: By using the seed file we created in the previous steps you will ensure starting off with 

a correctly geocoordinated file.  All subsequent DGNs should be created using this seed as 

your starting file. 

 

 
Creating the Survey Fieldbook DGN 

2. Launch the DGN file from the ProjectWise Explorer by double clicking on it.  Wait for InRoads 

to start up. 

3. Once InRoads has started, locate the Project Explorer and navigate to the Survey Tab.  

Expand the Default tab so that Field Books are visible. 

 
Survey Project Explorer 
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4. With the Field Books shown, right click on their entry.  Select New… entry. 

 
Creating a New Field Book 

5. A field book will then be created.  Note that you are not initially given the option to give it a 

name, it will be automatically created as Field Book 1.  To change this, right click on the field 

book and select Properties.  The field book information will then show up in the MicroStation 

Element Information panel, similar to any other MicroStation element.  You can rename it in 

the Name field, it’s recommended to maintain the Des #_SRxx convention. 

 
Renaming a Field Book 
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6. With the field book renamed, you can now import your data.  Right click on the field book and 

select Load > File…  Similar to SS2, OpenRoads field books allow for the import of a wide 

variety of data types and formats.  Additionally existing FWD surveys from SS2 can be directly 

imported into the OpenRoads environment using this tool. 

 
Loading Survey Data 

7. On the presented ProjectWise Open dialog, navigate to your Survey\_Raw Data folder and 

locate your data collector file(s). 

8. With your data files attached, you’ll see output similar to the following. 

 
Raw Survey Data in OpenRoads 

9. As you can see, there appear to be numerous issues with the TOPO display. 

a. First are the points denoted with the exclamation point (!) icon.  These are points that 

the OpenRoads environment does not have codes for.  These should be adjusted to 

known codes within the environment. 
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b. Point symbols and linestyles are not displaying properly.  Using the Drawing Scale 

tools mentioned in Chapter 5, first enable Annotation Scale Lock, and then pick your 

required scale.  This example will proceed with using 1”=50’. 

c. Linework denoting both the observations themselves, along with the instrument 

setups will be displayed.  On the Survey Project Explorer, disable these two options 

prior to handing your data to design. 

 
Disabling Setups and Observations 

d. Finally, survey notation information will appear around each point, similar to the old 

planimetric graphics in SS2.  To disable these, open the Level Display and disable the 

levels shown.  Alternatively, you can right click on the ALL Point Features in the 

Survey Fieldbook and select Annotations -> Turn Off All Annotations. 

 
Disable Survey Notation Graphics 
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Turn Off All Annotations 

10. With these previous items resolved, your TOPO display will now look like the following and in 

line with expectations. 

 
Cleaned up TOPO Display 

11. With the fieldbook now created, you can proceed to saving your file back to ProjectWise.  

Before closing the document, first save the settings.  This can be done by selecting Save 

Settings from the MicroStation File menu, or using the Ctrl+F hotkey combination.  When 

done, close the application and Check In your file. 
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6.3-3a Editing Fieldbook Features 

Unlike the previous version where all features were edited in the fieldbook in line with how they were 

shot, OpenRoads Survey prioritizes the individual features from an editing standpoint.  To interrogate 

individual features you have multiple options on how to interact with them.  This section will take a 

brief look at two of the more immediate methods. 

First up is the table based editor.  With your fieldbook open and selected, drill down to either the ALL 

Point or ALL Linear Features and select one of the codes.  Keep in mind that all breaklines will also 

have point definitions as that’s how OpenRoads defines them.  With a point or linear feature 

selected, go to the Survey Task under Civil Tools and expand the Survey Processing.  Locate the 

Show Details button shown. 
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This will open a tabular view of the selected feature.  Depending on the feature selected, you can 

change the name of the feature or shot, if it’s included in the triangulation, or 

northing/easting/elevations, and other items.  To modify any field, place your cursor within it, if it’s a 

dropdown, one will be presented with the applicable options.  If it’s a text entry field, enter the 

appropriate information.  In both instances, once complete, hit the Tab key to confirm the change. 

 
Survey Details 

The other method of editing surveyed features is graphically.  In the main display that shows your 

TOPO elements, you can select on any feature and review its properties in the Element Information 

panel.  In this view you can edit the same data as you can in the details.  Additionally, in the 

graphical side, all elements will be given heads up element handles that you can grab and 

manipulate. 

 

Graphically Editing Survey Data 
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6.3-4 Creating the Terrain Model 

With our Survey Fieldbook now created, we need to create the OpenRoads Terrain model.  Note that 

it’s no longer necessary to create a boundary surface as it is automatically created when the terrain 

model is generated.  This boundary is automatically defined by the extents of the triangulation and 

will automatically update as you’re editing features or the triangulation itself. 

If you’ve used the new county geocoordinate system for your files, please refer to section 6.3-4a for 

additional information on generating a correct DTM. 

1. To proceed with terrain generation, re-open your survey field book DGN from the previous 

steps. 

2. Navigate to the Survey tab on the Project Explorer.  Right click on your Des #_SRxx field book 

and select the Create Terrain Model… option. 

 

Create Terrain Model 

3. When completed processing, the terrain model will be created and displayed.  The default 

display style is to show Existing Contours at a 5:1 scale.  The display will look similar to the 

following. 

 

Survey with Created Terrain Model 
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4. At this time, you can investigate the terrain model.  To select it, go to the Civil Model tab on 

the Project Explorer.  Expand out the Terrain Model listing on the tree and select Des #_SRxx. 

 

The Terrain Model 

5. By selecting the Terrain Model, you can then interrogate its properties in the Element 

Information panel.  Reviewing the terrain in the panel allows you to control display items 

such as the maximum length of triangles, whether or not contours should be displayed, 

displaying the triangulation, etc.  The following shows all the relevant settings for controlling 

the terrain display. 
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Terrain Model Element Information 

6. With the terrain model now having display settings for items such as the perimeter, contours 

and triangulation; it’s no longer necessary to use the Level Display to disable these items.  

Simply use the Element information panel to shut these items off in preparation for the final 

deliverables. 
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TOPO Display with Terrain Display Off 

7. At any time, these features can be redisplayed simply by toggling the relevant feature on. 

8. For the terrain to correctly display in referenced documents, make sure it has been activated.  

Again on the Civil Model tab in Project Explorer, right click on your terrain and select the Set 

As Active Terrain Model option. 

 

Set As Active Terrain Model 

Note: This workflow no longer allows for the editing of features once they’ve been sent to the terrain 

model as it becomes a “ruled” feature.  If any changes are needed to surveyed features, the terrain 

should be deleted and recreated from the field book once the changes have been made. 
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6.3-4a DTM Export Issues with Metric Geocoordination 

The CAD Peer Group and CAD Support have identified an issue with how MicroStation/InRoads is 

exporting OpenRoads terrain models to the native InRoads DTM.  This issue occurs when exporting 

from a file where the Geocoordination has been enabled, and the units for the geocoordination are in 

metric.  This will most commonly occur in newer surveys that are geocoordinated using the new 

country coordinate system, which is configured in metric. 

How to check if the issue will occur. 

1. Load the Geographic toolbar from the MicroStation Tools > Geographic > Open as Toolbox 

menu. 

2. Click on the Select Geographic Coordinate System button on the left side of the toolbar.  It 

will load the Geographic Coordinate System dialog shown on the right. 

 

3. On the Geographic Coordinate System dialog, select the details button.  This will display the 

properties for the coordinate system applied.  If the highlighted Units field shown lists metric, 

your file will be affected by the issue and DTM exports will need to be performed using the 

following method. 
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How to Export if the Issue Occurs 

After identifying if your data will be affected, the following process should be used to avoid the export 

scaling issue. 

1. Copy a blank 2D seed file into your project folder.  Rename the file to designate that it’s used 

for DTM export.  Unlike most other files, do not use a provided geocoordinated seed file or 

apply geocoordination to this file. 

2. Reference attach any files with terrains that you want to export to DTM.  This can include 

survey fieldbook files, corridor models, or any other terrains that you want to export. 

3. By reference attaching these files, you may interact with the terrain models and export the 

data without the scaling being influenced by the Geographic Coordinate System.  From either 

the Project Explorer, Civil Tools > Terrain Model > Export to File, or heads up display with the 

terrain selected; export the terrain to .DTM  

 
Export from Project Explorer 
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Export from Civil Tools 

 
Export from Heads Up 

4. Upon completion, you will have a created DTM that you may use from your data.  You can 

validate the exported data by displaying it using the native InRoads surface display toolset 

and overlaying the referenced data to confirm that it falls in the same location.  

6.3-4b Missing Features 

With changes to the modeling engine in OpenRoads technologies, random elements with connecting 

lines are no longer included as part of a terrain model.  Some features that may have been coded 

and setup this way in the previous environment would be items such as fences and pipes.  If you 

have these features in your survey and they are not showing up properly, make sure that you’re 

connected to the correct XIN.  Definitions for these features have been changed in the default 

agency XIN to change them from random with connecting lines to breaklines that are not 

triangulated. 
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6.3-4c Triangulation Clean Up and Terrain Editing 

OpenRoads terrains have similar commands to the previous version of InRoads allowing for the 

modification of a triangulated terrain.  The first option to clean up the triangulation extents is to 

adjust the max length of the triangles it creates. 

In the software, select your terrain either from the Project Explorer, or graphically select the terrain 

perimeter on the screen.  In either instance, select the Properties button. 

 

 

On the properties panel for your terrain, locate the Edge Method heading and from there you can 

adjust the max length as you did when triangulating a DTM in the old version.  From here you can 

tighten up the triangle lengths to get a more defined perimeter for your project without editing the 

terrain content. 

Note: Changing the triangles max length will force the full triangulation to re-process.  Please make 

sure to have this value finalized prior to performing any further terrain edits. 
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Additionally, you can directly edit the terrain by disconnecting the survey processing rules to allow for 

such functions as cleaning up any unnecessary triangles.  These steps will look at how to disconnect 

the terrain from the survey for editing. 

1. Locate the Survey tab on the Project Explorer.  Right click on the model name (in this 

example, Default) 

2. Select the Deactivate Survey Processing Rules option. 

 
Deactivate Survey Processing Rules 

3. Once deactivated, a small lock icon will appear next to the model name noting that rules 

have been disabled. 

 
Deactivated Survey Rules 

This process disconnects your field book and terrain completely.  Changes made to the field book will 

no longer be automatically be reflected to the terrain.  This is similar to how the DTM and FWD were 

disconnected outside the Survey Data to Surface process.  Although they’re in the same file, they co-

exist as two separate entities. 

With this disconnection completed, you can then use the terrain editing tools to interact with the 

terrain for functions such as cleaning up triangles.  Please keep in mind that all terrain edits must 

occur in a 3D model.  For instance, to delete triangles: 

1. Continuing from the previous steps where we disconnected our survey and terrain model, 

expand the Terrain Model task. 
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Terrain Model Task 

2. Locate the Edit Terrain Model tool. 

 

Edit Terrain Model 

3. At this point you can modify the triangulation in a number of ways.  One of the most useful is 

the ability to remove triangles with a crossing line.  The 6th tool on this panel (highlighted) is 

the Delete Triangle by Line command.  Select it and then click on your terrain model. 

 
Delete Triangle by Line 
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4. With the terrain selected, draw a line as prompted across all the triangles that you wish to 

remove.  The bold lines indicate the crossing line as well as the outline of the triangles to be 

removed.  Confirm what’s to be cut with a single data point click. 

 

 
Top – Before Trimming  Bottom – Trimmed Result 

This same methodology can be applied to most of the terrain editing tools.  It’s imperative however, 

that as we did earlier in this chapter that the survey and terrain be disconnected through the survey 

rule deactivation. 

Throughout this section we’ve looked at how terrain editing works with the survey disconnected.  As 

an extension of this, one may ask what happens if they turn the survey rules back on.  To do so, 

reverse the process in the first part of this section and you’ll receive the following prompt: 

 
Reactivation of Survey Rules 
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Selecting Yes will cause the terrain and survey to relink.  It will also re-establish the terrain back to 

how it was created from the survey, removing any changes or cleanup performed. 

With the terrain model cleaned up and prepared for design, a pair of native InRoads DTMs should be 

produce that accurately reflect this information for additional design purposes.  The next two 

sections cover the steps required, and why these need done. 

6.3-5 Creating the Native InRoads DTM Existing Terrain 

With the terrain now created and cleaned up, a version of this information should be created for use 

with the native InRoads toolset.  Unlike the following process, this DTM will contain the accurate 

triangulation with applicable edits, and triangulated features, and can be used with 3D analysis tools 

in native InRoads by the design staff.  To export this DTM: 

1. Locate your Des #_SRxx Terrain model either in the display, or on the Project Explorer. 

 or  

Locating the Terrain Model 

2. If you’ve located your terrain on the Project Explorer, right click on it, and select Export 

Terrain Model > InRoads DTM. 

 
Exporting from the Project Explorer 
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3. You will then be prompted to save a copy of Des_SRxx.dtm to your project.  Adjust the 

naming to reflect that this file should be named as Des_SRxx Existing Terrain.dtm. 

Completing this will then provide a follow up prompt to check in the DTM.  Please do so. 

 
Saving and Checking the DTM In 

4. The other method, using the graphical location of the terrain, will be done as follows.  After 

locating the terrain as shown in step 1, click on it, and select the Export Terrain Model 

command, followed by InRoads DTM. 

 
Exporting the Terrain by Graphical Selection 

5. At this point, complete step 3 in the exact same manner to complete saving the file. 
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6.3-6 Creating the Native InRoads DTM for Annotation 

Any project that is surveyed using OpenRoads will not have an associated DTM file that contains the 

survey surface that was previously used to annotate the appropriate points from.  To accommodate 

this annotation need, a special graphical import tool has been configured to import the survey data 

into the InRoads DTM format for annotation. 

The reason for using this process instead of the direct export to DTM functionality that OpenRoads 

contains is due to the differing content between the OpenRoads terrain and the fieldbook.  As 

OpenRoads terrains do not carryover point features that aren’t triangulated, the graphical capture of 

these points is the most direct method of capturing all points that have been surveyed and displayed 

in a fieldbook for annotation purposes. 

The following steps look at creating the required DTM: 

1. With your Des #_SRxx Survey Fieldbook.dgn open, navigate to File -> Import -> Surface 

Advanced on the InRoads Explorer. 

 

Import -> Surface Advanced 
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2. This will present the Import Surface Advanced Window. 

 
Import Surface Advanced 

3. In the Rule Set field, set the value to Surface Feature Import as shown in the previous 

illustration. 

4. Set your Surface name to Des #_SRxx Annotation Surface, the Load From should be set to 

All. 

5. When prepared, select the Apply button.  InRoads will begin processing your features from 

graphics and creating a DTM with those features included. 

6. Once complete, make sure to save your DTM file to ProjectWise with your other project data. 

With the DTM created, you can view its contents on the Surface -> Features -> Feature Properties 

command on the InRoads Explorer.  With the import complete you will see the surface features 

similar to this illustration: 
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Graphically Imported Features 

Note:  The annotation DTM that you create as part of this process should not be used for any other 

processes other than various surface annotation processes.  It may not include all features and 

does not have the appropriate triangulation information. 

6.3-7 Creating the Geometry/Alignments DGN 

One of the major enhancements by moving to OpenRoads technology is that the DGN container 

allows for OpenRoads data to be available to other files simply by referencing them together.  This 

workflow will look at referencing the terrain model and using it and the survey features within to 

create your survey geometry.  

This section is the first area where one needs to be careful in regards to the usage of 2D/3D models.  

At any time when the OpenRoads Horizontal Geometry tools are being used, a 2D model should be 

used as when using 3D, reference elements are created at a 0 elevation regardless of vertical 

profile.  This can cause complications further downstream such as when cross sections are cut. 

1. Create a new DGN using the same steps as the survey field book.  Using the Des #_SRxx 

Seed 2D.dgn, create a new file called Des #_SRxx Survey Alignment.dgn. 

2. Open the newly created DGN in InRoads. 
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3. At this time, we now need to access our survey field book DGN to access our terrain model, 

and TOPO features.  As we’ve created this in the field book DGN file, we can use MicroStation 

file referencing to make the field book available to our terrain DGN.  On the MicroStation 

menu select File -> References and proceed to attach the file as you would any other CAD 

file. 

 
Reference Attachment Settings 

4. As shown in the previous capture, there are two settings specifically called out for Detail 

Scale and Global LineStyle Scale.  These two settings should always be set as shown in order 

for Drawing Scale to scale them correctly.  As we did in the previous drawing, set your 

Annotation Lock on, and enable the scale at 1”=50’ for TOPO elements to display properly. 

5. With the survey field book and terrain model attached, you’ll now see the referenced terrain 

model in your Civil Model tab, under the Reference Model listing. 

 
Referenced Civil Data 
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6. At this time, you can begin preparing to create your survey alignment.  The first step is to set 

the feature you’ll be using.  To do this, enable the Feature Definition Toggle Bar.  This can be 

found on the Task Navigation panel under Civil Tools-> General Geometry > Feature 

Definition Toggle Bar. 

 
Feature Definition Toggle Bar 

7. With the Feature Definition Toggle Bar turned on, first toggle on the Use Active Feature 

Definition button, second select the Survey -> Alignment -> S_ALG_Alignment feature shown. 

 
Survey Alignment Feature 
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8. After setting the correct feature, go to the task navigation panel again, and select the 

appropriate tool from the Horizontal Geometry tools to start the creation of your alignment. 

 
Horizontal Geometry Tools 

9. Upon completion of creating geometry, you’ll need to create a complex element.  Select the 

appropriate geometry command.  For this example we’ll be looking at the Complex By 

Elements command.  When prompted on the heads up display, enter the name of your 

alignment.  This example will use Line “A”; once entered, select the elements to create your 

alignment. 

 

Create Complex and Alignment Naming 

Note: The previous workflow example could be superseded depending on project requirements.  In 

those instances know that the general flow is the same, only the tool content may be slightly 

different. 

6.3-8 Creating the Native InRoads Alignment 

Similar to the need for a native DTM file, for OpenRoads SS4, alignment annotation must continue to 

take place using legacy InRoads tools requiring that alignments be sent back to an ALG.  This will 

allow for Stationing annotation to be placed on your alignment, along with preparing the alignment 

for the Design staff to use for their annotation needs. 

To send your alignments back to the InRoads ALG format, perform the following steps: 
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1. Go to the Civil Tools -> General Geometry -> Export to Native command on the Task 

Navigation panel. 

 

Export to Native 

2. The command will activate and you’ll be presented with a heads up tooltip in the drawing 

window requesting that you select the element. 

 

Locate Element Prompt 

3. As shown in the previous screen capture, the tooltip will also show element information for 

the item you’re currently hovering over.  Select all the geometry elements you wish to send 

back to ALG at this time. 
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4. When satisfied with your selections, right-click to Reset and complete the command.  Your 

alignment(s) will then be sent back to the native InRoads ALG format for your use with that 

toolset. 

 

OpenRoads Alignments Sent to InRoads ALG 

Note: When sending alignments back to the native InRoads format, OpenRoads will assume that 

your currently active Geometry Project on the InRoads Explorer is where it should place the 

alignment information.  If you wish to have your alignments placed in a Geometry Project of your 

choosing, makes sure that you first create and activate the Geometry Project on the InRoads 

Explorer prior to sending the alignments over. 

5. With the alignments now showing in an InRoads Geometry Project, you can proceed to save 

the .ALG file with the rest of your project data.  The file should be named Des #_SRxx Survey 

Alignment.alg. 

6.3-9 Verifying Topo using 3D Rotation and Shading the Triangulation 

The View toolbar (located in the upper left of the view window) gives us access to rotate 3D drawings 

to any one of 9 predefined Views.   
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Isometric Views and Right Isometric View are the most useful to rotate quickly to a 3D orientation.  

Option number1 – Rotate View allows dynamic view rotation. 

 

Results will be similar to below. 
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Note:  Alternate access to 3D rotation can be obtained from mouse functions.  This involves the Alt-

Middle dynamic rotation.  This is also the same as Option 1 Rotate View - dynamically 

Alt & Middle click 

 

The Drawing View will have a crosshair placed in the drawing.  This is automatically placed at the 

center of the graphical elements in the drawings. 
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Any subsequent rotation will be about this point unless you dictate otherwise.  (This is rarely the 

desired location.) 

The rotation origin can be modified by tentatively snapping to the desired location (left right chord) or 

by graphically dragging the cursor to a new location.  When the cursor is moved over the crosshairs 

they become highlighted as shown. 

 

Press and hold the left mouse to graphically drag to a new rotation origin.  AccuSnap is particularly 

useful in this operation.  When the left button is released, so is the cursor at the new location.   

Subsequent left mouse dragging will dynamically rotate the drawing.  (Make sure you are no longer 

over the origin.) 
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Results of left drag with triangulation displayed as reference: 

 

Note: Subsequent panning and additional Dynamic rotation will change the perspective, allowing 

us to see any portion of the project from any angle 

Returning to Plan View 

In CAD, the normal Plan View as we are accustomed to describing it is referred to as Top View. 

Simply select the icon to the right of Fit view. 
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Resulting view: 

 

You also may wish to verify the triangulation by applying shading to see if any holes exist.  With your 

triangulation displayed, click on the View Attributes button on the upper left hand corner of your 

active MicroStation view.  The very top option for presentation will be listed as wireframe by default.  

Change this setting to smooth as shown, and your triangulation will look as shown. 

 
Smooth Shading on View Attributes 
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Topo with Smooth Shading 

You can switch back to the wireframe display by performing the same steps, changing from Smooth 

and back to Wireframe.  Note that there are additional display styles available that can also be used. 

6.3-10 Updating SS2 Survey Data to SS4 

Depending on what features of InRoads Survey in SS2 were used, importing a field book from the old 

format can be a very straightforward process.  Please keep in mind that while reviewing these 

instructions, the extent of additional cleanup that will need to occur will depend heavily on if 3 point 

circles were created using the EXTARC command or if offsets were coded as part of the notes (+O, 

+D, +H).  The following steps will cover how to import the FWD files, and in the case of the offsets, 

how to find and modify the shot so the output is correct. 

1. To import a FWD field book file from SS2, navigate to the OpenRoads Survey tab on the Project 

Explorer. 

 

Survey Field Books/Project Explorer 
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2. On the Field Books heading, right click and create your Field Book.  Please use the standard Des 

#_SRXX naming conventions. 

 

New Field Book 

3. Right click on the newly created field book entry and select the Load -> File… option.  Navigate to 

your FWD file from SS2 and open it. 

 

Load Field Book from File 

4. OpenRoads Survey will now import this data and create the field book and graphics. 

5. If your survey didn’t use any offsets in the Note field (Descriptions in OpenRoads), you can 

proceed to work with the survey using the OpenRoads tools as we have throughout this chapter. 

6. If your survey contains offset notes, at this time these will need cleaned up so your data is 

consistent across versions.  Continue on for how to resolve these changes. 
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7. Select the All Point Features from the field book on the Project Explorer. 

 

ALL Point Features Selected 

8. On the Survey task, select the Show Details tool from the Survey Processing toolbox.  This will 

open the table view with all your points. 

 

Show Details 
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9. On the table view, right click on the Description field and use one of the sorting methods.  Be 

advised that this is just a single method, and you can also use the find commands, or even drill 

down to specific features and perform similar steps.  For this example we’ll be using the Sort 

Ascending command. 

 
Sorting Point Features 

10. With the list sorted, all common offset notes in the Description field will be grouped together.  

You may either scroll down to where these are, or use the Find… command to quickly jump to 

these in the list. 

 
Sorted by Description 
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11. Click on the Control Codes field for one of the entries.  Unfortunately this tool does not support 

bulk edits.  In the case of the following example, we have a left offset of 1 foot, so the Control 

Code will be set to LeftRight and a value of -1 entered.  Please keep in mind that you must use 

the Tab Key in the value field for the record to be confirmed.  Repeat this step for any point 

necessary. 

 
Modifying/Adding a Control Code for Left/Right Offsets 

12. Locating your point in the display, it will appear that it hasn’t moved to the offset entered.  Much 

like InRoads before, the display will need redrawn.  To do so, go to the Survey Task, and under 

Survey Processing, select the Redraw command.  Your observation will then be reflected in the 

TOPO. 

 

Redraw the Survey 

At this point you’ll have the SS2 survey migrated over to SS4/OpenRoads.  Note that there will still 

be clean up needed, such as resolving any 3 point circles or other coding issues that the above did 

not fix.  In many instances, bringing the survey forward should be a quick and painless process 

however. 
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6.4 Routeplat, Reference Box and Section Corner Card Creation 

The following sections will walk through the process to create a complete route plat sheet.  This will 

include creating the file in ProjectWise, examining its contents, and working with/referencing section 

corners. 

6.4-1 Creating the Route Plat .dgn file 

Prior to placing any content into the route plat, we need to create a drawing to work in.  This process 

will be same to the steps performed in section 6.3-1. 

Using these steps, you’ll need to make two adjustments. 

1. When selecting your seed file, select the appropriate unit file from:   

pw:\\indot-pw.bentley.com:indot-pw-01\Documents\Template Documents\SS4 

Seed\MicroStation\Survey Seed Files\ 

 
Selecting a Route Plat Seed 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/Survey%20Seed%20Files/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/Survey%20Seed%20Files/
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2. Your document name, description and file name should all be set in the Des #_SRxx LCRS 

Plat.dgn format. 

 
Route Plat naming 

6.4-2 Contents of the Route Plat template files 

Each of the route plat templates contains five models.  These can be accessed by going to the model 

icon in your MicroStation toolbars: 

 
Accessing the Models Dialog 

By selecting this icon, you’ll be presented with the following window and list of available models.  The 

plat sheet will come up by default: 

 
Available models in the template 
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The five models available are: 

1. Coordinate Table – This is the template Reference Point Coordinate Table. 

2. Default – This is the default MicroStation model, and is available in all .dgn files. 

3. Plat – This is the template route plat sheet model. 

4. Point Number – This is the template reference box model. 

5. Section Corner Reference Card Sheet – This is the template Section Corner Reference Card 

Model. 

6.4-3 Creating Reference Boxes 

The following steps go through the process of creating a model containing the control point reference 

box for use in either Route Plat Sheets or the Section Corner Reference Card. 

1. Open your Des #_SRxx LCRS Plat.dgn from ProjectWise. 

2. As shown in the previous section, open the models dialog from the toolbar icon. 

3. On the Models dialog, double click on the Point Number model to open it. 

 
The Point Number model open in MicroStation 

4. Select the Copy Model icon from the Models dialog. 

 
Copying a Model 
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5. The Point Number model has active field as shown in the earlier capture (the gray shaded 

areas for Point Number and Description).  During the model copying process, you’ll be 

prompted to create the new model with a new name and description.  The values for point 

name and description should be entered as you’d like them to appear on the completed 

control point. 

 
Point Number Model Copy 

6. Once the model information has been entered, select OK.  The completed model copy will 

become active, and will show the name and description in the control point as shown.  

Repeat steps 4 and 5 for each additional reference box you require. 

 
Completed Point Number Model Copy 
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7. Next, the control point content needs created.  If not active from the previous steps, enter 

your control point model by double clicking on its listing in the Models dialog.  Once in the 

appropriate model, open the Survey task from the INDOT Tools workflow in MicroStation: 

 
Survey Tasks 

8. First we’ll add the north arrow.  Load the Survey Symbols library from the Survey task. 

 
Survey Symbols 

9. This will load the Survey Cell Selector.  On the displayed panel, locate the cell called northsy.  

Do not use northsymb as it is scaled differently.  Clicking on the northsy button will bring up 

the cell placement tools at the appropriate scale.  At this time, place the cell in the correct 

spot in the control point border.  Note that cells are sorted by letter case then alphabetical 

order.  (PSSA would show up in the list before northsy as the capital P takes precedence) 

 
The Survey Cell Selector 
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10. Next locate the cells for the traverse station cell (PSSA) and any other object that needs 

placed.  In each of these instances, a scale of 1 should be used.  Snap this cell to the center 

of the provided centerline. 

  
PSSA Cell Placement 

11. After placing additional cells such as power poles (PPWP), you will need to place the lines for 

the dimension ties.  From the Survey task, select the Place Line command. 

 
Place Line 

12. While in the place line command, you’ll want to snap your initial point to the center of the 

PSSA symbol on the centerline. 

 
Drawing Dimension Ties 
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13. Next, in your AccuDraw toolbar/window, place your cursor in any of the fields and hit the 

space bar to set it to angular mode.   

 
AccuDraw Mode 

14. At this time, place your cursor in the angle field and enter the appropriate value.  This will 

also lock the angular value in allowing you to draw the line along the bearing you’ve 

specified.  Remember to specify degrees, using the ^ symbol (shift key + 6). 

 
Dimension tie 
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15. With the lines drawn, you can now adjust the placement of any cells that you’ve placed and 

your resulting reference box should look similar to the following: 

 
Reference Box 

16. Next, you’ll need to add the text labels to the Reference Box.  Start by selecting the Place 

Text tool from the task navigator.  You can find this either on the Drawing task, or from the 

INDOT Tools -> Survey Task. 

 
Place Text 

17. With the Place Text tool active, first set your Text Style to 10 Point Text.  This will initiate the 

appropriate justifications and sizes.  Due to the constrained size of the reference boxes, we 

will adjust our font to the Bentley WORKING font as shown.  Expand the dialog by clicking on 

the arrow in the lower right hand corner and select 1 WORKING from the Font section.  Note 

that upon changing the font, the Text Style field highlights itself blue.  This denotes that 

you’ve adjusted the font from the default style. 

 
Place Text Settings 
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A note on Text Styles 

As shown in the previous steps, we are deviating from the standard font applied to the 10 Point Text 

style, which will cause your text styles to become out of sync with the dgnlib.  In order to revert your 

text style to the appropriate values, either select the Reset Style button on the Place Text panel as 

shown: 

 
Reset Style 

Or you can reset the style from the Text Styles dialog located under Element -> Text Styles on the 

MicroStation menu.  When you locate the style that no longer matches (it will be denoted with a Δ), 

right click on it and select “Update from Library”. 

 
Update from Library 

In addition to adjusting the font, it may also be desirable to adjust the Justification options to more 

appropriately place your text along, above or below elements.  Again, you can revert back to the 

default text style settings using the methods shown above. 

More notes on Text Placement 

Various notes may require the use of special characters not directly accessible via the keyboard, 

such as the degree symbol.  There are two ways to place this and other symbols.  The first method is 
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via the Insert Symbol button on the Text Editor.  Selecting this button will bring up a fully illustrated 

list of the available characters in the active font.  Via this browser you can find the symbol, insert it 

into your text and quickly add it to the symbols favorite list. 

 
The Insert Symbol Tool 

 

The Symbol Browser and Adding to Favorites 

Additionally, if you know the appropriate key-in sequence, you can type the symbol in.  In the case of 

the degree symbol and the Working font, you can type it in by holding down the ALT key, then typing 

9 then 4.  This will place a ^ in the text editor, however when going to place the line of text, a degree 

symbol will appear. 
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18. After placing the appropriate labels, your reference box should look similar to the following. 

 
Reference Box with Labels 

19. Finally we need to place the note describing the monument type.  Similar to the Place Text 

tool, we will need to start the Place Note tool.  This tool can also be found in both the 

locations mentioned in step 16. 

 
Place Note 
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20. With the place note tool active, set your Text Style to 10 Point Text, the Dimension Style to 

Engr Arrow, and your Text Frame to Box as shown. 

 

Place Note Settings. 

21. Next, on the Text Editor, change your active font from Tahoma to the Bentley WORKING font. 

 
Setting the WORKING Font 
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22. With the Place Note tool configured, type the monument information into the Text Editor.  

When the text is typed, place your cursor on the monument in the reference box and select 

the location where you’d like to start the terminator.  A second placement will determine the 

leader length and direction and place the text box.  The resulting reference box will appear as 

follows: 

 

Completed Reference Box 

23. At this time you may need to restore your text and dimension settings to their default 

configuration.  These steps are noted in tips throughout this section and are similar for text 

and dimension styles.  With this first reference box created, you can now create additional 

reference boxes for each point in the plat. 

6.4-4 Creating the Reference Point Coordinate Table 

Since the coordinates for the Reference Points are no longer contained in the Reference Box, a 

Coordinate Table will need to be created.  It is recommended to create one overall coordinate table 

for the Route Plat. The following steps go through the process of creating a Coordinate Table. 

1. As we did with the reference box, we’re going to use the Models dialog to copy the template 

model included in our .dgn file.  Open the Models dialog and copy the Coordinate Table 

model. 

 
Copying the Coordinate Table 



 

309  

 

2. With our table copied, make sure the new model you created is active.  If not, double click on 

it in the Models dialog to activate it. 

3. All the text in this table is editable via the standard text editing tools in MicroStation.  Using 

either the Edit Text tool, or by double clicking on the pieces of text, edit the values for your 

coordinate table accordingly. 

6.4-5 Adding the TOPO to the Routeplat Sheet 

With our reference boxes and coordinate tables created, we can now begin the process of creating 

the route plat sheets and populating the file with content. 

1. As we’ve done in the previous two examples, take the template routeplat provided in the .dgn 

and copy it to a new model. 

 
Copying the Plat Model 

2. If not opened automatically, double click on your newly created model to activate it.  Should 

you need additional plat sheets, repeat step 1 as needed. 
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3. Now that we have a new routeplat model created and open, we can begin adding the various 

pieces of content.  When first entering the new routeplat model, you will see the following 

template information: 

 
The Template Routeplat 

As you can see in the following illustration, the template contains the appropriate border file 

and a grayscale border all in a sheet model (denoted by the virtual paper size around the 

border). 

4. At this time, we’re now ready to begin adding content to this file.  The vast majority of content 

that we’ll be adding will be via MicroStation references.  Open the References dialog from the 

MicroStation toolbar. 

 
MicroStation References 
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5. The first item we’ll attach is the topo drawing we’ve created for our project.  Start by selecting 

the Attach Reference button from the Reference dialog. 

 
Attaching References 

6. Unlike the prior version of our referencing procedures, we’ve created all our content in a 

single survey fieldbook DGN.  As such, when prompted for the file you’d like to attach, select 

your single topo drawing as shown.  Make sure to set the attachment method to Interactive 

so you can adjust the scaling and view orientation. 

 
Reference Attachment 

7. With your topo selected, select OK and configure the additional settings for your attachment.  

The following illustration shows the attachment made at 1”=100’.  Please note that on this 

panel we’ve selected Coincident-World as our Orientation. 
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Attachment Settings 

8. As we’ve selected a Coincident-World attachment, your topo will not appear within the 

border.  We need to move our topo back into the border.  Start by zooming extents, and then 

in the References dialog box, choose all the attached reference filenames you want to move, 

and select the Move Reference button. 

 
Move Reference 

Left click at the location in the drawing you want to move the files from and then left click at 

the location in the drawing you want to move the files to.  This will move all the selected files 

to the new location. 

9. Be sure to save settings by hitting Ctrl + F, or selecting File -> Save Settings.  This will ensure 

that the changes you made to the reference files will be saved for next time. 
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10. If you need to clip the reference, the easiest way is to use a fence.  Select the Fence tool 

from the Task Navigator. 

 
Place Fence 

11. On the place fence tool, make sure your Fence Mode is set to Inside.  In most instances, you 

can leave the Fence Type set to Block, however it may be advantageous to use one of the 

other fence methods to achieve a tighter clip around your topo. 

 
Place Fence Tool Settings 

12. With your fence placed around your topo, you now need to select Clip Reference from the 

References dialog as shown.  On the Set Reference Clip Boundary dialog, make sure the 

Method is set to Active Fence.  When satisfied with the boundary fence you’ve defined and 

the clipping settings, left-click in the drawing area to accept the clipped reference settings. 

 
Reference Clipping 
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Note: You could draw a polygon and change its Class to Construction.  Then by changing the Fence 

Type to Element you can create the fence by selecting the polygon.  This would give you a way of 

recreating the same clip area for additionally attached reference files. 

13. Be sure to save settings by hitting Ctrl + F, or selecting File -> Save Settings.  This will ensure 

that the changes you made to the reference files will be saved for next time. 

6.4-6 Adding Reference Boxes to the Routeplat Sheet 

Now that we’ve added the topo to the route plat, we need to add the reference boxes to the sheet.  

Continuing from the previous set of steps, make sure that you’re in the appropriate Plat model; 

otherwise open it via the models dialog as noted in step 2 of the previous section. 

1. With the plat sheet showing in our MicroStation view, you should see the frame of your topo 

and a dashed grid setup in the sheet.  If you don’t see the dashed grid, we need to enable it 

with the following steps. 

 
Routeplat with Topo and Grid 

2. If the grid isn’t visible, enable the Constructions option on the View Attribute panel.  This 

panel can be found on the View toolbar. 

 
View Attributes 
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3. The Constructions item can be found on the left side of the panel.  Make sure it’s highlighted 

as shown in the following capture: 

 
Constructions Elements Enabled 

4. At this time, we want to open both the Models and References dialog boxes from our Primary 

Tools toolbar.  They sit next to each other as shown: 

 
Models and References 
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5. With both dialogs open, we can now drag our Reference Box models from the models dialog 

and directly attach them to our Plat as references.  Note that you can drag and drop multiple 

references boxes at the same time on this dialog.  For this example we will only be attaching 

a single reference box. 

 
Reference Box Attachment Drag and Drop 

6. Upon completion of the drag and drop, you will be prompted with the Attach Source Files 

dialog requesting you to adjust the alignment of the references being attached.  For our 

reference boxes, we want to use the Top attachment method as shown: 

 
Attach Source Files 
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7. After accepting the attachment method, you will see an outline of the reference extents that 

you’re trying to attach.  Note that the attachment point is the center of the reference. 

 
Reference Attaching 

8. At this time, you need to position your cursor and snap to the appropriate grid location where 

you’d like to place the reference box.  When satisfied with your location, place the reference 

by a left-click. 

 
Placed Reference Box 

9. Repeat steps 5-8 for each successive reference box.  Finally, to disable the reference grid, 

disable the Constructions view attribute that we enabled in step 3. 

6.4-7 Adding the Coordinate Table to the Route Plat 

Next we need to add our Coordinate Table to our plat sheet. 

1. If not open and active, open your route plat and make sure the plat sheet is open in 

MicroStation. 
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2. Make sure you’ve fit the entire sheet in your view.  Do this by either performing a Fit View 

Zoom from the View toolbar or by double clicking your middle/mouse button. 

 
Fit View 

3. At this time, we want to open both the Models and References dialog boxes from our Primary 

Tools toolbar.  They sit next to each other as shown. 

 
Models and References 

4. With both dialogs open, we can now drag our Overall Coordinate Table model from the 

models dialog and directly attach it to our Plat as a reference. 

 
Attaching the Overall Coordinate Table 
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5. When prompted with the Attach Source Files dialog, set your attachment method to 

Coincident. 

 
Coincident Attachment 

6. This will attach the coordinate table to your routeplat sheet.  You can adjust this reference 

placement by highlighting it on the Reference dialog and selecting the Move References tool 

and moving the reference as you would any other element. 

 
Move References 

6.4-8 Creating Section Corner Cards 

This section will walk you through the creation of Section Corner Cards and attaching the appropriate 

reference boxes. 

1. Make sure your route plat file is open.  At this time you do not need to be in a specific model. 

2. Open the Models dialog.  As we have done in previous examples, we’ll be copying the 

template Section Corner Reference Card Sheet model as we did with both the reference 

boxes and the plat sheet. 

 
Accessing the Models Dialog 
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3. With the Models dialog open, highlight the Section Corner Reference Card Sheet model, then 

select the Copy Models button from the toolbar. 

 
Copying the Section Corner Reference 

4. In the Copy Model dialog, type the name and description of the reference card as shown in 

the previous illustration and hit OK.  This will copy the model and should open it in the 

MicroStation session.  If it doesn’t open automatically, switch to it by double left-clicking on 

the model in the Models dialog. 

 
Section Corner Card with Reference Box 

5. Open the References dialog from the Primary toolbar.  You’ll find that this model already has 

a reference back to the blank Point Number model in our active file.  This is pre-attached to 

appropriately place the reference and allow you to quickly select the appropriate point 

number attachment. 
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6. In the reference dialog, double-click on the reference with the Model named Point Number 

and when prompted, change the model on the Attachment Settings to the appropriate 

reference box as shown. 

 
Adjusting Reference Box Attachments 

 
Reference Box Attachment 
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7. At this time, you may conclude filling in the fields on the reference box and moving the 

section corner elements as needed.  To edit the text, use the Fill In Single Enter-Data Field 

tool found on the task navigator under the Drawing task. 

 
Editing Section Corner Fields 

8. Repeat the previous steps for each reference box as needed.  
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6.5 OpenRoads/InRoads Reporting 

6.5-1 Exporting OpenRoads Survey Data 

For Survey Data, OpenRoads technology uses different methodology for the reporting tools.  Using 

the built-in survey processing and display tools, reporting can be far more specific--down to the 

feature level.  This section will look at two different export methods:  direct export to .csv and usage 

of the OpenRoads reporting tools. 

Please keep in mind that these methods are not a way to directly export data to a ready-made 

format and are more akin to a direct coordinate export.  Any output that these methods produce 

may need some clean up and modification if the intention is to use the data these provide in other 

ways. 

6.5-1a Reporting on Survey Information 

The following steps look at how to turn OpenRoads survey information into a reported format similar 

to those provided in SS2.  This example will show reporting on Point Features. 

1. With your DGN open, navigate to the Survey tab of the Project Explorer.  Locate your 

fieldbook. 
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2. Locate the Point Features highlighted in the previous screen capture.  On the Survey task, 

under Survey Processing, select the Show Details entry. 

 

3. This will bring up the Survey Details for all the points.  Should you wish to only report on a 

certain feature, or subset thereof, you can continue to drill down under the All Point Features 

on the Project Explorer to the feature you’d like. 
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4. On the Survey Details display, you can select as much or a little as necessary.  This dialog 

adheres to standard Windows conventions of Ctrl-click and Shift-click methods to select 

multiple entries either one at a time or in a sequence.  For this example, all points have 

been selected by using the Ctrl+A (select all) command. 

 

5. With your points selected, right click on the far left hand column (to the left of the point 

names, the upper left box will not work), and select Report on selected items. 
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6. This will start the Bentley Civil Report Browser and initialize the 

SurveyPointsCompleteTable.xsl. 

 

7. You can then save the output to a number of formats, along with printing it to a printer or 

PDF file.  Additionally, by right-clicking on the report background, you can bring up a context 

menu that allows you to export the format directly to Excel. 
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By exporting to Excel, you will get a tabular file with all the data in the report shown in their 

appropriate columns.  This will allow for the data to be quickly adjusted, and then if needed, saved to 

a .csv or other needed formats. 

 

6.5-1b Direct Export 

The steps for this process are similar to those in the previous section.  Perform steps 1 through 3 as 

shown. 

4. To export the points directly out without reporting, you’ll right click on the upper left hand cell 

in the table (to the left of the Name field header).  Select the Export option shown. 
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5. You will be presented a Save As dialog.  Selecting the Save as type will present the different 

options you can save your file out as. 

 

Depending on the format chosen, you can then open the file either directly in Excel, a text editor, or a 

number of different applications. 

6.5-2 InRoads XIN Code Report 

Within the InRoads environment, it’s possible for each user to export a list of the survey codes from 

an InRoads report.  To do so, the following steps should be performed: 

1. Start MicroStation and InRoads, any DGN will work as no items need drawn up. 

2. On the InRoads Explorer, navigate to the Tools -> View XML Reports…. Option. 

 
View XML Reports 
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3. With the Bentley Civil Report Browser open, go to the File -> Open option. 

  
Report Browser 

4. Navigate to the location of the Production XIN in ProjectWise.  This location is under 

Documents\INDOT Workspace\OpenRoads\Workspace\xin\INDOT.XIN.  The Application 

dropdown will need changed to All Applications.  Select Open. 

 
Browsing for the Production XIN 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/xin/INDOT.xin
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5. With the XIN now open in the Report Browser, select the XIN folder in the left panel, and 

expand it.  Under this folder, select the FeatureStyles.xsl report type. 

 
The XIN Reports, and FeatureStyles.XSL 

6. This will process the opened XIN through the appropriate report and will provide a list of all 

features and where applicable, the Survey Codes used. 

 
XIN Report 
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7. With the XIN report open, there are a number of addition items that can be performed with 

the visible data.  Of particular note is the ability to print, and export to a variety of formats.  

To export to a different format such as Excel, right click in the report and select Export to 

Microsoft Excel.  With the report in other formats, the data can be adjusted to fit specific 

needs. 

 
Export to Excel 

7. InRoads Plans Production for Design 
The following sections discuss the usage of InRoads for INDOT Plans Production purposes.  We are 

continuing to employ the same layered approach to the drawing composition process.  These 

sections discuss how the drawings are created, layered and pieced together to form a fully realized 

data set that can then be turned into a plan set. 

7.1 Referenced Base Drawings 

As previously mentioned, we employ a layered drawing process allowing for maximum flexibility in 

configuring data to be displayed, referenced, and reused.  The base drawings for all these steps can 

be easily referenced together.  The only possible difficulty might be differences in coordinate systems 

between the files.  This may be resolved using MicroStation tools.  This problem is not likely unless 

you have drawings (MicroStation or AutoCAD) with information from sources outside of INDOT.  

Despite this problem, it can be fixed.  The following figure displays how base drawings are placed 

together. 
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Conceptual view of Base Drawings Referenced Together 

Note: With the combination of the Survey TOPO and Terrain model information being in a single 

DGN, it’s no longer necessary to create discreet contour drawings.  The following workflow will 

describe the process of acquiring and using this data for your project. 

This figure displays a view with Prplan set as the active drawing and with Explan referenced into 

Prplan.  The actual results would look like the illustration below. 

 

Prplan 50 with Explan 50 referenced 

  

 

Base drawing Explan 50 

Base drawing Prplan 50 
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7.2 Reference Windows 

The base drawings will have reference window views that show through to all of the base drawings.  

The tools contained in the Plan and Profile Generator are used to create plan profiles, bridge layouts, 

construction details, and other drawings.  The following figure displays how reference windows with 

multiple base drawings are placed together. 

 

Base Drawings Referenced Together with Reference Windows. 

The above figure displays a view with Prplan set as the active drawing and Explan referenced.  The 

addition to the figure is how reference windows are included, which is accomplished by using the 

Plan and Profile Generator. 

Each of the plan views represents a plan view area that is clipped into a given plan profile drawing.  

These same concepts apply to both plan and profile views.   

Construction details, Bridge Layouts, and other drawings use the same principles for each type of 

drawing but with different view sizes and layouts for each. 

InRoads will create saved drawings utilizing base drawings and then apply saved reference windows 

to each respectively based on the type of drawing and scale selected. 

  

Base drawing Explan 50 

Base drawing Prplan 50 

Planprofile001 

plan view 

Planprofile002 

plan view 

Planprofile003 

plan view 
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7.3 Text Drawings  

A common CAD technique is the incorporation of text drawings.  Text drawings are CAD drawings that 

only contain text elements.  These text drawings facilitate drawing file organization and make plan 

set creation easier.  When these text drawings are referenced together with base drawings and other 

drawings, they form composite drawings representing finished sheets.  One major advantage of 

these drawings is that they eliminate problems with text orientation and overlap.  The problem is 

related to the two possible locations to place text annotation on a set of drawings, in the base 

drawings and in the sheet (text) drawings.  Annotation placed in the base drawings is usually 

oriented with North being up.  This causes annotation to be readable only from one orientation.  Text 

could be rotated for each window, but this does not fix problems occurring in overlapping plan areas.  

See the following figure. 

 

Problem with Overlapping Text Area 

As seen in the above window, orientation of text in the overlap area is a problem.  The preferred 

method for text placement is in the reference view text drawing.  These reference view text drawings 

are the plan profile drawings, Bridge Layouts, construction detail, or other drawings.  The practical 

result of this is each drawing is a text drawing with no line work drawn in it.  For the most part, the 

only elements which reside in the sheet (text) drawings are text elements. 

Please note editing done on text drawings in overlapping areas will not be reflected in adjacent areas 

without editing each adjacent sheet. 

The InRoads Plan and Profile Generator automatically creates sheet text drawings for plan profiles, 

Layouts, Construction Details, and other InRoads created sheets.  The saved plan profiles, Layouts, 

and Construction details are essentially composite drawings made up of references for border, 

Text Drawings #2 

Plan view for sheet #2 

 

Text Drawings #1 

Plan view for sheet #1 

Overlapping Area – text 

orientation problems & 

interference between 

adjacent windows 

Text for plan view #2 goes 

on text drawing #2 

Text for plan view #1 goes 

on text drawing #1 

Text 
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existing topography, proposed design, etc. with reference windows clipped to match the size of the 

border.  These saved sheets are ready to accept text and are text drawings. 

It is also recommended that text drawings be used with cross section drawings.  When used with 

cross sections they are created as blank drawings that will then have the border and cross section 

referenced in.  This technique helps to preserve manual annotations on cross sections.  Please note 

that these drawings will need created manually. 

Annotations on the base drawings can be copied to each sheet.  On each requisite sheet the 

annotations can be moved, modified, and rotated as needed.  In order to prevent duplicate text 

coming from the base drawings, annotations can be changed to construction elements with the 

change element attributes tool in the base drawing.  Constructions can then be turned off in each 

text drawing while they will remain in the base drawings.  Use of save settings is important with these 

operations.  This will allow the sheet drawings to have construction elements turned off, prohibiting 

duplication. 
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7.4 Creating Base Drawings 

With the move to OpenRoads technology, a number of changes have been made to the base drawing 

process.  The most obvious change is that some of the supplemental files that were used by InRoads 

are no longer necessary for the creation of the base sheets, particularly the DTM file (surface).   

As the DTM content has now been split into various data containers within the DGN, there is some 

additional flexibility that has come about.  First, contours and triangles are no longer separate 

drawing steps, instead they are displayable portions of the terrain model that can be 

enabled/disabled with a toggle.  Additionally, as the DGN is now the container, standard 

MicroStation referencing can be used to make data available across files, while even allowing editing 

when used in conjunction with the Reference -> Activate command. 

This section looks at creating comparable base drawings to how processes in the past have 

compiled them.  This allows us to maintain a vast majority of our current workflow while maintaining 

flexibility in providing the base data across the project.  In that regard, the biggest change is that a 

drawing for existing contours will no longer be created separately. 

Next, a note on scaling.  OpenRoads tools are no longer dependent on a specific scale being 

assigned at the time they are drawn, and are now using Drawing Scale instead.  This allows for the 

scaling of data to be done on the fly as discussed in Chapter 5.8.  For the purposes of this document 

we will continue advocating that if possible a scale be given to the file.  Should multiple scales be 

unnecessary, the omission of the scaling is acceptable (ex. Explan 50.dgn becomes Explan.dgn).  

Also, be advised that once native InRoads tools are being used (Feature Annotation, Geometry 

Annotation, Plan and Profile Generator) the Global Scale Factors tool should be used. 

As a reminder and reinforcement from the previous sections, please pay special attention to the 

seed files that are recommended for use throughout this chapter.  Geometry elements drawn in a 

3D seed file will cause issues with cross section generation even after a vertical profile has been 

applied, so it’s very important that content is placed in the right file to eliminate potential issues. 

7.4-1 Geocoordinating Base Drawings 

Depending on the methodology used to start your base drawings, you may opt to start from fresh 

seed files.  The following documentation assumes the usage of already provided files that will be 

preset with the appropriate geocoordination information.  This section, however, covers the process 

of geocoordinating individual files and may not apply/be necessary in all workflow situations. 

One can easily geocoordinate a DGN file through the following process.  This process is not 

dependent on having InRoads running and can be accomplished in a regular MicroStation session. 
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1. In MicroStation, go to the Tools > Geographic menu option, and select Open as Toolbox. 

 

2. On the Geographic toolbox, select the “Select Geographic Coordinate System” button. 

 

3. On the Geographic Coordinate System window, select the From File option. 

 

4. This will present a ProjectWise file browser, navigate to your Survey/Project Files folder and 

select the Des #_SRxx Seed 3D.dgn or the 2D version. 

5. With the .dgn highlighted, select Open and the geocoordinated definition for the selected file 

will be imported into your active DGN configuring it for further operations that can use the 

coordinate system such as attaching rasters, and other project data. 
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7.4-2 Creating the Existing Plan Drawing 

Note:  The following exercises are based upon a production drawing example. 

With the move to OpenRoads technology, it’s no longer necessary to create a specific existing plan 

drawing.  All topographical elements are displayed directly from the Des #_SRxx Survey 

Fieldbook.dgn called out in the chapter 6.  As this file should be created from the Survey 

geocoordinated seed file, no adjustments should be needed and a copy of the file can be pulled 

directly into your project for design use.   

One of the many benefits to the OpenRoads technology is how the use of this data as a reference 

makes the underlying surface elements available without having to be directly in the file you’re 

interfacing your design with.  We’ll look at the different methods of showing the data necessary using 

this file as a reference throughout this section. 

To start acquiring your data, the first stop should be your survey project.  As the survey department 

updates their deliverable requirement, you should have access to a Des #_SRxx Survey 

Fieldbook.dgn file.  Copy this file to your Design\InRoads folder.  This file can be located under 

Survey\Project Files for internally surveyed projects or from your survey consultant. 

Once you’ve located the Des #_SRxx Survey Fieldbook.dgn, you have two methods to get this data 

into your project: 

1. You can drag/drop/copy the data in the ProjectWise Explorer and rename the file. 

2. Use the ProjectWise New Document -> Advanced Wizard 

7.4-2a Creating Explan Using Drag/Drop/Copy 

With your file located in the Survey\Project Files folder, Right click on the Des #_SRxx Survey 

Fieldbook.dgn, do not let go of the right mouse button.  While continuing to hold the right button 

down, drag the file from its current location to your Design\MS folder as shown. 

 

Right Click Dragging a File 



 

339  

 

With your cursor over the InRoads Folder, release the right click.  At this time you’ll be presented with 

the Copy Here/Move Here/Cancel options shown in the previous illustration.  Select Copy Here and 

ProjectWise will make a direct copy of the Des #_SRxx Survey Fieldbook.dgn in your InRoads folder. 

Now the file can be renamed in line with convention to Explan XX where XX is the scale.  Highlight the 

Des #_SR xx Survey Fieldbook.dgn under your InRoads folder and right click on it.  When you release 

the button, locate the Rename option on the displayed menu (these settings can also be located 

under the Document menu with the appropriate file highlighted). 

 

Renaming the File 

On the Rename command window, make sure that all 3 fields show Explan XX.dgn for the name 

where XX is the scale.  Note the lock icon and check box on the following illustration.  If enabled, 

ProjectWise will automatically keep the document and file name the same.  The description will still 

need copied/pasted. 

 

Renaming the File 

At this time you now have your existing plan, contours, and triangulation data. 
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7.4-2b Using the New Document -> Advanced Wizard 

The alternative method to creating your Explan file is to use the New Document -> Advanced Wizard 

to copy and rename the Des #_SRxx Survey Fieldbook.dgn in a streamlined process.  To start this 

process, right click in an open area in the upper right document panel in ProjectWise and select the 

New -> Advanced Wizard… option.  If you happen to have or inadvertently select a document, this 

wizard option will not be available and you should adjust your cursor placement to attempt this 

sequence again. 

 

Starting the Advanced Wizard 

This will initiate the Advanced Wizard for document creation.  The first panel is just information and 

the Next button can be selected to move to the second panel.  The second panel allows for a brief 

review of the location where you’re placing the new file.  Adjust the location if necessary and select 

Next. 

The third panel allows for the specification of the file that you’d like to use as a template.  There are 

3 major options: 

1. Use a ProjectWise document as a template – Allows for the selection of a file already in the 

datasource to copy as your new file. 

2. Use external file as a template – Allows for a file outside ProjectWise to be brought in as the 

new file.  This could be used to bring a copy of the survey data in if it’s not already located in 

the datasource. 
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3. Select from recent used templates – As one uses ProjectWise and the Advanced Wizard, this 

selection window will populate with recently used files.  These can be selected to quickly 

locate items such as seed files. 

 

Selecting a Template Document 

For this example, we’ll be looking at using the first option, Use a ProjectWise document as a 

template.  As shown in the previous illustration, first make sure the radio button for the first option is 

selected, the use the Select button that’s active on the right side of the window.  After picking the 

Select button, you’ll be presented a ProjectWise browsing dialog.  Navigate to and select your Des 

#_SRxx Survey Fieldbook.dgn. 

 

With Des #_SRxx Survey Fieldbook.dgn Selected 

After you’ve selected the file, pick the Next button to proceed through the next steps of the wizard.  

The first two panels you’ll see are for document properties which you can define at this time or defer 
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to later.  The third panel allows for the renaming of the file prior to it being created.  Enter your 

Explan XX.dgn in the fields shown.  Note that the operation of the lock icon is the same as on the 

Rename tool discussed in the previous example.  When finished, select next and complete the 

wizard. 

 

Setting the Document Name 

At this time, you should open the file and verify that the contents are 3D. 

7.4-2c Creating Explan from a SS2 DTM 

During the transition period between workspaces, it will be common to find surveys that have been 

done in SS2 InRoads formats while being designed in SS4.  In these instances, you will need to bring 

this data into the appropriate SS4 containers. 

The most direct way to convert terrain data from SS2 with be through importing the existing DTM file.  

This process has been fixed to allow for the import of all TOPO elements for display and review in the 

terrain model.  To import the DTM, the following steps should be performed: 

1. Create a new Explan XX.dgn using the appropriate 3D seed file for the project.  This can be 

done either as Drag and Drop, or through the advanced wizard as noted in the previous 

section.  Use the seed files located at:  

pw:\\indot-pw.bentley.com:indot-pw-01\Documents\Template Documents\SS4 

Seed\InRoads\ 

2. Make sure that the file association points to the correct product (InRoads SS4 or 

PowerInRoads), and open the file. 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/InRoads/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/InRoads/
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3. Start on the Civil Tools option on the Task Navigation panel. 

 

4. On the Civil Tools, expand the Terrain Model task and select Create from File. 

 

5. On the Import Terrain Model(s) Dialog, make sure that for the Feature Definition you pre-set 

one of the Display Styles.  For this example, the Existing_Contours and Triangles style has 

been selected.  Also make sure that the Import Options are set to both.  This will bring in both 

linear and point features as defined in the DTM. 
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6. Select Import and the DTM will be imported as a Terrain Model.  Selecting the Feature 

Definition display style upfront will bring the data in and show it triangulated and contoured.  

You can use the Element Information to disable these as needed. 

Note that after you select Import, the window doesn’t close, you will need to X it out in the 

upper right corner. 

7. Reviewing the Project Explorer to look at the Terrain Models will show your new model and 

how it’s linked to the DTM that was brought in. 

 

Importing the DTM will give a terrain model that is consistent with the legacy format, including any 

survey adjustments, offsets, boundaries and other model content. 

Note: DTMs and Random Features 

One major difference in how OpenRoads interacts with elements is how they are defined coming 

from a DTM.  OpenRoads is very explicit about how it translates DTM features into the terrain model 

and it can lead to some inconsistency in data display.  Particularly, features that are defined as 

Random in the DTM file and are not triangulated will only come across as a small point on the 

terrain.  This causes issues identifying items that may have been coded this way such as pipes, 

fences, etc.  This has come about as InRoads SS2 allows for connecting lines to be drawn between 

random points, which OpenRoads does not. 

The following steps should be used to check your data and then remedy any issues you may 

encounter: 

  



 

345  

 

1. Open your DTM on the InRoads Explorer using either File -> Open, or right clicking on the 

Surfaces and selecting Open. 

 

2. With your DTM open, open the Surface -> Feature -> Feature Properties tool. 

 

3. On the Feature Properties window, select the Filter button. 
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4. On the Feature Selection Filter window, select the Random Feat. – Not Triangulated option.  

This will display all random features that are not part of the triangulated and excludes point 

features. 

 

5. Back on the Feature Properties window, you’ll see a truncated list of the filtered features.  To 

resolve any features that you want displayed in the terrain model, select one of the features. 

In this example, we’ll select a DR (Pipe) feature 

6. With the DR feature selected, select the Triangulation -> Feature Type dropdown, and 

change the type from Random to Breakline.  Make sure the Exclude from Triangulation 

checkbox remains filled in.  Note that you can make bulk edits using Ctrl + Click or Shift + 

Click to select multiple or ranges of features. 
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7. With the filter active, as you make this modification you’ll see the features start to disappear.  

This is due to them no longer fitting the filter criteria.  Shut off the filter we enabled in Step 3 

to see all features again. 

7.4-2d Displaying Contours and Triangulations 

One of the major changes in moving to OpenRoads terrain models is that there are no longer 

discreet commands to create and display contours and triangulations.  These options have been 

moved to the OpenRoads display styles and are now accessible via the Element Information panel in 

MicroStation.  As they are directly associated with the terrain model, it will no longer be possible to 

create/display these features without duplicating the entire terrain, which is not recommended due 

to the possibility of data getting out of sync. 

To display the existing contours: 

1. First make sure your terrain model is active.  This can be done by locating it on the Civil 

Model tab of Project Explorer and right clicking on it.  Select Set As Active Terrain Model. 

 
Set As Active Terrain Model 

2. Alternatively, you can select the terrain in the heads up display in the drawing window and 

use the heads up display to make it active.  To enable the heads up display, locate the 

terrain boundary and click on it.  Hover over the location briefly until the toolbar pops up. 

 
Using the Heads Up Display 
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3. With the terrain now active, you can review its setting in the Element Information panel.  

Again there are two options for this process.  First is to again locate the terrain in the Project 

Explorer.  Right click on it and select Element Information from the bottom of the presented 

menu. 

 
Terrain Properties 

4. The second option is again on the heads up display.  Using the same process as step 2, 

select the first button on the menu. 

 
Terrain Properties on the HUD 
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5. The terrain should now be shown in the Element Information panel.  The following screen 

capture highlights the major areas of note: 

 
Terrain Element Information 

• 1. Feature – This lists the Feature Definition/Display Style that was used for the 

terrain.  In most instances Existing_Contours will be used.  Additional styles for 

different scales, or different displays (triangulations, thematic height, etc.) are 

also available. 

• 2. Edge Method –All triangles are displayed as long as they respect the Max 

Triangle Length which can be adjusted in this panel. 

• 3. Calculated Features Display – These can be used to override the default 

features displayed as part of the style.  For instance with contours and triangles 

can both be displayed by turned their entry to On. 
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6. Using the Element Information panel, set the Contours to the On position.  Your display will 

look similar to the following: 

 

Contours Turned On 

7.4-2e Additional Notes for Creating Explan XX.dgn 

Remember any projects that fall under Section 5.1-6 will have their geo-coordinated seed file 

provided as part of the survey deliverables.  This would be used when creating a file from legacy SS2 

data. 

Additionally, you may create these base drawings externally of MicroStation/InRoads using the 

document creation wizards and tools in ProjectWise as discussed in Section 5.3-1c. 

You may need to do a fit view command to see the elements drawn.  If you’d like to control the 

display of your contours and triangulation, you can additionally use the Level Display and select 

those specific levels.  Do not use the off by element command as the terrain is a single element 

(triangles and contours included) and it will shut off the entire terrain not just the specific level. 
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CAD Menu -> File -> Save Settings at this point to retain the information, additionally, you may use 

the Ctrl+F hotkey combination.  This also extends to OpenRoads commands as they are now part of 

base DGN functionality.  Save your settings and files early and often. 

Optional Steps: 

This process could be repeated for 1”=20’ and 1”=100’.  These scales are anticipated to be utilized 

in some plan sets. 

 

Topo surface as displayed in Explan 50 

At this point, it is desirable to add any other base drawings in the same manner as used for Explan 

and Excont.  These could include proposed contours (Prcont), existing right of way (RW existing), or 

any other drawing needed.   

Not all of these drawings will need to be referenced into the Prplan base drawing prior to creating 

any sheets (plan profiles, layouts, construction details, etc.).  All that is required is an alignment to 

orient the sheets.  

Next you will create the geometry dgn, Design Alignments.dgn 

7.4-3 Creating a Geometry DGN/Prplan 

Corridor Modeling in OpenRoads means that Alignments must exist as information within a Civil 

Model instead of part of an ALG file.  An ALG file is still needed for items such as feature annotation 

and plans production, but it will not be provided from survey unless it’s a legacy project.  The 

expectation for projects surveyed in OpenRoads is that a Des #_SRxx Survey Alignments.dgn will be 

provided as part of the project.  As with the other survey deliverables, this file and content will be 

geocoordinated and based off the provided Des #_SRxx Seed.dgn that’s part of the survey project. 
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Please keep in mind that whether you have a survey provided alignment in a DGN or ALG, the model 

with the alignment in it should be a 2D file, or if creating from legacy data, based on the provided 2D 

seed file for your project. 

For the purposes of this example we will be looking at keeping a separate DGN file for our alignment 

information and then creating the model and Terrain in the Prplan XX.dgn which we’ll create at a 

later time. 

To create the file you can use the processes outlined in 7.4-1a or 7.4-1b.  For this file however, your 

base file will be Des #_SRxx Survey Alignments.dgn.  With this file created and named Design 

Alignments.dgn, you can then proceed to modifying your survey alignments or creating additional 

alignments.  Again with the ability to reference the DGNs together to share the civil data, this 

alignment file can then be attached as needed for the purposes of corridor modeling. 

7.4-3a Creating Geometry from an SS2 ALG 

Should you have a SS2 project, and associated ALG file, the following steps will illustrate how to 

bring that information into your DGN.  These can either be work in progress or just the survey 

alignments provided. 

1. On the Civil Tools panel, go to the General Geometry task and select Import Geometry. 
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2. Navigate to your file and select Open.  On the Import Geometry, select the Alignments and 

points you want to bring in.  If you want to make sure the Civil Rules are enabled, the toggle 

for Create Civil Rules should be on.  Select Import when ready. 

 

3. In your Civil Model Project Explorer browser, you can then expand the Linear elements and 

see your Alignments and continue working on them using InRoads tools. 

 

Alignments in the Civil Model 
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7.4-3b Drawing the Proposed Profile to the Design Alignments.dgn 

Moving to OpenRoads technology requires a new mindset when it comes to working with profiles.  In 

the previous version of InRoads all profile work was used drawing directly on top of profile graphics in 

your base drawing file.  This was possible as the ALG file was portable across any file that was open 

with InRoads.  Due to the change of how an alignment is stored, we will look at process of creating a 

profile using the OpenRoads tools in preparation for plans production.  This example will assume that 

you’re starting with a Des #_SRxx Survey Alignment.dgn file that you’ve copied and renamed to 

Design Alignments.dgn. 

Please keep in mind, that this file should be 2D in nature.  A 3D model will be automatically created 

by the software and is reference attached as soon as a terrain is referenced and made active and 

when a vertical profile is being displayed.  OpenRoads will automatically generate the 3D geometry 

elements from the 2D information. 

To create a profile display in OpenRoads: 

1. Locate the Civil Tools -> Vertical Geometry -> Open Profile Model tool on the Task Navigation 

panel.  Alternatively you can locate this tool by highlighting the alignment and selecting the 

tool from the heads up display when hovering over the alignment. 

 
Open Profile Model 

2. If selected from the Task Navigation panel, the tool will prompt you to first locate the plan 

element.  Select the plan view representation of your alignment. 
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3. With the alignment selected, OpenRoads will then prompt for a view to be selected or 

opened. 

 
Select or Open View for Profile 

4. Use the View Groups toolbar to open an additional view.  Any of the view 2-8 are acceptable.  

Left click in the opened display to confirm the profile creation.  Note that the tool will 

redisplay in any view you select potentially erasing any data displayed.  In the event you 

overwrite a profile display know that only the graphics are lost.  The actual alignment 

information will persist as part of the Civil Model. 

 
Profile Display 

Note: In the previous version of InRoads, we needed to manually select the feature that the 

existing surface was on in order to have it display properly in profile.  In OpenRoads this is no 

longer necessary as the terrain model uses the same feature for the boundary and profile 

display.  The above illustration shows how the existing appears in OpenRoads (dashed green 

line). 
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With the existing profile now displayed, we can proceed to creating a proposed profile.  Please keep 

in mind that this profile display is not actually part of the base model in the DGN itself, rather it’s a 

dynamic view that allows for the creation of the civil data that makes up the profile. 

7.4-3c Adding the Proposed Vertical Alignment 

With the profile now displayed its own view, you can now begin placing the elements that will be used 

for the vertical profile.  For this process you’ll need to use the toolset under Civil Tools -> Vertical 

Geometry. 

 

Vertical Geometry Tools 

7.4-4 Creating the Proposed Plan Drawing 

With our existing plan and design alignments in separate DGNs, it’s time to bring the base sheets 

together as preparation for plans production.  The following steps assume that the corridor model 

and proposed terrain have been created and are prepared to be attached to the proposed plan 

drawing.   

Use MicroStation -> File -> New to create the drawing Prplan 50.  
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This will create and open a .dgn with this name in the folder you specify in the New Document dialog.  

Make sure to select the Des #_SRxx Seed 2D.dgn from under your Survey\Project Files folder if 

available, make sure to create a 2D design model in this file for design purposes.  If no 

geocoordinated seed file is available, use the appropriate 2D seed file from under  

pw:\\indot-pw.bentley.com:indot-pw-01\Documents\Template Documents\SS4 Seed\InRoads\ 

 

The New Document, No Wizard dialog 

Click OK – a blank drawing is opened, and a new MicroStation/InRoads drawing is created. 

At this time, you can begin by referencing your Explan XX and Design Alignment DGN files. 

1. Open the References window from either File -> References on the MicroStation menu, or 

from the References button on the Primary Tools toolbar. 

  

References 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/InRoads/
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2. On the References window, select the Attach References button. 

 

Attaching References 

3. Select both the Explan and Design Alignments DGN files.  This can be done by holding the 

Ctrl key on the keyboard while left clicking on each file.  Select OK when ready to proceed. 

 

Selecting the File to Attach 
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4. As all files should be in the same coordinate system, the Coincident – World orientation 

setting should be used.  All other settings can be left to their default values.  When ready 

select the OK button. 

 

Attachment Settings 

5. Repeat this process for all the files you’re attaching. 

6. Finally, adjust your Drawing Scale to the appropriate value.  For this example we’ll be using 

1”=50’. 

 

References Attached and Displayed a 1”=50’ 
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As an alternative to attaching each file in specific, you could also use Live Nesting to attach Explan 

XX.dgn to the Design Alignments.dgn and then into Prplan XX.dgn.  Just make sure that the Nested 

Attachments are set to Live Nesting and that the depth is 1 or greater depending on your project 

needs.  In that instance, your reference dialog may look similar to the following: 

 

Using Nested References 

 

Civil Model with Nested References 
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At this point you’ll have the required data to begin the corridor modeling process.  Upon completion 

of your modeling, you’ll be prepared to continue in Prplan XX.dgn. 

Corridor Modeling with Referenced Geometry and Terrains 

As we’ve discussed at numerous points throughout this document, OpenRoads allows for the 

separation of design items by placing them in separate DGN files and then referencing them back 

together.  While a very powerful tool to have, there are a few items to keep in mind while working 

with referenced elements. 

The first item to keep in mind is making sure you activate the terrain properly.  In our above example 

we’ve attached our Explan 50.dgn which contains the terrain model that we’ll be targeting.  Prior to 

performing any modeling process, we first must make sure it’s the active model.  Unfortunately, it 

won’t show up in the Civil Model dialog until we activate it.  To do so, hover over the perimeter of the 

terrain.  When the heads up display appears, select the Set As Active Terrain Model option. 

 

Set As Active Terrain Model 
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With the terrain activated, your Civil Model tab will then populate with the referenced in information 

and look similar to the following: 

 

Civil Model with Active Reference Data 

At this point, a new 3D model will be created and referenced back in.  Please keep in mind the multi 

model display process from section 5.7-2 as having both 2D and 3D views will be beneficial. 

Next, while modeling with referenced alignment information, know that you will not be able to 

graphically pick vertical profiles as they won’t be able to be drawn up from a referenced file.  To 

further that, please keep in mind that the horizontal alignment and its vertical profile MUST reside in 

the same DGN file.  When creating a corridor, you’ll first select the plan view alignment.  On the 

following dialog requesting the Profile Element, select the appropriate vertical from the Locate Profile 

Element dialog. 

 

Selecting the Vertical Profile 
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With the terrain active, and the horizontal and vertical profiles selected, you can then proceed to 

create your corridor in Prplan XX.dgn 

Note:  One thing to be very careful when working with referenced civil data is the detaching 

references.  All civil data is based on an ever-evolving set of rules and connections to available data 

in your project.  Should you have civil data that is connected in this manner and then go to detach a 

file, you may see the following dialog. 

 

Civil Dependencies and References 

When displayed this means that there are civil dependencies that exist with your data.  Special care 

should be used, and best practice is to avoid detaching references when possible as not to break 

any civil references. 

With your design completed and being displayed over your existing, you can now being the final 

preparation steps for creating cut sheets. 
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7.5 Preparing Files for Plans Production 

As we’ve seen in the previous sections, there’s numerous changes to the base drawing creating 

process.  As illustrated, many of the design tools have now moved to those in the OpenRoads 

environment except the InRoads Plan and Profile Generator. 

This section will look at some of the specifics needed to prepare your data for Plans Production, and 

where data needs to be migrated back to standards InRoads formats (DTMs, ALGs) for use in the 

sheet generation and annotation processes. 

A note on file management:  Throughout the following section we’ll be looking at processes to create 

InRoads files from OpenRoads data.  To allow for full flexibility, these tools are not set to 

automatically keep OpenRoads and existing formats in sync.  Please keep in mind that for any 

iterations of OpenRoads data that you’ll need to re-push your data back to their legacy formats for 

use.  Doing so does lend itself to creating multiple files and versions which may cause confusion.  

Please use detailed naming where possible, and discard old data as needed to minimize this 

possibility. 

7.5-1 Adjusting your Design Stage for Plans Generation 

As you work on your design, much of the display control on your corridor will be through the use of 

the options in the Design Stages.  Design Stages are a combined set of rules that govern how your 

corridor is displayed and the level of accuracy which it’s modeled. 

As your design is completed, you’ll notice that there are a number of different Final Design Stages 

such as: 

• 3 – Final 

• 4 – Final w/Meshes 

• 5 – Final – Top Mesh 

• 6 – Final – Bottom Mesh 

• 7 – Final Linear Features 

• 8 – Final Components 

These options all allow for different representations of the corridor and how it displays in the plan 

view.  While each of these have different uses the 3 – Final is the one that will be used most 

commonly as it allows for the most thorough display of all corridor information.  However, this display 

setting contains far more information than is needed for plans generation: 
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Corridor Using 3 – Final Design Stage 

For the purposes of plans generation, most instances will need to display the final linear elements of 

the corridor.  The recommended Design Stage to display just this information is 8 – Final 

Components.  This corridor stage has been modified to display both the components and linear 

features allowing for the display of the components in cross sections. 

 

Corridor Using 8 – Final Components 

This is the most appropriate display for plans generation and should be used when displaying the 

corridor to cut plan sheets and cross section and will be reflected in the ModelName-3D that’s 

created.  At this point you can control the display of any subgrade features by shutting the relevant 

levels off in the level display. 
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7.5-2 Creating Native Formats 

The next two sections cover the creation of civil data in native InRoads formats.  Depending on the 

tool set necessary, these formats may be needed for tools such as annotation.  For some of these 

items, the provided files as part of the survey or legacy project may be suitable, and these steps 

could be optional depending on need. 

7.5-3 Generating a Native InRoads ALG 

Plan and Profile Generator is one of the major tools that has not been integrated into the OpenRoads 

toolset and still uses the existing InRoads tool.  In order to use this tool, OpenRoads alignments must 

be sent backward to their InRoads counterpart in the ALG file.  This accomplishes two items, first is 

that the alignment will be available for plan and profile generator, second is that it will be in the 

correct format for all the existing InRoads annotation tools. 

To send your alignments back to the InRoads ALG format, perform the following steps: 

6. Go to the Civil Tools -> General Geometry -> Export to Native command on the Task 

Navigation panel. 

 
Export to Native 

7. The command will activate and you’ll be presented with a heads up tooltip in the drawing 

window requesting that you select the element. 

 
Locate Element Prompt 
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8. As shown in the previous screen capture, the tooltip will also show element information for 

the item you’re currently hovering over.  Select all the geometry elements you wish to send 

back to ALG at this time. 

9. When satisfied with your selections, right click to Reset and complete the command.  Your 

alignment(s) will be sent back to the native InRoads ALG format for your use with that toolset. 

 

OpenRoads Alignments Sent to InRoads ALG 

Note: When sending alignments back to the native InRoads format, OpenRoads will assume that the 

currently active Geometry Project on the InRoads Explorer is where it should place the alignment 

information.  If you wish to have your alignments placed in a Geometry Project of your choosing, 

makes sure that you first create and activate the Geometry Project on the InRoads Explorer prior to 

sending the alignments over. 

10. With the alignments now showing in an InRoads Geometry Project, you can proceed to save 

the .ALG file with the rest of your project data. 

7.5-3a Displaying Alignments 

Since InRoads requires you to use alignments to layout sheets and display annotation, you will 

display each alignment.  Also, you want to have sheets laid out beyond the project limits to show 

incidental construction limits and some of the existing survey beyond.   

To display the alignments, you can perform 1 of 3 methods.  The first is quick display of all horizontal 

alignments via the InRoads Explorer. 
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To display the alignments in this fashion, right click on the name of your geometry project on the 

InRoads Explorer’s Geometry tab and select View All Horizontals as shown: 

 

View All Horizontal Alignments 

This will have InRoads display all horizontal alignments defined in your geometry project. 

The next method is displaying a single horizontal alignment from the InRoads Explorer.  As in the 

previous example, you will need to browse to the Geometry tab and expand your project so it shows 

the horizontal alignment you’d like to display.  You will then right click on the alignment and select 

View as shown: 

 

Viewing a Single Horizontal Alignment 
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This will display only the selected horizontal alignment in your DGN. 

The final method is displaying the active horizontal alignment from the InRoads Explorer -> Geometry 

-> View Active Horizontal menu item. 

 

View Active Horizontal 

This will display the currently active InRoads horizontal alignment in your DGN. 

7.5-4 Generating a Native InRoads DTM 

Similar to alignments, so far all surface data has been processed as an OpenRoads terrain.  For the 

purposes of profile generation, the legacy InRoads tools will need an existing surface to exist so that 

profiled can be generated.  Additionally, should any projected profile elements been needed from the 

corridor model, InRoads will need those features brought into a proposed surface.  The steps in this 

section will cover both of these processes. 

If you’re working with data that was created with the newest version of the county geocoordination 

system, please see 7.5-4c for additional information on this process and a workaround to generate 

the appropriate data. 

Note: If your source terrain was generated from OpenRoads Survey tools, it will only contain those 

elements which were included in the triangulation.  It will not be complete and have features that 

were excluded.  This DTM should only be used generate the surface that will be displayed in the 

native InRoads Profile tools.  This DTM should not be used for any other function, especially for 

station offset point annotation as it does not include all features. 
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7.5-4a Creating an Existing Surface DTM from OpenRoads Terrain Models 

To create a DTM file containing your existing terrain, the following should be performed. 

1. Go to the Civil Tools -> Terrain Model -> Export to File command on the Task Navigation 

Panel. 

 

Export to File 

2. The command will activate, similar to the Geometry tool, with a heads up tooltip in the 

drawing area.  This tooltip will prompt you to select your terrain. 

 

Select Terrain to Export 
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3. This command will also show element information when you’re hovered over an element.  

Select the boundary of the terrain you wish to export.  Additionally, you can also select the 

terrain directly in its tool window as shown in the previous screen capture. 

4. Once the appropriate terrain has been selected, the second prompt will be for the format 

that the surface should be sent to.  This tool will default to the format of your currently active 

product, in this case it will automatically select InRoads DTM (.dtm). 

5. When satisfied with the selection, data select on the screen.  You will be then prompted to 

save the .DTM file directly to ProjectWise in the same folder as the currently active DGN file.  

Adjust any naming and save the file, and then check it in when prompted. 

 

Export Terrain – Save to ProjectWise 

6. Slightly different from how the ALG export works, the surface you’ve created will not be 

automatically attached to the InRoads Explorer, however the file will be saved and posted to 

ProjectWise already.  If needed, open the DTM on the InRoads Explorer for additional use. 

7.5-4b Creating a Proposed Surface DTM from an OpenRoads Corridor 

For the purposes of creating profiles with projected features, it may be beneficial to have the 

OpenRoads corridor carried over to an InRoads DTM file as well.  This process will examine the 

combination of OpenRoads and InRoads commands that must be used in order to create this 

content. 
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1. In the DGN file with your corridor (presumably Prplan XX.dgn), go to the Task Navigation 

panel and located the following command: Civil Tools -> Terrain Model -> Create Terrain 

Model by Graphical Filter command. 

 

Create Terrain Model by Graphical Filter 

2. This will activate the command and the following dialog.  The commands on this panel will be 

used to define the graphical filter and other aspects of the terrain that is created. 

 

Tool Settings 
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 To briefly cover each of the options: 

• Append To Terrain – Allows for the graphical selection to be added to an existing 

terrain model.  In this instance, the elements should not be appended and a new 

terrain will be created. 

• Graphical Filter Group – This defines the rule set that governs how the data should 

be brought into a terrain model.  To bring in INDOT corridor data created with our 

template library, use the _INDOT Corridor Features filter set. 

• Terrain Filter Manager – This will display a graphical picklist of all available filter 

groups in both the base DGN and any attached Dgnlib files with filters in them. 

• Preview – This will highlight any elements that would be selected by the Graphical 

Filter Group. 

• Edge Method – This determines how the triangulation would be created for the 

terrain.  As we’re using this as a purely translational method to get the breaklines for 

the corridor into a DTM, this setting is inconsequential. 

• Maximum Triangle Side Length – This is only displayed when the Edge Method is set 

to Max. Triangle Length. 

• Feature Definition – This defines the feature that the terrain will be created as.  In 

this instance one of the Design_ Terrain Display features should be used. 

• Name – Defines the name of the terrain that will be created. 

3. As was briefly alluded to above, the Graphical Filter Group to be used should be used when 

bringing in an INDOT generated corridor. 

Note: This graphical filter has been built to automatically select all XS_TL_ features that are 

created as part of the corridors breakline features.  If you deviate outside the provided 

feature naming, this graphical filter will need amended to include these additional features.  

As with other OpenRoads features, the first time you use the filter in a DGN, it will be copied 

into the file where you can amend its settings to your needs. 

4. Prior to committing the command and creating the terrain, it’s highly advised to use the 

Preview command to verify that the elements you’re needing are captured.  An example of 

what the previewed elements look like are in the following illustration. 

 

Graphical Filter Preview 
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5. With the settings configured, confirm the selection in the drawing window by left clicking to 

accept each setting.  Under your Civil Model a new terrain will be created with the name you 

provided. 

 

New Terrain Created 

6. At this time with your terrain created, you can then send the terrain back to the Native DTM 

using the same steps as the previous section.  Again, when prompted provide an appropriate 

name and check your file into ProjectWise and re-open the DTM in InRoads if needed. 

Note:  As we discussed earlier, it’s very important that you use provided point names and their 

associated features from the INDOT template library for the terrain and subsequently the DTM to 

have the correct features.  The following screen capture is an illustration of what may occur when 

the features used do not match what’s available in the XIN. 

 

Features Not In the XIN 
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In the above example, this is what can potentially occur if the features do not exist in the XIN used.  

Those listed above do exist in the newest XIN.  This illustration shows those features not being found 

in the instance that this may be using an old XIN that doesn’t contain the data necessary.  These 

features can still be used and projected, however they will have no symbology associated.  

Alternatively, they can be mapped to other features that may exist in the XIN for display purposes. 

7.5-4c DTM Export Issues with Metric Geocoordination 

The CAD Peer Group and CAD Support have identified an issue with how MicroStation/InRoads is 

exporting OpenRoads terrain models to the native InRoads DTM.  This issue occurs when exporting 

from a file where the Geocoordination has been enabled, and the units for the geocoordination are in 

metric.  This will most commonly occur in newer surveys that are geocoordinated using the new 

county coordinate system, which is configured in metric. 

How to check if the issue will occur. 

4. Load the Geographic toolbar from the MicroStation Tools > Geographic > Open as Toolbox 

menu. 

5. Click on the Select Geographic Coordinate System button on the left side of the toolbar.  It 

will load the Geographic Coordinate System dialog shown on the right. 

 

6. On the Geographic Coordinate System dialog, select the details button.  This will display the 

properties for the coordinate system applied.  If the highlighted Units field shown lists metric, 

your file will be affected by the issue and DTM exports will need to be performed using the 

following method. 
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How to Export if the Issue Occurs 

After identifying if your data will be affected, the following process should be used to avoid the export 

scaling issue. 

5. Copy a blank 2D seed file into your project folder.  Rename the file to designate that it’s used 

for DTM export.  Unlike most other files, do not use a provided geocoordinated seed file or 

apply geocoordination to this file. 

6. Reference attach any files with terrains that you want to export to DTM.  This can include 

survey fieldbook files, corridor models, or any other terrains that you want to export. 

7. By reference attaching these files, you may interact with the terrain models and export the 

data without the scaling being influenced by the Geographic Coordinate System.  From either 

the Project Explorer, Civil Tools > Terrain Model > Export to File, or heads up display with the 

terrain selected; export the terrain to .DTM  

 
Export from Project Explorer 
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Export from Civil Tools 

 
Export from Heads Up 

8. Upon completion, you will have a created DTM that you may use from your data.  You can 

validate the exported data by displaying it using the native InRoads surface display toolset 

and overlaying the referenced data to confirm that it falls in the same location.  
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7.6 Sheet Layout and Creation (Plan Profile Sheets) 

One of the major items that has not yet been transitioned to OpenRoads technology is the Plan and 

Profile Generator.  The steps in this section assume that you’ve stepped through all other preceding 

steps to generate your native file formats. 

Note: Unless otherwise specified, please keep in mind that these tools will fall back and rely on the 

Global Scale Factor Application Add-In for InRoads.  Further discussion of this tool can be found in 

Chapter 5.6.  Also, due to a requested change, the Station Lock tool has been set to be on by 

default.  This can cause plan sheet creation to shorten the first sheet in the plan set by forcing the 

2nd and subsequent sheets to start on even stations.  Disable the station lock prior to cutting sheets. 

The following section discusses the various functions included in the Plan and Profile Generator.  

This will include reviewing some of the differences between creating a profile using the previously 

discussed method, and how Plan and Profile Generator will create its own for use during the sheet 

cutting process.  For further reference on this tool and its functionality, please refer to the Bentley 

InRoads Plans Production course via the Bentley Learn Network. 

7.6-1 Files Required for Plans Production 

Throughout the document to this point we’ve largely been working in the OpenRoads format directly 

with DGNs except where we’ve created native InRoads format files (DTM, ALG).  To this point, the 

assumption is that while you’ve created these files, they may not actually be open in InRoads to be 

used.  For the purposes of plans production make sure you have the following three items open: 

• Your geometry ALG file with the appropriate alignments included. 

• Your surface DTM file created from the survey generated terrain model. 

• Your Prplan XX.dgn (which you should initiate Plan and Profile Generator from), which 

references your Explan XX.dgn.  Specifically you should be working out of the ModelName-3D 

model so all civil content is displayed. 

As a slight deviation from the SS2 method, we’ll not be drawing any elements from the ALG and DTM 

except for the legacy SS2 profile which Plan and Profile Generator relies on when cutting sheets.  All 

other plan elements will be displayed as their OpenRoads format elements and will be displayed 

based on their reference attachments. 

Also remember that you can use a .RWK project file to compile all your InRoads native files for ease 

of use. 
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7.6-2 Plan and Profile Generator 

While in the prplan.dgn, open the Plan and Profile Generator from the Drafting -> Plan and Profile 

Generator as shown in the following illustration: 

 

Plan and Profile Generator 

This will present the Plan and Profile Generator window.  With the sheer number of options available 

in this tool, it is highly advised that one use the preferences that are provided.  These correspond to 

the INDOT standard sheets.  As there are numerous preferences available, please refer to the 

following table for a listing of the preferences and their function.  For all preferences listed as IN PW, 

please note that these are configured to attach the appropriate border from within the ProjectWise 

system. 

Default Default Preference, settings are configured the 

same as IN PW Plan Profile 50 Scale 

IN PW Bridge Layout XX Scale INDOT Bridge Layout sheet, available in 30 and 

50 scales 

IN PW Dbl Plan XX Scale INDOT Double Plan sheet, available in 10, 20, 

30, 50, and 100 scales 

IN PW Ltr Dbl Plan XX Scale INDOT Double Plan sheet, letter size in 200 

scale. 

IN PW Ltr Plan XX Scale INDOT Plan only sheet in 200 scale. 

IN PW Plan XX Scale INDOT Plan only sheet, available in 10, 20, 30, 

50, and 100 scales 

IN PW Plan Profile XX Scale INDOT Plan Profile sheet, available in 20, 30, 

50, and 100 scales 

IN PW Profile XX Scale INDOT Profile only sheet, available in 20, 30, 

and 50 scales. 

INPWPlanProfileXXScaleLargePlan INDOT Plan Profile sheet, available in 20, 30, 

50, and 100 scales 

xBentley Default Original, as shipped Bentley Default preference 
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To illustrate the most extensive sheet cutting path, you will review the process for cutting a 50 scale 

Plan Profile sheet.  

Prior to cutting sheets, please ensure that the InRoads Station Lock is turned off.  If it’s left on, 

sheets may not cut using the full extents of the plan and profile views until even stations are found.  

To disable the Station Lock, go to Tools > Locks on the InRoads Explorer and make sure that the 

Station option is not checked. 

 
Disabling Station Lock 
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7.6-3 Sheet Creation 

Like numerous other InRoads tools, Plan and Profile Generator defaults to using the active geometry 

project and subsequent horizontal and vertical alignments.  One can either pre-activate each 

alignment prior to opening the tool, or they can interactively select these items from within the Plan 

and Profile Generator. 

Note:  The various text and symbology functions within the Plan and Profile Generator all respect the 

values in the Global Scale Factors add-in.  For the correct display of these elements, make sure that 

Global Scale Factors are consistent with the scale sheet being cut. 

When first starting the tool, the following window will be displayed: 

 

Plan and Profile Generator Main Tab 
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With this tab displayed, select the Preferences button in the bottom center.  You’ll start by loading 

the appropriate preference for a 50 scale plan profile sheet. 

 

Loading IN PW Plan Profile 50 Scale 

With the preference loaded, you can now start reviewing the options that are loaded for an INDOT 

specific sheet.  For specific information on each of these settings, please refer to the online help in 

the software, or the InRoads Plans Production course guide. 

Note: SS4 and SS10 InRoads have a bug during the selection of the Plan Profile Generator 

preferences that may result in this panel only displaying the preferences for Profile generation.  This 

typically occurs when using one of the preferences that are setup for plan and profile or profile only 

sheet generation.  If this bug occurs, the only way to get the appropriate preferences to load again is 

to restart the InRoads/MicroStation session. 



 

383  

 

 

Plan Controls Tab 

For the features on this tab, the preference defines the seed view name, the left and right widths 

and the sheet overlap.  You can attach additional base drawings (Explan, etc.) by attaching these in 

the Model Files portion of the dialog.  If you maintain the attachments to Prplan and do not attach 

files with this tool, you will need to adjust your reference settings to enable Live Nesting via the 

Nested Attachments button.  Both are suitable methods, where possible, nested attachments have 

been enabled to enable maximum flexibility. 
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Nested Attachments 

 

Profile Controls Tab 

On this tab, customized values from the preference are the profile height, horizontal and vertical 

spacing, and the left and right margins.  Additionally, the Profile Preference is set to the IN Profile 50 

consistent with this layout.  An item to note, no vertical alignment is defined.  Should the sheet be 

cut with these settings as is, the profile will only display the existing surface along the horizontal 

alignment. 
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Sheet Layout Tab 

The first items on this tab defined are the Sheet Number and Name.  These are incrementing 

numbers and used in the Sheet Index for reviewing sheets.  It should be noted that any value defined 

in these fields is only for reference in the Plan and Profile Generator and do not influence the naming 

of the sheet DGN files. 

The Host File is the name of the first finished DGN from the sheet cutting process.  Additional sheets 

are named sequentially from the last character of the file name.  In the above example, the name is 

Sht PlanProfile_50_1.dgn; each additional sheet would be Sht PlanProfile_50_2.dgn, _3.dgn, etc.  

Also, the preference defaults for the process of cutting a set of test sheets.  As such, the file path 

has been set to the local C:\Projects\ folder.  This has been done to alleviate issues with the cutting 

and re-cutting of sheets into ProjectWise.  Sheets should be cut into this location until the desired 

end result is achieved at which point the sheets can be cut directly into the appropriate project path 

in ProjectWise. 
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Note: The C:\Projects folder is no longer automatically provided on new/refreshed PCs and will not 

be available for new users.  Prior to cutting sheets, the end user needs to verify that this folder is 

available and accessible in Windows Explorer prior to cutting sheets to this location. 

The Seed Host File is the MicroStation seed file that InRoads will use as a base sheet when creating, 

clipping and bordering the references.  This file will be copied and renamed each time a new sheet is 

cut. 

The clipping boundary is an element that follows the end of the clipped reference for both the plan 

and profile.  This feature is enabled and also enumerated to coincide with the names of the sheets 

for quick referencing to adjust annotation that may need to carry through from the base sheets. 

Host File Content defines how the finished sheets are provided when cut.  Single Sheet places each 

cut sheet into a separate DGN which is the normal convention.  All Sheets in One places to the 

border and references next to each other in a single DGN and is dependent on the Sheet Location 

setting. 

Sheet Location determines how the sheets are aligned when cut.  The default behavior is to place 

the sheets along the alignment.  One can adjust these to show up in a grid view as well.  If Layout in 

Grid is selected, the Horizontal and Vertical Space items become available. 

Note:  Sheets in InRoads are laid out along the alignment in the INDOT preferences.  When viewing 

the finished sheets, InRoads does rotate the view to appear aligned with the border, however if one 

adjusts the view rotation, the border and references will adjust their rotation and will appear rotated 

at the appropriate angle. 

Also, if All Sheets in One is selected and used, the borders and references will be cut along the 

alignment and will appear overlapped as they are cut along the alignment. 
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View Layout Tab 

On this tab, one will find the values used to determine how the plan and profile line up on the sheet.  

When cutting INDOT sheets, these should not be adjusted from the values loaded with the 

preference.  Also, the Scale value should be consistent with the scale of the sheet being cut. 
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Border and Title Tab 

The values customized on this tab are the Scale, Reference File Name, and Custom Width and 

Height.  As with the scale value on the previous panel, this should be consistent with the scale value 

of the sheet being cut.  

 The Reference File Name is the name of the appropriate border for the sheet being cut.  In this 

example, the border is INDOT_Border.dgn, and can be found in ProjectWise.  This is preset in the 

preference and should not be adjusted. 

The Sheet Size should be set to CUSTOM to enable the Custom Width and Height options.  As shown, 

the 36 x24 is the standard size for a full size INDOT sheet. 
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Symbols and Details Tab 

On this tab, the North Arrow, and ProjectWise Title Block are enabled. 

This tab is where having the INDOT_InRoads.cel attached is of paramount importance.  Without the 

cell library attached, the default values of the cell names for both features will be “antiquis” (the first 

cell alphabetically in the library) if the cells are not attached, and upon sheet creation, the incorrect 

cell will be placed. 

The North Arrow is enabled, and given a defined scale, and location on the cut sheet.  It is place on 

the same level as the sheet border and can be moved as necessary. 
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The high level of ProjectWise integration is evident in the inclusion of the ProjectWise Title Block 

option on this tab.  This cell is placed automatically when the sheets are created, and should not be 

modified in any way for the title block integration to function properly. 

 

Match Lines Tab 

On the Match Lines tab, the Start and Stop stations and linear indicator are all enabled, along with 

the placement of the station at the match lines. 
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Sheet Index Tab 

This tab becomes populated once sheets have been cut and are ready to be reviewed.  Further 

discussion of the features on this tab will be covered later in this section once the sheet cutting 

process is complete. 

7.6-4 Cutting Sheets 

At this point, you’ve reviewed the preferences and the information that is pre-populated on each tab 

of the Plan and Profile Generator.  For the next example, you’ll be looking at a three sheet plan 

profile set and run the steps required to cut the sheet.  This procedure will follow the process 

provided in the Bentley InRoads Plans Production course guide.  To recap this process: 

1. Start Plan and Profile Generator and select a preference 

2. Set horizontal alignment and station limits 

3. List model files 



 

392  

 

4. Define vertical alignments and surface for profiles 

5. Set the host file 

6. Set the title block data 

7. Set plan views 

8. Set profile views based on plan limits 

9. Save the VDF file 

1.  As noted previously, start the Plan and Profile Generator from the Drafting -> Plan and Profile 

Generator menu item.  With the generator loaded, select the Preferences… button and select IN PW 

Plan Profile 50 Scale. 

2.  With the preference loaded, navigate to the Main tab.  Select the appropriate horizontal 

alignment that sheets should be laid out along.  This can be preset with the active Horizontal 

Alignment, or can be picked interactively.  

 

With the Horizontal Alignment selected, the Station Limits will default to the full extents of the 

alignment.  If you want to cut a different station range; adjust the start and stop accordingly.  The 

Length should be left alone, as this is a predefined value determined by the scale and stored in the 

preference.  The full extents will be used in this example. 

 

3.  List Model files on the Plan Controls tab.  This tab will be populated automatically with the name 

of the base drawing currently open.  If additional files such as the existing contours or additional 

base drawings are not included in this list, the live nesting for each base drawing reference in the 

finished sheet (normally Prplan 50.dgn) may need enabled.  Additionally, the Live Nesting toggle on 

this panel can be enabled as well. 

4.  Now that you have a horizontal alignment and associated vertical alignment, you can define the 

profile information on the Profile Controls tab.  In the following illustration, one can see the 

appropriate Profile Preference that coincides with the scale of our finished sheet is enabled.  

Additionally, the appropriate Vertical Alignment has been selected. 
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Next, in the Surface section, you’ve selected the surface representing your TOPO model with its 

associated triangulation. 

 

5.  For the next item, the Host File needs to be defined. Navigate to the Sheet Layout tab.  With the 

InRoads/ProjectWise integration, our Seed Host File will be located in ProjectWise, and is preset in 

the preference.  The Host File itself can be placed in on the local PC for test cuts, or in ProjectWise 

for finished sheets. 
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6.  In a diversion from the InRoads Plans Production course guide, this step six leads to the Symbols 

and Details tab to verify that the ProjectWise Title Block is enabled.  This is defined in the preference, 

however if you see a cell name other than PlanSheet Tags, verify that your cell library is attached and 

re-start the Plan and Profile Generator and reload the appropriate preference. 

 

7.  The next step is to define the plan views.  Navigate back to the Main tab.  Set the Method to Plan 

Only, and then enable the Use Station Limits option.  Make sure that Generate Sheets is disabled, 

and finally verify that Station Lock (Tools -> Locks -> Station) is disabled as well.  When appropriately 

configured your panel should look like the following: 
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Now, select Apply, and note the information populated in the Plan Views region of the tab.  Note that 

this example a 50 scale sheet will encompass the entire alignment. 

 

By defining our plan views in this way (with station lock off, and not generating the sheets) the first 

sheet in the set is ensured to be a complete sheet.  If station lock is on, the potential for a partial 

first sheet exists in order to start subsequent sheets on an even station.  Station Lock should remain 

disabled through the next step. 

8.  With the plan view stationing defined, one can now look at defining the coincident profile views.  

As discussed earlier in this document, a profile drawn up using the Evaluation -> Profile -> Create 

Profile tools is not usable by the Plan and Profile Generator.  Due to this, InRoads will prompt you to 

regenerate and replace your profile as part of the sheet creation process. 

Again, on the Main tab, the Method needs to be adjusted.  Set this to Plan and Profile.  Then change 

the Plan Views to Use Plan Views.  This will have InRoads create the profiles and sheets using the 

same per sheet station ranges as you just defined in the previous step.  Finally, the Generate Sheets 

option needs enabled.  When the tab looks similar to the following, select Apply to create the sheets: 
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After hitting Apply, InRoads will prompt in one of two ways.  If there is no existing profile created by 

Plan and Profile Generator, you will receive a notification in the lower left corner of the MicroStation 

window prompting for the location to place these new profiles. 

If there’s a series of pre-existing profiles, InRoads will prompt to regenerate and replace the existing 

ones.  If this is the case, the following dialog will be shown: 
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If Yes is selected InRoads will create a completely new set of profiles along with any required 

adjustments to the layout range and location.  If No is picked, InRoads will prompt for a location, but 

will not re-create the profiles. 

9.  With the sheets completely created at this point, one can now create a VDF file.  Navigate to the 

Sheet Index tab.  The very first area is where this file is defined: 

 

To create a new VDF, select the Save/Save As option from the right side of the tab.  This will provide 

either a ProjectWise or Windows Save dialog depending on where InRoads was started from.  

Navigate to the project location, and provide a file name, then select Save.   This will place a copy of 

the VDF in the location specified.  With the VDF saved, one can reload this file in order to re-cut, or 

review sheets already cut. 

Note:  In order to preserve finalized sheet layouts, do NOT select the New… button.  This will prompt 

to save the existing VDF and clear out any sheet information in the Plan and Profile Generator that 

has been filled in since the last VDF save. 

At this point, the Sheet Index should be completely populated with data regarding the finished 

sheets.  The functionality of this page allows for the fine adjustment of sheets, removal of 

unnecessary sheets, regeneration of sheets, or the ability to browse between sheets. 
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7.6-5 Saving Sheets to ProjectWise and Resolving References 

The previous section shows how to create your sheets to a local folder on your hard drive.  Previous 

versions of the DOTWise document have advised re-publishing your files to ProjectWise by re-running 

the Plan and Profile generator and placing your files directly into ProjectWise.  Due to the function of 

the managed workspace, this process is no longer recommended as it can occasionally lock up, and 

requires manual intervention as each sheet is cut. 

Going forward, the recommended method will be an extension of the previous section.  Continuing 

from the previous section, locate the Sheet Index list on the Sheet Index Tab.  This will provide the 

location of your cut sheets. 
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Note that the default for all sheet creation preferences is to place files under C:\Projects.  This 

folder is no longer automatically provided on new/refreshed PCs and will not be available for new 

users.  Prior to cutting sheets, the end user needs to verify that this folder is available and 

accessible in Windows Explorer prior to cutting sheets to this location. 

 
Sheet Index 

Navigate to this location in Windows Explorer and close your InRoads session.  Check in your files.  

Then select the cut sheets and drag and drop them into ProjectWise into your project folder.  For this 

example we will place these within the InRoads folder to ease subsequent steps.  You can place 

these under subfolders or other locations, but be advised that the next steps may need adjusted to 

accommodate your situation.  In most instances, the following will resolve anything that is placed 

under the InRoads folder and subfolders beneath it. 

 
Drag and Drop Cut Sheets 
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If you have not selected a default method for new document creation, proceed with either the 

Advanced Document Wizard or No Wizard.  Either option will allow you to place/create your files in 

the system.  Note that upon conclusion of the drag and drop process, you will still have copies of 

these files on your local hard drive.  Please retain these copies until you’ve completed all steps of the 

process in case you need to bring them in again. 

Once placed into ProjectWise, you will see the files placed in system and associated with 

MicroStation.  These may stay associated with MicroStation and do not need opened with InRoads.  

You will notice that the files do not show that they have any references, which is a side effect of this 

method.  References to the plan and profile views must be re-established for the files to view 

properly. 

 
Files after Import, No References 

Be aware that opening these files prior to re-establishing the references may make it appear that 

the files are already fixed.  The references that are being shown point to local locations on your PC 

that may or may not be out of date and should not be considered complete. 
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With the base files and cut sheets all in ProjectWise, we will use the Tools -> Scan References and 

Link Sets command.  You can also start the wizard by Right Clicking on your folder and locating the 

option near the bottom of the context menu. 

 
Scan References and Link Sets 

The Scan References and Link Sets wizard (will be referred to by ScanRef throughout the remainder 

of the section) will launch.  Select Next to proceed. 
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On the next panel, make sure that Scan for master and referenced document is enabled as shown.  

The DGN Link Sets option can either be disabled or left enabled, it will make minimal difference in 

scan performance. 

 
Scan Master and Referenced Documents 

If you start the Wizard from the right click menu on your folder, it will pre-populate the folder location 

as shown.  To add additional folders or documents, select the appropriate icon on the panel. 

 

For this example, we will be looking and scanning just the files we’re wanting to put back together.  

In this case, select the document icon, and browse the ProjectWise location where you placed your 

cut sheets.  Select Next when the appropriate files/location have been set. 
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On the next panel, select the applications associations that will be searched when re-assembling the 

references.  These will be applications such as MicroStation, InRoads SS4, etc. that use DGN files 

that make up your sheets.  This will allow the tool to scan these documents to put the references 

back together.  Select Next when ready to proceed. 

 

The next panel is where you begin setting your locations to scan for potential reference files.  If your 

files reside in a folder different from where the base files (PrPlan, ExPlan, etc.) reside, you can define 

that folder path here.  In all instances, you will need to place the path to the border in this panel.  

This path should point to pw:\\indot-pw.bentley.com:indot-pw-01\Documents\INDOT 

Workspace\OpenRoads\Workspace\Plans Production\.  Select Next to proceed once configured. 

 

pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/Plans%20Production/
pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/OpenRoads/Workspace/Plans%20Production/
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If you bypass the priority search, the next panel for Proximity search will be automatically enabled. 

For this example, we can select the search to occur in the same folder as the files we’ve selected, 

and then subfolders if any may exist.  If your imported sheets are in a subfolder, you can select a 

higher level folder for it to also search in by selecting the Parent folder or the Advanced X folders 

above option.  In this example, we will be searching the Master File’s Folder as shown and then 

select Next to proceed. 

 

 

On the final panel, you can define your search order and a log file if you wish to debug the command 

once it’s completed.  The search order will default to whichever of the search methods you enabled, 

and if both were selected, allow you to define the order the scan will run them.  This example will 

want a Proximity then Priority search to reference the border location and then base sheets.  Select 

Next to proceed. 
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Finally, select Scan to proceed with the command. 

 

The scan will then run, and provide a status of which file is being worked on, and if it was able to 

succeed in finding references. 
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Finally, the scan will give the summary of its results, similar to what is shown below.  Select Close to 

exit the wizard. 

 

At this time, you can then review the files with the scan completed.  As shown, you can see that the 

cut sheets now show that they’re attached to ProjectWise reference files, and the dependency viewer 

shown, shows the file connections in this instance and how they are referenced together. 

 

Opening the files will show the file and references directly out of ProjectWise illustrating that the files 

have been re-assembled. 
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7.6-6 Publishing Sheets to ProjectWise Directly 

Should you have a small set and opt to publish directly to ProjectWise instead of the previous 

recommendation, you can use the following instructions to adjust your publishing to ProjectWise 

directly.  All steps are exactly the same, except for step 5, which is where the change to publish to 

ProjectWise is made. 

From the IN PW PlanProfile 50 Scale preference, the Host File defaults to the C:\Projects path, 

outside of ProjectWise: 

 

To change the location where the files are saved, select the browse button at the end of the Host File 

line and you will be presented with an InRoads/ProjectWise Save As dialog where the appropriate 

path can be selected.  The completed Save As window is shown below: 

 

Like other ProjectWise file functions, it’s highly recommended to keep the Name, File name, and 

Description consistent.  The Host File line will now show the ProjectWise path that was specified: 

 

Once the sheets have been created, the Sheet Index tab will now show the following information in 

the Sheet Index section now show the appropriate ProjectWise paths. 
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In addition to creating the files, InRoads will also make sure the new sheets are checked out. 

In the event you receive the following dialog, make sure that sheets you’re either recreating or 

editing are checked out. 

 

  



 

409  

 

7.7 Annotation and Text Drawing Cleanup 

In this section, you will review the process of adding various annotations to InRoads drawings, and 

the process of cleaning this data up after it’s been created.  Most of the procedures for clean-up are 

performed with a combination of InRoads and MicroStation tools, and will require that you continue 

using InRoads to interact with your drawing in particular situations. 

7.7-1 Setting Up an Annotation Drawing 

All plan view annotation will be drawn in a new drawing in InRoads.  The new drawing of the 

alignment annotation should be called Annotate Alignment <Alignment Name> <Scale>.dgn.  If you 

have multiple alignments that you wish to have annotated, you will need to repeat all of the following 

steps for each string in a new plan display with similar naming.  PlanProfile sheets will need to have 

been created in order to properly align the text for these other M-string annotations. 

Using standard ProjectWise functionality, create a new DGN in the project path named Annotate 

Alignment <Alignment Name> <Scale>.dgn (Ex. Annotate Alignment LineA 50.dgn).  Make sure to 

use the same 2D seed file for your project 

7.7-2 Adding Horizontal Alignment Annotation 

InRoads does not integrate the alignment annotation commands into the alignment/profile creation 

tools.  In order to annotate your profile, you need to first have a horizontal alignment for horizontal 

annotation purposes; and a vertical alignment and profile for vertical annotation purposes. 

With a horizontal alignment drawn in the display (Geometry -> View Geometry -> Active Horizontal), 

navigate to Geometry -> View Geometry -> Horizontal Annotation.   

 

Horizontal Annotation Menu Location 
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This will present the View Horizontal Annotation tools. 

  

View Horizontal Annotation 

In order to use this tool, one should first load the INDOT specific preference, and then select their 

alignment.  To select the alignments that should be annotated, select the graphical selector under 

the Horizontal Alignments portion of the Main tab.  You will then be prompted to select the alignment 

to annotate.   

With the alignment now listed in the Horizontal Alignments section, select Apply.  This will place 

annotation on the alignment listed.  Note that InRoads will allow the annotation of multiple horizontal 

alignments at the same time, as long as they are in the same active geometry project. 

 

Horizontal Annotation Sample 
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Due to the methodology that InRoads uses for text placement in conjunction with Styles and Named 

Symbologies, you may see results similar to the previous illustration.  In this instance, you will note 

that on a right hand curve, the Bearing and Radius values are upside down when related to final 

sheet placement (legible from left to right when view in landscape or right hand portrait).  Therefore, 

you must clean these annotations manually prior to plan completion. 

7.7-3 Adding Horizontal Curve Set Annotation 

InRoads splits the various annotation functions in to numerous tools, providing a higher degree of 

customization and additional flexibility.  This can be found in the placement of horizontal curve 

annotation separate from other Horizontal Annotation tools.  As shown in the previous section, 

horizontal annotation for bearings, distances, radii, etc. can be found in the View Horizontal 

Annotation tools.  Curve annotation is placed by a separate tool called Curve Set Annotation. 

This tool is found under Geometry -> View Geometry -> Curve Set Annotation. 

 

Curve Set Annotation Menu Location 

Similar to other InRoads tools, the Curve Set Annotation tool will open with the active horizontal 

alignment selected.  With this preset, verify that the correct preference is loaded.  INDOT customized 

preferences are provided. 

 

Curve Set Annotation Preferences 
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With the preference loaded, make any necessary adjustments then select Apply.  This will place the 

curve annotation at the center of the curve.  This will need moved as part of plan clean up. 

 

Finished Curve Set Annotation 

7.7-4 Adding Profile Annotation 

To add vertical annotation, a similar process will be followed only using the vertical versions of the 

tools used previously.  Unlike the previous steps for adding horizontal annotation, profiles and profile 

annotation cannot be placed without the final cut profile displayed.  Since your sheets will be cut 

from Prplan XX.dgn, your profile will be displayed and annotated in this drawing. 

Note:  Remember that a vertical alignment and its associated annotation cannot be created without 

a pre-existing profile. Additionally, for annotation to properly carry through nested references, you 

must make sure that annotations are placed on the appropriate split profile created by the Plan and 

Profile Generator. 
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With the existing profile and proposed vertical alignment drawn on it (Evaluation -> Profile -> Create 

Profile and Geometry -> View Geometry -> Active Horizontal), navigate to Geometry -> View Geometry 

-> Vertical Annotation. 

 

Vertical Annotation Menu Location 

This will open the View Vertical Annotation tools. 

 

View Vertical Annotation 
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In order to use this tool, you should first load the INDOT specific preference, and then select their 

alignment.  To select the alignments that should be annotated, select the graphical selector under 

the Horizontal Alignments portion of the General leaf.  You will then be prompted to select the 

alignment to annotate.   

As shown in the previous screen capture, you must define the appropriate horizontal, vertical and 

profile set to place your alignment on.  Additionally, there is an INDOT specific annotation preference 

to display the appropriate information in the correct format. 

When placing the Vertical Annotation, there will be some manual clean up required as InRoads 

preferences don't allow for the specific configuration of all annotation as is considered INDOT 

standard. 

In the following screen capture, the default vertical profile annotation is shown.  What is immediately 

noticeable is that the PVI Station and Elevation are annotated below the PVI and not with the Vertical 

Curve (VC) length. 

 

Vertical Annotation Sample 

In order to appropriately clean up the annotation: 

1. Use the Edit Text tool and select the PVI Sta text to your clipboard. 

2. Use the Edit Text tool and select the VC text. 

3. Place your cursor to the right of the VC text and make sure that it's not highlighted. 
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4. Place a single return and then paste the PVI Sta text on the empty line from the previous 

step. 

5. Repeat steps 1-4 for the Elevation text. 

6. Adjust the placement of the merged PVI Sta/Elev/VC text node. 

7. Delete the PVI Sta and Elev text along with the leaders from the display. 

Upon the conclusion of these edits, a finished vertical profile annotation will appear similar to the 

following. 

 

Finished Vertical Annotation at PVI 

The basic geometry annotation tools only provide annotation for the actual alignment features of the 

profile, which does not include the existing and proposed elevation annotations.  These features are 

annotated by a separate set of profile annotation tools. 

To add the elevations, one needs to use the tools located under Evaluation -> Profile -> Annotate 

Profile.  Much like the vertical alignment annotation tools, an existing profile must exist before you’re 

able to annotate the information.  A preference has been created, adhering to INDOT annotation 

standards, and is named IN ProfileElevations. 

 

Profile Annotation Panel 
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Selecting the appropriate Profile Set, Vertical Alignment and Surface will allow InRoads to 

appropriately annotate the profile elevations.  When annotating multiple portions of a profile set 

(finished profiles cut for plan profile sheets), it is necessary to make sure that the relevant station 

ranges are selected in the Profiles are of the General section as shown below: 

 

 

Existing/Proposed Profile Elevation Annotation 

7.7-5 Station Offset Feature Annotation 

Next is the placement of Station/Offset annotation.  This will provide the appropriate station offset 

and feature names at the location of the feature in the plan view.  This example will provide the 

necessary steps to adjust and move the annotations appropriately after they have been placed. 

InRoads will scale and rotate the border along your alignment.  With this change, it’s to your 

advantage to place your annotations directly on the cut sheet, leveraging the rotation of the border 
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and view to align them.  With this being the more flexible and direct method of placing annotation on 

our sheets, this will be the example you use going forward. 

Alternatively, you can have a drawing created specifically for this kind of annotation and for each 

alignment.  This will require creating a new drawing within InRoads called Annotate station offset 

<Alignment Name> <Scale>.dgn.  Using standard ProjectWise functionality, create a new DGN in the 

project path named Annotate station offset <Alignment Name> <Scale>.dgn (Ex. Annotate station 

offset mcac 50.dgn).  Make sure to use the same seed file as your base drawing to maintain the 

geocoordination setup. 

If you have multiple sheets or for your second method, M-strings, that you wish to annotate about, 

you will need to repeat all of the following steps for each sheet/string in a new plan display with 

similar naming.  For both methods, make sure that your Survey Surface DTM file is open and active 

for use with the Annotation tools. 

7.7-5a Acquiring the Point Features from OpenRoads Survey 

Any project that is surveyed using OpenRoads should now have an associated DTM file that contains 

the survey features that was previously used to annotate the appropriate points from.  If it does not, 

this DTM will need created to accommodate this annotation need, a special graphical import tool has 

been configured to import the survey data into the InRoads DTM format for annotation. 

The following steps look at creating the required DTM: 

1. With your Explan XX.dgn open, navigate to File -> Import -> Surface Advanced on the InRoads 

Explorer. 

 

Import -> Surface Advanced 
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2. This will present the Import Surface Advanced Window. 

 

Import Surface Advanced 

3. In the Rule Set field, set the value to Surface Feature Import as shown in the previous 

illustration. 

4. Set your Surface name to Des #_SRxx Annotation Surface, the Load From should be set to 

All. 

5. When prepared, select the Apply button.  InRoads will begin processing your features from 

graphics and creating a DTM with those features included. 

6. Once complete, make sure to save your DTM file to ProjectWise with your other project data. 
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With the DTM created, you can view its contents on the Surface -> Features -> Feature Properties 

command on the InRoads Explorer.  With the import complete you will see the point features similar 

to this illustration: 

 

Graphically Imported Point Features 

Note:  The annotation DTM that you create as part of this process should not be used for any other 

processes except station offset annotation.  It will not include all features and does not have the 

appropriate triangulation information. 
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7.7-5b Feature Annotation 

With your drawing opened, you can now look at using the Surface -> View Surface -> Annotate 

Feature… tool to place the station and offset of your survey features.  This tool, along with many 

others in the InRoads Suite, allows you to specify a fenced area that you’d like to work within or 

outside of.  As shown in the following screen capture, place a fence over the plan portion of your 

DGN, which is denoted by the shaded block. 

 

The Plan View Highlighted 

Remember, the color of this shading is dependent on the Mode of the fence that you’ve placed, in 

the above example, the block was placed with an Inside Fence Mode.  For the purposes of the 

InRoads tools that use this functionality, the actual fence type isn’t important, as each tool allows 

you to define how InRoads should respect the fence. 

With your plan area now highlighted, start the Annotate Feature tool from the Surface -> View 

Surface menu.  This tool can place various pieces of annotation relative to your survey surface 

features and their type, be it a point or linear feature.  Some examples that both will annotate are 

the Feature Name, Description and Style.  Point features (which you will look at for Station/Offset 

annotation) include items such as Northing, East, and Elevation, and the selected station of a 

Centerline.  Linear features will annotate items such as Length, Bearing, and Slope. 
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Of particular interest, we want to examine what is included for point features using the IN Survey Sta 

Offset preference.  Select the Preferences button and load this preference at this time.  For your 

Station/Offset annotation, you’ll see that on the Points tab Centerline Station, Offset and Feature 

Description are all enabled, along with the precision and format being adjusted accordingly.  These 

items will all be annotated with respect to the features Default Text style setting. 

 

Annotate Features/Points Tab 
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To limit the features being annotated, you’ll use a pre-made filter to assist in the selection of your 

items.  On the Main tab of the Annotate Feature dialog, select the filter button.  On the filters, you 

want to use the SurveyStationOSFeatures filter option as shown. 

 

Station Offset Filter Settings 

With the filter selected, you’ll see your list of features shrink greatly to only those features that are 

allowed through the filter.  Be aware that should you not have any features show up, you may have 

the wrong surface selected, so verify that the Annotation Surface is selected on the main tab. 
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Next, you need to set the fence mode.  With your fence around the plan view of the sheet, make sure 

the Fence Mode is set to inside.  This will restrict annotation to only being placed on features that 

exist in this fence; anything that falls outside it will not be included.  Finally, you need to select your 

features by right clicking in the Features: area and selecting all.  

 

Selecting All Features 

All other settings have been set appropriately with the Preference loaded earlier in the exercise.  Go 

ahead and select Apply at this time. 

 

Example Annotations 
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7.7-5c Feature Annotation Clean Up 

Unlike DCRepo and Geometric Annotation, InRoads does not provide capabilities to automatically 

align annotations to the border as shown in the previous example.  In order to get the annotations 

placed appropriately, you will need to look at using standard MicroStation tools.   

First you need to enable the TextUtil tools.  These can be found under the Text Tools & Miscellaneous 

Annotation task on the Task Navigator. 

 

TextUtil Task Button 

By loading the TextUtil tools, you will now have access to the TextAlign tool that is found next to the 

TextUtil button on the Task Navigator.  Just as you placed a MicroStation fence over the plan view to 

place our annotations, you will do the same thing, as TextAlign will use this fence as a limiting factor 

in what text to rotate.  TextAlign also uses the active angle relative to your view.  In this instance, you 

want to use an active angle of 90 degrees. 

To set the active angle, you can use one of three methods.  The first is to set it under the Active Angle 

leaf of the Settings -> Design File menu item.  The second is via the MicroStation key-in AA=90.  

Finally, the active angle can be set by invoking any tool that uses this value in its configuration such 

as the Rotate tool. 

With the active angle and fence set and the TextAlign tool started, set the tool configuration as 

shown. 

 

TextAlign Settings 

When ready, select a data point any place in your MicroStation view.  Almost all plan text should now 

be rotated 90 degrees and aligned properly with the frame.  Some annotations may not have been 

picked up in the fence however, so these should be aligned by selecting them individually (these are 

normally along the edges of the plan view where the fence would have crossed but not included 

them).  Finally, remember, should any additional text have been placed prior to these annotations, 
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it’s likely they too will have been rotated, so be careful when selecting what text you’re rotating.  

Depending on the situation, it may be to your advantage to use the MicroStation Element Selection 

tools to have more discreet control over the text you’re selecting for alignment. 

With the text now rotated appropriately, you’ll now begin the process of moving your text to the edges 

of the plan view.  For this, we will be using the Align Elements by Edge tool which can be found either 

under the Main tools, or has been included as part of the Annotation Text task for convenience.  To 

use this tool, first select the annotations you’d like to move either to the top or the bottom.   

This tool will work with multiple items selected, so it is very easy to adjust the alignment of numerous 

annotations at once.  Using the MicroStation Element Selection tools, select some of your 

annotations to one side of the alignment.  As shown in the following illustration, you’ll see that 

elements below the alignment have been selected.  For the Align Edges tool in this instance, you’ll 

want to have the Align option set to bottom and then when prompted, select the top gridline of the 

profile which will align all the text to it. 

For elements above the alignment, the same procedure is used, however the Align should be set to 

top and the top edge of the border should be selected to align those items to that element.  As this 

only pushes the annotations to the edge of the sheet, overlap is still an issue and additional clean up 

may be needed to separate annotations that are overlapping. 

 

Align Edges 
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7.8 Additional Sheet Types 

You can create a wide variety of sheets from the InRoads Plan Profile Generator.  The process you’ve 

stepped through for the Plan Profile sheets can be applied to these other sheet types such as Bridge 

Layouts, Large Plan sheets, and Double Plan sheets; all of which have preferences created for their 

setups. 

Be aware that the Station Offset annotation procedure that you’ve examined will not work properly 

when annotating double plan sheets as the sheet rotation is not the same.  In this instance, you will 

need to create an intermediary text drawing and annotate the features in that file instead of directly 

on the sheet.  This procedure is identical to that which we performed previously, however both the 

base drawing and the frames must be referenced to achieve the appropriate text alignment. 

7.9 Adding Other Base Drawings to Sheets 

Other base drawings such as Existing Right of Way can be added to InRoads created sheets such as 

Plan Profiles, Layout sheets, etc.  The user must first obtain right of way drawings from whatever 

sources are available.  For most projects, the existing right of way information will come from Route 

Survey Plat drawings and these should exist in the same coordinate system for any new projects and 

will line up automatically. (These are provided by your Surveyor).  Other sources may include CAD 

drawings from Real Estate consultants (following complete abstracting and title searches).  

Throughout this section, Existing Right of Way drawings are referenced as being created.  The same 

processes work for adding any additional information to the sheets. 

Depending on your surveyor, it is entirely possible that you may receive your Existing Right of Way in 

InRoads native surface features or as alignments.  Be aware you may still have to graphically convert 

either of these data types into the other for the purpose of cross section display (Right of Way must 

be a surface feature if you wish for it to display on cross sections). 

7.9-1 Combine multiple drawings into one base drawing 

If you have more than one existing right of way drawing for your project, you will want to combine all 

of the drawings into one.  Reference the drawings into each other. If the drawings do not line up 

automatically, you will need to move the files based on corresponding coordinates present in both 

drawings. Next copy the reference files into the base drawing. Repeat procedure if you have multiple 

files to copy in. 

When you have completed the above steps, the desired result is one combined existing right of way 

drawing. 

7.9-2 Move to same coordinates system as Prplan.dgn 

In order for the combined existing right of way drawing to be used in the plan profile sheets, the 

elements must exist in the same coordinate system.  To accommodate this, you will reference in the 

Prplan drawing.  If the drawings do not line up automatically, you will need to move the files based on 

corresponding coordinates present in both drawings.   

The resulting existing right of way drawing is now ready to be added into other proposed drawings. 



 

427  

 

7.9-3 Graphically Importing Existing Right of Way 

As the procedures necessary vary depending on the source of your Right of Way data, you will 

examine a few of the more common methods for importing this data and working with it in InRoads 

and making it available to others. 

Data which is graphical in nature can be converted to a format InRoads will interact with.  

MicroStation, AutoCAD, and DXF files are all supported for this process.  Utilizing the File import tools 

available allows vector graphics data to be converted to geometry or surface features.  Often-times 

the largest barrier to conversion is the sheer volume of data in the CAD file provided.  Disseminating 

the contents requires patience and organization. 

In both instances, be aware that the element must be drawn up graphically, as there is no direct 

translation method from Surface Features to Geometry Alignments. 

7.9-3a Importing to Geometry 

Using an existing CAD file provided by either Survey or a Consultant, you will convert the vector 

graphics representing Right of Way elements to InRoads Geometry.  If data provider is an INDOT 

employee, then the file is accessible through ProjectWise from the design folder structure.  Files 

provided by external consultants can be imported to a convenient location in ProjectWise by dragging 

and dropping. Select no wizard for the creation option.  

First you need to reference and possibly merge your data into our base drawing (alignments can be 

imported from reference elements).  Attach your file using either the MicroStation -> File -> 

References menu item or by the Reference toolbar button.  With the references dialog open, attach 

the file containing your right of way.  This may be the LCRS Plat provided by survey or another file 

provided by a consultant.   Note that the file you attach may have additional data displayed that you 

do not wish to import.  Should this be the case, you can use your level display to disable the levels of 

features you don’t wish to display. 

At this point you will no doubt recognize the Right of way elements in the drawing.  Elements can be 

converted to InRoads Geometry. Careful inspections of right of way elements may show elements 

that have been constructed, segmented, and are not joined.  For convenience in later operations, 

you may wish to join them to be continuous.  To join these elements using MicroStation, use the 

Create Complex Chain tool.   Create Complex Chain will generate a new chain from the selected 

elements on the active MicroStation level.  Because you don’t want the level of the element to 

change, first match the attributes of the element you are chaining. 

 

Create Complex Chain 
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Selection of elements is possible utilizing Element Selection or Select by Element Attributes.  Note: 

the element selection window using selections around elements is suggested.  Alternately the “select 

all” (world icon) will add all elements to selection sets (even levels turned off).  Elements may be 

converted one at a time, however for speed of conversion, you will convert by level.  Different data 

may require various methods. 

With your elements selected, you can now import them into Geometry features.  For this, you will use 

the File -> Import -> Geometry menu item on the InRoads Explorer.  On this panel, you will want to 

define settings similar to the following illustration.  Of particular note, notice the Style selected, and 

make sure that you use good naming so each feature you include is clear.   

 

Import Geometry 

With your settings configured, you can now select Apply to begin the import.  During the import 

process, InRoads will enumerate the name of the alignments, should you have more than one 
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distinct item selected (Existing RW1, Existing RW2, RW3… etc.).  At this time, you can either delete 

any graphics merged in from the references or detach your referenced file depending on the method 

used.  Then, you can redisplay the alignments from InRoads Geometry menu. 

7.9-3b Importing to a Surface 

Again, you will be starting with existing data provided in the same manner as the Geometry import.  

As such, the steps preceding the actual import process are the same. 

With the data prepared, you can now look at importing the graphics into Surface Features.  This time, 

you’ll use the File -> Import -> Surface menu item on the InRoads Explorer.  On this panel, you will 

want to define settings similar to the following illustration.  Here you have a few more options that 

require adjustment than in the Geometry panel. 

First, you need to define where you’d like your new features to be created.  As you can add the new 

features to existing cross sections, you’ll create a new DTM names Des XXXXXX_SRXX Existing 

RW.dtm.  With this defined, you need to determine what you’re loading the data from; particularly for 

internal data you’ll be able to use the Level option, as any existing RW should be on the 

RW_ExistingRW level.  This could vary however, depending on the source of your data and could 

possibly require that you potentially use the Single Element or Fence options.  

Next, you need to determine how the elevations of the RW lines will be determined, which will 

influence their display on the cross sections.  To adjust these appropriately, make sure your 

Elevations are set to Drape Surface and that your Intercept Surface is set to your projects Survey 

Surface.  This will drape the feature over the existing triangulation and display the features properly 

on the cross sections. 

Finally, you need to define the style these features should be imported as.  As you can see, you’ve 

defined our import to use a seed name of RW.  Place the imported features into the 

RW_TemporaryRW style with a point type of Breakline which is being excluded from the triangulation.   
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With these settings, you can go ahead and select Apply and the features will be created in a new 

DTM.  Make sure you save this DTM back to ProjectWise so it’s available later when you’d like to 

display the Right of Way features on your cross sections. 

 

Import Surface 
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7.10 Cross Sections 

In OpenRoads, Cross Sections have undergone a major revamp to now work with the OpenRoads 

terrain models and corridors.  While using the Cross Section tools, you will see many familiar settings 

to the InRoads cross section tools.  However, it should be noted that the OpenRoads cross sections 

do not have all the functionality that the old tools did. 

7.10-1 Cross Section Changes 

The following functions have been removed/changed from Cross Sections in OpenRoads: 

• Update Cross Sections – The update cross sections command is no longer available.  Existing 

sections must be re-cut for any changes to be displayed. 

• Cross Sections now cut through graphical elements directly instead of re-drawing and 

projecting the sections.  For surfaces and components they must be active and displayed 

using the correct Terrain Display. 

• Cross Section Annotation has been migrated to its own command. 

• The terrain model will be displayed using its defined perimeter feature, XE and XP linestyles 

are no longer supported. 

• Cross Sections no longer use Global Scale Factors, being an OpenRoads based tool these 

now use Drawing Scale.  This is automatically adjusted via the scaled preferences. 

• Stationing now uses DGN Settings to control significant figures.  These will need changed 

prior to cutting sheets. 

With OpenRoads, the InRoads Explorer is no longer used to create cross sections.  The appropriate 

tools can be found on the MicroStation Task Navigation panel under Civil Tools > Corridor Modeling.  

The only legacy component to remain on the InRoads Explorer is the reporting functionality, which 

does still work with OpenRoads created sections. 

7.10-2 Preparing Prplan XX.dgn for Cross Sections 

As we discussed in the previous section on changes, for the proposed corridor to display on your 

sections, it must be displayed with the proper Design Stage in the Prplan.dgn.  To adjust the setting 

accordingly: 

1. Open your Prplan XX.dgn. 
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2. Select the corridor model by its handle. 

 

Selecting the Corridor 

3. Examine the corridor in the Element Information panel.  Locate the Design Stages setting. 

4. Set the Design Stages to 8 – Final Components. 

 

Design Stages 
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5. With the setting adjusted, save your settings and check your file back into ProjectWise. 

7.10-3 Cross Section DGN 

OpenRoads will only cut cross sections to a model in your currently active DGN.  InterPlot will 

continue to extract the cross section borders and content as they are based on a plot shape 

surrounding the border.  Using the following naming suggestions, create/open a DGN named for your 

proposed sections. 

Cross Section Drawings 

Drawing Names Descriptions Examples 

exSections_LineA Existing Sections along Line “A”  exSections_LineA.dgn 

prSections_LineA Proposed Sections along Line “A” prSections_LineA.dgn 

Unlike the original method of cutting InRoads Cross sections, Global Scale Factors no longer need 

set to properly display the sections.  Even though these tools rely heavily on the XIN for configuration 

and preference, the Drawing Scale dropdown on the Create Cross Sections dialog now governs the 

scaling of elements. 

Additionally, as mentioned in the changes section, station text now uses DGN settings to control the 

number of significant figures displayed on the sections.  The following steps will briefly describe how 

to adjust these. 

1. In the DGN file, locate the Settings -> Design File menu from the MicroStation toolbar. 

 
Design File Settings 
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2. On the Design File settings panel, go to the Civil Formatting entry. 

 
Civil Formatting 

3. In the Station Settings leaf, change the Precision from .12 to 0 

 
Setting Precision 
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With OpenRoads using the DGN stored corridors and terrains we can now use MicroStation 

referencing to make all the civil components we need available for cross sections.  This replaces the 

need for DTMs and ALG alignments in the cutting process. 

In your new DGN, reference attach the Explan XX.dgn, Design Alignments.dgn, and Prplan XX.dgn.  

Remember that depending on your referencing scheme you may be able to attach a single file and 

use nested references to attach the other content.  The following illustration shows this process in 

practice. 

 

Nested References 

With all the files attached, you’re almost prepared to cut your sections.  As a final preparation step, 

locate the terrain model and make it active.  This can be done either through the heads up display or 

on the Civil Model.  Note that the terrain will be listed under Referenced Models.  

7.10-4 Cross Section Creation 

With your files attached and your corridor model displayed using the correct design stage, sections 

can now be cut.  The cross section tools can be found on the Task Navigation panel under Civil Tools 

-> Corridor Modeling -> Create Cross Sections tool. 

 

Create Cross Section 
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With the tool active, you will be prompted to select the alignment you’ll be cutting your sheets along.  

Select the appropriate alignment to finish initializing the command. 

7.10-4a Cross Section Preferences 

Cross sections in OpenRoads are still largely based on the existing tool set from SS2, as such, our 

existing INDOT customized preferences are available for use.  As discussed in the section on 

changes, note that cross sections no longer use Global Scale Factors, favoring Drawing Scale 

instead.  For the purposes of the following examples, you’ll look at the settings used in the IN PW 

XSec 10 Scale Sheets preference. 

7.10-4b The General Leaf 

With the 10 Scale preference loaded, you’ll examine many of the settings that are pre-configured for 

use in this scale.  First, look at the General Leaf. 

The General Tab contains settings such as the Section Set Name, the interval between sections, the 

left/right offsets, and the vertical exaggeration.  Additionally, there is a new Scale setting that will 

create the sections using the appropriate drawing scale.  These settings are preset via the use of the 

Preference, except the Set Name.  The Set Name can be set one of two ways, the first being it 

assumes the name of the active Horizontal Alignment set via the Source leaf or it can be keyed in 

directly. 

Note:  Please keep in mind that if you named your alignment with quotation marks, that these 

characters will not be accepted for the set name, they should simply be removed for the section set 

to function properly. 

 

Cross Sections – General Leaf 
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As we no longer have the ability to define the surface being cut through, the features you have 

displayed will determine the content of your sections.  In the instance of existing sections you will 

only want to have your Explan XX.dgn and Design Alignments.dgn attached.  For proposed sections 

you will want to have Explan XX.dgn, Design Alignments.dgn, and Prplan XX.dgn all attached. 

7.10-4c The Controls Leaf 

The items in the Controls Leaf allow us to define the station range of the sections.  The default is for 

the entire length of the selected alignment.  In addition to this, the Critical Sections sub-item allows 

for the creation of sections at a series of pre-defined InRoads points. 

Should you need to display the section cut lines in the plan view, navigate to the Plan Display option 

and enable the Planimetric and Planimetric Stations options as shown: 

 

Plan View Section Items 

7.10-4d The Custom Leaf 

The Custom tools allow for the definition of custom section ranges within your section set as a whole.  

For instance, you can define a station range within your set that has a smaller interval, or instead of 

being perpendicular to the alignment, is skewed with different offsets should you need to include 

more information.  For these custom sections, you can also define whether or not crossing and 

projected features are included, independently of the full set definition. 
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7.10-4e Everything Else 

The remaining items under the Create Cross Section Leaf are all predefined using INDOT standard 

values for sheet borders, grid values, etc.  In most instances, these values can be left as is, as they 

come in from the appropriate preference.  With all the settings defined, select Apply and InRoads will 

create the Cross Sections using the settings you’ve defined throughout this example. 

7.10-4f Cross Section Notes 

1. Be careful when working with the sections once they’re created.  Deleting or modifying parts 

of the sections can cause InRoads to lose the ability to identify and Annotate/Update your 

sections. 

2. ProjectWise title block integration is enabled on these sheets and is immediately available if 

you create the sections in a DGN opened from ProjectWise.  A new DGN that has not been 

checked in will display the placeholder tags until the file is checked in and re-opened. 

3. When cross section components are displayed, these are closed shapes that can be 

measured for area at the scale drawn. 

7.10-4g Crossing Features 

With the changes to how OpenRoads now cuts sections, the process for showing point symbols for 

specific crossing features (guardrail, R/W lines, underground utilities) has slightly changed.  Instead 

of adding these features to an existing set of sections after they have been cut, now all that needs to 

occur is that the features use the appropriate style and are displayed at the time the sections are 

cut.  They will then be automatically displayed when the sheets are created and no longer require 

any special configuration. 

7.10-4h Cross Section Troubleshooting 

During the process of Cross Section creation, one of the most common issues is an error that 

specifies a section is out of range.  This is most commonly caused by a section that is cutting 

through a surface that has triangulated features that are located at 0 elevations or is from a 3D 

model where geometry elements have been created.  The latter causes a reference element to be 

placed at a 0 elevation.  In this instance, you might want to cut the sections without sheet borders in 

order to locate the item in question. 
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To cut sections without sheet borders select the Stacked option on the General tab of the Cross 

Section tool. 

 

Cross Section Layout 

This will allow InRoads to create all specified sections without limits on the horizontal extents and 

allow for the inspection of sections to locate the area where the triangulation may be an issue. 

7.10-5 Cross Section Annotation 

With a section set created, you’ll now look at the annotation process.  For OpenRoads, the Cross 

Section Annotation tools have been moved to their own tool.  This can be located on the Task 

Navigation panel under Civil Tools -> Corridor Modeling -> Annotate Cross Sections. 

 

Annotate Cross Sections 
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The first thing you should notice when activating this leaf is the Cross Section Model: option 

becomes active. 

 

Cross Section Set Active 

In the instance that the DGN has multiple section sets defined, this will allow you to specify which 

section set you’d like to interact with.  In most cases, you’ll only need to select the surface you’d like 

to annotate, along with the corresponding Preference.  This will appropriately define all the remaining 

features in the Annotate Cross Section tree. When you’re satisfied with the setup, select Apply, and 

the annotation selected will be placed on your sections. 

7.10-6 Update Cross Sections 

One of the more important changes to the OpenRoads sections is the lost ability to update cross 

sections directly to an existing set.  As previously discussed, any section iterations must be cut as a 

new section.  To somewhat alleviate this process Bentley has provided a tool that will update new 

sections from an existing set. 
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With multiple sets of sections in the same DGN, locate the Cross Section Synchronization tool on the 

Task Navigation Panel.  It can be found under INDOT Tools -> OpenRoads Extensions -> Cross 

Section Synchronization.  This should be started when you’re in the cross section model you want to 

pull existing data into. 

 

Cross Section Synchronization 

Once running, the following panel will be displayed. 

 

Synchronize Settings 
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The source model defines the section set you wish to pull information from.  The target model is the 

file you’re currently in.  The Source Model Levels to Sync allow for the granular selection of 

information that you wish to bring forward.  By selecting the appropriate levels and selecting process, 

the content of these levels will synchronized at the appropriate stations on your sections. 

7.10-7 End Area Volumes 

To get End-Area Volumes displayed on the sections, you’ll use the End Area Volumes command on 

the Civil Tools -> Corridor Modeling Task Navigation panel. 

 

End Area Volumes 

Currently, this tool is configured to place this annotation below each related section.  Along with your 

other cross section tools, you do have appropriately scaled preferences.  For this example, you’ll be 

placing the annotation using the EndAreaVolume10scale.  With this Preference, all other items will 

be appropriately configured per INDOT standards.  When ready, select Apply, and the annotations will 

be placed. 

 

End-Area Volumes 

7.10-8 Benching Area Volumes 

As the InRoads cross section annotation tools do not allow for the placement of the Benching Area 

and Volumes, the following process is recommended: 

1. Select the Cut Area and Volume with the Power Selector. 
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2. Select the Copy tool for the Task Navigator. 

3. Using the center snap mode, snap to the center of the Fill Volume and then drag to the left, 

and again center snap to the Cut Volume.  This will ensure consistent spacing between all 

text as shown: 

 
4. The newly copied text should be modified so it's on the level XS_G_Benching Area and 

XS_G_Benching Volume respectively. 

7.10-9 InRoads RW Modeling and Cross Section Tips (courtesy H. Brown) 

While no longer explicitly used as most modeling has been moved to the OpenRoads terrain models, 

these following information has been kept as reference in the event existing data exists that used 

this functionality. 

7.10-9a Steps to Model Right-of-Way in InRoads Using Cogo Points: 

1. Open the InRoads Geometry Project that will be used to store R/W Cogo Points and R/W 

alignments. 

2. Create a Cogo Point for each R/W point using Geometry/Cogo Points/New.  Select 

Station/Offset for the Define By field.  Enter the desired point number in the Name field.  For 

the Horizontal Alignment field, enter the alignment from which the R/W point is described.  

Enter the appropriate values in the Station and Offset fields.  Leave the Elevation field as 

0.00. For the Style field, select RW_ProposedRW. Click Apply when finished.  (Note: Example 

is for Permanent R/W on left side for US 231, Des. No. 0800856.  See attached plan 

sheets.) 

 



 

444  

 

3. For parallel R/W on curves, three points should be created at the following locations: 

beginning of parallel R/W on curve, curve center, and end of parallel R/W on curve.  The 

same curve center point can be used for multiple arcs on the same curve. 

4. After Cogo Points are created, they can be edited if needed using Geometry/Cogo 

Points/Edit. 
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5. After the Cogo Points have been created, create the alignment using 

Geometry/Utilities/Create Edit Alignment by Cogo Points. Enter the appropriate Alignment 

Name and Description in the Name and Description fields.  It’s recommended that a new 

alignment name be used in the Name field to prevent the accidental overwriting of an 

existing alignment.  Use the style RW_ProposedRW (for permanent R/W) or 

RW_TemporaryRW (for temporary R/W).  In the Alignment Definition field, enter each point 

number separated by a space. For a point that represents a curve center, use the prefix “c” 

and suffix “l” (curve to the left) or “r” (curve to the right).  In this example, point number 303 

is the curve center for a curve to the right (Station = 449+26.05, Offset = 1432.44’).  Click 

Apply when finished. 

 

6. After the R/W Alignment is created, points can be added to or removed from the R/W 

alignment using Geometry/Utilities/Create Edit Alignment by Cogo Points.  
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7. Individual points can be edited after the alignment is created (refer to Step 4).  The 

alignment will automatically be updated when a point on the alignment is edited.  To edit 

points that are part of an arc for parallel R/W on curves, change the Alignment Definition to 

remove the “c” prefix and “l” or “r” suffix and click Apply (refer to Step 5). After the arc points 

are edited, the “c” prefix and “l” or “r” suffix should then be added again to the alignment 

description. 

8. The R/W alignments can be drawn in plan view using Geometry/View Geometry/Active 

Horizontal. All horizontal alignments in a Geometry Project can be drawn using 

Geometry/View Geometry/All Horizontals. The linestyles can be changed using MicroStation 

commands. 

9. To show R/W on cross sections, R/W surface features need to be created from the R/W 

Alignments.  The features can be created using File/Import/Surface/From Geometry. Set the 

Target Surface to the surface that will be used to store R/W features.  Check the Alignments 

radio button and use the Filter button (after clicking in the Alignment field) to select the 

alignments that will be used to create features.  The Geometry Selection Filter panel is shown 

below: 
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10. On the Import Surface panel, select the following settings in the Features section: Name = 

From Geometry, Type = Breakline, Point Density Interval = Value Selected by User (10.00 in 

this example), Duplicate Names = Rename, Exclude from Triangulation = unchecked. A lower 

Point Density Interval improves the accuracy of the elevations on the R/W features.  In the 

Elevation section, select Surface in the Source field and select the Surface used to generate 

the R/W feature elevations in the Surface field. Click Apply when finished. 

 

  



 

448  

 

11. Check to ensure that the features have been created with the correct styles using 

Surface/Feature/Feature Properties. 

 

12. Triangulate the surface containing the right-of-way features using Surface/Triangulate 

Surface.   
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7.11 InRoads Performance Tips 

While working with InRoads, DGNs have a tendency to become bloated due to many of the 

automated processes that occur during day to day use of the software.  To alleviate some of these 

issues that result in poor performance, these items should be tried prior to contacting CAD Support: 

1. Make sure the appropriate seed files are being used.  These files can be found at pw:\\indot-

pw.bentley.com:indot-pw-01\Documents\Template Documents\SS4 Seed\InRoads\.  These 

seed files are configured without Design History enabled to prevent the historical recording of 

subsequent display commands and to maintain a manageable file size. 

2. Compress DGNs regularly.  Again, displaying items repeatedly can also build up in the DGN 

buffer, which can be alleviated by using the File -> Compress -> Design and Options items in 

MicroStation.  It’s advised to perform both types of compression, and enabling all features on 

the options panel, as each function removes cached items from the DGN. 

3. After performing any plans production operations (plan profile sheets, cross sections, etc.) 

that place sheets in the base drawing, consider the following: 

a. Detach any unneeded references (borders, etc.) 

b. Delete and compress any unneeded elements. 

c. Remove tag sets (Element -> Tags -> Define), highlight each tag set and select 

Remove. 

4. Isolate long sets of cross sections, and dispose of draft copies when possible. 

By performing these operations throughout the design process, performance will be increased by 

minimizing the amount of data in a single DGN.  Additionally, this will limit the number of instances of 

ProjectWise title block integration that must be resolved prior to a DGN becoming available to use 

once open. 

8. Using InRoads and ProjectWise for Real Estate 
The following chapter will examine possible workflows for numerous Real Estate functions, such as 

the development of Parcel Plats, Exhibits, Right of Way plans; along with the review of the custom 

reporting functions that have been created.  Note that this chapter is procedural in nature, so further 

review of ProjectWise, MicroStation and InRoads functions and integrations should be reviewed in 

their respective chapters. 

8.1 The Real Estate Project Structure. 

When creating a Real Estate Project using the DOTWise Project Creator, all Real Estate projects will 

be provided the following folder structure: 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/InRoads/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/InRoads/
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The Real Estate Folder Structure 

In these folders, the following types of data are recommended: 

• Documents – Any project documentation, correspondence, or other files relevant to the 

project including spreadsheets, PDFs, etc. 

• ERMS Submittals – These should include any documents that are prepared and finalized in 

preparation to upload to the INDOT ERMS system. 

• Images – Any imagery for the project can be stored in this folder.  This can include aerials, or 

on site digital photos. 

• InRoads – This folder should include all the project CAD data such as MicroStation and 

InRoads data. 

In addition to the provided folder structure, additional folders can be created under the Real Estate 

level and each of the provided sub folders to fit the needs of the projects.  These are merely the 

folders that are initially provided. 
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8.2 Required InRoads Application Add Ins 

As part of the InRoads Real Estate process, there are specific Application Add-Ins that need enabled 

in the InRoads environment.  These Add-Ins can be enabled from the InRoads Explorer -> Tools -> 

Application Add-Ins menu option.  The following Add-Ins should have their respective check boxes 

enabled: 

• Lot Layout Add-In – Commands for the creation and manipulation of lots, setbacks and 

rights-of-way. 

• Traverse Edit Add-In – Tool used to create horizontal alignments from deed/plat descriptions. 

• Multiple Horizontal Element Regression Analysis Add-In – Commands for horizontal 

alignment creation and editing with the inclusion of regression by least squares analysis. 

Additional Add-Ins such as those discussed in Chapter 5.5.4 can/should be enabled as needed as 

they will simplify locating tools and features, and ease the development of finalized deliverables. 
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8.3 Incorporating and Converting Survey Data 

Incorporation of survey data will insure a logical starting point for Real Estate activities.  Survey Data 

for many projects will be available in ProjectWise in the Survey folder.  If the survey has been 

completed in InRoads much of the data will be available with minimal effort. 

8.3-1 Inspecting the Survey Folder in ProjectWise 

Upon inspection of the Survey folder in ProjectWise, you are likely to find numerous relevant files in 

ProjectWise. Per the most recent revisions to the Indiana Design Manual: 

“Each InRoads survey file submitted to INDOT shall use the format and provide the content as 

described below. 

DES#_SRxx Name.extension 

Key: 

• DES#: designation number for project as provided by INDOT 

• SRxx: route number of project, for example: SR37, SR162, I64, US150 

• Name: descriptive name of information in file, for example: Topo, LCRS Plat 

• Extension: file extension name, for example, .xin, .dgn, .fwd 

The files to be submitted to INDOT for each survey are as follows: 

FOR SS2 VERSION PROJECTS 

11. Des #_SRxx Control Points.fwd – InRoads survey book with control points 

12. Des #_SRxx LCRS Plat.dgn – MicroStation plat DGN 

13. Des #_SRxx Survey Alignment.alg – InRoads Survey Alignments 

14. Des #_SRxx Survey Surface.dtm – InRoads DTM of Survey processed features 

15. Des #_SRxx Survey Surface Boundary.dtm – InRoads DTM of Survey Boundary 

16. Des #_SRxx Survey.xin – InRoads XIN, specific to the processed data 

17. Des #_SRxx Topo.dgn – MicroStation DGN of topographical features 

18. Des #_SRxx Topo.fwd – InRoads DTM containing the processed Survey 

19. Des #_SRxxSeed.dgn – Sets the coordinate system for every InRoads based file in your 

project. 

20. IN_GeoCS.dty - This file contains the customized coordinate system information and should 

not be needed as this is also provided as part of the Seed file. 

FOR SS4 VERSION PROJECTS 

10. Des #_SRxx Seed 2D.dgn – Sets the coordinate system for every InRoads based file in your 

project and contains a Default model in 2D. 

11. Des #_SRxx Seed 3D.dgn – Sets the coordinate system for every InRoads based file in your 

project and contains a Default model in 3D. 

12. IN_GeoCS.dty - This file contains the customized coordinate system information and should 

not be needed as this is also provided as part of the Seed file. 
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13. Des #_SRxx Survey Fieldbook.dgn - Contains Fieldbook information for TOPO and Control 

Points in the OpenRoads Format (survey fieldbook) along with the existing terrain model.  

This will be done in a 3D model. 

14. Des #_SRxx Survey Alignment.dgn - Contains Survey alignment(s) in the OpenRoads Format 

(civil data – linear elements).  This will be done in a 2D model. 

15. Des #_SRxx LCRS Plat.dgn  - MicroStation plat DGN 

16. Des #_SRxx Survey Alignment.alg – InRoads Survey Alignments, Legacy format for 

annotation. 

17. Des #_SRxx Existing Terrain.dtm – InRoads DTM of Survey terrain model, with applicable 

triangulation cleanup.  This terrain will only contain the existing triangulated terrain and any 

features that are included in that triangulation.  This can be used with the native InRoads 

tools for 3D analysis as it will match the OpenRoads existing terrain and is discussed in 

Chapter 6.3-5 

18. Des #_SRxx Annotation Surface.dtm – InRoads DTM of Survey processed features, Legacy 

formant for annotation.  This should not be used for any functions beyond the native 

annotation tools and should be created using the import process described in Chapter 6.3-6. 

In some instances, survey data has not been placed in the Survey folder. This is often the case when 

surveyed by non-INDOT staff.  It can be located as a subfolder to Design. As can be expected when 

the data is not present in the Survey folder, further investigation by the responsible party is 

necessary. 

ROUTE SURVEY 

The Route Survey (LCRS) document for the project is also likely to be present with the above referred 

to Survey documentation. It likely exists in Cad file format as well as the recorded adobe pdf 

document.  Both of these types of data are readily utilized in MicroStation. 

8.3-2 Copying Data from within ProjectWise 

Data present in the Survey folder may need to be accessible in a read/write manner to perform 

further Coordinate geometry operations.  ProjectWise permissions ensure that users only have the 

ability to modify files in their folders. Because of these permissions, data is protected from groups 

other than their creators and is visible in a read only fashion to everyone else. When read/write is 

required the most straightforward workflow is to copy the file(s) in question to the user(s) folder. For 

example dragging files from Survey\Project Files folder to Real Estate\InRoads. 

8.3-3 Copying Data from Other Sources 

In some cases, you may receive your data from sources that don’t have access to ProjectWise.  In 

these instances, you could possible receive your information via e-mail, CD, or ERMS.  For these 

situations, we will look at using a Drag and Drop import to bring this information into our datasource. 

For ERMS file transfers, you must first get the documents to a folder on your local PC, in a folder you 

have access to.  Some suggested locations could be a folder on your desktop, a C:\Projects location, 

or perhaps C:\temp. As the steps to extract data from ERMS are specific to the application, we will 

not discuss them here. 

With the files in a location that you can access, open your ProjectWise Explorer to the appropriate 

folder in the Real Estate folder structure. With this location now open, navigate in Windows Explorer 
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or your Outlook E-mail client and select the file or files (using either Ctrl+Click or Shift+Click selection 

methods), and continue holding your lt. mouse button down while dragging the selection into the 

Document Panel of ProjectWise. 

 
Drag and Drop from a PC 

8.3-4 Converting Survey Data to Geometry 

Incorporation of Survey field book data (*.fwd) into Geometry Project Data can be accomplished 

using the Survey Data to Geometry functionality from the Survey menu.  Survey data will be available 

with the same code numbers used by survey for all data collected. Survey alignment geometry *.alg 

files are likely to only contain what the surveyor thought was necessary for creation of survey 

geometry elements.  Any remaining surveyed points can be published to COGO geometry if it is felt 

desirable items is missing.  Using the option to replace data will insure that no duplicates are 

created with the Survey Data to Geometry functionality. 
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On the Survey Data to Geometry panel, options to filter the data being copied are available.  Filter is 

consistent throughout InRoads.  Utilize filter to restrict; points by code range, random vs breaklines, 

specific style names, and numerous other alternatives.  Curve stroking option inserts vertices in 

linear elements based on a chord to arc tolerance.  This may not be desirable as more points that 

were collected in the field are generated.  Duplicate Name set to Replace or rename will dictate the 

copy behavior when the same COGO point names already exist in the destination geometry project. 

Preferences button reveals specific settings predefined for a particular reason (ex. 

SurveyDataToRW). 

 
Survey Data to Geometry 

  



 

456  

 

 

8.4 Incorporating Proposed Right of Way Data from Design 

Design right of way information can be included in the project process through a number of different 

methods depending on the type of data available.  The most desirable form of data would be 

Geometry defined in a designers InRoads geometry file or .alg.  InRoads geometry files will require 

virtually no manipulation of data to incorporate the details of the proposed right of way into 

coordinate geometry calculation. In the event that the designer does not provide InRoads geometry, 

conversion of cad graphics is likely the next most practical vehicle for incorporation of geometry data 

in the project. 

Cad data is probably the most readily available data, especially from INDOT consultants.  When cad 

data is not available, and the range or information available is more likely an adobe PDF file, 

proposed alignments can be created using the methods described in the InRoads Right of way 

training. Coordinates file type data can also be incorporated using the InRoads text import wizard 

utility. Typical examples might be Traverse PC, PC Survey, MX, PDF files, OCR PDF file, or other ASCII 

type data. 

8.4-1 Right of Way from InRoads Geometry 

When Project data is available via InRoads Geometry Project, users should open the appropriate 

designer’s alg file.  Using the Geometry > Copy Geometry tool will allow elements to be copied from 

the designer’s alg to your current geometry project.  This ensures you will have full access to the 

alignments, and COGO points as needed 

 
Copy Geometry 
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From this panel, you can select all the various components of a Geometry project and copy them to a 

differing file.  This includes horizontal alignments, vertical alignments, and COGO Points. 

 
Copy Geometry 

Once data Geometry data has been copied, it may be necessary to rename the data for clarity 

purposes.  This can be accomplished using the Geometry -> Rename Geometry tool on the InRoads 

Explorer. 

8.4-2 Right of Way from Graphical Data 

In many instances, Right of Way information may only be provided via a CAD file (DGNs, DWGs, DXFs, 

etc.).  InRoads can accommodate this via the File -> Import -> Geometry option on the InRoads 

Explorer. 

 
Importing Geometry Data 
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When in the Geometry import tool, the first option presented will be the Graphical option.  On this 

panel one can configure all the relevant options to capture a pre-existing CAD element and turn it 

into Geometry data. 

 
Graphical Geometry Import 

The highlighted options in the previous illustration should be configured as necessary.  A brief 

description of each option: 

• Type – This is the type of Geometry element that will be created upon import.  For the 

purposes of Right of Way, this should only be Horizontal Alignment or COGO Points. 

• Name – This is the name of the element that will be created in the Geometry project.  Note 

that when multiple elements are selected for import, this name will be enumerated so it may 

be advantageous to have the name end in a number. 

• Style – This is the style that each element will be defined with upon import.  Most instances 

should have this as one of the RW_ (Right of Way) or CG_ (COGO Point) feature styles. 

• Resolve Gaps – Closes gaps between adjacent linear elements. The software passes across 

the data and removes gaps between adjacent linear elements. 

• Join Elements – If checked, joins two adjacent elements provided that they are joinable (like 

elements, coincident common points, like tangential directions, like radii for circular). 

• All Selected Elements Added to Single Alignment – If checked, imports all elements of a 

selected multi-element graphic to a single alignment. If not checked, imports each element 

of a multi-element graphic into different alignments. 
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Once configured, selecting the Apply button will switch back to MicroStation allowing for the 

graphical selection of the CAD elements.  This selection follows all MicroStation conventions for 

element selection so Shift + Click, Ctrl+Click, and Drag/Window selection methods are all viable for 

selecting the elements. 

In addition to this method, elements can also be pre-selected prior to starting the Import -> Geometry 

tool using the standard MicroStation element selection tools such as Power Selector.  When used in 

this manner, any pre-selected elements will automatically be added to the Geometry project when 

the Apply button is selected. 

8.4-3 The Text Import Wizard 

In addition to InRoads Surface data, and CAD data; text data may also be provided specifically for 

COGO points as their nature lends itself to being transferred as tabular data.  In these instances one 

may receive data in TXT or CSV formats which can be brought directly into InRoads via the Text 

Import Wizard. 

The Text Import Wizard can be found on the InRoads Explorer under File -> Text Import Wizard. 

 
Text Import Wizard 

When starting the Text Import Wizard, one must first select the Data Type being imported, along with 

the file name where the data can be found.  Note that when selecting a file from ProjectWise, the 

Application Type on the ProjectWise Open dialog may need changed to All Applications as this data 

is not limited to text only formats. 

 
Text Import Wizard – Setting Data Type and File 
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Upon selecting the OK button, the Wizard will begin with the process of configuring the data.  The 

first panel allows for the definition of the Import Range.  This is provided by giving the start and end 

lines of the data being imported.  Depending on the source there may be header or other data that 

needs excluded as in the following illustration.  As shown, starting at line 7 will exclude the header 

information from the import. 

 

 
Changing the Import Range 
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With the Import Range set, one can proceed to the next panel and start setting up the data type and 

any filters. 

 
Filters and Data Types 

Depending on the source data, there may be rows that need filtered out for a clean import.  Often 

times this will be items such as embedded time stamps/dates or page numbers.  On this panel 

these types of data can be filtered out as necessary.  Also, this panel contains the definition for how 

the data should be separated.  Again depending on the source and file type, the provided data may 

be in a Fixed Width (consistent column layout) or Delimited (common field separator) format.  This 

should be identified on this panel. 

The next panel allows for the definition of the data columns and changes depending on the Original 

Data Type defined.  The following illustrations show both potential options. 

 
Fixed Width 
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The fixed width option allows for the separation of data columns through consistent spacing.  When 

using this method, one only needs to click on the appropriate space between columns to set the 

column definition. 

 
Delimited 

When using Delimited, this panel will allow for the configuration of the columns based on a 

consistent character.  Often this will be spaces or commas depending on the original data source 

and the selection should be made appropriately to separate the data. 

In both instances a live preview will show how the columns are separated allowing for adjustment as 

needed.  Once setup, proceeding to the next panel allows for the definition of each columns data 

type. 

 
Setting Column Data Types 
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On this panel one can define the type of data each column contains.  There are a variety of different 

data types, but the primary ones used are Point Name, Northing, Easting and Elevation.  The other 

options can be reviewed via the Help file.  Once the column data is defined, selecting Finish will kick 

off the import process.  Upon completion, InRoads will provide an import status as follows. 

 
Import Status 
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8.5 Creating Parcels from COGO Points 

The previous sections have discussed the process of gathering and getting data from a variety of 

sources prepared for use.  This section will review creating parcels and the various manipulation 

tools that are used throughout this process. 

8.5-1 Create/Edit Alignment by COGO Points 

Geometry Alignments often follow Existing COGO points that have been observed through field data 

collection.  When these points are provided and brought into the geometry project through one of the 

methods described in the previous section, creating the Parcels is often as easy as “connecting the 

dots”.  This method is accomplished through the Create/Edit Alignment by COGO points tool which 

can be found under the Geometry -> Utilities -> Create/Edit Alignment by COGO points option on the 

InRoads Explorer. 

 
Create/Edit Alignment by COGO Points 
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When starting this tool, the following window is presented. 

 
Create/Edit Alignment by COGO Points 

When using this tool, one can provide a new alignment name and description directly on the tool.  

Once these have been defined the appropriate Style should be selected, again this will be one of the 

RW_ (Right of Way) styles provided in InRoads.  With these items configured, the alignment can then 

be created.  There are two methods to do so: 

• Manual Key-In – When using this method, the cursor should be placed in the Alignment 

Definition portion of the window.  COGO point names can then be keyed in with a space 

between each point name.  To close the alignment, the first point should also be entered as 

the last as well. 

• Graphical Input – This method uses the Graphical Input buttons on the lower portion of the 

panel and allows for the graphical selection of the points.  When selecting points this way, 

their names will be populated in the Alignment Definition section allowing for the adjustment 

of COGO point names as needed. 

When satisfied, selecting the Apply button will confirm the alignment definition and create it in the 

Geometry project.  It will also display a graphical representation of the alignment in the CAD file using 

the defined InRoads style. 
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8.5-2 The Traverse Tool 

An additional method to creating the Alignment (Parcels, deeds, plats, or otherwise) is through the 

Traverse command.  This command isn’t part of the base InRoads setup, and has to be enabled as an 

Application Add-In which is discussed in Chapter 5. 

With the Add-In enabled, the following new commands will show up under Geometry -> Utilities. 

• Traverse Edit 

• Metes and Bounds 

• Traverse Adjustments 

This section will look at the Traverse tool found under Geometry -> Traverse. 

 
The Traverse Tool 

The Traverse tool has 3 separate methods for alignment creation: Angle, Direction, and Curve.  Each 

of these methods behaves differently so the following discusses each briefly. 
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Angle Method locates new foresight points by specifying the angle and distance from a known 

occupied point and backsighting another point. 

 
Angle Method 

Direction Method locates new points by starting at a known point and going in direction for given 

distance.  For example: from point 1 a distance of 120 ft. at a bearing of N85^50’34”E. 

 
Direction Method 
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Curve Method creates points along curved paths such as lots on curves. 

 
Curve Method 

The Traverse command had several ways to deal with how the new points are added. These options 

are: 

• To COGO Buffer – Creates new points in the geometry COGO buffer. 

• Before Alignment – creates new segments on the active alignment before the beginning of 

the selected element.  COGO points are referred to but not created in the COGO buffer. 

• After Alignment– creates new segments on the active alignment after the end of the selected 

element.  COGO points are referred to but not created in the COGO buffer. 

• Radial - holds the occupied point, computing new coordinate geometry points radially from of 

this point. COGO points are created and placed in the COGO buffer. 

The circumstances of creation will dictate which Insertion Point mode is needed. If alignment modes 

are used, but COGO buffer points are desired, other methods will be required to generate the buffer 

points.  One such tool is Geometry > Utilities -> Assign Names. 

Foresight point options allow the new points names to be specified as well as description and style. 

Course provides an interface to enter the appropriate Direction, distance, etc.  For 2d entry verify 

distances are set to horizontal. 

Close traverse button will create a closed element after other elements have been added. Graphic 

Selection buttons throughout the panel allow screen interaction to set distances, select 

COGO points, and set bearings. Be aware InRoads locks will affect the behavior of these tools.  An 

example of this might be using element lock when picking the direction will allow a graphical pick of 

an existing geometry element to match the bearing. 
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8.5-3 Assign Names 

In addition to using COGO points to create an alignment, alignments can be used to create COGO 

points.  In order to do this, the Geometry -> Utilities -> Assign Names should be used. 

 
Assign Names 

When using the Assign Names tool, one can take a pre-existing alignment and create COGO points at 

each vertex.  In addition to the creation of the COGO points, this tool also associates the COGO 

points to the alignment they’re created from. 

 
Assign Names Tool 

On this panel a few of the items of note: 

• Include – Determines the types of elements to have names assigned, in most instances this 

should be set to Alignments. 

• Name – The name of the element to have names assigned, the values for this entry can be 

either graphically selected or setup using the InRoads Filter command. 

• On/Off-Alignment Points – Specifies the point types to be consumed and assigned names. 

• Method – Determines how points are created.  Assign creates new COGO Points, Delete will 

delete COGO points along an Alignment, and Rename will create duplicated points with a new 

name. 

• Seed Name – Specifies the starting point for the assigned names.  Commonly numeric, this 

value will increment starting at the entered number for each subsequent point in the 

alignment. 
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• Check for Coincident Points – Will cause the alignment association to use an existing point 

when the coordinates are identical to a pre-existing point. 

Upon selection of an alignment, and Applying the selection, COGO points coincident with each point 

of the alignment.  These points can then be used for parcel reporting and other functions.  The 

assign names is especially useful when converting a CAD element into an Alignment and then to 

derive the COGO points off that Alignment. 

8.5-4 Metes and Bounds 

Metes and Bounds is an application add-in best suited for deed entry when data is simply keyed in 

from known deed data.  It can be found under Geometry -> Utilities -> Metes and Bounds. 

 
Metes and Bounds 

On the Metes & Bounds tool, both the Name (of the created Alignment) and description can be 

keyed-in.  The defining style should be set to the appropriate InRoads Style for the type of element 

being created.  To allow for angular deflections, the Maintain Tangency box should be unchecked. 
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The starting point should be selected either via graphical selection or by direct key-in of the starting 

COGO point.  Subsequent segments can then be added and removed by right clicking in the 

Elements section.  When creating each segment, the CAD graphics will update dynamically 

throughout the process.  These fields also allow for the use of mathematical functions directly on the 

tool.  For each segment and vertex, COGO points are not automatically created.  To create these 

points the Assign Names tool discussed in the previous section can be used. 

 
Metes and Bounds 

 
Example of a Completed Alignment/Parcel 
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8.5-5 Traverse Edit 

After Property alignments have been constructed, opportunities to examine/edit them in further 

detail can be achieved with the Traverse edit command.  Traverse Edit is accessed from InRoads 

Explorer -> Geometry -> Utilities -> Traverse Edit. Both the geometry project and horizontal alignment 

can be selected. 

 
Traverse Edit 

The Traverse edit dialog has a number of useful tools/features that may be advantageous during the 

Real Estate workflow: 

• Individual alignment segments can be selected for modification, or for the insertion of new 

segments before or after the selected segment. 

• Traverse closure results such as closing distance, precision, etc. are based on the as entered 

data on the alignment. 

• Using the Map Check option allows for the investigation of Traverses that are not closed. 

• The Adjustments option allows for the elements to be adjusted using mathematic methods 

such as Compass, Crandall, and Transit Rule. 
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When using the Traverse edit command, usage of the Map Check option will initiate the InRoads Civil 

Report Browser.  The default report provided is the generic Map Check format, however there are a 

series of addition reports types that are available and may be more relevant to the data at hand. 

 
Map Check Report Types 

Map Check Report results will resemble those shown below. Report results be saved, printed, or 

copied to other documentation. 

 
Map Check Report Sample 

8.5-6 Other Traverse Command Alternatives 

The following tools can also be used to create parcel (alignment) geometry, each having their own 

merits.  As with all operations, care should be taken to use the appropriate tool from both a usability 

and comfort level: 
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• Geometry -> Utilities -> Metes and Bounds  (Application Add in) 

• Geometry -> Horizontal Curve Set commands 

• Geometry -> Horizontal Element commands 

• MicroStation-> Place Smartline using AccuDraw in conjunction with InRoads import 

geometry. 

HORIZONTAL CURVE SET 

Horizontal Curve Set commands allow for the creation of alignments by specifying the location of 

PI’s.  InRoads will auto connect these elements.  Precision input of PI location can be specified by 

using the MicroStation key in dialog. 

HORIZONTAL ELEMENT 

Horizontal Element commands allow for the creation of alignment elements individually by specifying 

the location of each of the various elements.  Elements are connected together with various 

horizontal element commands.  Precision input of element locations can be specified by using the 

MicroStation key in dialog. 

MICROSTATION AND ACCUDRAW 

Precision input of element data in CAD has long been available in MicroStation using AccuDraw in 

conjunction with Place smartline.  Most often elements are entered using accudraw’s polar mode, 

available by pressing spacebar.  MicroStation design file settings can be adjusted to have angular 

readout set to Bearing, or Azimuth.  Save setting to keep these changes in subsequent sessions. 

Precision input data can be imported to InRoads geometry using File -> import -> Geometry using the 

graphical import method discussed earlier in this chapter. 

8.5-7 MicroStation and Civil AccuDraw 

As a highly flexible solution for creation of coordinate geometry, Civil AccuDraw performs similarly to 

MicroStation AccuDraw but with expanded capabilities to augment any placement tool.  This tool can 

be used in conjunction with the tools discussed in the previous section. 

It is advised to suspend MicroStation AccuDraw when using Civil AccuDraw as much of their 

functionality does overlap.  Should both be active during the element placement process, one may 

witness unpredictable behavior, or results. 

 Make sure to disable the standard AccuDraw tool! 

Locate Civil AccuDraw from the Tools -> Civil AccuDraw -> Active Toolbar menu option in 

MicroStation.  Remember to perform as Save Settings to insure MicroStation will keep this toolbar 

open and located were you placed it from the File -> Save Settings menu option. 
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The Civil AccuDraw Window 

AccuDraw Help is available.  Included in the help is an overview of the specific key-ins that the tool 

accepts, along with information on creating custom modes to streamline the data entry process. 

8.5-8 Translation and Rotation (Transform) 

Alignment information is often available without regard to how it fits into a specific coordinate 

system.  Use of the InRoads command Transform Geometry allows alignments or COGO points to be 

moved, rotated, or scaled accordingly.  This tool allows for the graphical selection of individual 

geometry elements, or has a provision to transform all data contained within the selected Geometry 

Project.  Additionally, this tool can also convert data from one set of units to another, for example 

metric to imperial. 

 
Transformation Types 
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User can select the original Point as well as destination point for translation.  When rotation is 

desired, user may select angle to specify amount of rotation, or by direction mode to specify original 

direction as well as destination direction. 

 
Transformation Dialog 
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8.6 Right of Way Tools 

Through use of previously discussed tools, a project should have both completed property parcels 

and Right of Way alignments that cross them.  Through the use of the Right of Way tool, one can 

create parcel takes and the net or remainder.  This tool can be found under Geometry -> Utilities -> 

Create Right of Way and must be loaded as an Application Add In to be visible.  To load the 

application add-in refer to Chapter 5.5.4 for this process.  This tool in particular is part of the Lot 

Layout Add-Ins as noted in Chapter 8.2. 

 
Create Right-of-Way 

The Create-Right of Way tool allows for the graphical selection of closed alignments, or the multiple 

selection of closed alignments via the Filter option.  The selection of multiple alignments allow for 

the quick processing of a series of parcels when the Right of Way line crosses them.  Additionally, 

these tools are valuable for Right of Way processes for many types of projects including Permanent, 

Temporary, etc.  In addition to this tool creating both the takes and the net/remainders; it can do the 

following: 

• The Cogo Points section allows for the creation of new COGO points at the intersection of the 

parcel and the right of way alignment.  The naming, description, and InRoads style can all be 

defined. 

• The Right of Way section allows for the creation of the Right of Way alignment, while adding 

options for Prefixes and Suffixes.  These are concatenated with the source name.  

Additionally the description and InRoads Style can be defined. 

• The Remainder section allows for the creation of the net/remainder alignment, while adding 

options for Prefixes and Suffixes.  These are concatenated with the source name.  

Additionally the description and InRoads Style can be defined. 
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In order to use the Right of Way tools, the parcel alignments must first be selected.  With these 

showing in the Selected portion of the tool, settings for the Cogo Points, Right of Way and Remainder 

settings should be configured.  The capture on the previous page shows an example of potential 

style names as they exist in the INDOT XIN file. 

With the dialog configured, selecting Apply will send control back to MicroStation with a series of 

prompts in the status bar.  These prompts are as follows: 

1. Identify Right of Way line - This will be the graphical alignment illustrating the Right of Way. 

2. Accept/Reject – A graphical preview of the resulting Right of Way alignment will be shown.  

Left Clicking will create the alignment using the parameters (prefix/suffix/style) as defined on 

the Create Right of Way tool.  Right clicking will result in InRoads will flip the preview to the 

opposite side of the alignment for potential creation. 

With the Right of Way and net/remainder alignments created, the next step is to review the finished 

alignments to verify that all values agree. 

8.6-1 Horizontal Alignment Review 

Horizontal alignment reports (Quick Reports) provide an opportunity to verify what has been created. 

As a follow up to creation of the alignments that are parcel takes, one might want to quickly verify 

the area of the parcels as well as the COGO points passed through.  Quick reports are efficient ways 

to see this information prior to committing to creating documentation style reports. 

To view a Quick Report, simply right click in the workspace bar on the alignment in question. From 

the context menu that appears, select Review.  The quick report dialog will appear. Alternately the 

report can be generated from the Geometry -> Review Horizontal menu option. 

 
Opening a Quick Report 
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Horizontal Alignment Quick Report 
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8.7 Exhibit Creation 

This section will review the process to create Exhibit documents using ProjectWise templates.  This 

will leverage many of the processes spelled out earlier in this chapter, particularly information on 

retrieving data from other sources.  While not specific to survey files, these procedures can be 

extended to gather other data such as the templates referred to throughout this section.  As always it 

is recommended to always begin with the default template documents and not to carry project files 

from one project to the next 

8.7-1a Template Real Estate Documents 

For Real Estate projects, a pair of document templates have been created to facilitate the creation of 

the Parcel Coordinate Charts and Exhibit documents.  As with other templates, these can be found in 

ProjectWise under the Template Documents\Seed folder.  Specifically, they are located under 

MicroSoft Office\Real Estate. 

 
Real Estate Document Templates 

The two templates reside within the above folder 

 
Real Estate Template Files 

When working on Real Estate projects, these files should be copied in as needed.  There may be 

instances where multiple copies of the template are needed throughout the life of the project and 

the files should be renamed accordingly to maintain consistency with other project data. 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/Seed/MicroSoft%20Office/Real%20Estate/
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In addition to the template Microsoft Office documents, a template CAD file has also been created.  

This file contains standardized borders for both portrait and landscape Exhibit documents.  Being a 

CAD based file, there are certain advantages that can be applied.  With the model control in 

MicroStation, it’s possible to host the Exhibit for each parcel in a single file as opposed to a file for 

each parcel.  This cuts down on the required document management; however, it will prevent 

multiple users from working on the same project CAD file at the same time.  In this instance, 

appropriate care should be taken to determine the best workflow. 

The Parcel_Plat_Templates.dgn can be found in ProjectWise under the Template 

Documents\Seed\MicroStation\Real Estate Seed Files (2D only) folder. 

 
Read Estate CAD Templates 

Included in this folder are a series of different files, each of which is described as follows: 

• INDOT_US_2Dseed.dgn - This is a 2d blank CAD file in imperial units.  This file should be 

used to draw up InRoads elements such as the alignments and parcels that are part of a 

project. 

• INDOT_US_SVFT_2Dseed.dgn - This is a 2d blank CAD file in US Survey Foot units.  This file 

should be used to draw up InRoads elements such as the alignments and parcels that are 

part of a project. 

• Parcel_Plat_Templates.dgn – This is the file containing the standardized Real Estate borders 

in both portrait and landscape orientations.  The drawings containing the parcels should be 

referenced into these borders for sheet composition purposes and printing. 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/Real%20Estate%20Seed%20Files%20(2D%20only)/Parcel_Plat_Templates.dgn
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/Real%20Estate%20Seed%20Files%20(2D%20only)/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/Real%20Estate%20Seed%20Files%20(2D%20only)/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/Real%20Estate%20Seed%20Files%20(2D%20only)/INDOT_US_2Dseed.dgn
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/Real%20Estate%20Seed%20Files%20(2D%20only)/INDOT_US_SVFT_2Dseed.dgn
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/Real%20Estate%20Seed%20Files%20(2D%20only)/Parcel_Plat_Templates.dgn
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Real Estate Portrait Border 

8.7-1b Creating an Exhibit Drawing 

The following examples will step through each of the major requirements for creating an Exhibit 

drawing using InRoads, MicroStation, and ProjectWise. 

THE BASE DRAWING 

The first step in the creation of any exhibit is to start with a base drawing.  As referenced in the 

previous section, the appropriate seed file should be located in the Template Documents\SS4 

Seed\MicroStation\Real Estate Seed Files (2D only)\ folder.  These documents can be copied into 

the Real Estate\InRoads folder under the appropriate des using the methods described in Chapter 

2.8 – Creating New Documents. 

With the base drawing created, it should then be opened in MicroStation and InRoads started from 

within the session.  Note that throughout the parcel creation and display process additional 

MicroStation Drawing models should be used to separate data. 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/Real%20Estate%20Seed%20Files%20(2D%20only)/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/Real%20Estate%20Seed%20Files%20(2D%20only)/
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VIEWING PARCELS/HORIZONTAL GRAPHICS 

With a base drawing created, it is now time to start displaying the horizontal alignments that form 

each parcel.  As part of the alignment display process, scaling should be considered and set 

accordingly using the InRoads Global Scale Factors tool as noted in Chapter 5.6 Global Scale 

Factors.  With an appropriate scale selected, the following commands can all be used to display the 

alignment/parcel in the MicroStation display. 

• Right-Click, View – This is performed by right clicking on the parcel name as it exists in 

InRoads Geometry tab.  This will display the currently selected alignment.  The same process 

can be reach through the Geometry -> View Geometry -> Active Horizontal menu option. 

 
InRoads Geometry, Right Click View 

• Right Click, View All Horizontals - This command will display all the horizontal alignments in 

the currently active Geometry project.  It’ is only available by right clicking on the name of the 

Geometry project.  The same process can be found under the Geometry -> View Geometry -> 

All Horizontals menu option 

 
View All Horizontals 
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HORIZONTAL ANNOTATIONS 

With parcels now displayed, annotation may be required to show items such as stationing, COGO 

point names, and alignment names.  Three of the major annotation styles needed are described as 

follows: 

• Geometry -> View Geometry -> View Horizontal Annotation – This command contains the 

bulk of the necessary annotation tools needed throughout the Exhibit creation process.  To 

ease in the usage of this tool, numerous Preferences have been created specifically for Real 

Estate use and can be accessed through the Preference button on the lower edge of the 

panel. 

 
View Horizontal Annotations 

• Geometry -> View Geometry -> Stationing –This tool is used to display the stationing on the 

design alignment. 

• Geometry -> View Geometry -> View Curve Set Annotation – Curve set annotations places 

annotations on horizontal curves.  This is highly useful for displaying Degree of Curve, Radius, 

etc. 
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• Geometry -> View Geometry -> View Closed Areas –This command places area annotations 

on closed alignment elements. 

REFERENCING PARCEL MODELS TO EXHIBIT BORDERS 

With the parcel drawn and annotated, it’s now time to reference this data together with the 

appropriate border.  As discussed previously in this chapter, this can be handled multiple ways.  For 

this example, a model import/referencing process will be reviewed.  Additionally, a separate DGN 

could be used with referencing. 

1. To start this process, the first step will be to make sure that the base drawing with the 

annotated parcel models is open and prepared.  InRoads is not required for this step, and 

does not need to be (or remain) open. 

2. In MicroStation, locate the Models button on the Primary Tools toolbar.  It can also be found 

under the File -> Models command in the MicroStation menus. 

 
Models Button 

3. With the Models dialog open, select the Import Model button.  When prompted, navigate to a 

copy of the Parcel_Plat_Templates.dgn that is either in the Template Documents or that has 

been copied into your project. 

 
Import Models 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/Seed/MicroStation/Real%20Estate%20Seed%20Files%20(2D%20only)/Parcel_Plat_Templates.dgn
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4. This will open the Select Models dialog where the appropriate borders can be pulled from.  

Note that multiple models can be selected, and this can be performed multiple times to get 

the appropriate number of borders for each parcel.  With the appropriate border selected, hit 

OK. 

 
Select Models 

5. Upon completion of the border import, the appropriate border should be made the active 

model by double clicking it’s entry in the Models dialog. 

6. With the border model now imported in and selected, the referencing process can begin.  

This is initiated by selecting the References button from the Standard toolbar. 

 
References 

7. This will open the References dialog, allowing for the attachment of other models or sheets 

from the current or other DGN.  For the purposes of this example, referencing two models 

from the same DGN will be reviewed. 

 
The References Dialog 
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8. Continuing from the previous instructions, both the Models and References dialogs should 

be open.  As the models being referenced are in the same file, a simple drag and drop of the 

appropriate model from one dialog to the other will initiate the attachment process. 

 
Drag and Drop Referencing 

9. Once the parcel model is attached, the Attach Source Files dialog will appear, requesting 

feedback on how the model should be attached.  As additional adjustments are required to 

get the parcel to fit, the Interactive method should be used. 

 
Attach Source Files 
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10. Selecting Interactive allows for the configuration of additional attachment settings prior to 

final attachment placement.  Note that many of these settings can be adjusted to acquire the 

desired results.  The following screen capture shows an example where the parcel will be 

aligned to the border, with a 1”=100’ scale.  As each deliverable is different, these settings 

should be adjusted as needed. 

 
Reference Attachment Settings 

11. At this time, the parcel will be attached to the border using the provided scale and 

orientation, and in most instances will require movement to fall in the appropriate location 

on the border.  To do so, select the Move Reference tool from the References dialog toolbar. 

 
Move References 

12.  The parcel should then be moved to the appropriate location within the border.  Further 

adjustments to scaling or placement could be necessary and should be changed using the 

tools above.  Further parcels/exhibit sheets can be created by repeating the above steps as 

needed. 
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ANNOTATIONS AND DRAFTING NOTES 

Annotation of any InRoads Geometry is available from the usage of the InRoads Plan Drafting notes. 

The behavior of these tools is covered elsewhere, in documentation such as the InRoads ROW 

Fundamentals. 
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8.8 InRoads Reporting 

8.8-1 InRoads and Excel – Parcel Coordinate Charts 

We will examine a method of creating Parcel Coordinate Charts using a combination of InRoads XML 

Reports and Excel. 

Included with each InRoads installation, a customized XML for the parcel coordinate chart has been 

added. This report will provide a listing of points in a parcel, along with the name, reference 

alignment, station, offset, northing and easting.  For added flexibility, we have also created an Excel 

workbook that will process InRoads Report data and provide the correct formatting.  Using Excel in 

the method will create a mechanism to edit various aspects of the documentation without the 

inflexibility of highly customized report. 

8.8-1a The Parcel Coordinate Chart Report 

In order to generate the parcel coordinate chart, a modified version of the InRoads clearance report 

is provided that provides the required information.  With an alignment and parcel created, the XML 

reporting tools will need started in order to acquire our information. 

In order to start the clearance reporting tools, navigate on the InRoads Explorer to Tools -> XML 

Reports -> Clearance… as shown in the following illustration. 

 
Clearance Reporting 
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With clearance report dialog now open, the appropriate data fields need populated.  First is the 

General leaf.  The information on this leaf defines the mainline alignment to derive the parcel 

coordinates from, along with what points in particular should be reported.  In the following 

illustration, one can see that for this particular data set, the mainline alignment is defined as Line 

“A”. 

 
Clearance Report Dialog 

Additionally, as shown, the Include Horizontal Points option has On-Alignment points enabled.  This 

will have the report provide the point information required. 

Next, we need to define our parcels on the Horizontal Alignments leaf. There are two methods that 

can be used to select your parcel.  The first is through the usage of the graphical selector.  The 

second is the use of the Geometry Selection Filter. Briefly reviewing this tool, place your cursor in the 

Include box.  This will enable the use of the Filter button. 

 
Filter Button 

Clicking on the Filter button will bring up the Geometry Selection Filter.  For this dataset, Parcel 1 will 

need moved from the Available to the Selected side of the dialog.  This is done by highlighting the 

appropriate alignment and then selecting the Add button in the middle. 
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Geometry Filters 

With the parcel alignment moved over, select OK to confirm the alignments.  This will then populate 

the Horizontal Alignments leaf. 

As a reminder, nothing should be selected on either the COGO Points or Features tab. When you’re 

satisfied with the setup of the report, select Apply, which will kick off the InRoads Report Browser 

with the default Clearance report selected.  

 
Clearance Report Example 
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For the purposes of the Parcel Coordinate Chart, this is not the appropriate report, however the 

framework for the Clearance report provides the majority of the relevant information.  To streamline 

the coordinate chart creation, a customized report has been provided under the INDOT Real Estate 

leaf in the Report Browser. 

 
INDOT Real Estate Reports 

There are additional report types provided in this location that will be discussed later in this chapter. 

For right now, the Parcel Coordinate Chart report will provide a table that can be sent to Excel for 

formatting and placement back into the DGN. 

With the Parcel Coordinate Chart selected, one will see something similar to the following. 

 
Parcel Coordinate Chart 
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The preceding screen capture shows the full report, which can be sent to a variety of formats for use 

in other documents.  Instead of using one of these differing formats, this content of this chart will be 

copied to the Windows.  In particular, all the data from the leftmost column, first row under the Point 

Name heading, to the last row, rightmost column available should be copied as shown. 

 
Parcel Coordinate Copy 

With this data selected, copying the data to the clipboard can be accomplished by using the Window 

shortcut key Ctrl+C or the rt. click Copy command.  With the copy completed, this next steps are to 

adjust the data into a usable format for the exhibit drawing. 

8.8-1b Parcel Coordinates in Excel 

Even though the InRoads report appears to have the appropriate formatting, it cannot be directly 

pasted into the Exhibit drawing.  MicroStation interprets this formatting using its own formatting 

which is inconsistent from the formatting required.  To resolve this issue, each Real Estate template 

has an Excel workbook under the Real Estate\Documents folder named Parcel Coordinate 

Chart.xlsm.  Alternatively, template copies can be found in ProjectWise under the Template 

Documents\Seed\Microsoft Office\Real Estate location in ProjectWise. It’s recommended that you 

make a new copy of this file each time you need a new parcel coordinate chart and rename it 

appropriately. 

Note:  This is a macro-enabled workbook, which may give a security warning upon opening in Excel. 

Testing has shown that this should not be an issue on standard user accounts, however if errors or 

messages regarding the macros are encountered, please contact CAD Support for assistance. 

With a new, appropriately named copy of the Parcel Coordinate Chart workbook, open the file in 

Excel by double clicking on the file in ProjectWise and checking it out. In the Excel workbook two 

sheets are available. 

 
Parcel Coordinate Sheets 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/Seed/MicroSoft%20Office/Real%20Estate/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/Seed/MicroSoft%20Office/Real%20Estate/
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The first sheet, Parcel Coordinate Chart is where to get the finished formatting from.  The second 

sheet, Paste Coordinate List Here, is where the table data copied to the clipboard from the InRoads 

XML report will be pasted. 

First, we need to navigate to the Paste sheet. As shown, place your cursor in cell A1, where the text 

reads “Paste Here”. 

 
Paste Coordinates Here 

Next, paste the contents of the clipboard at this location.  This can be done either by using the 

shortcut key Ctrl+V, or using the Paste button the Home ribbon. After the table is pasted, the sheet 

will look similar to the following. 

 
Pasted Parcel Coordinates 

Next, navigate back to the first sheet, the Parcel Coordinate Chart.  On this sheet, formatting more 

appropriate for pasting into the plat will be available. This data isn’t in the appropriate format yet.  

The two buttons along the right side of the sheet will bring this data in, format it, and then allow for it 

to be placed back on the clipboard to paste into MicroStation. 
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First, select the Create Parcel Table button, this will bring all the information from the second sheet 

into our table and format it correctly.  As there may be some editing required on this sheet, make any 

adjustments, such as the information regarding the Route Plat location as needed. 

 
Processed Parcel Coordinate Chart 

With the table created and adjusted, it can now be placed back on the clipboard. At this time, the 

Copy Table to Clipboard button can be selected. With the Excel table ready to be pasted, switch back 

to MicroStation, and to the Parcel Plat model which it belongs on. 

As with the Excel process, one needs to paste the chart back into MicroStation.  The same paste 

commands are available as in Excel (Ctrl+V or Edit -> Paste).  With the paste command active, a 

MicroStation command window for Paste OLE Object will be displayed.  MicroStation has the 

appropriate knowledge of what type of information that is being pasted into the file.  Shown below, 

are the recommended settings for pasting the chart.  The other options can be used, but do require 

additional configuration outside the scope of this procedure.  Of particular importance, one needs to 

verify the Method is set to “By Size” and selecting the expand button on the panel, make sure Scale 

is set to 1.0. As always, the chart should be rotated relative to the sheet, Rotate With View should be 

disabled. 

 
Paste OLE Object 
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At this time, a rectangular outline of the chart extents will be displayed in MicroStation and follow the 

cursor.  These extents should be set to an appropriate location, and confirmed by a lt. click. 

 
Paste Extents 

 
Pasted Parcel Coordinate Chart 

With the chart pasted, the files can now be saved, closed, and checked in; and this procedure should 

be repeated as necessary for additional parcels. 
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A few items to note throughout this procedure: 

• If there is a need to recreate the chart in Excel and it has already been used with the Create 

Parcel Table button to bring over the data and reformat it, delete the row that are brought 

over from the second sheet. Make sure the chart header and footer information is left. 

• The pasted picture of the table can be modified in MicroStation like any other element.  

Moving, stretching and other element functions can be used in the usual manner. 

• One can report the coordinates on multiple Parcels by selecting them for reporting.  

Remember that the report is not automatically saved, so if this function is used, it is 

beneficial to save the report to another format so it can be reused at a later time. 

• As a reminder, the Excel workbook is macro-enabled, so any errors should be reported to 

CAD Support. 

8.8-2 InRoads and Word – Exhibit “A” 

In addition to the tools used to generate the Parcel Coordinate Chart, CAD Support has also included 

customized reports to assist in the creation of Exhibit “A” documents. Like the coordinate chart, 

these reports will be used to generate the appropriate information for use in other documents. 

8.8-2a The Property Description Reports 

With our data open from the previous section, again navigate to the Tools -> XML Reports menu on 

the InRoads Explorer.  For the report type in this section, select Legal Description… 

 
Legal Description Reports 
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This will present the Legal Description Report dialog.  As done in previous sections, the relevant 

parcel should be selected in the Alignments section.  This can be accomplished either by a graphical 

selection or by using the InRoads Filter dialog option. With the parcel selected, the dialog will look 

similar to the following: 

 
Legal Description Report 

Remember that multiple legal descriptions can be generated by adding additional parcels to the 

Selected section of the dialog prior to selecting Apply.  Once satisfied with the report configuration, 

the Apply button should be selected to start the Bentley Civil Report browser with the default report 

selected. 

 
Default Legal Description Report 
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This report does provide the basic information required, however it does not reflect the appropriate 

INDOT formatting and verbiage. As with the coordinate chart, navigate in the InRoads Report Browser 

to the INDOT Real Estate folder, this time selecting the Property Description with Points report. 

 
Property Description with Points 

This report is configured to adhere to INDOT wording standards and is setup for placement directly 

into a Word document template. 

 
Property Description Report 
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With the report generated, we will now copy the parcel description text to our clipboard as we did 

with the coordinate chart.  The following illustration shows the area where the text will be selected 

from: 

 
Property Description Copy to Clipboard 

Next, place this data on the clipboard either by using the shortcut key-in Ctrl+C, or rt. clicking on the 

selected text and select copy. With the text on the clipboard it can now be placed into the Exhibit “A” 

template Word document. 

8.8-3 Parcels with a Lead-In 

Due to limitations in the InRoads reporting tools and formatting, if a Lead-In alignment exists for the 

selected parcel, the Property Description Lead-In report will need used in addition to the preceding 

report for the Parcel.  This report is again formatted specifically to adhere to INDOT verbiage for a 

Lead-In alignment.  The process for acquiring this report is identical to the previous example, instead 

of selecting the parcel however, select the lead-in alignment.  This will then be combined with the 

text from the parcel report to generate the finished Exhibit “A”.  Please be aware that one will need to 

adjust wording between the two reports as some information may be duplicated, or incorrect 

depending on the circumstance. 

8.8-4 The Exhibit “A” Word Document Template 

To conform with the appropriate INDOT Exhibit “A” form and to provide as much flexibility as 

possible, each real estate project has a copy of the Exhibit “A” Word document template. As with the 

Excel workbook discussed earlier, this file can be found under the Real Estate\Documents folder of a 

project, or in ProjectWise under the Template Documents\Seed\Microsoft Office\Real Estate 

location. As with the coordinate chart, it is recommended to create a copy of this document for each 

parcel being generated either from the one provided or from the template location.  It’s again 

recommended to rename subsequent copies as necessary to keep track of what parcel each 

document contains. 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/Seed/MicroSoft%20Office/Real%20Estate/
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Navigating to the Real Estate\Documents folder, double click on the Exhibit A Template.docx 

document, checking it out and opening it for editing. 

 
Exhibit “A” Legal Description 

Shown above, the Exhibit “A” has numerous areas where data either needs typed in, or edited from 

the existing.  The first item, however, is the pasting of the legal description from the InRoads report. 

Located in the body of the document, find the text “Paste Parcel Report Here” and select it so the 

report data can be pasted over it. When selected, one can either use a Ctrl+V to paste the text 

directly in, or you can use the Paste button on the ribbon. Depending on the method used, there will 

be supplemental steps required to match the formatting. 

8.8-5 Using the Word Paste Button 

To easily match the formatting of the existing text, the Paste button the ribbon provides the preferred 

method.  Selecting the drop arrow below the clipboard button will provide a menu with the following 

options: 

 
Paste Special 
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For this example, one should use the Paste Special… option.  Once the dialog is presented, select 

the Unformatted Text option.  This will have Word strip all formatting off the clipboard text from the 

report and use the existing formatting present.  

 
Paste Special 

8.8-6 Rt. Click /Ctrl+V Pasting 

Alternatively, one can use either a rt. click or the Ctrl+V shortcut key to paste the legal description. 

Should this method be used, the existing formatting must be matched. 

As illustrated, when initially pasted in, the text is rather small, in Arial and not italicized.  This is the 

formatting provided by the InRoads report. After initially pasting this information in, one will see a 

small clipboard after the last character pasted. 

 
Pasting Method 

By selecting this drop menu, one can then determine the appropriate formatting to be used. In this 

instance, the Match Destination Formatting option should be used; this will cause the text to assume 

the existing formatting in the correct manner. 
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As this method is only available immediately after the text is pasted, it is entirely possible to miss the 

opportunity to adjust the text in this manner.  Should this happen, one could then use the Format 

Painter tools to match the format.  To use this, place the cursor in a section of text that matches the 

formatting needed, for this example, the line of text at the bottom of the body can be used.  Next, 

select the Format Painter tool on the Home ribbon: 

 
Format Painter 

After selecting the tool, one needs to then highlight the text and then select the text that should be 

changed to the new format.  This will adjust the text as necessary. 

8.8-7 Exhibit “A” Title and Signature 

To ease the entry of data into the title and signature areas of the Exhibit A, CAD Support has 

modified the document to use embedded tables for text alignment.  In the title area, if one enables 

the borders, it would look similar to the following: 

 

Table with Borders Enabled 

Every field is editable, and prior to completion, one should fill them out as needed.  The default 

template doesn’t have the borders enabled, but the cells are aligned so that one should be able to 

easily pick where to enter data. 
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The signature area behaves in much the same way. With the cell borders turned on, the alignment is 

as shown: 

 
Signature Block with Borders Enabled 

The cell on the right is for the placement of the PE/LS stamp using imagery included in ProjectWise. 

To insert the PE/LS Stamp, use the Insert/Picture on the ProjectWise ribbon tab with the cursor in 

the appropriate location. 

 
Pasting Pictures from ProjectWise 

This will open the ProjectWise browser where one can select your PE/LS Stamp image.  These can be 

found in the INDOT Workspace\PE Stamp Images folder. If a stamp doesn’t exist, please contact CAD 

Support with the information so one can be created. 

At this time, select the appropriate stamp and hit open, this will place and appropriately sized image 

of the stamp.  The remainder of the items on this sheet should be edited by hand, as the InRoads 

reporting tools cannot take this information into account. 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/INDOT%20Workspace/PE%20Stamp%20Images/
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Upon completion, the Exhibit should look similar to the following: 

 
Sample Exhibit Sheet 

With the legal description pasted, the file can now be saved, closed, and checked in and then 

repeated to create additional Exhibits as necessary.  One can report the coordinates on multiple 

Parcels by selecting them for reporting. 
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8.9 Report Settings - Unit Format and Report Defaults 

In the previous sections, discussion has looked at procedures for generating different InRoads 

reports and their associated documents using customized reports.  In either situation, one may 

notice that InRoads may have sent them to a specific report, or that unit readout may have been 

incorrect.  The following sections discuss how to adjust these settings should one like to incorporate 

the customized reports as defaults and adjusting unit readouts. 

8.9-1 Default Reports 

Each InRoads report type under the Tools -> XML Reports menu item has a corresponding report 

default in the InRoads report browser. Depending on function, one may wish to change these to a 

more suitable report for the workflow. 

The first step is to open the InRoads report browser using the Tools -> View XML Reports… tool on 

the InRoads Explorer.  This will start the report browser without the need to actually create and 

configure a report. With the report browser now open, one can now navigate down to the INDOT Real 

Estate folder in the report browser and set the reports to the default report types when running 

Clearance or Legal Description reports. 

To start, set the Parcel Coordinate Chart report as the default clearance report.  With the browser 

open to the appropriate location, rt. click on the Parcel Coordinate Chart.xls, which will present a list 

of menu items, and then select Set as Default Clearance. 

 
Setting Default Reports 

By doing this, each time one run a Clearance report from the Tools -> XML Reports -> Clearance… 

tool, the Parcel Coordinate Chart will be the first report option taken to in the browser. Be aware that 

the reporting is dynamic, so even though InRoads will send one to the default report defined, it can 

select different reports which will automatically be updated based on the previously defined criteria.  

This will only work if the reports are for the same tools, so in this case one would only get data on. 

In regards to the Exhibit A/Legal Description, one would perform the same procedure only assigning 

one of the Property Description reports under the INDOT Real Estate folder (Property Description with 

Points would be best suited) as the Default Legal Description report that consumes information from 

the Clearance tools. 
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8.9-2 Report Unit Format 

During the first run of reports, one may find that the unit readouts do not appropriately reflect the 

number of significant figures required for the report.  To adjust these settings, again on the InRoads 

Report Browser, navigate to the Tools -> Format Options… button from the menu. 

 
Format Options 

On the presented panel, one will find numerous settings to adjust the coordinate readout to 

whatever formatting is required. 

 
Format Options 

These settings will be saved between sessions, so one can adjust them initially and they will become 

the default for subsequent sessions. In the event that the installation be upgraded/reinstalled or 

new PC be received, these settings will have to be reconfigured. 
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9. MicroStation Plans Production 

9.1 Resurface Plans 

The following sections discuss MicroStation and Microsoft Excel resources to be used in the 

development of a set of resurface plans. 

Resurface plans can be composed of one .dgn file with multiple sheet models, or several .dgn files 

each having a single sheet model.  Regardless of the method that is used to create these plans, they 

should be produced using the 8.5” x 11” borders available in the Ltr_Sheets.dgn template file. 

pw:\\indot-pw.bentley.com:indot-pw-01\Documents\Template Documents\DGN\Ltr_sheets.dgn 

 

Ltr_sheets.dgn Location 

This file contains a title sheet model, along with a set of 4 sheet models that can and should be used 

to develop each of the sheets in a set of Resurface Plans.  These sheet models are: 

- Ltr. Title Sheet. This sheet model is the standard title sheet to be used with 8.5” x 11” plans. 

- Ltr. Detail.  This sheet model is a standard, empty 8.5” x 11” border sheet oriented in 

portrait.   

- Ltr. Landscape Detail.  This sheet model is a standard, empty 8.5” x 11” border sheet 

oriented in landscape.   

- Ltr. Detour Sheet Signing. This sheet model is available to be used for the Recommended 

Detour Signing sheet. 

- Ltr. Index  This sheet model is for index sheet content. 

For each of these sheets, there is a corresponding version for the placement of an engineer stamp. 

These plan sheets should follow all drafting standards as specified the INDOT CAD Standards 

Manual, available for download from the INDOT CAD Support web page.  See the Indiana Design 

Manual for information regarding the sheet content. 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/DGN/Ltr_sheets.dgn
http://www.in.gov/indot/design_manual/files/INDOT_CAD_Standards.pdf
http://www.in.gov/indot/design_manual/files/INDOT_CAD_Standards.pdf
http://www.in.gov/indot/3084.htm
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9.1-1 Ltr. Title Sheet 

This sheet model should be used as the title sheet for all plans created using the 8.5” x 11” format.  

This and all other sheet models in Ltr_Sheets.dgn takes advantage of attribute exchange information 

which allows population of fields using the Universal Title sheet. 

While in the open MicroStation file, import the sheet model titled Ltr. Title Sheet model from 

Ltr_Sheets.dgn.    When you open the newly imported sheet model, it will appear as shown in the 

illustration below. 

 

 

9.1-1a Placing the Location Map 

Refer to Chapter 10 for instructions on placing a location map on this sheet. 

9.1-1b  Placement of County Cells and Project Location Symbol 

Placement of the county cell and project location symbol are accomplished by using INDOT Tools 

within the MicroStation tasks tool bar. 

1. Select INDOT Tools → Cell Libraries → County District Maps from the Task bar in 

MicroStation. 
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2. Within the Cell Library, navigate to and double left mouse click on the appropriate county or 

counties. 

 
3. For 8.5” x 11” plans, you will need to set the X and Y scales to 0.50 

 
4. Place the active cell by using the lower left corner of the Project Location box as your hook 

point. 
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To place the location symbol, use MicroStation commands to copy the symbol from within the Project 

Location box to its correct positioning. 

 

9.1-1c Universal Title Sheet  

The Universal Title Sheet is used to populate portions of the 8.5” x 11” Title sheet.  This information 

should only be edited using the Universal Title Sheet to insure that that information is populated 

throughout the entire set of plans. 

The Universal Title Sheet is access within ProjectWise by selecting the Attributes Tab of the 

Properties dialog box of MicroStation design file (.dgn) and ensuring that the Interface is set to 

_PROJECT INFORMATION 

 

See Chapter 2 for more information regarding use of the Universal Title Sheet.  
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9.1-2 Ltr. Detail and Ltr. Landscape Detail 

These sheet models are standard, empty 8.5” x 11” border sheets oriented in portrait and 

landscape.  This border sheet can be used for any drawing detail or table in a set of resurface plans.  

While in the open MicroStation file import the sheet model titled Ltr. Detail Model from 

Ltr_Sheets.dgn.    When you open the newly imported sheet model, it will appear as shown below.   

Text outside of the border is populated with the Universal Title Sheet.  The title of the sheet is edited 

by changing the description of the sheet model within the Model Properties dialog box.  Draw or 

reference details into the area within the border. 

      

Ltr Detail Sheets w/PE Stamp 
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9.1-2a Editing the Sheet Title. 

1. Within MicroStation (you do not need to be in the target sheet model) open the Models 

Properties dialog for the target sheet model. 

 
2. Edit the description of the sheet model to reflect the title of the drawing Detail 

 
3. The title change will be reflected in your sheet model. 
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9.1-3 Ltr. Detour Sheet Signing 

This sheet model was set up to be used for the Recommended Detour Signing sheet.  This sheet 

model is pre-populated with a standard signing legend and uses the Universal Title Sheet to populate 

the route into the title of the sheet. 

While in the open MicroStation file import the sheet model titled Ltr. Detour Sheet Signing Model 

from Ltr_Sheets.dgn.    When you open the newly imported sheet model, it will appear as shown 

below. 
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9.1-4 Miscellaneous Tables and Strip Maps 

During the process of creating a set of plans on the 8.5” x 11” border sheets, you will need to add 

various summary tables and or strip map.   

9.1-4a Miscellaneous Tables 

INDOT has provided a template Microsoft Excel file that contains several different tables that are 

commonly used (and some not so commonly used) on resurface plans.  These Excel tables have 

been formatted to be cut/pasted into the provided sheet models at a 1:1 scale. 

The Microsoft Excel Tables are available in ProjectWise at… 

pw:\\indot-pw.bentley.com:indot-pw-01\Documents\Template Documents\Seed\Spreadsheets\ 

Instructions for each table are included on each sheet within the Microsoft Excel file.  Once 

completed, the tables can then be copied and pasted into a MicroStation sheet model. 

Copy and Paste Tables into Sheet Model. 

1. Complete the Excel spreadsheet and select the area that you wish to copy into a sheet 

model.  Then either Right Click → Copy with your mouse or enter Ctrl + C on your keyboard to 

copy that information. 

 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/Seed/Spreadsheets/
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2. In the target sheet model, select Edit → Paste  

 
3. Select the area in which you want to paste the table in the sheet model using tentative 

snaps.  This will paste a picture of the table in the sheet model.  This image is not editable.  

To edit the table you will need to edit the spreadsheet file and then repeat the copy – paste 

operation. 

 

Due to ProjectWise functionality, it’s highly recommended that users not embed or link Excel sheets.  

There are two major issues that make these processes undesirable: 

• Embedding – With an embedded spreadsheet, the CAD file must be open and then the Excel 

content opened from within the DGN.  Additionally, one cannot link data across sheets with 

embedded Excel content. 

• Linking – Due to the way ProjectWise functions with unique working directories for all users, 

linking will not work for any users other than the link creator. 
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9.1-4b Strip Maps 

Additionally, as part of a set of Resurface Plans, per the Indiana Design manual a Strip Map is 

required.  This should also be created using either the Ltr. Detail or Ltr. Landscape Detail sheet 

model(s). 

Examples of a typical Strip Map are shown here. 

 

9.1-4c Page Numbering and Electronic Signatures. 

Please refer to Chapter 4 of this document to review usage of ProjectWise InterPlot Organizer to 

make use of automatic page numbering and electronic Signatures. 

  

http://www.in.gov/indot/design_manual/files/INDOT_CAD_Standards.pdf
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9.2 Traffic Plans Production 

9.2-1 Signs Signals and Lighting Plans 

The following sections discuss MicroStation resources to be used in the development of a set of 

Traffic plans for Signs Signals or Lighting. 

Traffic plans can will normally start from one of two different DGN Seed Files.  These can be the US 

Survey Foot Seed File (INDOT_US_SVFT_seed.dgn) or the US Unit Seed File (INDOT_US_seed.dgn).  If 

the project is newer and has survey related data, a geocoordinated version of one of these files will 

be found in the Survey Project Files folder.   

 
Example Geocoordinated Seed Location 

The previous screen capture shows an illustration of where you might find the Geocoordinated Seed 

files if your project has been setup.  This should be the first location where seed files should be 

located.  If there is no survey data and the project has not been geocoordinated, the files will need 

selected from the Template Documents location shown below.  Regardless of which unit of measure 

you select or which file you are creating you should create the file using the Advanced Document 

Creation Wizard. 

pw:\\indot-pw.bentley.com:indot-pw-01\Documents\Template Documents\SS4 Seed\MicroStation\ 

9.2-2 Base Sheet Creation from Various Seed Files 

In order to make sure all documents start off with the appropriate metadata, and to enable such 

features including automatic sheet population; all documents should be created using the Advanced 

Document Wizard.   

For Traffic Plans, locate the Des Number\Signs Signals and Lighting\MS folder.  With this folder 

selected, the Document Pane will show the folder contents as they exist currently.  To create a new 

document, right click in the document pane and select New -> Advanced Wizard. 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/Seed/MicroStation/INDOT_US_SVFT_seed.dgn
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/Seed/MicroStation/INDOT_US_seed.dgn
pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/
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Starting the New Document Advanced Wizard 

This will initiate the Advanced Document Creation Wizard dialog. 

 
Selecting the Advanced Wizard 
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The first panel is informational and can be bypassed (Next).  The second panel confirms your 

location.  If for some reason you didn’t have the correct folder active in your document panel, you 

can select it now or confirm the path shown. 

 
Location Confirmation 

The next panel allows you to select the template document you’d like to use.  On the first line “Use a 

ProjectWise document as a template” option.  Press the select button. 

 
Select a Template dialog 

In the “Select Template Document” panel, navigate to the MicroStation Seed files in the ProjectWise 

System and select the appropriate unit files for your project.  These files can be found at:  

 

pw:\\indot-pw.bentley.com:indot-pw-01\Documents\Template Documents\SS4 Seed\MicroStation\ 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/SS4%20Seed/MicroStation/


 

522  

 

Or if your project is provided with Survey Geocoordinated Seed files, look under the Des 

Number\Survey\Project Files folder as discussed earlier in this section. 

 
Selecting the Proper Seed File 

With your file selected, you can then proceed to the next screen.  If you are prompted for Document 

Attributes, you may proceed beyond this screen as well, however it may be advantageous to populate 

the contents of this panel for any of the information you may already have.  Below is a sample of the 

type of information that’s configured for the auto sheet population for title sheets. 

 
Auto Sheet Population Panel 
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The final step in creating the document is to provide a name.  Traffic Signal Plans should be 

consistently titled with the following format: Des #_ Traffic Signal Plans.dgn.  To ease document 

searches and for consistency purposes, all three names should be the same as shown. 

 
Document Properties and Naming 

With the document named, you may now proceed through the remaining panels of the wizard and 

complete creating the document. 

9.2-2a Document Creation via Drag and Drop 

In addition to the Advanced Wizard, you can also create files using drag and drop.  To do so, you can 

open the Seed location in another window (right click, Open in New Window) and then drag the file 

from the seed location to your active project folder.   

 
Drag and Drop File Creation 

At this time you’ll be prompted if you want to use either the Advanced or No Wizard options.  If you 

select advanced, you’ll be prompted through the steps from the previous section.  No Wizard will 

bring the file into the location you’ve specified without an opportunity to adjust naming, etc. 



 

524  

 

9.2-3 Traffic Plans Creation 

With a template document now created, the Traffic Plans can start being assembled.  The first 

portion of the Traffic Plan composition is the creation of the project title sheet.  The first method of 

creation will be from pre-existing plan images. 

9.2-3a Creating the Design from As-Built Plan Image 

To start this process, first go back to the DGN that was created earlier in this section, Des#_Traffic 

Signal Plans.dgn.  Open the file from ProjectWise and switch to a new model.  For more details on 

creating/editing models, please refer to Appendix C of this document, or the MicroStation help file. 

In a new model, start by opening the Raster Manager: 

 
Start Raster Manager 

After initiating the Raster Manager from one of the two locations shown above, the Raster Manager 

dialog will be displayed.  On this dialog, select the Attach Reference command from the File menu or 

toolbar as shown: 

 
Attaching a Raster 
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Next, locate the scanned/PDF copy of the As Built Plans for the project.  As with most other project 

deliverables, these should be uploaded to ProjectWise for easy location, management, and security.   

 
Locating the As Built Reference 

During the attachment process, make sure that the Raster is attached at a 1:1 scale.  It’s very 

important that the raster be attached this way in order to determine the necessary scale factor to 

rescale the raster by. 

At this time, scaling of the As Built needs determined in order to draft the elements true scale.  In 

order to determine the scale, locate some of the dimensioned elements on the raster and measure 

them using the MicroStation measurement tools. 

 
MicroStation Measurement Tools 
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To determine the scale factor needed to upscale the raster by, take the as dimensioned 

measurement from the drawing and divide it by the measured value using the MicroStation tools.  

For example the following illustration shows a dimensioned line that is listed at 19.5’.  The 

MicroStation tools measured this to be displayed as 0.0752’.  To calculate the scale factor, divide 

the dimensioned by the measured (19.5’/0.0752’) resulting in a scale factor of 259.31. 

 
Raster Scaling 

With the raster now scaled properly, one can now start drafting based on the As Built raster.  Using 

the standard MicroStation drawing and Level tools, trace the geometry on the appropriate levels as 

provided in the DGNLib.  These levels include the _TRAF_ prefix and can be filtered using the DGNLib 

filters as shown. 

 
Traffic Proposed and Existing Filters 
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Setting the Active Level, Color, and Linestyle 

Once completed tracing the As Built information, the Raster Image can be detached.  Do so by 

opening the Raster Manager, and highlighting the As Built, and either Right Click -> Detach, or from 

the File -> Detach menu option shown below.  

 
Detaching a Raster 

At this point, the Traffic Plans should be completed using standard MicroStation tools.  Later in this 

chapter, a review of sheet creation will occur.  First however, brief explanations of alternate plan 

creation methods will be discussed. 
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9.2-3b Creating Traffic Plans Without As Builts 

In many projects, it’s quite common to start a project without any As Built data.  In this instance, 

alternate sources of data can be used in order to have a raster image background from which the 

geometry can be traced.   

As with the previous section, start by creating a new model.  Once prepared, start the Raster 

Manager as discussed in the previous section.  

In this instance, an As Built will not be available.  In lieu of this, the INDOT GIS department has made 

available a listing of WMS Web Map Services.  These map services are discussed further in Chapter 

10, however a brief overview of the attachment process is provided here. 

The first step is to select the File -> Attach -> WMS: 

 
Attaching a WMS Map 

On the presented Attach Raster Reference File dialog, navigate to the XWMS folder in ProjectWise.  

This folder is located at:  

pw:\\indot-pw.bentley.com:indot-pw-01\Documents\Resources\XWMS\ 

Select the CADStreetAnno.xwms, and the 2011_2013 Statewide Imagery.xwms and select OK.  

Please note that the GIS staff is constantly acquiring and processing new imagery, so newer versions 

of these maps may be available, especially the Full Res images.  Check often if new images have 

been made available. 

Note:  When using the rasters, the following issues may be encountered: 

1. The 2011_2013 Statewide Imagery.xwms may have performance issues during usage.  This 

is a known issue and cannot be resolved by CAD or GIS Support staffs. 

2. The Orthos Full Res 2005.xmws perform very well, but are out of date. 

3. Each set of rasters has benefits and disadvantages, use the Orthos that fit your project 

needs for the best experience. 

pw://dotwise.indot.in.gov:DOTWise/Documents/Resources/XWMS/
pw://indot-pw.bentley.com:indot-pw-01/Documents/Resources/XWMS/
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WMS Raster Attachment 

With the images now attached, MicroStation will start streaming the images based on where your 

view is located.  It’s highly recommended to zoom all the way out so the entire state map is visible, 

and then Zoom down to the intersection. 

With the location of the intersection found, go back to the Raster Manager.  Highlight the 

CADStreetAnno.xwms, and then select Display -> Bring to Front from the Raster Manager toolbar. 

 
Bringing the CADStreetAnno.xwms to the Front 

At this time, the extraneous raster imagery needs cropped out.  Select the clip tool from the Raster 

Manager toolbar and then crop just the rasters to just the needed area. 
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Raster Clipping 

 
Clipped Rasters 

Next, the rasters need to have their geolocation enabled so they display in the correct spot on the 

DGN.  To do so, set the Option to Not Inherited under Geometry (as shown below), so that image falls 

into place. 
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Setting the GeoCS to Not Inherited 

At this point, the plan development process is the same as in the previous example.  Trace the 

geometry using the appropriate symbology, and detach the rasters when completed. 

9.2-3c Traffic Plans when Survey or Design Data is Available 

In this instance, the traffic plans process will start from pre-existing data directly in a MicroStation 

format.  As was discussed earlier in this chapter, the first place to look for a seed file in this instance 

will be under the Survey\Project Files folder for the project. 

At this time, the Survey Geometry can be used directly from the TOPO drawings.  Note that there are 

a variety of methods to get and use this data: 

• The data can be referenced and traced. 

• The data can be referenced, and merged. 

• The data can be referenced and copied directly. 

Depending on the method chosen, the data must be modified to the appropriate symbology for 

Traffic Plans and the development process can occur. 

The above processes are also valid when working on Traffic Plans that are part of a broader Design 

project.  In this instance, instead of using the TOPO, the pavement markings will be used in the same 

fashion listed above. 

At this point for all 3 methods, it’s time to take the created Traffic Plan and place it appropriately in a 

MicroStation border. 

9.2-3d Creating the Detail Sheet 

The final steps for completing the Traffic Plans is the creation of the Detail Sheet for the project.  

Working out of the Signals Plan drawing, import a separate Arch D size sheet model using Models 

tool with appropriate sheet border.  These borders can be found in the D_size_sheets.dgn located in 

ProjectWise at: 

pw:\\indot-pw.bentley.com:indot-pw-01\Documents\Template Documents\DGN\D size_sheets.dgn 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Template%20Documents/DGN/D%20size_sheets.dgn


 

532  

 

 
Locating the D_size_sheets.dgn 

With the border file located and opened, select the appropriate border from the list to Import into the 

Open dgn.  For example, the SG_Detail Sheet. 

 
Selecting the Detail Model 
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This will bring a copy of the model into the active drawing.  Select this newly imported model and 

open the Reference Attachment dialog: 

 
Attaching a Reference 

Next, reference in the model containing the Intersection design as required to the appropriate scale 

(1”-20’ or 1”-30’ As per IDM).  Note that an alternative method would be to drag and drop the model 

from the Models dialog to the References dialog. 

 
Intersection Attachment 

This concludes the Traffic Plans development process.  At this time, the final file is prepared for 

plotting using the tools discussed in Chapter 4 of this document. 
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10. Using Imagery with CAD and the Map Insert Application 

10.1 WMS and Aerial Imagery 

10.1-1 Introduction to WMS 

A Web Map Service (WMS) is a standard protocol which provides georeferenced map images over 

the Internet that have been created by a map server using data from a GIS database.  At INDOT the 

map data is obtained from the ArcGIS Server.  MicroStation or Bentley Map via InRoads can then be 

used to connect to the WMS.  The INDOT WMS server connections have already been established 

and preset WMS map definitions (XWMS files) have been created for the available images.  Currently 

the available map definitions are NAIP 2008, NAIP 2010, NAIP 2012, NAIP 2014, NAIP 2016, Ortho 

2005, Quad 24k, 2011_2013 Statewide Imagery, Best Available (which is a constantly updated map 

containing the most recent and highest resolution imagery, currently the 2011/2013 images), and 

Most Recent Available Imagery (which is the most recent imagery available, but is not survey grade 

and will show differences in geocoordinated data situations).  These preset map definitions are 

located in ProjectWise at the following location:  Documents\Resources\XWMS. 

Note:  In MicroStation SS4/SS10 there is a bug pertaining to XWMS imagery attachments in a 

nested references.  If you encounter any instances of a CAD file where certain models will not open, 

please submit a ticket to CAD Support for assistance.  Additional resources on what to do if this 

occurs can also be found later in this section. 

10.1-2 Open existing Map Definition 

1. Open a MicroStation or Bentley Map session within ProjectWise.  Under the File dropdown 

menu open Raster Manager, as shown below: 

 

  

pw://indot-pw.bentley.com:indot-pw-01/Documents/Resources/XWMS/
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2. On the Raster Manager window select File -> Attach -> WMS. 

 

3. ProjectWise’s Attach Raster Reference File window appears.  In ProjectWise navigate to 

pw:\\indot-pw.bentley.com:indot-pw-01\Documents\Resources\XWMS\.  Within this folder, 

select the XWMS resource file you need to attach. 

 

4. Once the XWMS file has been selected, select Add -> OK. 

 

pw://indot-pw.bentley.com:indot-pw-01/Documents/Resources/XWMS/
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5. In the Raster Attachment Options window make adjustments to options as desired, and then 

select Attach at the bottom of the window. 

 

6. The image is now attached to the DGN as shown in the Raster Manager window. 

 

10.1-3 WMS Raster Attachment Issues 

Per the note earlier in this section, MicroStation SS4 has an inconsistent bug pertaining to the 

attachment of WMS imagery and is particularly prevalent when this imagery is displayed through a 

nested attachment (such as plan sheets cut via InRoads, or situations where the reference is 

manipulated and fit to a border sheet).  In this section, we will briefly discuss three methods that can 

be used to alleviate the impact of this bug. 
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10.1-3a Saving the DGN in a Model without WMS Imagery 

The most common occurrence of this issue is when loading up a file with nested WMS reference 

attachments in a fresh session of MicroStation/InRoads.  If this occurs, please contact CAD Support 

so we can assist in getting the file so it will open.  Once that has been done, the potential for the 

issue to recur is relatively high.  The first method to alleviate this is to make sure a model without 

imagery is the last one opened and where you File -> Save Settings prior to checking the file back in.   

10.1-3b Controlling Raster Display via References 

The next option to help with this issue is to use reference control to change where you’re controlling 

the display of the WMS imagery from.  In the following steps, we will look at example with the raster 

attached to a base drawing, but then using files that reference it to control when it’s displayed. 

1. The first step is to go into your base sheet with the raster attached.  On the Raster Manager, 

locate the .xwms file you need, and ensure that its display is disabled for all views (1-8) as 

shown. 

 

2. With the raster disabled, do a File -> Save Settings and check in your file.  Note that you can 

turn the raster on and off as needed, but it should be left off prior to checking the file in. 
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3. In the sheets that are referencing the base drawing, open the Raster Manager.  In this 

example, we’re looking at a double plan sheet, so there are two instances of the raster 

reference shown.  The display for these can be re-enabled in this file as needed in the same 

location where we disabled them in the base sheet. 

 

Using this method, we have seen greatly decreased instances of the bug occurring but it still allows 

for flexibility in the attachment method and usage of referencing to get it located properly. 

10.1-3c Descartes Tools 

In some situations, it might possibly be easier to just export the necessary portion of the WMS image 

to a separate file.  In this situation, the tools provided by the Descartes application can be used 

(Tasks -> INDOT Tools -> Applications -> Load Descartes) to create these files. 

With Descartes loaded, the primary tool is under the Edit -> Merge menu on the Raster Manager.   

1. Start off by placing a fence or shape around the area you want to turn into an image.  Keep in 

mind that areas that aren’t rectangular will expand to a rectangular shape and the maximum 

extents of the shape. 

2. Start the Merge command.  If you used a shape select its boundary, if you used a fence, 

make sure to select the checkbox for Use Fence. 

3. With the shape/fence selected, the Merge Options dialog will be displayed.  This dialog will 

allow you to select a number of options such as resolution, what should be created as the 

final attachment (image, image plus linework, linework only) and the file type.  It’s highly 

advised to review the options for this dialog in the Descartes help file under the Help -> 

Contents menu on the Raster Manager. 

This tool will create a direct raster attachment to your dgn which will not result in causing the WMS 

image bug.  Care should be used as the imagery files created in this way do have the possibility of 

becoming incredibly large and taking substantial amounts of time to check in/out of ProjectWise. 
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10.2 Map Insert Application 

1. Locate the INDOT-Info linkset on the MicroStation Project Explorer.  As shown, the Map Insert

Link will be available

2. Click on the Map Insert link or copy the following URL to the web browser navigation (INDOT

Map Insert (arcgis.com).  NOTE: The Map Insert Tool prefers Chrome or Firefox

3. At startup the entire State of Indiana is displayed.  To zoom in to a specific area of the state

you can use the mouse wheel.  By clicking the left mouse button and holding it down you can

pan the view.

4. Searching:  To zoom to a desired location, enter one of the following: county name, district

name, project des#, or address. You may optionally select the type of search in the drop

down.

https://indot.maps.arcgis.com/apps/webappviewer/index.html?id=54f54997312b44bea5765e6fcd223fa7
https://indot.maps.arcgis.com/apps/webappviewer/index.html?id=54f54997312b44bea5765e6fcd223fa7
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5. The layer list toolbox allows you to toggle on/off which layers are displayed in the view.  Use

the arrows to expand the main folders in the list (Projects and Map Insert), and the

checkboxes to toggle the layers on/off.  Several of the layers are off by default, which means

they will not be visible until you check the box to make them visible.

6. Once you have the area of interest displayed and the desired layers turned on, use the Print

widget to create the Map Insert image.

7. Select the applicable Layout and Format for the exported map.  You may need to test the

sizes to find the desired output.

8. Type a title for the map in the Map title text box.  Note: The MAP_ONLY format prints only the

map, omitting any marginal information from the output.

9. For additonal Printing options, click Advanced.

a. The following options are available:



541 

i. Map scale/extent—Defines the method that the print service uses to

calculate the printed extent of the map.

ii. Preserving map scale causes the printed map to maintain its scale while

recalculating the extent around the existing center point. Preserving map

extent causes the scale to adjust to fit the current map extent onto the

printed map. You can also force a specific scale by clicking the Force

scale option and providing a scale. Click current to populate the value with

the present scale of the map.

iii. Output spatial reference WKID—Defines the output spatial references of the

print by specifying a valid well-known ID (WKID).

iv. Layout metadata—Allows you to override the default values set in the

configuration.

v. Specify values for the Author and Copyright properties to provide current

information to the print service. Check the Include legend check box to

display the legend on the printed map.

vi. MAP_ONLY size—If the Map_Only format is selected, you can provide

dimensions for the Width and Height properties in pixels. Otherwise, these

values are ignored.

vii. Print quality—Allows you to update the resolution of the printed map.

viii. Provide an updated value for the DPI (dots per inch) in the text box.

ix. Feature attributes—If Include attributes is checked, the feature's attributes

are included in feature collection layers. This is only applicable to custom

print services that use the feature attributes, for example, to display a table

of features and their attributes.

10. After all options have been set with the applicable values, click Print to submit all information

to the print service.

A progress bar displays next to the executing task. 

Upon completion of the print job, a link to the print output displays. 

11. Click the task to open the file in a new window.

12. Click Clear prints to clear the print history.

Note: The date and time format of the printout is based on the location of the printer. 

https://developers.arcgis.com/javascript/3/jshelp/ref_coordsystems.html
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11. Appendices 

11.1 Appendix A - Naming Conventions 

Good naming is required to alleviate many problems when sharing data.  The following are 

recommended names for various design resources.  The following naming conventions can be 

applied to either DGNs themselves or the models contained in a DGN. 

Note:  Throughout Appendix A, LineB is used to indicate a generic alignment 

11.1-1 InRoads DTM Names 

Uniform model naming is necessary to insure consistency between users and to allow for continuity 

when projects are passed from one designer to another, or when multiple designers work on the 

same project.  The following list is compiled based on historically used models/surfaces at INDOT. 

Tables begin on the next page: 
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DTM Name Contents 

Des Proposed design Strings 

Des LineA Proposed design Strings for line LineA 

Des Alignments Proposed Alignments 

Des Culvert Box & Three Sided Culverts Structures 

Des Pipes Drainage Culverts Structures 

Des Drive Drives (if separated from other design strings) 

Des Subgrade LineA Subgrade model for line LineA 

Des TEMP RUNAROUND Temporary Runaround Strings 

Underdrain LineA Underdrains 

Hydraulic Surface LineA Ditches 

Sections LineA Cross Sections for line LineA 

Survey alignment Alignments Created by Survey Unit 

Volumes LineA Volumes calculated along LineA 

Topo Existing Topography information from Survey 

(provided by the Survey Unit) 

Topotria Triangulated Topo model 

Excont Existing Contours (provided by the Survey Unit) 

Prcont Proposed Contour Models 

Merge LineA Model containing design strings from LineA and 

topo strings outside the limits of the design 

Existing Terrrain Completed and cleaned up Terrain Model surface 

as created and exported from the OpenRoads 

Terrain, provided by Survey 

Annotation Surface DTM containing all surveyed features, not to be 

used for 3D analysis, provided for surface 

annotation only by Survey 

Alternate Naming, Used for larger more complex projects 

Des Roads Contains Proposed Design strings for all 

alignments 

Des Final Contains all proposed design strings with all gaps 

and editing completed 

Merge Roads Model containing design strings from all 

alignments and topo strings outside the limits of 

the design 

Merge Final Model containing design strings from all 

alignments and topo strings outside the limits of 

the design 

Note:  Not every project will need every type of suggested model nor is the user restricted to only 

create the models listed above.  Many additional temporary models can be created while using the 

GUI. 
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11.1-2 MicroStation Drawing/Model Names 

As with the previous section, these are only recommended names for files.  Please keep in mind that 

these can be applied to individual DGN models when one doesn’t create a DGN for each file type. 

Note:   Please abbreviate .dgn/model names as needed using the INDOT standard abbreviations  

I.e. Sht – Sheet, MOT - Maintenance of Traffic, etc 

nn is used to denote the drawing number when there are multiple DGNs (or sheet files) for the same 

type of drawing.  Users should note that it is acceptable to create multiple sheet models within a 

single DGN, thus eliminating the need for multiple DGNs with the same description/drawing file 

name. 

Description Drawing File Name Examples 

Road Project 

Title Sheet Sht Title.dgn  

Drawing Index and General 

Notes 

Sht Index.dgn  

Typical Cross Sections Sht Typical_nn.dgn Sht Typical_07.dgn 

Survey Route (Plat No. 1) Sht Plat1_nn.dgn Sht Plat1.dgn 

Sht Plat1_05.dgn 

Survey Route Plat with Aerial 

Photography (Plat No. 3) 

Sht Plat3_nn.dgn Sht Plat3.dgn 

Sht Plat3_05.dgn 

Geometric Tie-Up Sht Geometric Tie_nn.dgn Sht Geometric Tie.dgn 

Sht Geometric Tie_01.dgn 

Traffic Maintenance Details Sht MOT_nn.dgn Sht MOT 02.dgn 

Plan and Profile Sht PlanProfile_scale_nn.dgn Sht PlanProfile_50_01.dgn 

Superelevation-Transition 

Diagram 

Sht Super_nn.dgn Sht Super.dgn 

Sht Super_01.dgn 

Details   

Construction Details Sht Const Detail_scale_nn.dgn Sht Const Detail_30_01.dgn 

Intersection Details Sht Intersection_scale_nn.dgn Sht Intersection_30_01.dgn 

Spot Elevation Details Sht Spot Elev_nn.dgn Sht Spot Elev.dgn 

Sht Spot Elev_01.dgn 

Channel Details Sht Channel_nn.dgn Sht Channel_01.dgn 

Geometric Details Sht Geom Detail_nn.dgn  

Right-of-Way Details Sht ROW Detail_nn.dgn Sht ROW Detail.dgn  

Sht ROW Detail_01.dgn 

Grading Plan Sht Grading_scale_nn.dgn Sht Grading_30_01.dgn 

Drainage Details Sht Drainage_nn.dgn Sht Drainage_01.dgn 

Erosion and Sediment 

Control Details (plan view)  

Sht TEC_scale_nn.dgn Sht TEC_30_01.dgn 

Retaining Wall Details Sht Retaining Wall_nn.dgn Sht Retaining Wall.dgn 

Sht Retaining Wall_01.dgn 

Wetland Mitigation Details Sht Mitigation_scale_nn.dgn Sht Mitigation_30_01.dgn 

Traffic-Work Details   

Signs (if separate traffic-sign 

plans are not required)  

Sht Signs_nn.dgn Sht Signs.dgn 

Sht Signs_01.dgn 

Signals Sht Signal_scale_nn.dgn Sht Signal_30_02.dgn 
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Lighting (if separate lighting 

plans are not required) 

Sht Lighting_nn.dgn Sht Lighting.dgn 

Sht Lighting_01.dgn 

Pavement Markings Sht Pvmt Markings_scale_nn.dgn Sht Pvmt Markings_30_03.dgn 

Road Summary Sheet Sht Road Summary.dgn  

Description Drawing File Name Examples 

Bridge Project 

Title Sheet Sht Title.dgn  

Index Sht Index.dgn  

Typical Cross Sections Sht Typical Cross Sections.dgn  

Traffic Maintenance Details Sht MOT_nn.dgn Sht MOT_02.dgn 

Traffic Detour Details Sht Detour_nn.dgn  

Temporary Runaround 

Details 

Sht Runaround_scale_nn.dgn Sht Runaround_50_02.dgn 

Road Plan and Profile Sht PlanProfile_scale_nn.dgn Sht PlanProfile_50_01.dgn 

Superelevation-Transition 

Diagram 

Sht Super_nn.dgn Sht Super.dgn 

Sht Super_01.dgn 

Roadway Details (see Road 

Plan sheets) 

  

Traffic-Work Details (see 

Road Plan sheets) 

  

Soil Borings Sht Borings TB_nn.dgn Sht Borings TB_01.dgn 

Channel Change Layout Sht Channel_nn.dgn Sht Channel_01.dgn 

Layout Sht Layout_scale_nn.dgn Sht Layout_30_01.dgn 

General Plan Sht General Plan.dgn  

Structure Details Sht Structure.dgn  

Abutment/Bent/Pier Details Sht End Bent Details_nn.dgn 

Sht Pier No x_nn.dgn 

Sht End Bent Details_02.dgn 

Sht Pier No 2 and 3_01.dgn 

Framing Plan Sht Framing Plan.dgn  

Structural Steel Details or 

Precast-Concrete Beam 

Details 

Sht Beam Details_nn.dgn Sht Beam Details_01.dgn 

Bearing Details Sht Bearings.dgn  

Superstructure/Floor Details Sht Superstructure_nn.dgn Sht Superstructure_02.dgn 

Railing Details Sht Railing Details.dgn  

Screeds Sht Screed_nn.dgn Sht Screed_02.dgn 

Reinforced-Concrete Bridge 

Approach Details 

Sht Approach Slab Details nn.dgn Sht Approach Slab 

Details_02.dgn 

Bridge Summary Sht Bridge Summary.dgn  

Road Summary Sht Road Summary. dgn  

Pipe Materials Sht Materials.dgn  

Cross Sections Sht Xsec_scale_nn.dgn Sht Xsec_50_03.dgn 
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Description Drawing File Name Examples 

Traffic-Signs Project 

Title Sheet Sht Title.dgn  

Index and General Notes Sht Index.dgn  

Signing Plan Sht Signing Plan_nn.dgn Sht Signing Plan_01.dgn 

Sign Layout Sht Panel Sign Layout_nn.dgn 

Sht Sheet Sign Layout_nn.dgn 

Sht Panel Sign Layout_01.dgn 

/ Sht Sheet Sign 

Layout_01.dgn 

Cross Sections Sht Sign Cross Sections.dgn  

Sign Summary Sht Panel Sign & Post 

Summary_nn.dgn 

Sht Sheet Sign & Post 

Summary_nn.dgn 

Sht Panel Sign & Post 

Summary _01.dgn 

Sht Sheet Sign & Post 

Summary_01.dgn 

Footing Details Sht Signal Footing Details.dgn  

Structural Details Sht Structural Details.dgn  

Signalization Project 

Title Sheet Sht Title.dgn  

Index and General Notes Sht Index.dgn  

Signal Plan Sht Signal Plan.dgn Sht US 41 & SR 57 Signal 

Plan.dgn 

Signal Details Sht Signal Details.dgn  

Lighting Project 

Title Sheet Sht Title.dgn  

Index and General Notes Sht Index.dgn  

Lighting Plan Sht Lighting Plan.dgn  

Cross Sections Sht Lighting Cross Sections.dgn  

Lighting Details Sht Lighting Details.dgn  

 

The following files are required as part of the GIS Data Standards and Validation process.  More 

information on this process can be found in Chapter 9, Section 4. 

GIS Deliverables 

GIS Existing Plan Des #_GIS_explan_stg #.dgn  

GIS Proposed Plan Des #_GIS_prplan_stg #.dgn  

GIS Right of Way Plan Des #_GIS_rwplan_stg #.dgn  
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Standard Base Drawings 

Drawing Names / 

Logical Names 

Descriptions / 

Reference Descriptions 

Examples 

Survey Alignment Survey Centerline Survey Alignment.dgn 

Survey Section Corner US Government Section 

Corners 

Survey Section Corner.dgn 

Survey Contours Survey Existing Contours Survey Contours.dgn 

Survey Topography Survey Existing 

Topography 

Survey Topography.dgn 

Survey Triangulation Existing Triangulation Survey Triangulation.dgn 

Explan scale 

 

Design Existing 

Topography 

Explan 50.dgn 

Explan 100.dgn 

Design Alignment Design Alignment Design Alignment.dgn 

Prplan scale  Proposed Design Strings Prplan 50.dgn 

Prplan 100.dgn 

RW Existing scale Existing Right of Way RW Existing 50.dgn 

RW Existing 100.dgn 

Annotate Alignment LineB 

scale 

Proposed  Alignment 

Annotation 

Annotate alignment LineB 50.dgn 

Annotate alignment LineB 100.dgn 

Annotate Survey 

Alignment LineB scale 

Survey Alignment 

Annotation  

Annotate survey alignment LineB  

50.dgn 

Annotate station offset 

LineB scale 

Annotation of Survey 

points with station and 

offset 

Annotate station offset LineB 

50.dgn 

Annotate survey points 

LineB scale 

Annotation of Survey 

points 

Annotate survey points LineB 

50.dgn 
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Standard Sheet Drawings 

Drawing Names Descriptions Examples 

Planprofile LineB scale n Plan & profiles drawings  Planprofile LineB 50 001.dgn  

PlanProfile LineB 50 002.dgn 

PlanProfile LineB 50 n.dgn 

Layout LineB scale n Bridge layout sheet Layout LineB 50 001.dgn  

Layout LineB 50 002.dgn 

Layout LineB 50 n.dgn 

Const det LineB scale n Construction details  

drawings 

Const det LineB 50 001.dgn  

Const det LineB 50 002.dgn 

Const det LineB 50 n.dgn 

Pvmt Markings scale n Pavement marking details Pvmt Markings 50.dgn 

Pvmt Markings 50 01.dgn  

Pvmt Markings 50 02.dgn 

Pvmt Markings 50 n.dgn 

Runaround LineB scale n Temporary Runaround 

plan profile drawings.   

Runaround LineB 50 001.dgn  

Runaround LineB 50 002.dgn 

Runaround LineB 50 n.dgn 

TEC det LineB scale n Temporary Erosion Control 

details 

TEC det LineB 50 01.dgn 

TEC det LineB 50 02.dgn  

TEC det LineB 50 n.dgn 

Intersection Det scale n Intersection details Intersection det 50 n.dgn 

 

For Sheets created by InRoads, the pertinent Plan Profile Generator Preference should set the 

default naming appropriately.  If this name is incorrect, adjust as necessary. 

For all of the above InRoads created sheets, the alignment name, scale, and sheet number indicates 

which alignment, scale, and sheet number is reflected.  Following this convention will allow easy 

differentiation between alignments and scales. 
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11.2 Appendix B - MicroStation Libraries 

11.2-1 DGN Library 

A DGN library is a DGN file used to store: 

• Text styles 

• Dimension styles 

• Levels (Filters) 

• Models 

These are shared within the workgroup as standards.  A DGN library is sometimes referred to as a 

DGN lib (pronounced with a long 'I'). The recommended file extension for this file is *.dgnlib. 

Cells/Models, dimension styles, levels, and text styles are created in a DGN library using 

MicroStation tools, the same way they are created in a DGN file. INDOT DGN libraries are now 

automatically attached as part of the ProjectWise Managed Workspace.  Be aware that if you’re not 

working out of ProjectWise, INDOT specific tools, levels, and customizations will not be available to 

you. 

11.2-2 Text Styles 

11.2-2a What is a Text Style? 

MicroStation supports text styles and provides an interface for constructing text using available 

system fonts and a wide variety of text attributes. A text style comprises a group of text attributes, 

such as font type, width, height, and color. Text styles enable you to place text within a model in a 

consistent and automated manner. 

The following fonts are supported natively in MicroStation: 

• Traditional MicroStation fonts 

• TrueType fonts 

• AutoCAD Shape fonts (.shx)  

Tip1.  Fonts are not embedded in the DGN file.  

Tip2.  If a specific font is not found on the system, MicroStation substitutes font #127, Fast Font. 

Tip3.  If a Text Style changes in a Text Style library, Text Styles placed in DGN files prior to the change 

are not automatically updated in the DGN files. To update a DGN file to reflect the changes in the 

Text Style library, use the dgnlib to Update from Library from the text styles dialog. 

11.2-2b INDOT Text Styles 

Text styles at INDOT have been changed in this new workspace to be more in line with their size and 

use rather than related to the section of INDOT as in previous workspaces.  With the release of this 

version of the workspace, INDOT has now standardized the use of Tahoma as the primary font used, 

except in limited circumstances. 

You will notice that the Text Styles are now using only True Type fonts.  This gives us more flexibility 

with Bold and Italics settings.  The Bentley fonts will only be provided where necessary and will not 
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be available for new projects.  The following tables will show you the settings for each Text Style 

provided as part of the INDOT Workspace.   

Text Style Name Font 
Height 

(in.) 

Width 

(in.) 
Notes/Guidelines for Use 

Text Styles for D-Size Plan Sheets 

10 Point Text Tahoma 0.10 0.10 May be used for table data. 

10 Point Text 

(Existing 

Elevations) 

Tahoma 0.10 0.08 

(Italic, Color 222) 

Use for existing-grade elevations on grid of 

plan and profile view. 

10 Point Text 

(Survey Text) 
Arial Narrow 0.10 0.10 

(Color 225) 

Use for selected survey text. 

12 Point Text Tahoma 0.12 0.12 

Use for text callouts, dimensions, and 

notes.  Minimum size for text placed on D-

size plans other than text specified under 

10 Point Text. 

14 Point Text Tahoma 0.14 0.14 
Use for selected text on title block, view 

subtitles, and column headings in tables. 

14 Point Text 

(Property Owners) 

Bookman Old 

Style 
0.14 0.14 Use for parcel-owner text only. 

18 Point Text Tahoma 0.18 0.18 
Use for detail and section titles, and table 

titles on detail sheets. 

30 Point Text Tahoma 0.30 0.30 
Use for selected text on title sheet of 

plans. 

GIS Annotation – 

Full Size 
Tahoma 30 30 

Used for annotation of GIS Required 

elements and provided for legacy 

compatibility. 

Text Styles for Ltr-Size Plan Sheets 

6 Point Text Tahoma 0.06 0.06 

May be used for table data, existing-grade 

elevations on grid of plan and profile view, 

and selected survey text. 

7 Point Text Tahoma 0.07 0.07 

Use for selected text on title block. 

Column headings in tables, and parcel-

owner text. 

7 Point Text 

(Survey Text) 
Arial Narrow 0.07 0.07 

(Color 222) 

Use for selected survey text. 

9 Point Text Tahoma 0.09 0.09 

Use for text callouts, dimensions, notes, 

column headings in tables, and parcel-

owner text.  Minimum size for all text 

placed on letter-size plans, other than text 

specified under 6 Point Text. 

12 Point Text Tahoma 0.12 0.12 
Use for selected text on title sheet of 

plans. 

14 Point Text Tahoma 0.14 0.14 
Use for detail and section titles, and table 

titles on detail sheets. 

NOTES: 

1. All styles are set to 0.65 (exact) line spacing. 

2. All styles are Center-Center justified initially. 
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3. All styles are non-bold and non-italic and should remain so unless indicated otherwise above. 

(Values in the preceding chart are representative of a 1 to 1 scale) 

There are additional styles provided from the Bentley default configuration.  These named styles 

come from other application sources and are not used in the INDOT workflow and should not be 

removed as they are used as part of other default application configurations. 

11.2-3 Dimension Styles and Settings 

MicroStation dimension styles allow you to save dimension settings by name. This allows for greater 

unity between groups of dimensions in the file, as several different styles can be used for various 

models or portions of a model. Dimension styles are managed through the Dimension Styles Settings 

dialog box.  

11.2-3a INDOT Dimension Styles 

As with Text Styles, we have made significant changes to our Dimension Styles at INDOT.  The first 

change you will notice is the Dimension Styles Settings dialog box is different.  It gives the users 

more options and breaks the settings down into categories like Geometry, Units, and Text.  There is 

also a preview window at the bottom allowing you to preview the style prior to using it.  We have 

combined all of the old V8 Dimension Styles into 23 styles (7 for full size sheets, 5 for letter size 

sheets, 2 for architectural sheets, and 9 for standards drawings).  These Dimension Styles relate to 

the size of text and are linked to the appropriate Text Style.  The following tables will show you the 

settings for each Dimension Style that is used in the plans production process:  

 

Text Styles 
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Dimension Style 

Name 
Text Style Units Notes / Settings 

Dimension Styles for D-Size Plan Sheets 

Arch 12 Point Text 

MU label-SU label, 

round to nearest 

1/16 

Arrow terminator, 

no text frame 

Arch_Struc 30 Point Text 

MU label-SU label, 

round to nearest 

1/16 

Arrow terminator, 

no text frame 

Engr Arrow 12 Point Text 
MU label,  

round to nearest 0.01 

Arrow terminator, 

no text frame 

Engr Arrow Line 12 Point Text 
MU label,  

round to nearest 0.01 

Arrow terminator, 

line text frame 

Engr Circle 12 Point Text 
MU label,  

round to nearest 0.01 

Circle terminator, 

no text frame 

Engr Circle Line 12 Point Text 
MU label,  

round to nearest 0.01 

Circle terminator, 

no text frame 

Engr None 12 Point Text 
MU label,  

round to nearest 0.01 

No terminator, 

no text frame 

GIS Notation 

GIS 

Annotation – 

Full Size 

MU label,  

round to nearest 0.01 

Arrow terminator, 

no text frame 

Dimension Styles for Ltr-Size Plan Sheets 

Arch Ltr 9 Point Text 

MU label-SU label, 

round to nearest 

1/16 

Arrow terminator, 

no text frame 

Engr Arrow Ltr 9 Point Text 
MU label,  

round to nearest 0.01 

Arrow terminator, 

no text frame 

Engr Arrow Line Ltr 9 Point Text 
MU label,  

round to nearest 0.01 

Arrow terminator, 

line text frame 

Engr Circle Ltr 9 Point Text 
MU label,  

round to nearest 0.01 

Circle terminator, 

no text frame 

Engr Circle Line Ltr 9 Point Text 
MU label,  

round to nearest 0.01 

Circle terminator, 

no text frame 

Engr None Ltr 9 Point Text 
MU label,  

round to nearest 0.01 

No terminator, 

no text frame 

NOTES: 

1. All styles are set to use Working Units. 

2. All styles are set to Dynamic Justify text notes. 

(Values in the above chart are representative of a 1 to 1 scale) 
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11.3 Appendix C - MicroStation Advanced References 

11.3-1 Models 

A Model gives you the ability to store multiple independent sets of design data within the same file.  

(See Appendix A for recommended naming) 

11.3-1a Model Properties 

   

Model Properties dialog box for Sheet (left), Design (center), and Drawing (right) 

Type 

Sets the model's type (Sheet, Design, or Drawing) and dimensionality (2D or 3D). 

Name 

Sets the model's name. 

Description 

Sets the model's description. 

Ref Logical 

Sets the Reference Logical name for the model. The logical name identifies the model when the DGN 

file is attached to another file as a reference (see the Reference Attachment Setting dialog box). 

Annotation Scale 

Switching to InRoads has changed philosophy in regards to the use of annotation scale.  Any non-

InRoads sheet will continue to use these tools, however those sheets generated either with the Plan 

and Profile Generator or those created from the Cross Sections tools are maintained at 1:1 scale 

with the borders scaled up to the data.  In these instances, all features, including linestyles, are 

scaled independently of the Annotation Scale settings. 
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Display Sheet Boundary 

(Sheet Model only) If on, a sheet element will display in the new sheet model. 

Size 

(Sheet Models only) Sets the sheet size. Standard sheet sizes are available from the drop-down 

menu, or you can select Custom and input your own size values in the H and W fields. The H and W 

fields are disabled when a standard sheet size is chosen. 

Origin 

(Sheet Models only) Sets the origin of the sheet. 

Rotation 

(Sheet Models only) Sets the rotation angle of the sheet, measured in degrees counter-clockwise 

from the x-axis (horizontal). 

Can be placed as a cell 

If on, it is possible to place the model as a cell. (Should be checked by default) 

Cell Type 

Sets the cell type (Graphic or Point). This option menu is enabled only if Can be placed as a cell is on. 

OK 

Accepts the changes and closes the dialog box. 

Cancel 

Closes the dialog box without making any changes. 

11.3-2 Drawing Scale 

The Drawing Scale window is used to adjust drawing scale settings. These settings are particularly 

relevant to the process of creating sheet models for drawing production. 

To open the Drawing Scale window, navigate to MicroStation > Settings > Drawing Scale. 

Drawing Scale window  

The Drawing Scale window is a dockable window that contains controls for viewing and/or modifying 

working units, the annotation scale factor, and the Annotation Scale Lock.  
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Drawing/Annotation Scale Dialog 

 

Drawing/Annotation Scale Docked 

The units that display in the Master Units and Sub Units option menus can be customized by editing 

the file "units.def". The scale factors that display in the annotation scale option menu can be 

customized by editing the file "scales.def" (do not attempt to edit this file). 

Note: The selection of controls displayed in the Drawing Scale window can be customized by right-

clicking in the window. The technique is the same as that for showing and hiding tools in tool boxes. 

Master Units (option menu) 

Sets the Master Units component of working units. 

Sub Units (option menu) 

Sets the Sub Units component of working units. 

Annotation Scale (option menu) 

Sets the annotation scale factor.  

Annotation Scale (Icon) 

Sets the Annotation Scale Lock. When this lock is on, the annotation scale is applied to any text that 

is placed in the model. 

Scaling Definitions 

The following charts represent the scales defined in the scales.def file. 

Note: The scales in this chart are to be used on metric sheets or US sheets (straight ratio) as well as 

metric base drawings when setting the annotation scale. 
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Scale Name  Scale Factor 

Full Size 1=1 1:1 

6"=1'-0" 2:1 

3"=1'-0" 4:1 

1 1/2"=1'-0" 8:1 

1"=1'-0" 12:1 

3/4"=1'-0" 16:1 

1/2"=1'-0" 21:1 

3/8"=1'-0" 32:1 

1/4"=1'-0" 48:1 

3/16"=1'-0" 64:1 

1/8"=1'-0" 96:1 

1/16"=1'-0" 192:1 

1/32"=1'-0" 384:1 

1"=10' 120:1 

1"=20' 240:1 

1"=30' 360:1 

1"=40' 480:1 

1"=50' 600:1 

1"=60' 720:1 

1"=100' 1200:1 

1"=200' 2400:1 

1"=300' 3600:1 

1"=400' 4800:1 

1"=500' 6000:1 

1"=600' 7200:1 

1"=1000' 12000:1 

11.3-3 Reference Files and Models 

With the emphasis of the use of Models at INDOT it is very important to understand how they are 

used and how they can be referenced within a dgn (self referencing), to another DGN, and back 

(Cyclical referencing).   

11.3-3a Using References 

Elements in a reference display as though they were in the active model. Although you cannot 

manipulate the elements in a reference, you can snap to them and even copy them into the active 

model. 

The most common usage of references is in the creation of design compositions. Design 

compositions are used by engineers and other technical professionals to communicate through the 

visual content of their designs. 

To create a design composition using MicroStation, you build a design model consisting of a working 

collection of references used in the performance of particular engineering tasks. For example, you 

may attach as references a collection of survey points as a guide for placement of additional 

geometry. Reference attachments in a design composition are usually coincident. 

It is sometimes convenient to refer to one part of a model while drawing in another area by attaching 

the active model to itself. 
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You can attach a redline file created using Bentley Redline to your model for reviewing purposes. 

Another common usage of references is in the creation of drawings for publication. This task is called 

drawing composition. Whereas a design composition is typically contained in a design model, a 

drawing is composed in a sheet model. 

11.3-3b  Attaching references 

The most common way to attach a reference is to attach it coincidentally, which means that the 

coordinates of the referenced model's design plane and optionally its Global Origin are aligned with 

those of the active model, without any rotation, scaling, or offset. 

To attach a reference coincidentally: 

From the File menu, choose Reference. (The References dialog box opens.) 

 

References Dialog 
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1. From the dialog box's Tools menu, choose Attach. Or In the Reference dialog box, right-click 

in the list box and choose Attach from the pull down menu. (The Attach Reference dialog box 

opens.) 

 

ProjectWise Attach Reference Dialog 
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2. Select the DGN file that contains the model to attach as a reference and click ADD and then 

click OK.  (The Attach Reference Settings dialog box opens.) 

 

Reference Attachment Settings 

3. (Optional) From the Model option menu, choose the model to attach. 

4. The default is the reference's master model. 

5. (Optional) (unless the selected model is already attached) In the Logical Name field, key in a 

brief name for the attachment. 

6. (Optional) In the dialog box's Description field, key in a description of the model. 

7. To align the reference with the active model with regard to both Global Origin and design 

plane coordinates, select Coincident - World in the Orientation list box. This option is 

available only when referencing a model in a DGN file. Or To align the reference with regard 

to design plane coordinates only, select Coincident in the Orientation list box. 

8. (Optional) In the Scale (Master:Ref) fields, define the ratio of the active model's Master Units 

to the referenced model's Master Units. For example: 

To set  Left  Right  

One active model master unit per referenced model master unit (the 

default).  
1  1  

Five active model master units per referenced model master unit.  5  1  
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Note: Since the same model can be attached many times, give the references logical names and 

descriptions that help you remember which reference is which. 

11.3-3c Working with nested references 

When a MicroStation design file used as a reference has its own attachments, they become nested 

references. The links between these files can be maintained through many levels (depths) of nesting, 

so that if you open only one file, you can view the contents of many files. The individual references 

can be updated, and the changes will be shown in the master (or parent) file. When you attach a 

parent reference to your model and turn on live nesting, you can also control how many levels of 

nested references are attached to the model. 

To attach a reference with live nesting 

1. In the Primary tool box, click the References icon. (The Reference dialog box opens.) 

 

References Dialog 

2. In the dialog box's tool bar, select the Attach Reference tool. (The Attach Reference dialog 

box opens.) 

 

ProjectWise Attach Reference Dialog 
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3. Select the DGN file that contains the model to attach as a reference, and click OK.  (The 

Attach References Settings dialog box opens.) 

4. From the Nested Attachments options menu, choose Live Nesting. 

5. The Nested Attachments options are only available when the selected model has referenced 

attachments. When the Live Nesting option is on, the hierarchical structure of any nested 

references are maintained when attaching the parent reference to a model. In MicroStation, 

a nested attachment is displayed only if the child reference does not have its Ignore 

Attachment When Live Nesting setting turned on (in the Attachment Settings dialog box), and 

the parent reference has Live Nesting enabled. 

6. In the Nest Depth field, enter a high value (for example, 10). 

7. Set the depth setting to a high number to include even the most deeply nested references. 

Although the nested attachments will display in the view window, you will see only the parent 

reference in the References dialog box's list box. 

Nested Attachments 

Determines if referenced models attached to reference models (and so on) are recognized when a 

model is attached to the active model. 

• No Nesting — Models attached to the attached model are not recognized in the active model. 

• Live Nesting — Models attached to the attached model are recognized in the active model. 

• Copy Attachments — Models attached to the attached model copied into the active model. 

When working in a DWG or DXF file, live nesting is always on, and there is no limit to nest depth. 

Therefore the Nested Attachments and Depth items are disabled. To control the display of nested 

attachments, use the Ignore Attachment When Live Nesting setting (on the Attachment Settings 

dialog box). 

Nest Depth 

Sets the number of levels of referenced models that are recognized. Models can have their own 

referenced models, which, in turn, can have more referenced models, and so on. 

If Depth is set to 0, only the model is attached to the master model; referenced models in the 

referenced model are ignored. 

MicroStation V8i includes the ability for live nesting of reference files.  Essentially this means that 

referencing a file causes its children (and potentially their children) to be automatically referenced as 

well.  For example, a MicroStation design file a.dgn has a single reference b.dgn that is attached as a 

standard attachment. In MicroStation, it is possible to attach a.dgn as a reference and include the 

display of b.dgn (in c.dgn) or to disable the display of children by turning off live nesting (in d.dgn).  
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Nested Reference Map 
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11.3-4 Levels 

In the new unified workspace environment we have taken and combined the levels from all previous 

workspaces to eliminate redundancy and establish consistency throughout the agency.  The total 

number of levels is now well over 650.  Due to the large number of levels, Filters can be used to limit 

the level list to only those levels needed. 

11.3-4a Level Classifications 

With the large number of levels that now exist in the INDOT CAD Workspace; a new level naming 

scheme has been created to assist in filter creation, and for consistent creation and categorization of 

levels.   

Example: P_RDWY_Guardrail 

• P_ - First Position Prefix, indicates that the level contains information related to Proposed 

work 

• RDWY_ - Second Position Prefix, indicates that the level contains information related to 

Roadway Features 

• Guardrail - Brief Description, indicates that the level contains line work specifically related to 

Guardrail 

 

The following table lists the new level classifications: 

First Position Description Second Position Description 

G_ Ground Surface SURF_ Surface Features 

P_ Proposed EW_ Earthworks Features 

RW_ Right of Way HY_ Hydraulics Feature 

S_ Survey (TOPO) RDWY_ Roadway Feature 

XS_ Cross Section ALG_ Alignment 

CG_ COGO Points BR_ Bridge Features 

PROF_ Profile Features CTRL_ Survey Control 

ST_ Standards Drawings DR_ Drainage Features 

PP_ Plans Production PROP_ Property Features 

BD_ Border RW_ Right of Way 

E_ 

Existing Features (non-

Survey) TOPO_ Topographical Features 

CC_ Construction TRAF_ Traffic Features 

XT_ Cross Section Template UTIL_ Utility Features 

  G_ Graphical Feature 

  TC_ Template Component 

  E_ Existing Feature 

  OBJT_ Object (Standards Only) 

  ANNO_ Annotation (Standards Only) 

  REFR_ Reference (Standards Only) 

  TTLB_ Title Block (Standards Only) 
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  TXT_ Text 

  SHT_ Sheet 

  TL Template Library 

  EC Erosion Control 

  PVMT Pavement 

 

11.3-4b Level Filters 

Filters are a useful way to group associated levels for the purposes of viewing or not viewing as a 

group. For example, you might have a DGN file with several hundred levels. Within these levels could 

be filters for different disciplines such as Bridge and Traffic. Within Bridge there might be levels for 

proposed or existing elements. You could easily define a filter called Bridge that would show only 

levels that would be associated with Bridge work. 

Filters can be named, saved, and recalled as needed or defined on-the-fly for immediate one-time 

viewing using the Filter Row in the Level Manager dialog box. Filters can be turned on or off using the 

Level Display dialog box. Filters can be used to turn on or off levels across a model and all of its 

attached models.  

Levels can be filtered by a number of attributes such as filename, color, style, line weight, and level 

groups, to name a few. To display the levels that are defined in a filter, select the Active Level filter 

button from the Attributes toolbar and select the filter of choice.  This will display those levels only 

and turn off all other levels in the dgn.  Note that the levels will not actually be turned on or off, but 

the ability to view them in the Level Display will be dictated by the filter selected.   

DOTWise now offers an updated set of filters for use within the CAD Workspace.  Due to the updated 

level naming convention, levels are now filtered by categorization instead of rigidly defined level 

definitions.  The following table explains the qualifications for the new filters: 

Filter Name Description 

_IN Bridge Level name contains _BR_ 

Bridge - Existing Level name starts with S_BR_ or E_BR_ 

Bridge - Proposed Level name starts with P_BR_ 

_IN COGO Level name starts with CG_ 

_IN Cross Section Components Level name starts with XS_TC_ 

_IN Drainage Level name contains _DR_ 

Drainage - Existing Level name starts with S_DR_ or E_DR_ 

Drainage - Proposed Level name starts with P_DR_ 

_IN Erosion Control Level name contains _EC_ 

Erosion Control Proposed Level name starts with P_EC_ 

_IN Rehab Custom Level filter as specified by Bridge 

Rehab 

_IN Right of Way Level name contains RW_ 

Right of Way - Existing Level name starts with S_RW_ or E_RW_ 

Right of Way - Proposed Level name starts with RW_ 

_IN Roadway Level name contains _RDWY_ 

Roadway - Existing Level name starts with S_RDWY_ or E_RDWY_ 

Roadway - Proposed Level name starts with P_RDWY_ 
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_IN Sheet Component Level name contains BD_, PP_, XS_G_ 

Sheet Component - Border Level name contains BD_ 

Sheet Component – Cross Section Level name contains XS_G_ 

Sheet Component – Plans Production Level name contains PP_ 

_IN Standards Level name starts with ST_ 

_IN Survey Level name starts with S_ 

Survey - Bridge Level name starts with S_BR_ 

Survey - Drainage Level name starts with S_DR_ 

Survey - Property Level name starts with S_PROP_ 

Survey - Right of Way Level name starts with S_RW_ 

Survey - Roadway Level name starts with S_RDWY_ 

Survey - Surface Level name starts with S_SURF_ 

Survey - Survey Control Level name starts with S_CTRL_ 

Survey - TOPO Level name starts with S_TOPO_ 

Survey - Traffic Level name starts with S_TRAF_ 

Survey - Utilities Level name starts with S_UTIL_ 

_IN Text Levels Level names contain TXT, Text 

_IN Traffic Level names contain _TRAF_ 

Traffic – Existing Level names start with E_TRAF_ or S_TRAF_ 

Traffic – Proposed  Level names start with P_TRAF_  

_IN Triangulation and Contours Level name starts with G_SURF_ 

 

11.3-5 Design File Settings 

Under Settings> Design File you will see the following screen: 

 

Design Files 
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Active Angle 

Sets the Active Angle — the angle, in degrees, used with tools that require an angle specification, 

including the Place Line, the Place Active Cell, the Place Text, the Rotate, and the Construct Array.  If 

Angle Lock is enabled, the Active Angle is rounded to the nearest multiple, in degrees, of the 

specified tolerance. 

Active Scale 

Consists of controls that are used to set the active scale factors and to toggle Scale Lock. 

Angle Readout 

Controls how angular measurements are reported. 

Axis 

Consists of controls that are also available in the Axis section of the Locks dialog box. (Settings menu 

> Locks > Full) 

Axis Lock: If on, each data point is forced to lie at an angle (or multiples of that angle) from the 

previous data point. The angle is specified by the (Axis) Increment relative to the (Axis) Start Angle. 

Civil Formatting 

Controls display of Civil Geometry functions and features. 

Color 

Consists of controls that are used to modify the color settings in the elements and the dynamic X 

pointer along with the color of a selection set. 

Element Attributes 

Color, line style, line weight, class, level, and fill. Global Line Scale can also be adjusted here. 

Fence 

Consists only of a control used to set the fence selection mode. 

Grid 

Consists of controls that are used to set Grid Lock and the grid's spacing and configuration.  If Grid 

Lock is enabled, each data point is forced to lie on the grid. 

Isometric 

If Isometric Lock is enabled, each data point is forced to lie on the Isometric Plane. 
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Locks 

Consists of controls that are also available in the Locks dialog box. 

Text Node Lock: If on, newly placed text is attached to empty text nodes, and you cannot place text if 

there aren't any empty text nodes. 

Level Lock: If on, you can select elements only on the Active Level; you cannot manipulate elements 

that are not on the Active Level. 

Graphic Group: If on, any manipulation performed on one member of a graphic group is 

automatically performed on all members.  If off, the member elements of a graphic group can be 

manipulated individually. 

ACS Plane: (3D only) If on, each data point is forced to lie on the Active ACS's XY plane (z=0). Still you 

can snap to elements at any depth. 

The Active ACS is set in the Auxiliary Coordinates System dialog box, which is opened by choosing 

Auxiliary Coordinates from the Utilities menu. 

Snaps 

Consists of controls that are also available in the Locks dialog box. 

Association: 

If on, an association point is created each time an element is snapped to: Dimensioning tools, the 

Place Multi-line tool, the Place Active Cell tool or Use Shared Cell. 

ACS Plane Snap: 

(3D only) If on, and AccuDraw is active, the first snap point is forced to lie on the Active ACS's XY 

plane (z=0). 

Depth Lock: 

(3D Only) If on, each tentative point is projected along the view z-axis at the Active Depth. 

Stream 

Consists of controls that are used to set how data points are sampled while using the Place Stream 

Line String tool and the Place Point or Stream Curve tool. 

Stream Delta: 

Sets the minimum distance, in working units, between sampled points (vertices in the stream line 

string or curve).  

When the distance between the pointer's location and the previously sampled point exceeds the 

Active Stream Delta, the point is sampled and the Tolerance, Stream Angle, and Stream Area are 

applied to see if a data point should be recorded. 
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Stream Tol(erance): 

Sets the maximum distance, in working units, between recorded data points. The distance from the 

most recently recorded data point is checked for each sampled point. If that distance exceeds the 

active stream Tolerance, the sampled point is recorded as a data point. 

Stream Angle 

Set the angle, in degrees, that when exceeded, causes the last sampled point (not the current one) 

to be recorded as a data point. 

Stream Area: 

Set the area that, when exceeded, causes a sampled point to be recorded as a data point. 

Acceptance Display: 

If on, the status bar shows criteria being satisfied as data points are recorded with the Place Stream 

Line String tool or Place Stream Curve tool. 

Views 

To edit Pixel width and Height in the corresponding view.  Enabling Proportional Resize will maintain 

the current displays aspect ratio when resizing.  Background allow for a user defined background 

image for the display. 

Working Units 

The units in which the current dgn is working in. 

11.3-6 Seed Files – (Template Documents) 

The following paragraph is quoted from the Bentley Institute Course Guide titled ProjectWise V8 XM 

Edition User. 

“A ProjectWise template is the same as a Microsoft template, or a seed file in MicroStation.  It is a 

file that is copied to create a new document.  You can use a document stored in ProjectWise or 

document that resides outside ProjectWise as a template.” 

All Seed files can be found under the Template Documents\SS4 Seed folder in ProjectWise.  Each 

set of seed files (Template Documents) resides within a sub folder describing their specific use. 

(Example:  MicroStation files are stored in the MicroStation folder). 

  

pw://dotwise.indot.in.gov:DOTWise/Documents/Template&space;Documents/SS4&space;Seed/DGN/D&space;size_sheets.dgn
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Documents\Template Documents 

 

ProjectWise Template Documents 
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11.3-7 Structure of a V8 Design File 

We’ve had a number of requests from users for a chart that shows the “structure of a design file” for 

an understanding of which settings are stored globally and which are stored with the model. The 

following image is only intended for learning purposes and is not a technical representation of the 

design file structure: 

 

DGN Feature Map 
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11.3-8 Cell Libraries 

With the move to a ProjectWise Managed Workspace, cells should no longer be directly referenced 

from outside MicroStation.  All Cell Libraries can be found on the Cell Libraries/Tools task in the 

MicroStation interface. 

11.3-9 Using Place Cell Along for MOT Barrels 

1. Attach the IN_Symbols cell library from either the INDOT Tools -> Cell Libraries -> Symbols Lib 

task navigator or Element -> Cells and File -> Attach File. 

 

2. In the cell selector, activate RD_MOT Barrel for Placement by double clicking on it. 

3. Start the Cell Tools from the task navigator under INDOT Tools -> Cell Libraries -> Load Cell 

Tools button. 

 

4. Select the Place Cell Along tool from the Cell Tools toolbox. 
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5. The RD_MOT Barrel is already active from selecting placement earlier.  At this time you can 

adjust the spacing as needed, along with the angle and offset.  

 

6. When satisfied with the settings, click on the line you’d like to place the cells along.  Your 

initial selection point will be the starting point of the cells, so if you require a certain point, 

make sure to tentative snap to it.  Note that the placement of the cell is always in the 

direction of the element.   

 

7. The Offset value should be used when you want to adjust which side of the linear element 

you’d like to place the cells.  Each of the following illustrations shows how the cells behave 

with a linear element drawn from right to left: 
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Cells are placed at a positive 1.5 offset, on a line drawn along a line from left to right. 

 

Cells placed at a negative -1.5 offset, on a line drawn along a line from left to right. 

A  Few Items of Note: 

a. This tool does work with complex chains and graphic groups, so it will work along an 

alignment 

b. Each cell is a distinct element, so they can be modified after placement without affecting 

other cells placed along the element. 

c. There is no way to limit the number of occurrences of cell placement, as this tool will place 

cells along an element to where it ends. 
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11.4 Appendix D - MicroStation Tips and Functionality 

11.4-1 Task Navigation Tips 

Task Navigation can be displayed horizontally as well as the default vertical.  As with other tool bars 

in MicroStation, tools can be stretched and reoriented.  The default placement for this toolbar is on 

the right side of the MicroStation window displayed vertically. 

Note: The main icons have numbers in the lower left corner for quick activation. Tasks icons have 

Letters in the lower left corner. 

 

The task list icon allows users to select the appropriate task.   

 

The default tasks are drawing and drawing composition.  Since some tasks require the same tools, 

tasks can include some of the same tools. 
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The task list can be expanded where the plus symbols exist. 

 

Certain tasks are subs to other tasks as illustrated in the following image: 

 

The resulting toolbar would look as follows: 

 

Hint: Simplification of Tasks can be achieved by changing how tasks are displayed in the user 

preferences.  Users who are new to MicroStation may not know what an icon is indicating.  This 

modified view shows the icons in conjunction with text describing the tools. 
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To implement this change, users should select from the Cad menu. Workspace -> Preferences -> 

Task Navigation -> Presentation -> Dialog. 

 

Resulting Task Navigation dialog: 

  

Sub items can select when the expand arrow exists. 

Open as toolbox allows users to work as with previous versions of MicroStation. 

11.4-2 Positional keyboard Mapping 

Positional mapping allows users to access commands by selecting the items from the Keyboard.  The 

keyboard is divided into zones to group access to commands.  Further discussion on how positional 

mapping works is covered in the following Dialog Focus section. 
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11.4-3 Dialog Focus 

MicroStation manages the inputs from users for positional mapping by managing the focus (or part 

of MicroStation you are currently interacting with). Feedback is provided to the user on the MS status 

bar in the lower right.  Focus is indicated with the following icons: 

                                 

 Home focus,  tool settings window,   Key-in,       AccuDraw 

When at home focus, the keyboard key selected corresponds to the tool selected.  Home focus also 

allows tools to be changed.  To return to home focus Press Esc 

When placing an element, focus may move to tool settings (as settings are changed), to AccuDraw 

(as precision input is provided) during placement, and then to home. 

Access Tools in the Main Toolbox with Positional mapping: 
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With focus at home, pressing a number will access the main tool box.  For Example selecting 3 will 

open a menu at the current cursor location listing the manipulate tools.  Pressing a second number, 

let’s say 1, will access copy.  Remember Esc returns dialog focus to home.   

Some examples of the sequence would be: 

• Esc -> 3 ->3   Scale 

• Esc -> 7 ->1   Modify element 

• Esc -> 4 ->4   Window Area 

Access Tools in Task Navigation with Positional mapping. 

With focus at home, pressing a letter will access the task toolbox.  For Example, selecting Q will open 

a menu at the current cursor location listing the tools.  Pressing a second entry, let’s say 2, will 

access Place line.  Remember Esc returns dialog focus to home.   

Some examples of the sequence would be: 

• Esc -> Q ->1   Place Smart line 

• Esc -> A ->1   Place Text 

• Esc -> D ->5  Measure Area 

• Tips: <space> Switches focus to AccuDraw 

11.4-4 View toolbar 

The view toolbar has been repositioned at the top left of the View window.  The default view toolbar 

for 3D drawings has the following icons.  The icons are referenced as listed starting at 1 from left to 

right. 

 

1. View Attributes. Used to select, control and change the type of elements and graphic 

attributes in the information displayed in the view.  

2. View Display Mode. Used to quickly set and customize the display mode such as wireframe, 

hidden lines, filled, etc. 

3. Adjust View Brightness. Used to quickly adjust lighting in the drawing. 

4. Update View. Used to refresh the active view. 

5. Zoom In. Increase the magnification of a view. 

6. Zoom Out. Decrease the magnification of a view. 

7. Window Area. Use to magnify an area of the display, in the selected view. 

8. Fit View. Used to fit the entire display in a view. Further specific options are available. 

9. View Rotation. Used to rotate the display in a view. Select from Top View or one of the other 

nine variations of rotation available from the fly-out tool bar. 

10. Pan view. Used to move (pan) the display without changing the view magnification. Move the 

display under the cursor by holding the left mouse button down and moving the cursor 

around the screen.  
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11. Walk. Used in 3D drawings to show a walking perspective along a path. 

12. View Previous. Cancels the last view control operation and returns you to the previous view. 

13. View Next. Applies the last undone view control operation. 

14. Copy View. Used to copy the active view settings to another view. 

15. Change View Perspective. Change the perspective angle of a 3D view. 

16. Clip Volume. Clips a view so no elements outside a defined boundary are visible. 

17. Clip Mask. Used to clip visible areas in a view. 

11.4-5 Mouse Operations 

Mouse functionality has been slightly modified and enhanced.  The graphic below illustrates current 

default settings.  Changes to defaults are discouraged. 

 

Changes to note: Tentative snapping requires a simultaneous left and right mouse click. 

Additions:  Double middle click (wheel) performs Fit View 

 Press and hold middle is pan 

Shift Lt is Dynamic pan 

Roll wheel forward and back is zoom in and out 
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11.4-6 Missing buttons and Toolbars 

Right Click to customize the menu Icons displayed. 

RT click on nearly every menu allows the user to select which icons are included. 

 

Select by left clicking on items to add or remove items.  Only items with checks will be displayed.   

 
The standard toolbar 

Have you been looking for this toolbar?  It is off by default. 

To activate it select CAD Menu -> Tools -> Standard. 

11.4-7 Button Bar 

Using the Button Bar to constantly monitor or change snaps will help users to properly utilize CAD 

snaps at all times.  This is especially beneficial when used in conjunction with AccuSnap.  CAD Menu 

-> Settings Snaps -> Button Bar 

 

11.4-8 Save Settings 

Retaining changes to Menus. 

Changes made to customize toolbar layouts and other Menu changes can be retained from one user 

session to the next by Saving Settings. 

Access save setting from the CAD menu -> File -> Save Settings. 

Alternately, CTRL + F 
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11.5 Appendix E – Reference Documentation 

The following references include a wealth of information to supplement the documentation in this 

publication.  Included are standards, policy, and procedural information outside the scope of this 

document and are provided as an end user reference should further information be needed.  

INDOT CAD Support Site – http://www.in.gov/indot/3084.htm 

INDOT Design Manual - http://www.in.gov/indot/design_manual/index.htm 

INDOT Designers - https://www.in.gov/indot/2731.htm 

Land & Aerial Survey Office - http://www.in.gov/indot/2715.htm 

Standards & Specifications - http://www.in.gov/dot/div/contracts/standards/index.html 

ProjectWise Documentation and Resources - Documentation 

  

http://www.in.gov/indot/3084.htm
http://www.in.gov/indot/design_manual/index.htm
https://www.in.gov/indot/2731.htm
http://www.in.gov/indot/2715.htm
http://www.in.gov/dot/div/contracts/standards/index.html
pw://dotwise.indot.in.gov:DOTWise/Documents/Resources/Documentation/
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11.6 Appendix F – DOTWise Change log 

11.6-1 DOTWise 3.x Change logs  

• The DOTWise 3.x changelogs have been removed and can be found in ProjectWise at 

DOTWise 3.x Change Logs.pdf 

11.6-2 DOTWise 4.0 Change log (Released 6/6/16) 

Major New Functionality 

This release is a full upgrade of the INDOT CAD workspace to make all elements OpenRoads 

compatible.  Due to the no base functionality has been lost and all features still exist.  New levels 

have been added to accommodate required features and will not be listed here. 

11.6-2a ProjectWise 

• Created the SS4 Workspace Configuration 

• Created InRoads SS4 Application Association 

• Updated managed workspaces to be applied directly to application associations 

o MicroStation has the legacy SS2 workspace blocks applied for completing existing 

projects. 

o InRoads SS4 has the OpenRoads Civil workspace blocks assigned. 

o PowerInRoads has the SS4 and OpenRoads workspace blocks assigned. 

• New Seed files have been published under Documents\Template Documents\ SS4 Seed 

11.6-2b MicroStation 

• Upgrade to MicroStation SS4 08.11.09.932 

• Full workspace upgrade to SS4 including all DGNLibs, and configurations. 

• Updated INDOT Tools task navigation to remove outmoded tools. 

• Renamed all level filters to start with _IN so they appear at the top of the list. 

• Moved INDOT-INFO from the MicroStation Help menu to a Project Explorer linkset. 

11.6-2c InRoads 

• Upgrade to InRoads SS4 08.11.09.872 

• Current Alternative Upgrade Path – Power InRoads SS4 08.11.09.872 

• Reconfigured XIN for SS4 compatibility 

• Surface Advanced Imports built for Point Feature Annotation and all graphical elements. 

• Scaling adjustments for various text and annotation configurations to maintain backwards 

compatibility. 

• Updated all sheet creation tools to use new SS4 seed files. 

• Addition of XS_TL features for standardized template naming. 

  

pw://dotwise.indot.in.gov:DOTWise/Documents/Resources/Documentation/DOTWise%203.x%20Change%20Logs.pdf
pw://dotwise.indot.in.gov:DOTWise/Documents/Template&space;Documents/SS4&space;Seed/DGN/D&space;size_sheets.dgn
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11.6-3 DOTWise 4.1 Change log (Released 9/16/16) 

11.6-3a DOTWise Document 

• Substantial changes to Chapters 5-7 to include process changes as determined via coaching 

sessions. 

o Chapter 5 includes new documentation on the need to work in 2D seed files. 

o Chapter 6 includes new documentation on updated survey coding and how to work 

with legacy project data in OpenRoads Survey. 

o Chapter 7 includes new documentation on upgrading existing projects and 

interacting with legacy project data. 

o Chapter 7 Section 7.4-1c includes additional information on survey features that may 

captured as random, but that do not draw connecting lines (fences, property lines, 

etc.) 

11.6-3b InRoads 

• INDOT.xin 

o Adjusted corridor features to point to correct levels for more discreet display control. 

o Cross section annotation adjustments for text scaling issues.  This included changes 

to PG Elevations and End Area Volume annotation styles. 

o Included the following new features for Survey.  Please see the 

IN_Design_Features_ElementTemplates_Levels.dgnlib section for symbology 

specifics for each. 

▪ Brick Pavers - BK,BKL,BKR 

▪ Decorative Blocks - BL,BLL,BLR 

▪ Detectable Warning - PR,PRL,PRR 

▪ Overhead Utility Line - OV,OVL,OVR 

▪ Sidewalk Joint - SJ,SJL,SJR 

▪ Harrison Monument - PHAR 

▪ Mag Spike - PMSP 

▪ Overhead Low Point - POHL 

▪ Pedestrian Signal Pole - PPSP 

11.6-3c OpenRoads Technologies 

• IN_Survey_Features_Project_Settings.dgnlib 

o Incorporated new Control Codes to replace +O, +D, +H InRoads offset commands.  

Note that the (-) indicates which direction would be a negative value 

▪ AD* is for vertical offsets, Up/Down(-) 

• Example: AD*-2 UE02 B would result in UE02 2 feet below the 

observation at the start of the string. 

▪ NF* is for distance offset, Front(-)/Back 

• Example: NF*4.5 PTCS would result in PTCS 4.5 feet back from the 

observation. 

▪ LR* are for left/right offsets, Up/Down(-) 

• Example: LR*-7 TB04 would result in TB04 7 feet to the left of the 

observation. 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT&space;Workspace/OpenRoads/Workspace/xin/INDOT.xin
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT&space;Workspace/OpenRoads/Workspace/dgnlib/IN_Survey_Features_Project_Settings.dgnlib


 

584  

 

o The EXTARC code can no longer be used to create a closed 3 point circle.  

Advisement from Bentley is that circles should have 4 shots, with the fourth shot 

being near the first shot so only a small linear element closes out the circle. 

o All Survey Point feature definitions were configured to point to the native XIN styles 

for 3D display.  This allows for these features to display properly in a terrain model 

when imported from DTM. 

o Configured linear survey elements to have appropriate cross section native feature 

definition to allow display in cross sections as crossing features (UG Utils, R/W, etc.) 

o Added features and coding definitions for the following survey features, consistent 

with the XIN: 

▪ Brick Pavers - BK,BKL,BKR 

▪ Decorative Blocks - BL,BLL,BLR 

▪ Detectable Warning - PR,PRL,PRR 

▪ Overhead Utility Line - OV,OVL,OVR 

▪ Sidewalk Joint - SJ,SJL,SJR 

▪ Harrison Monument - PHAR 

▪ Mag Spike - PMSP 

▪ Overhead Low Point - POHL 

▪ Pedestrian Signal Pole - PPSP 

• IN_Design_Features_ElementTemplates_Levels.dgnlib 

o All Point feature definitions were configured to point to the native XIN styles for 3D 

display.  This allows for these features to display properly in a terrain model when 

imported from DTM. 

o Created new levels for all Template Library Features so corridor strings have 

additional flexibility in displaying discreet levels.  Previously all features went to the 

same level. 

o Incorporated Bentley provided Terrain Filters. 

o Added element templates and levels for use with the noted survey features: 

Feature Linestyle/Cell Color Level Name 

Brick Pavers 2 115 S_PROP_Brick Pavers 

Decorative Blocks 3 96 S_PROP_Decorative Blocks 

Detectable Warning 2 46 S_PROP_Detectable Warning 

Overhead Utility Line utoh 0 S_UTIL_Overhead Utility Line 

Sidewalk Joint 0 2 S_PROP_Sidewalk Joint 

Harrison Monument PHAR 0 S_CTRL_Harrison Monument 

Mag Spike PMSP 0 S_CTRL_Mag spike 

Overhead Low Point POHL 39 S_UTIL_Overhead Low Point 

Pedestrian Signal Pole PPSP 0 S_UTIL_Pole-Pedestrian Signal 

• Civil Cells 

o INDOT_CurbRamps.dgnlib – Included adjusted curb ramp cells, with additional 

placement flexibility. 

o Added all default Bentley Civil Cell libraries as xBentley_XXX.dgnlibs. 

• IN_InRoads.cel 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT&space;Workspace/OpenRoads/Workspace/dgnlib/civil&space;cells/
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT&space;Workspace/OpenRoads/Workspace/cell/IN_InRoads.cel
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o Added new cells for the following survey features: 

▪ Harrison Monument – PHAR 

▪ Mag Spike – PMSP 

▪ Overhead Low Points – POHL 

▪ Pedestrian Signal Pole – PPSP 

• Line_Styles.dgnlib 

o Added UTOH linestyle for use with Overhead Utility Line survey features.  This is 

associated with level/element template S_UTIL_Overhead Utility Line. 

11.6-3d InterPlot 

• INDOT Design Script_AN.pen & INDOT Design Script_NN.pen 

o The following existing levels have been removed from the 80% screening when using 

these pen tables with InterPlot.  Please note that * denote wildcards that can be any 

combination of characters, and the following will include any levels that fit the criteria 

presented. 

▪ E_BR_Bridge_Text* 

▪ E_BR_Text-* 

▪ E_DR_*-Text 

▪ E_TRAF_*-Text 

  

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT&space;Workspace/OpenRoads/Workspace/dgnlib/Line_Styles.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/Resources/Plotting/Design&space;Scripts/INDOT&space;Design&space;Script_AN.pen
pw://dotwise.indot.in.gov:DOTWise/Documents/Resources/Plotting/Design&space;Scripts/INDOT&space;Design&space;Script_NN.pen
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11.6-4 DOTWise 4.2 Change log (Released 3/17/17) 

11.6-4a DOTWise Document 

• All references to PowerInRoads SS4 have been modified to accurately reflect the complete 

migration to InRoads SS4 and PowerInRoads SS2 for legacy projects. 

• Added the following sections: 

o 4.3-2 InterPlot Troubleshooting and the Rasterized Setting 

o 6.3-3a Editing Fieldbook Features 

o 6.3-4b Triangulation Clean Up 

o 6.3-5 Creating the Native InRoads DTM Existing Terrain 

o 6.3-6 Creating the Native InRoads DTM for Annotation 

o 6.3-8 Creating the Native InRoads Alignment 

o 6.5 OpenRoads/InRoads Reporting 

o 7.4-1 Geocoordination Base Drawings 

o 7.10-4hg Crossing Features 

• All OpenRoads/InRoads documentation has been revised based on troubleshooting efforts 

since the 4.1 release, and has had a greater emphasis placed on when drawing content 

should be 2D or 3D. 

11.6-4b InRoads 

• INDOT.xin 

o Set Default Global Scales to 1 

o Station Lock is defaulted to On 

o Set default point symbology for S_TRAF_Loop Detector to use PISL cell from 

IN_InRoads.cel 

o The following features have been changed to breakline features, excluded from 

triangulation 

▪ S_DR_Drainage Pipe 

▪ S_PROP_Fence-barbed 

▪ S_PROP_Fence-chain link 

▪ S_PROP_Fence-Elec. 

▪ S_PROP_Fence-farm field 

▪ S_PROP_Fence-iron 

▪ S_PROP_Fence-metal 

▪ S_PROP_Fence-other 

▪ S_PROP_Fence-privacy 

▪ S_PROP_Fence-woven rail 

▪ S_PROP_Fence-stone 

▪ S_PROP_Fence-wood 

▪ S_UTIL_Hedge 

o Set Project Options to use INDOT Project Options as the Default settings. 

11.6-4c OpenRoads Technology 

• IN_InRoads.cel 

o Reduced scaling of left and right guardrail symbols for cross sections 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/xin/INDOT.xin
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_InRoads.cel
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o Removed linear elements from all Material – point cells. 

• Civil.cel 

o Renamed duplicate cell definitions to prevent wrong cells being placed by civil tools. 

• IN_Design_Features_ElementTemplates_Levels.dgnlib 

o Fixed working units to use Survey Feet and Survey Inches. 

o Duplicated 3D guardrail feature types to P_RDWY_3D GR Left and P_RDWY_3D GR 

Right. 

o Revised P_RDWY_GR Left and P_RDWY_GR Right to remove 3d cross section 

linestyle and replaced with legacy cross section symbol functionality. 

o Added P_RDWY_Filter Sock element template, Civil Style and level (P_RDWY_Filter 

Sock, color 0, linestyle Filter Sock) 

o Revised Terrain element templates displaying contours to even values for text 

spacing, major and minor contours. 

• IN_Project_Settings.dgnlib 

o Adjusted Corridor Design Stage 8 – Final Components to also create linear features, 

allowing for direct annotation on Cross Sections. 

11.6-4d MicroStation 

• IN_Symbols.cel 

o Added the following cells: 

▪ SN_CONSTWARNLGT – Low intensity warning light, Type A 

▪ SN_ROADCLOSUREASSY – Road Closure Sign Assembly 

• IN_PvmtMarkings.cel 

o Added SN_INTSYMACCSY – International Symbol of Accessibility 

• Line_Styles.dgnlib 

o Added new linestyles for: 

▪ gpr – Proposed Guardrail, Right 

▪ gpl – Proposed Guardrail, Left 

▪ Filter Sock 

• Ltr_sheets.dgn 

o Revised Portrait and Landscape Detail sheets with Stamps to better use available 

space. 

• D size_sheets.dgn 

o Modified the title sheet models to remove the dependency on the INDOT logo image, 

and replaced the image with vector elements. 

• SS4 Seed 

o All seed files have been modified to resolve unitary inconsistencies. 

  

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/Civil.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Project_Settings.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_Symbols.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_PvmtMarkings.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/Line_Styles.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/DGN/Ltr_sheets.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/DGN/D%20size_sheets.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/SS4%20Seed/
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11.6-5 DOTWise 4.3 Change log (Released 9/15/17) 

11.6-5a DOTWise Document 

• Added Chapter 7.6-5 Saving Sheets to ProjectWise and Resolving References  

• Appendix A – Modified verbiage to indicate that naming can apply to model names as well as 

file names where applicable. 

• Removed previous Appendix F – GIS Conversion Matrix.  Following appendices have been 

renamed to Appendix F – Reference Documentation and Appendix G – DOTWise Changelog. 

11.6-5b InRoads 

• INDOT.xin 

o PPSP changed to display the correct symbol 

o PMSP changed to display the correct symbol 

o Changed IN End_Area_Volume preference for End-Area Volumes tool to 0.1 decimal 

precision for Cut/Fill Area/Volume. 

o Added the following named symbologies for use with the InRoads Drafting Notes 

tools: 

▪ PP_DN_Plan 

▪ PP_DN_Cross Section 

▪ PP_DN_Profile 

▪ PP_DN_Plan_RW 

o Added the following preferences to the Plan and Profile Generator 

▪ IN PW Ltr Dbl Plan 200 Scale 

▪ IN PW Dbl Plan 200 Scale 

• notes.dft 

o Added Notes folder and added this file.  These are the default drafting notes 

assigned the appropriate symbologies. 

• IN_InRoads.cel 

o Modified $FILE$ tag placement on the TINFO, PlanSheetTags and CrossSectionTags 

cells to accommodate new text replacement in border files via IPLOT. 

o Added ltrtinfo cell for use with letter size borders on the Plan and Profile Generator. 

• INDOT_Border.dgn – Added $MODEL_NAME$ to accommodate new text replacement in 

border files via IPLOT. 

• INDOT_CrossSectionBorder.dgn - Added $MODEL_NAME$ to accommodate new text 

replacement in border files via IPLOT. 

• INDOT_DblPlanBorder.dgn - Added $MODEL_NAME$ to accommodate new text replacement 

in border files via IPLOT. 

• INDOT_Ltr Border.dgn – Added for use with IN PW Ltr Dbl Plan 200 Scale preference. 

11.6-5c OpenRoads Technology 

• IN_Survey_Features_Project_Settings.dgnlib 

o Added BPC linking code for StartPC functionality.  This resolves issues with using B 

and PC as separate linking codes to start a survey string on a curve. 

o Change S_UTIL_Pole-Pedestrian Signal style name to S_UTIL_Pole-Pedestrian Signal. 

• IN_Drainage Features Defs.dgnlib 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT&space;Workspace/OpenRoads/Workspace/xin/INDOT.xin
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/notes/notes.dft
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_InRoads.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/Plans%20Production/INDOT_Border.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/Plans%20Production/INDOT_CrossSectionBorder.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/Plans%20Production/INDOT_DblPlanBorder.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/Plans%20Production/INDOT_Ltr%20Border.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Survey_Features_Project_Settings.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Drainage%20Features%20Defs.dgnlib
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o Utility Filters > Gas10 

▪ Added filter groups: Color: 36, Element Types (Line, Line String, Complex 

Chain), LineStyle: 10”GAS LINE 

• IN_Design_Features_ElementTemplates_Levels.dgnlib 

o Added new OpenRoads Linear Features for the following items 

▪ P_TRAF_Pavement Marking-Gore Line ((Color 32, Linestyle Gore Line 8”) 

▪ P_TRAF_Pavement Marking-White Broken Line 4in 10-30  

▪ P_TRAF_Pavement Marking-White Dotted Line 4in 3-9 

▪ P_TRAF_Pavement Marking-White Line 12in 

▪ P_TRAF_Pavement Marking-White Line 24in  

▪ P_TRAF_Pavement Marking-White Line 4in  

▪ P_TRAF_Pavement Marking-White Line 8in  

▪ P_TRAF_Pavement Marking-White Transverse Line 24in  

▪ P_TRAF_Pavement Marking-White Transverse Line 8in  

▪ P_TRAF_Pavement Marking-Yellow Diagonal Line 4in  

▪ P_TRAF_Pavement Marking-Yellow Line 12in  

▪ P_TRAF_Pavement Marking-Yellow Line 24in  

▪ P_TRAF_Pavement Marking-Yellow Line 4in  

▪ P_TRAF_Pavement Marking-Yellow Line 8in  

▪ P_TRAF_Pavement Marking-Yellow Skip Lt Solid Rt Line 4in  

▪ P_TRAF_Pavement Marking-Yellow Solid Lt Skip Rt Line 4in  

▪ P_TRAF_Pavement Marking-Yellow Transverse Line 8in  

11.6-5d MicroStation 

• Purged unused linestyles from IN_Terrain_Model_Filters.dgnlib and 

Text_Styles_Dimensions.dgnlib 

• IN_Patterns.cel  

o  Set all cell definitions to be point instead of graphic cells. 

o Added SAND Pattern 

• IN_Design_Features_ElementTemplates_Levels.dgnlib 

o Added Level: 

o Added BD_SHT_Clip Boundary (No Plot) (Color 207) 

o Reduced the lineweight of the following items to 1: 

▪ XS_TL_CL6 

▪ XS_TL_CL5 

▪ XS_TL_CL4 

▪ XS_TL_CL3 

▪ XS_TL_CL2 

▪ XS_TL_CL1 

▪ XS_TL_CL 

▪ XS_TC_Struc - Inside Wall Top 

▪ XS_TC_Sidewalk 

▪ XS_TC_Retaining Wall 

▪ XS_TC_Raised Median 

▪ XS_TC_Proposed 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Terrain_Model_Filters.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/Text_Styles_Dimensions.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_Patterns.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
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▪ XS_TC_PCCP 

▪ XS_TC_HMA Pavement 

▪ XS_TC_Guardrail_Post_Only 

▪ XS_TC_Guardrail_Post 

▪ XS_TC_Guardrail_Anchor 

▪ XS_TC_Grass Median 

▪ XS_TC_Grading 

▪ XS_TC_Curb 

▪ XS_TC_Asph_Curb 

▪ XS_TC_Aggregate 

▪ XS_TC_Aggregate 

▪ XS_TL_Centerlines 

o Modified the following linestyles to use the Physical attribute.  This prevents 

annotation or global scaling affecting these styles: 

▪ cl double 

▪ cl left pass 

▪ cl no passing 

▪ cl passing 

▪ cl right pass 

▪ Crosswalk 

▪ curb – 4 

▪ curb – 6 

▪ curb – 8 

▪ curb & gutter - 4 

▪ curb & gutter - 6 

▪ curb & gutter - 8 

▪ ex. c & g – 4 

▪ ex. c & g – 6 

▪ ex. c & g – 8 

▪ ex. curb – 4 

▪ ex. curb – 6 

▪ ex. curb – 8 

▪ exagerated left pass 

▪ exagerated no passing 

▪ exagerated right pass 

▪ MOT Barrels 100 

▪ MOT Barrels 50 

▪ RPM 40ft 

▪ RPM 80ft 

▪ skip turning 

▪ Skips 

▪ stop line 

▪ Striping 

▪ TWLTL 

o Added the following linestyles 
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▪ Prpipe (Proposed pipe) 

▪ Gore Line 8” 

▪ Line (4”) 2/2 

o Added the following levels: 

▪ PP_G_Phase 1 (Color 1, Linestyle 0, Lineweight 1, Transparency 80) 

▪ PP_G_Phase 2 (Color 3, Linestyle 0, Lineweight 1, Transparency 80) 

▪ PP_G_Phase 3 (Color 5, Linestyle 0, Lineweight 1, Transparency 80) 

▪ PP_G_Phase 4 (Color 71, Linestyle 0, Lineweight 1, Transparency 80) 

▪ PP_G_Phase 5 (Color 86, Linestyle 0, Lineweight 1, Transparency 80) 

▪ PP_G_Phase 6 (Color 112, Linestyle 0, Lineweight 1, Transparency 80) 

▪ P_TRAF_Pavement Marking-Gore Line ((Color 32, Linestyle Gore Line 8”, 

Lineweight 1) 

▪ P_TRAF_Pavement Marking-White Broken Line 4in 10-30 (Color 32, Linestyle 

Line (4") 10/30, Lineweight 1) 

▪ P_TRAF_Pavement Marking-White Dotted Line 4in 3-9(Color 32, Linestyle 

Line (4") 3/9, Lineweight 1) 

▪ P_TRAF_Pavement Marking-White Line 12in (Color 32, Linestyle Line (12"), 

Lineweight 1) 

▪ P_TRAF_Pavement Marking-White Line 24in (Color 32, Linestyle Line (24"), 

Lineweight 1) 

▪ P_TRAF_Pavement Marking-White Line 4in (Color 32, Linestyle Line (4"), 

Lineweight 1) 

▪ P_TRAF_Pavement Marking-White Line 8in (Color 32, Linestyle Line (8"), 

Lineweight 1) 

▪ P_TRAF_Pavement Marking-White Transverse Line 24in (Color 32, Linestyle 

Line (24"), Lineweight 1) 

▪ P_TRAF_Pavement Marking-White Transverse Line 8in (Color 32, Linestyle 

Line (8"), Lineweight 1) 

▪ P_TRAF_Pavement Marking-Yellow Diagonal Line 4in (Color 52, Linestyle Line 

(4"), Lineweight 1) 

▪ P_TRAF_Pavement Marking-Yellow Line 12in (Color 52, Linestyle Line (12"), 

Lineweight 1) 

▪ P_TRAF_Pavement Marking-Yellow Line 24in (Color 52, Linestyle Line (24"), 

Lineweight 1) 

▪ P_TRAF_Pavement Marking-Yellow Line 4in (Color 52, Linestyle Line (4"), 

Lineweight 1) 

▪ P_TRAF_Pavement Marking-Yellow Line 8in (Color 52, Linestyle Line (8"), 

Lineweight 1) 

▪ P_TRAF_Pavement Marking-Yellow Skip Lt Solid Rt Line 4in (Color 52, 

Linestyle Line (4") Skip Lt Solid Rt, Lineweight 1) 

▪ P_TRAF_Pavement Marking-Yellow Solid Lt Skip Rt Line 4in (Color 52, 

Linestyle Line (4") Solid Lt Skip Rt, Lineweight 1) 

▪ P_TRAF_Pavement Marking-Yellow Transverse Line 8in (Color 52, Linestyle 

Line (8"), Lineweight 1) 
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o Added the Plans Production Graphics template group and following Element 

Templates 

▪ PP_G_Phase 1 (Level PP_G_Phase 1, all symbology set to ByLevel except 

General Setting > Transparencies 80, and Closed Linear Settings > Fill Type 

Opaque) 

▪ PP_G_Phase 2 (Level PP_G_Phase 2, all symbology set to ByLevel except 

General Setting > Transparencies 80, and Closed Linear Settings > Fill Type 

Opaque) 

▪ PP_G_Phase 3 (Level PP_G_Phase 3, all symbology set to ByLevel except 

General Setting > Transparencies 80, and Closed Linear Settings > Fill Type 

Opaque) 

▪ PP_G_Phase 4 (Level PP_G_Phase 4, all symbology set to ByLevel except 

General Setting > Transparencies 80, and Closed Linear Settings > Fill Type 

Opaque) 

▪ PP_G_Phase 5 (Level PP_G_Phase 5, all symbology set to ByLevel except 

General Setting > Transparencies 80, and Closed Linear Settings > Fill Type 

Opaque) 

▪ PP_G_Phase 6(Level PP_G_Phase 6, all symbology set to ByLevel except 

General Setting > Transparencies 80, and Closed Linear Settings > Fill Type 

Opaque) 

o Added the following Element Templates to Linear > Traffic > Proposed  (All symbology 

set to ByLevel) 

▪ P_TRAF_Pavement Marking-Gore Line  

▪ P_TRAF_Pavement Marking-White Broken Line 4in 10-30  

▪ P_TRAF_Pavement Marking-White Dotted Line 4in 3-9 

▪ P_TRAF_Pavement Marking-White Line 12in 

▪ P_TRAF_Pavement Marking-White Line 24in  

▪ P_TRAF_Pavement Marking-White Line 4in  

▪ P_TRAF_Pavement Marking-White Line 8in  

▪ P_TRAF_Pavement Marking-White Transverse Line 24in  

▪ P_TRAF_Pavement Marking-White Transverse Line 8in  

▪ P_TRAF_Pavement Marking-Yellow Diagonal Line 4in  

▪ P_TRAF_Pavement Marking-Yellow Line 12in  

▪ P_TRAF_Pavement Marking-Yellow Line 24in  

▪ P_TRAF_Pavement Marking-Yellow Line 4in  

▪ P_TRAF_Pavement Marking-Yellow Line 8in  

▪ P_TRAF_Pavement Marking-Yellow Skip Lt Solid Rt Line 4in  

▪ P_TRAF_Pavement Marking-Yellow Solid Lt Skip Rt Line 4in  

▪ P_TRAF_Pavement Marking-Yellow Transverse Line 8in  

• Text_Styles_Dimensions.dgnlib 

o Added the following Dimension Styles 

▪ Boxed Text 

• All Text styles will be enclosed in a box proportional to the text size. 

▪ Legend Bubble Large  

• Bubbles used for 10/12/14 Point Text with Spline Leader 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/Text_Styles_Dimensions.dgnlib
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▪ Legend Bubble Small (5/6/7/9 Point Text) 

• Bubbles used for 5/6/7/9 Point Text with Spline Leader 

• IN_Symbols.cel 

o Updated INDOT seals to match Title Sheets 

• IN_Signs.cel 

o Updated all signs. 

▪ Renamed signs to match MUTCD 

▪ Sizing and Origin point locations modified  

• IN_Interface.dgnlib 

o Resolved icons for Survey > Quick Tools > Survey Display and Survey > Cell Tools > 

Survey Topo Symbols 

o Spelling correction for OpenRoads Extensions > Cross Section Synchronization 

• Line Styles.dgnlib 

o Removed file and workspace dependency. All Linestyles provided in 

IN_Design_Features_ElementTemplates_Levels.dgnlib 

• IN_LevelFilters.dgnlib 

o Added BD_SHT_Clipe Boundary (No Plot) level 

• D size_sheets.dgn – Added $MODEL_NAME$ to accommodate new text replacement in 

border files via IPLOT. 

• IN_Scales.def – Added 1”=15’ Scale option. 

11.6-5e InterPlot 

• INDOT Design Script_AN.pen & INDOT Design Script_NN.pen – Added text replacement 

variables to replace newly added $MODEL_NAME$ text on all sheet borders. 

• Removed INDOT Letter_AN.set and INDOT Letter_NN.set as these have been superseded by 

the INDOT HP_Letter settings files. 

11.6-5f ProjectWise 

• Added 2018 as an available SPEC DATE on the _PROJECT INFORMATION Interface for 

universal title sheets. 

  

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_Symbols.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/Development/OpenRoads/Workspace/cell/IN_Signs.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Interface.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/Development/OpenRoads/Workspace/dgnlib/IN_LevelFilters.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/Development/OpenRoads/Workspace/dgnlib/IN_LevelFilters.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/DGN/D%20size_sheets.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/data/IN_Scales.def
pw://dotwise.indot.in.gov:DOTWise/Documents/Resources/Plotting/Design%20Scripts/INDOT%20Design%20Script_AN.pen
pw://dotwise.indot.in.gov:DOTWise/Documents/Resources/Plotting/Design%20Scripts/INDOT%20Design%20Script_NN.pen
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11.6-6 DOTWise 4.3.1 Change log (Released on 3/16/18) 

11.6-6a DOTWise Documentation 

• Added sections 6.3-4a and 7.5-4c regarding DTM exports with metric geocoordination and 

the applicable workaround. 

11.6-6b MicroStation 

• IN_Symbols.cel 

o Added Cells 

▪ SHT W STAMP LANDSCAPE – Interior layout of 8.5x11 frame for manual 

layout. 

▪ SHT W STAMP PORTRAIT – Interior layout of 8.5x11 frame for manual layout. 

▪ 811Logo_Dsize – Call 811 before you dig logo, for D size index sheets 

▪ 811Logo_Ltrsize – Call 811 before you dig logo, for letter size index sheets 

• IN_PE-LS-Stamps.cel 

o Cleanup of all Cells for Naming, and Leveling (Thanks to A. Bowen) 

o All PE Stamps have been prefixed with PE. 

o All LS Stamps have been prefixed with LS. 

• D size_sheets.dgn 

o All Models – Set Active Scale for XYZ to 1, Active Angle to 0. 

o All Index sheets – Added Call 811 logo 

o All Title sheets – Changed text replacement for Certification date to use ProjectWise 

_SIGNATURE interface value. 

o SN_Sheet Sign and Post Summary Sheet 

▪ Removed U-Channel Posts from table (no longer an option for designers).  

Replaced with the Type 3 Square Post columns. 

▪ Replaced Mile Marker Post Table with Bridge Reference Post Marker Table. 

o RD_Title Sheet 

▪ Added Culvert Assets table per Design Memo 17-04 

o Added the following two sheet models, replacing the previous SN_Panel Sign and 

Post Summary Sheet: 

▪ SN_Panel Sign and Post Summary Sheet (ASD) 

▪ SN_Panel Sign and Post Summary Sheet (LRFD) 

• Ltr_sheets.dgn 

o All Models – Set Active Scale for XYZ to 1, Active Angle to 0. 

o Ltr. Title Sheet 

▪ Added Culvert Assets table per Design Memo 17-04 

▪ Changed text replacement for Certification date to use ProjectWise 

_SIGNATURE interface value. 

o All Index sheets – Added Call 811 logo 

• IN_Signs.cel 

o Renamed XW2-6 to XW2-6-A, modified text to read Max 6 Yrs. 

o Renamed XW2-6A to XW2-6A-B 

o Renamed XW2-6B to XW-2-6B-B, modified text to ready Max 6 Yrs. 

• IN_Design_Features_ElementTemplates_Levels.dgnlib 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_Symbols.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_PE-LS-Stamps.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/DGN/D%20size_sheets.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/DGN/Ltr_sheets.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_Signs.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
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o Linestyle Updates: 

▪ Added RPM 48, Rumble Centerline, Rumble Edgeline LT, and Rumble 

Edgeline RT linestyles. 

▪ Imported revised Filter Sock and Silt Fence linestyles.  Styles have been 

recreated from scratch and no longer share a linear pattern. 

o Level Additions: 

▪ P_TRAF_Pavement Rumble Stripes Center (Color 325, Linestyle Rumble 

Centerline, Lineweight 0)  

▪ P_TRAF_Pavement Rumble Stripes Edgeline LT (Color 325, Linestyle Rumble  

Edgeline LT, Lineweight 0)  

▪ P_TRAF_Pavement Rumble Stripes Edgeline RT (Color 325, Linestyle Rumble 

Edgeline RT, Lineweight 0) 

▪ S_PROP_Property Corner (Color 3, Linestyle 0, Lineweight 0) 

▪ S_UTIL_Sanitary Force Main (Color 2, Linestyle 0, Lineweight 0) 

▪ S_UTIL_Outlet Box 110v (Color 22, Linestyle 0, Lineweight 0) 

▪ S_TOPO_Matl Prop-Brick (Color 225, Linestyle 0, Lineweight 0) 

▪ S_DR_Sewer Cleanout (Color 15, Linestyle 0, Lineweight 0) 

▪ S_TRAF_ADA Pedestrian Button (Color 52, Linestyle 0, Lineweight 0) 

▪ P_EC_Splashpad (Color 17, Linestyle 0, Lineweight 1) 

▪ P_EC_Pump Around (Color 33, Linestyle 0, Lineweight 1) 

▪ P_EC_Dewatering (Color 186, Linestyle 0, Lineweight 1) 

▪ P_EC_Filter Berm (Color 79, Linestyle 0, Lineweight 1) 

▪ P_EC_Cofferdam (Color 21, Linestyle 0, Lineweight 1) 

o Renamed the following levels from P_RDWY_ and modified the symbology as listed: 

▪ P_EC_Check Dam – Riprap (Color 10,  Linestyle 0, Lineweight 1) 

▪ P_RDWY_Check Dam – Straw Bale to P_EC_Check Dam – Traversable (Color 

38,  Linestyle 0, Lineweight 1) 

▪ P_RDWY_Ditch Inlet Protection to P_EC_Inlet Protection (Color 36,  Linestyle 

0, Lineweight 1) 

▪ P_EC_Erosion Control (Color 87,  Linestyle 0, Lineweight 0) 

▪ P_EC_Erosion Control Txt (Color 0,  Linestyle 0, Lineweight 0) 

▪ P_EC_Filter Sock (Color 12,  Linestyle Filter Sock, Lineweight 1) 

▪ P_EC_Sediment Basin (Color 23,  Linestyle 0, Lineweight 1) 

▪ P_EC_Sediment Trap (Color 202,  Linestyle 0, Lineweight 1) 

▪ P_EC_Silt Fence (Color 13,  Linestyle Silt Fence, Lineweight 1) 

▪ P_EC_Slope Drain (Color 15,  Linestyle 0, Lineweight 1) 

▪ P_EC_Vegatative Filter Strip (Color 26,  Linestyle 0, Lineweight 0) 

o Added the following Element Templates to Traffic > Proposed  (All symbology set to 

ByLevel) 

▪ P_TRAF_Pavement Rumble Stripes Edgeline 

▪ P_TRAF_Pavement Rumble Stripes Edgeline LT 

▪ P_TRAF_Pavement Rumble Stripes Center 

o Added the following Element Templates to Survey (All symbology set to ByLevel) 

▪ Property\ S_PROP_Property Corner 

▪ Utilities\S_UTIL_Sanitary Force Main 
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▪ Utilities\S_UTIL_Outlet Box 110v 

▪ TOPO\S_TOPO_Matl Prop-Brick 

▪ Drainage\S_DR_Sewer Cleanout 

▪ Traffic\S_TRAF_ADA Pedestrian Button 

o Added the following Element Templates to Erosion Control > Proposed  (All symbology 

set to ByLevel) 

▪ P_EC_Splashpad  

▪ P_EC_Pump Around  

▪ P_EC_Dewatering  

▪ P_EC_Filter Berm 

▪ P_EC_Cofferdam 

▪ The following have been renamed and moved from Roadway Proposed 

• P_EC_Check Dam – Riprap  

• P_RDWY_Check Dam – Straw Bale to P_EC_Check Dam – 

Traversable  

• P_RDWY_Ditch Inlet Protection to P_EC_Inlet Protection 

• P_EC_Erosion Control  

• P_EC_Erosion Control Txt  

• P_EC_Filter Sock  

• P_EC_Sediment Basin 

• P_EC_Sediment Trap  

• P_EC_Silt Fence  

• P_EC_Slope Drain  

• P_EC_Vegatative Filter Strip  

• IN_LevelFilters.dgnlib 

o Added P_EC_ Filtering for Erosion Control level prefix. 

11.6-6c InRoads/OpenRoads Technology 

• INDOT.ITL 

o Updated components naming as provided by INDOT Design section.   

o Guardrail components updated to match MASH system. 

• IN_InRoads.cel 

o Renamed PSNDA to PODS to correct the S_TRAF_Sign-Oh double arm cant feature 

definition. 

o Added the following cells: 

▪ PCUT – Property Corner Cut X or V 

▪ PSUM – Sanitary Force Main 

▪ PEBX – Outlet Box 110v 

▪ PMBK – Material Property Brick 

▪ PSCO – Sewer Cleanout 

▪ PPBN – ADA Pedestrian Button 

• IN_Design_Features_ElementTemplates_Levels.dgnlib 

o Added new OpenRoads Linear\Traffic\Proposed Features for the following items 

▪ P_TRAF_Pavement Rumble Stripes Center 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_LevelFilters.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/data/template_library/INDOT.ITL
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_InRoads.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
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▪ P_TRAF_Pavement Rumble Stripes Edgeline LT 

▪ P_TRAF_Pavement Rumble Stripes Edgeline RT 

o Added new OpenRoads Linear\Erosion Control\Proposed Features for the following 

items: 

▪ P_EC_Splashpad  

▪ P_EC_Pump Around  

▪ P_EC_Dewatering  

▪ P_EC_Filter Berm 

▪ P_EC_Cofferdam 

▪ The following have been renamed and moved from Roadway > Proposed 

• P_EC_Check Dam – Riprap  

• P_RDWY_Check Dam – Straw Bale to P_EC_Check Dam – 

Traversable  

• P_RDWY_Ditch Inlet Protection to P_EC_Inlet Protection 

• P_EC_Erosion Control  

• P_EC_Erosion Control Txt  

• P_EC_Filter Sock  

• P_EC_Sediment Basin 

• P_EC_Sediment Trap  

• P_EC_Silt Fence  

• P_EC_Slope Drain  

• P_EC_Vegatative Filter Strip  

o Added new OpenRoads Linear\Survey\ Point and Linear Features for the following 

items: 

▪ Property\ S_PROP_Property Corner (Survey Code PCUT) 

▪ Utilities\S_UTIL_Sanitary Force Main (Survey Code PSUM) 

▪ Utilities\S_UTIL_Outlet Box 110v (Survey Code PEBX) 

▪ TOPO\S_TOPO_Matl Prop-Brick (Survey Code PMBK) 

▪ Drainage\S_DR_Sewer Cleanout (Survey Code PSCO) 

▪ Traffic\S_TRAF_ADA Pedestrian Button (Survey Code PPBN) 

• INDOT.xin 

o Added Styles/Named Symbologies for the following features: 

▪ S_PROP_Property Corner 

▪ S_UTIL_Sanitary Force Main 

▪ S_UTIL_Outlet Box 110v 

▪ S_TOPO_Matl Prop-Brick 

▪ S_DR_Sewer Cleanout 

▪ S_TRAF_ADA Pedestrian Button 

11.6-6d InterPlot 

• INDOT Design Script_AN.pen – Changed formatting for Signature Date to SHORT_DATE 

(m/d/yyyy) from DATE (dd-mmm-yyyy) 

• INDOT Design Script_NN.pen – Changed formatting for Signature Date to SHORT_DATE 

(m/d/yyyy) from DATE (dd-mmm-yyyy) 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/xin/INDOT.xin
pw://dotwise.indot.in.gov:DOTWise/Documents/Resources/Plotting/Design%20Scripts/INDOT%20Design%20Script_AN.pen
pw://dotwise.indot.in.gov:DOTWise/Documents/Resources/Plotting/Design%20Scripts/INDOT%20Design%20Script_NN.pen
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• INDOT Design Script_AN No Screening.pen – Added pen table to remove S_ and E_ level 

screening. 

• INDOT Design Script_NN No Screening.pen – Added pen table to remove S_ and E_ level 

screening. 

11.6-6e Seed Files 

• TB_SIGN_SHEET_SUMMARY_ms.xlsm 

o Removed U-Channel Posts from table (no longer an option for designers).  Replaced 

with the Type 3 Square Post columns. 

o Replaced Mile Marker Post Table with Bridge Reference Post Marker Table. 

  

pw://dotwise.indot.in.gov:DOTWise/Documents/Resources/Plotting/Design%20Scripts/INDOT%20Design%20Script_AN%20No%20Screening.pen
pw://dotwise.indot.in.gov:DOTWise/Documents/Resources/Plotting/Design%20Scripts/INDOT%20Design%20Script_NN%20No%20Screening.pen
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/Seed/Spreadsheets/US%20-%20Drawing%20Spreadsheets/TB_SIGN_SHEET_SUMMARY_ms.xlsm
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11.6-7 DOTWise 4.4 Change log (Released on 9/14/18) 

11.6-7a DOTWise Documentation 

• Substantial documentation cleanup of all chapters.  Updated imagery and example 

information where needed.  No procedural changes. 

• Chapter 2 – Added individual sections for each of the LEAP Products/Bentley Structural and 

their ProjectWise integration methods. 

• Chapter 4 – Complete rewrite of plotting chapter.  Plotting process via Interplot Organizer is 

now presented as a full plotting example with supplemental plotting information embedded 

in the process where applicable.  Digital Signature process has been updated using Adobe 

Acrobat DC as the appropriate version. 

• Chapter 10 has been renamed to Using Imagery with CAD and the Map Insert Application 

(formerly ArcGIS and CAD, Geocoordination and Data Sharing) 

• Removed Appendix D – True Scale Linestyles.  The material in this section has been 

depreciated by the adjustment of pavement marking and other needed linestyles being set to 

have the Physical linestyle attribute, removing their ability to scale by Annotation Scale. 

11.6-7b MicroStation 

• IN_Design_Features_ElementTemplates_Levels.dgnlib 

o Set linestyle for S_TOPO_Row of trees-coniferous to treeconif 

o Set linestyle for S_TOPO_Row of trees-deciduous to treedecid 

o Level Additions: 

▪ PP_G_Revision 1 (Color 10, Linestyle cloud, Lineweight 1) 

▪ PP_G_Revision 2 (Color 10, Linestyle cloud, Lineweight 1) 

▪ PP_G_Revision 3 (Color 10, Linestyle cloud, Lineweight 1) 

▪ PP_G_Revision 4 (Color 10, Linestyle cloud, Lineweight 1) 

▪ PP_G_Construction Change 1 (Color 10, Linestyle cloud, Lineweight 1) 

▪ PP_G_Construction Change 2 (Color 10, Linestyle cloud, Lineweight 1) 

▪ PP_G_Construction Change 3 (Color 10, Linestyle cloud, Lineweight 1) 

▪ PP_G_Construction Change 4 (Color 10, Linestyle cloud, Lineweight 1) 

• D size_sheets.dgn 

o RD_Title Sheet – Modified Culvert Asset Table to accommodate a longer text string in 

the Work Type column. 

o Added KIN Project Information table to the following models: BR_Title Sheet, BR_Title 

Sheet ROW, BR_Title Sheet Rehab, RD_Title Sheet, RD_Title Sheet ROW, SG_Title 

Sheet, SL_Title Sheet. 

o Removed No Additional Right of Way notation from BR_Title Sheet ROW and RD_Title 

Sheet ROW. 

• Ltr_sheets.dgn 

o Ltr. Title Sheet – Modified Culvert Asset Table to accommodate a longer text string in 

the Work Type column. 

• MicroStation Steel MDL – Added the Bentley Steel MicroStation MDL application.  Details on 

this tool can be found at this link. 

• IN_Lighting.cel 

o Modified cell to remove hatch pattern and use filled shape object. 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/DGN/D%20size_sheets.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/DGN/Ltr_sheets.dgn
https://communities.bentley.com/communities/other_communities/bentley_library/w/bentley_library__wiki/3944/steel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_Lighting.cel
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▪ LG_HH 

▪ LG_CAMBAR 

▪ LG_SVPT II 

▪ LG_SVPT I 

11.6-7c InRoads/OpenRoads 

• INDOT.xin 

o Set linestyle for named symbology S_TOPO_Row of trees-coniferous to treeconif 

o Set linestyle for named symbology S_TOPO_Row of trees-deciduous to treedecid 

o Removed point symbol symbology for S_TRAF_Sig Loop Detector 

• notes.dft 

o Adjusted all pre-defined note styles to use INDOT styles and symbology. 

o Adjusted stationing to use correct imperial settings (SS+SS.SS) 

11.6-7d Seed Files 

• TB_STRUCTUREDATA_ms.xls 

o Modified per M. Bailey/C. Martin 

11.6-8 DOTWise 4.4.1 Change log (Released on 3/15/19) 

11.6-8a MicroStation 

• IN_TitleSheetIntegration.cel – Added PlanSheetTags model from IN_InRoads.cel to allow use 

on InRoads sheets that these tags do not appear on (Profile Only sheets) 

• IN_Design_Features_ElementTemplates_Levels.dgnlib 

o Added linestyle Line (12”) 2/2 

o Level/Element Template Additions: 

▪ P_TRAF_Pavement White Broken Line 12in 2-2 (Color 32, Linestyle Line (12”) 

2/2, Lineweight 1)  

▪ P_ALG_Ditch Lt (Color 7, Linestyle 0, Lineweight 1) 

▪ P_ALG_Ditch Rt (Color 1, Linestyle 0, Lineweight 1) 

▪ P_ALG_Headwall Lt (Color 10, Linestyle 0, Lineweight 1) 

▪ P_ALG_Headwall Rt (Color 13, Linestyle 0, Lineweight 1) 

▪ P_ALG_Horizontal Approach (Color 3, Linestyle 0, Lineweight 1) 

▪ P_ALG_Horizontal Drive (Color 3, Linestyle 0, Lineweight 1) 

▪ P_ALG_Horizontal PR (Color 10, Linestyle 0, Lineweight 1) 

▪ P_ALG_Horizontal Ramp (Color 12, Linestyle 0, Lineweight 1) 

▪ P_ALG_Horizontal Secondary (Color 13, Linestyle 0, Lineweight 1) 

▪ P_ALG_Horizontal Stream (Color 1, Linestyle 0, Lineweight 1) 

▪ P_ALG_Underdrain Lt (Color 119, Linestyle 0, Lineweight 1) 

▪ P_ALG_Underdrain Rt (Color 17, Linestyle 0, Lineweight 1) 

▪ P_ALG_Vertical Alt 1 (Color 3, Linestyle 0, Lineweight 1) 

▪ P_ALG_Vertical Alt 2 (Color 4, Linestyle 0, Lineweight 1) 

▪ P_ALG_Vertical Alt 3 (Color 5, Linestyle 0, Lineweight 1) 

▪ P_ALG_Vertical Alt 4 (Color 6, Linestyle 0, Lineweight 1) 

▪ P_ALG_Vertical RC (Color 134, Linestyle 0, Lineweight 1) 

▪ Vertical Profile (blue) (Color 1, Linestyle 0, Lineweight 1) 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/Development/OpenRoads/Workspace/xin/INDOT.xin
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/notes/notes.dft
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/Seed/Spreadsheets/US%20-%20Drawing%20Spreadsheets/TB_STRUCTUREDATA_ms.xls
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_TitleSheetIntegration.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
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▪ Vertical Profile (brown) (Color 134, Linestyle 0, Lineweight 1) 

▪ Vertical Profile (cyan) (Color 7, Linestyle 0, Lineweight 1) 

▪ Vertical Profile (green) (Color 2, Linestyle 0, Lineweight 1) 

▪ Vertical Profile (grey) (Color 9, Linestyle 0, Lineweight 1) 

▪ Vertical Profile (magenta) (Color 5, Linestyle 0, Lineweight 1) 

▪ Vertical Profile (orange) (Color 6, Linestyle 0, Lineweight 1) 

▪ Vertical Profile (red) (Color 3, Linestyle 0, Lineweight 1) 

▪ Vertical Profile (yellow) (Color 4, Linestyle 0, Lineweight 1) 

• IN_Interface.dgnlib 

o Added button for IN_MOTCells.cel to INDOT Tools > Cell Libraries/Tools task. 

• Ltr_sheets.dgn  

o Modified sheet models for each to have an interior shape for raster/reference 

clipping. 

o Modified Ltr. Title Sheet model to change the note in the title block from “Approved 

for Letting” to “Recommended for Letting”. 

• D size_sheets.dgn – Modified BR_Title Sheet, BR_Title Sheet Rehab, RD_Title Sheet, 

SG_Title Sheet, and SL_Title Sheet models to change the note in the title block from 

“Approved for Letting” to “Recommended for Letting”. 

• Consultant_Ltr_sheets.dgn– Modified Ltr. Title Sheet model to change the note in the title 

block from “Approved for Letting” to “Recommended for Letting”. 

• IN_MOTCells.cel – Created new cell library to have a centralized location for all MOT-related 

symbols that are often used in MOT drawings.  The following cells are contained in the library: 

o Barrel Plan 

o Barrel Section 

o Barricade Type III-A 

o Barricade Type III-B 

o Cone Large Section 

o Cone Small Section 

o Constr. Sign 

o Constr. Sign Assembly 

o Constr. Sign with Light 

o Constr. Warning Light 

o Flagger 

o Flashing Arrow Sign 

o Flashing Arrow Sign Double 

o Pickup Truck 

o Police Car 1 

o Shadow Vehicle 

o Temp Conc Barrier Plan 

o Temp Conc Barrier Section 

o Traffic Flow Arrow 

o Truck Mounted Attenuator 

o Tubular Marker Section 

o Work Vehicle 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Interface.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/DGN/Ltr_sheets.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/DGN/D%20size_sheets.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/DGN/Consultant_Ltr_sheets.dgn
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• IN_Signs.cel 

o Added Cells: 

▪ ASY-BI-DIR (BI-DIRECTIONAL DETOUR ROUTE MARKER ASSEMBLY) 

▪ ASY-BI-DIR-CONFIRM (BI-DIRECTIONAL CONFIRMING DETOUR ROUTE 

MARKER ASSEMBLY) 

▪ W3-5 (REDUCED SPEED LIMIT AHEAD) 

▪ XW20-YWL(C) (NO LOADS OVER XX FT WIDE) 

▪ XW20-YWR(A) (WIDE LOAD RESTRICTION XX MILES) 

▪ XW20-YWR(B) (WIDE LOAD OVER XX FT MUST EXIT) 

▪ XW20-6 (LANE RESTRICTIONS ON OR AFTER ______) 

o Removed cell for XW21-4 (ROAD WORK AHEAD). 

o Renamed M4-9L and R to M4-10L and R to reflect the correct MUTCD designation. 

o Renamed G20-4 to XG20-4. 

11.6-8b InRoads/OpenRoads 

• INDOT.xin –  

o For the Plan, Dbl Plan, Bridge Layout, Plan Profile, and Plan Profile LargePlan sheets, 

increased the scaling of the north arrow by a factor of 2.0833 to have it conform to 

the correct sizing per INDOT CAD Standards. 

o S_TRAF_Loop Detector – Adjusted symbology so it appropriately displays the PISL cell 

for this code. 

o Style/Named Symbologies Added (all use bylevel symbology) 

▪ P_ALG_Ditch Lt 

▪ P_ALG_Ditch Rt 

▪ P_ALG_Headwall Lt 

▪ P_ALG_Headwall Rt 

▪ P_ALG_Horizontal Approach 

▪ P_ALG_Horizontal Drive 

▪ P_ALG_Horizontal PR 

▪ P_ALG_Horizontal Ramp 

▪ P_ALG_Horizontal Secondary 

▪ P_ALG_Horizontal Stream 

▪ P_ALG_Underdrain Lt 

▪ P_ALG_Underdrain Rt 

▪ P_ALG_Vertical Alt 1 

▪ P_ALG_Vertical Alt 2 

▪ P_ALG_Vertical Alt 3 

▪ P_ALG_Vertical Alt 4 

▪ P_ALG_Vertical RC 

▪ Vertical Profile (blue) 

▪ Vertical Profile (brown) 

▪ Vertical Profile (cyan) 

▪ Vertical Profile (green) 

▪ Vertical Profile (grey) 

▪ Vertical Profile (magenta) 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_Signs.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/Development/OpenRoads/Workspace/xin/INDOT.xin
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▪ Vertical Profile (orange) 

▪ Vertical Profile (red) 

▪ Vertical Profile (yellow) 

• IN_Design_Features_ElementTemplates_Levels.dgnlib 

o Added the following styles under Linear\Alignment 

▪ P_ALG_Ditch Lt 

▪ P_ALG_Ditch Rt 

▪ P_ALG_Headwall Lt 

▪ P_ALG_Headwall Rt 

▪ P_ALG_Horizontal Approach 

▪ P_ALG_Horizontal Drive 

▪ P_ALG_Horizontal PR 

▪ P_ALG_Horizontal Ramp 

▪ P_ALG_Horizontal Secondary 

▪ P_ALG_Horizontal Stream 

▪ P_ALG_Underdrain Lt 

▪ P_ALG_Underdrain Rt 

▪ P_ALG_Vertical Alt 1 

▪ P_ALG_Vertical Alt 2 

▪ P_ALG_Vertical Alt 3 

▪ P_ALG_Vertical Alt 4 

▪ P_ALG_Vertical RC 

▪ Vertical Profile (blue) 

▪ Vertical Profile (brown) 

▪ Vertical Profile (cyan) 

▪ Vertical Profile (green) 

▪ Vertical Profile (grey) 

▪ Vertical Profile (magenta) 

▪ Vertical Profile (orange) 

▪ Vertical Profile (red) 

▪ Vertical Profile (yellow) 

• IN_Survey_Features_Project_Settings.dgnlib 

o Added the following styles under Survey\Linear\Alignment 

▪ S_ALG_Alignment Secondary 

11.1.1.1. Seed Files 

• TB_ROAD_SUMMARY_ms.xls 

o Added updated Guardrail Summary Table 

11.6-9 DOTWise 4.5 Change log (Released on 9/13/19) (Updated 3/20/20 & 12/4/20) 

11.6-9a DOTWise Documentation 

• Added section 2.2-4 covering the Documentation\Resources folder and contents. 

• Added section 2.13 covering ProjectWise Views 

• Added section 2.14 covering Versioning 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Survey_Features_Project_Settings.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/Seed/Spreadsheets/US%20-%20Drawing%20Spreadsheets/TB_ROAD_SUMMARY_ms.xls
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• Added section 2.17-2 covering the additional of Agency Global Folders (Custom Folders) 

• Added section 2.20 covering the usage of OpenBridge Designer in addition to LEAP 

standalone products. 

• Added section 10.1-3 covering WMS Raster Imagery issues and workarounds to alleviate it’s 

impact. 

• Revised Chapter 4 – Plotting to include updates for Print Organizer usage and updates to 

signature process when creating plots using this utility in lieu of Interplot Organizer. 

• Revised all content to accommodate ProjectWise Cloud migration, screenshot and links 

updated. 

11.6-9b MicroStation 

• Text_Styles_Dimensions.dgnlib – Changed all dimension styles that do not start with 

Standards to have Survey Foot (‘) and Survey Inch (“) as the preferred display when the 

Working Units checkbox is disabled. 

• IN_Interface.dgnlib – Updated to include links to new signage cell libraries. 

• D size_sheets.dgn – Removed Survey Book notation and tag from all sheet models.  Tags for 

$PLN_PREP_BY$, $ENG_SIGNATURE$ and $SIG_DT$ have been moved to level 

BD_SHT_Attribute Exchange - Sig-Date to allow for granular display control. 

• Ltr_sheets.dgn - Tags for $PLN_PREP_BY$, $ENG_SIGNATURE$ and $SIG_DT$ have been 

moved to level BD_SHT_Attribute Exchange - Sig-Date to allow for granular display control. 

• IN_TitleSheetIntegration.cel – Removed Survey Book tag from all tag set cells in this library. 

• IN_Signs.cel has been removed from the workspace.  New signs cell libraries have been 

added to accommodate these cells by their classification in the MUTCD.  The newly created 

cell libraries are: 

o IN_Signs_Construction.cel 

o IN_Signs_Guide.cel 

o IN_Signs_Recreational.cel 

o IN_Signs_Regulatory.cel 

o IN_Signs_School-ObjectMarkers.cel 

o IN_Signs_Warning.cel 

• IN_Design_Features_ElementTemplates_Levels.dgnlib 

o Adjusted color of levels G_SURF_ExFlowArrows and G_SURF_PropFlowArrows from 

color 7 (cyan) to 4 (yellow) to increase visibility with contours and/or triangles 

enabled. 

o Added HY_DR_Pond (Color 63, Linestyle 0, Lineweight 2) 

o Added HY_DR_Trace Slope (Color 63, Linestyle dpfl, Lineweight 2) 

o Added linestyles: 

▪ MOT Barrels 20 

▪ Line (4”) Contrast 

▪ Line (5”) Contrast 

▪ Line (6”) Contrast Edge 

o Added the following 3D linestyles (Please note that most have Left and Right 

variants): 

▪ 3D Cable Barrier v2 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/Text_Styles_Dimensions.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Interface.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/DGN/D%20size_sheets.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/DGN/Ltr_sheets.dgn
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_TitleSheetIntegration.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
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▪ 3D Concrete Barrier Wall – TL3 

▪ 3D Concrete Barrier Wall – TL4 

▪ 3D Concrete Barrier Wall – TL5 

▪ 3D GRail Post 

▪ 3D Guardrail v2 

▪ 3D Traffic Rails SSTR 

▪ Channelizer Cone (10 ft spacing) 

▪ Construction Barrel (50 ft spacing) 

▪ Guardrail Double Sided v2 

▪ Guardrail Flared End 

▪ Jersey Barrier 

▪ Jersey Barrier w/ Screen 

▪ Traffic Cone 10’ Spacing 

▪ Wrought Iron Fence 4’ 

• IN_LevelFilters.dgnlib 

o Added filter IN_Drainage > Hydraulics (_DR_,HY_) 

• All seed files and template borders under Template Documents have had design history 

removed.  All except for D_Size_Sheets, Ltr_Sheets, Design_Manual_Seed2D, and 

Standards_Seed2D have had UTM84-16N geocoordination applied. 

• IN_PrintStyles.dgnlib – Added for usage with the MicroStation based Print Organizer.  

Contains INDOT customized Print Styles for use with this tool. 

o Adjusted print layouts to accommodate sheet formatting and rotation. 

o Added additional workspace variables to further accommodate maximization of sheet 

layouts and rotations for scaling purposes. 

11.6-9c InRoads/OpenRoads 

• IN_InRoads.cel – Removed Survey Book tag from CrossSectionTags, ltrtinfo, and tinfo cells 

used in cross section and plans profile generation. 

o Added XSECOHLine for use with S_UTIL_Overhead Utility Line cross section display 

• Plans Production – Removed Survey Book notation from each sheet model. 

• IN_Design_Features_ElementTemplates_Levels.dgnlib 

o Added Design_Hydraulic_Terrain_1 : 0.2 Terrain Display and Element Template.  

Based on Design_Contours_1 : 0.2 with Triangles disabled; Flow Arrows, Low Point, 

and High Point annotations enabled. 

o Added Existing_Hydraulic_Terrain_1 : 0.2 Terrain Display and Element Template.  

Based on Existing_Contours_1 : 0.2 with Triangles disabled; Flow Arrows, Low Point, 

and High Point annotations enabled. 

o Added HY_DR_Pond Linear Feature and Element Template for use with Terrain Model 

-> Analyze Pond command. 

o Added HY_DR_Trace Slope Linear Feature and Element Template for use with Terrain 

Model -> Analyze Trace Slope command. 

o Renamed Feature Definition/Element Template for XS_TC_HMA Base to XS_TC_HMA 

Base1.  Changed Level definition to XS_TC_HMA_Base1. 

o Added Feature Definition/Element Template for XS_TC_HMA_Base2. 

o Changed XS_TC_HMA Intermediate Level definition to XS_TC_HMA_INT. 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_LevelFilters.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/Template%20Documents/
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_PrintStyles.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/cell/IN_InRoads.cel
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/Plans%20Production/
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Design_Features_ElementTemplates_Levels.dgnlib
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o Changed XS_TC_HMA Surface Level definition to XS_TC_HMA_Surface.  

• IN_Survey_Features_Project_Settings.dgnlib 

o Adjusted S_UTIL_Overhead Utility Line feature to have a native cross section 

symbology of the same name. 

• INDOT.xin 

o Adjusted Named Symbology for S_UTIL_Overhead Utility Line to show a cross section 

point symbol. 

 

 

pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/dgnlib/IN_Survey_Features_Project_Settings.dgnlib
pw://dotwise.indot.in.gov:DOTWise/Documents/INDOT%20Workspace/OpenRoads/Workspace/xin/INDOT.xin
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